Subject: Re: [netmod] Y34 - root node

From: Randy Presuhn <[email-masked]>
Date: Tue, 18 Aug 2015 13:26:42 -0700 (GMT-07:00)

Hi -

> From: Andy Bierman
> Sent: Aug 18, 2015 10:22 AM
> To: Robert Wilton
> Cc: NETMOD Working Group
> Subject: Re: [netmod] Y34 - root node
>
> On Tue, Aug 18, 2015 at 9:59 AM, Robert Wilton <[email-masked]> wrote:
...
> > I think that having fixed paths may end up being too restrictive.
>
> This is how languages like SMIv2 and YANG work. A conceptual object
> is given a permanent "home" within the tree of object identifiers.

But it's *not*, for example, how GDMO works.  The CMIP world
maintains clear distinctions between the (organizational) hierarchy
of object identifiers, the conceptual hierarchies of inheritance
and class composition, and the containment hierarchy of object
instances.  There the "NAME BINDING" template provides the means
of describing places where instances of a given class may come
home to roost.

Randy

---

From: Ladislav Lhotka <[email-masked]>
Date: Wed, 19 Aug 2015 08:03:33 +0200

> of describing places where instances of a given class may come

FWIW, RELAX NG also allows for embedding complete grammars inside
grammars through the "externalRef" pattern.

In our case, the most difficult problem would be XPath expressions and
inter-module leafrefs. That's why I thought packages could also be made
relocatable, provided that they are self-contained and don't use any
references to modules external to the package.

Lada

>
> Randy
>
> _______________________________________________
> netmod mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/netmod

-- 
Ladislav Lhotka, CZ.NIC Labs
PGP Key ID: E74E8C0C