Subject: [netmod] issue & question: yang submodule contains newer revision than parent module

From: "Martin Ciglan -X (mciglan - PANTHEON TECHNOLOGIES at Cisco)" <[email-masked]>
Date: Fri, 21 Aug 2015 14:25:39 +0000

Hello

I'm dealing with issue where one yang module includes many yang submodules.
My question is if one of submodules gets updated with newer revision than parent module,
does parent module needs to be updated too? 
Is this mandatory?
If parent module doesn't get updated, can we consider this as invalid set of yangs?

   Thank you in advance

     Best Regards

         Martin

---

From: Martin Bjorklund <[email-masked]>
Date: Mon, 24 Aug 2015 10:00:48 +0200 (CEST)

> If parent module doesn't get updated, can we consider this as invalid

If the parent module uses include-by revision, then it obviously has
to be updated.  If it doesn't use include-by revision it is not clear
what it has to do.  We always use include-by revision for this
reason.

/martin

---

From: "Martin Ciglan -X (mciglan - PANTHEON TECHNOLOGIES at Cisco)" <[email-masked]>
Date: Mon, 24 Aug 2015 08:58:16 +0000

Hi Martin

Thank you for your answer.

Just to be precise, our input looks like this (just relevant parts):

parent module a:
------------------------
 include b {
    revision-date 2015-05-05;
  }

revision 2015-03-19 {
    description
      ".......................";
  }

submodule b:
------------------
revision 2015-05-05 {
    description
      "................";
  }

What I am missing here is update of parent module with latest submodule revision:

revision 2015-05-05 {
    description
      ".................";
  }

Can you confirm that this should be present in parent module a to make it all valid? Thanks.

    Best Regards

         Martin

______________________________
Od: Martin Bjorklund [[email-masked]]
Odoslané: 24. augusta 2015 10:00
Do: Martin Ciglan -X (mciglan - PANTHEON TECHNOLOGIES at Cisco)
Kópia: [email-masked]
Predmet: Re: [netmod] issue & question: yang submodule contains newer revision than parent module

/martin

---

From: Martin Bjorklund <[email-masked]>
Date: Mon, 24 Aug 2015 11:06:48 +0200 (CEST)

> Just to be precise, our input looks like this (just relevant parts):

This is incorrect.  Whenever you make a (published) change to your
module, you should update the revision date.  In this case, you have
changed the parent module a, but forgot to update the revision date.

> submodule b:

Yes.

/martin