Subject: [netmod] WebEx meeting invitation: NETMOD Interm meeting on OpenConfig

From: NETMOD Working Group <[email-masked]>
Date: Thu, 6 Aug 2015 19:03:54 +0000 (GMT)

Hello,

NETMOD Working Group invites you to join this WebEx meeting.

NETMOD Interm meeting on OpenConfig
Thursday, September 10, 2015
11:00 am  |  Eastern Daylight Time (New York, GMT-04:00)  |  1 hr

JOIN WEBEX MEETING
https://ietf.webex.com/ietf/j.php?MTID=m54c7bcbed84a08dc78fba128d500f8c0
Meeting number: 645 732 277
Meeting password: 1234

JOIN BY PHONE
1-877-668-4493 Call-in toll free number (US/Canada) 
1-650-479-3208 Call-in toll number (US/Canada)
Access code: 645 732 277

Toll-free dialing restrictions: 
http://www.webex.com/pdf/tollfree_restrictions.pdf

Add this meeting to your calendar:
https://ietf.webex.com/ietf/j.php?MTID=m17086d6b9810a2722c5dc8c64ec795b9

Can't join the meeting? Contact support here:
https://ietf.webex.com/ietf/mc

IMPORTANT NOTICE: Please note that this WebEx service allows audio and other information sent during the session to be recorded, which may be discoverable in a legal matter. By joining this session, you automatically consent to such recordings. If you do not consent to being recorded, discuss your concerns with the host or do not join the session.

---

From: Benoit Claise <[email-masked]>
Date: Fri, 7 Aug 2015 17:21:16 +0200

Dear all,

Let me set the stage for this future interim.

First of (and let me repeat), I'm happy that the operators gathered and 
collectively worked on YANG models and related requirements.

The previous two interim meetings in June on the openconfig issues 
(draft-openconfig-netmod-opstate-01 
<http://datatracker.ietf.org/doc/draft-openconfig-netmod-opstate/> and 
draft-openconfig-netmod-model-structure-00 
<http://datatracker.ietf.org/doc/draft-openconfig-netmod-model-structure/>) 
were successful in the sense that the requirements are now understood.

Unfortunately, some key players were not in Prague and we could not 
finalize the discussion.
How to represent the operational state is one important guidance from 
RFC 6087bis that we must be providing to all existing and future YANG 
models (and not only in the IETF).

We need to bring closure on that topic, and this is the plan for that 
interim meeting in September.

http://datatracker.ietf.org/doc/draft-openconfig-netmod-opstate/ has 
been updated. Please comment on this version.
Also, any alternate proposals must be prepared for that interim in 
September. They must be prepared with the same level of rigour as 
draft-openconfig-netmod-opstate., i.e. must have the same level of details.

In the meeting in September, the goal is to take a decision.

Regards, Benoit (OPS AD)

> *NETMOD Interm meeting on OpenConfig*
> *Join WebEx meeting* 
> <https://ietf.webex.com/ietf/j.php?MTID=m54c7bcbed84a08dc78fba128d500f8c0> 
>
>
> *Join by phone*
> *1-877-668-4493* Call-in toll free number (US/Canada)
> *1-650-479-3208* Call-in toll number (US/Canada)
> Access code: 645 732 277
> Toll-free calling restrictions 
> <http://www.webex.com/pdf/tollfree_restrictions.pdf>
>
> Add this meeting 
> <https://ietf.webex.com/ietf/j.php?MTID=m17086d6b9810a2722c5dc8c64ec795b9> 
> to your calendar.
>
> Can't join the meeting? Contact support. <https://ietf.webex.com/ietf/mc>
>
> IMPORTANT NOTICE: Please note that this WebEx service allows audio and 
> other information sent during the session to be recorded, which may be 
> discoverable in a legal matter. By joining this session, you 
> automatically consent to such recordings. If you do not consent to 
> being recorded, discuss your concerns with the host or do not join the 
> session.
>
>
>
> _______________________________________________
> netmod mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/netmod

---

From: Benoit Claise <[email-masked]>
Date: Fri, 7 Aug 2015 18:09:20 +0200

Dear all,

During the YANG Model Coordination Group webex call today, we discussed
this oper status and structure open issues. We're ready to help
facilitate the discussion between the different proposals
We could compare the pros/cons of the different solutions from our point
of view.

To allow us some preparation time, alternate proposals should be posted
a week before the NETMOD interim meeting, i.e. Sept 3rd.

The YANG Model Coordination Group

---

From: Juergen Schoenwaelder <[email-masked]>
Date: Sun, 9 Aug 2015 08:59:29 +0200

I am most likely not able to join this interim meeting due to other
commitments. I hope Martin and others knowing NETCONF/YANG by heart
are able to join. Anyway, if this is supposed to a virtual interim
meeting, it also needs to be announced as such.

/js

-- 
Juergen Schoenwaelder           Jacobs University Bremen gGmbH
Phone: +49 421 200 3587         Campus Ring 1 | 28759 Bremen | Germany
Fax:   +49 421 200 3103         <http://www.jacobs-university.de/>

---

From: Nadeau Thomas <[email-masked]>
Date: Thu, 13 Aug 2015 15:41:02 -0400

> On Aug 7, 2015:12:09 PM, at 12:09 PM, Benoit Claise <[email-masked]> wrote:
> 
> Dear all,
> 
	Speaking as Co-chair:

	Just to clarify a bit on this. The purpose of the next Interim meeting is to close on the issues around the Open Config proposal. We meant to do this in Praha, but we could not get the right people to attend the meeting to have the right discussion. We need to close on this issue as soon as possible, as this is possibly blocking a lot of other WG-related work; therefore, if no alternative proposals are posted to discuss ahead of the interim meeting, then the original proposal will become the solution to move forward with in the WG. Alternatives must be complete proposals, not bullet points of complaints or such things - they must be a solution or they will not be allowed onto the agenda.  As Benoit declared above, these must be posted ahead of the meeting and will be put on the agenda for the meeting to present/discuss/debate as well as to give everyone ample time to read and understand the document/s.

	Thanks,

	—Tom 

>> Join WebEx meeting <https://ietf.webex.com/ietf/j.php?MTID=m54c7bcbed84a08dc78fba128d500f8c0>
>> Join by phone
>> Toll-free calling restrictions <http://www.webex.com/pdf/tollfree_restrictions.pdf>
>>  
>> Add this meeting <https://ietf.webex.com/ietf/j.php?MTID=m17086d6b9810a2722c5dc8c64ec795b9> to your calendar.
>>  
>> [email-masked] <mailto:[email-masked]>
>> https://www.ietf.org/mailman/listinfo/netmod <https://www.ietf.org/mailman/listinfo/netmod>
> 
> [email-masked] <mailto:[email-masked]>
> https://www.ietf.org/mailman/listinfo/netmod <https://www.ietf.org/mailman/listinfo/netmod>

---

From: Andy Bierman <[email-masked]>
Date: Thu, 13 Aug 2015 13:03:33 -0700

On Thu, Aug 13, 2015 at 12:41 PM, Nadeau Thomas <[email-masked]>
wrote:

> Just to clarify a bit on this. The purpose of the next Interim meeting is
> to close on the issues around the Open Config proposal. We meant to do this
> in Praha, but we could not get the right people to attend the meeting to
> have the right discussion. We need to close on this issue as soon as
> possible, as this is possibly blocking a lot of other WG-related work;
> therefore, if no alternative proposals are posted to discuss ahead of the
> interim meeting, then the original proposal will become the solution to
> move forward with in the WG. Alternatives must be complete proposals, not
> bullet points of complaints or such things - they must be a solution or
> they will not be allowed onto the agenda.  As Benoit declared above, these
> must be posted ahead of the meeting and will be put on the agenda for the
> meeting to present/discuss/debate as well as to give everyone ample time to
> read and understand the document/s.
>
>

Are you proposing that all existing RFCs with YANG modules in them be
changed to "obsolete", and new modules published that move the data
under a container named "device" (from some TBD module)?  If not, then
what is the proposal for data root placement for existing RFC modules?

Are you also proposing that all YANG modules with config in them must
define that config in a grouping, and all config must appear in a
container named "config"? Also, that all config data must be replicated
(i.e., use that grouping) under a config false container named <state>?
This will be done even though in 90% of all servers, it doesn't take very
long for intended config to become the active config?  If not, then what
is the exact proposal for usage within IETF modules?

Everyone should understand the impact of these changes.
Silence should not mean "I read the openconfig proposals and
approve of these changes".  Only emails to this list that state as much
should mean that.

Thanks,
> —Tom

Andy

>
> Hello,NETMOD Working Group invites you to join this WebEx meeting. *NETMOD
> Interm meeting on OpenConfig*Thursday, September 10, 2015 11:00
> am  |  Eastern Daylight Time (New York, GMT-04:00)  |  1 hr  *Join WebEx
> meeting*
> <https://ietf.webex.com/ietf/j.php?MTID=m54c7bcbed84a08dc78fba128d500f8c0>Meeting
> number:645 732 277 Meeting password:1234 *Join by phone**1-877-668-4493* Call-in
> toll free number (US/Canada)*1-650-479-3208* Call-in toll number
> (US/Canada)Access code: 645 732 277Toll-free calling restrictions
> <http://www.webex.com/pdf/tollfree_restrictions.pdf> Add this meeting
>  to your calendar. Can't join the meeting? Contact support.
> <https://ietf.webex.com/ietf/mc> IMPORTANT NOTICE: Please note that this
> WebEx service allows audio and other information sent during the session to
> be recorded, which may be discoverable in a legal matter. By joining this
> session, you automatically consent to such recordings. If you do not
> consent to being recorded, discuss your concerns with the host or do not
> join the session.
>
> netmod mailing [email-masked]://www.ietf.org/mailman/listinfo/netmod
>
>

---

From: Nadeau Thomas <[email-masked]>
Date: Thu, 13 Aug 2015 16:14:41 -0400

> On Aug 13, 2015:4:03 PM, at 4:03 PM, Andy Bierman <[email-masked]> wrote:
> 
> 
> 
> On Thu, Aug 13, 2015 at 12:41 PM, Nadeau Thomas <[email-masked] <mailto:[email-masked]>> wrote:
> 
> 
> 
>> On Aug 7, 2015:12:09 PM, at 12:09 PM, Benoit Claise <[email-masked] <mailto:[email-masked]>> wrote:
>> 
>> Dear all,
>> 

	Andy,

	Yes, people should read and understand the proposal. If they don’t like it please come up with a 
viable alternative. If the alternative is to do nothing, then propose that and we will see what the consensus 
is.  If the proposal is to constructively alter parts of their proposal, thats great too.  After we get consensus on 
the general approach, I will manage things issue-by-issue as we are doing with other major initiatives in 
NETMOD.  What we will not do is continue to go round and round about points of their proposal without
coming to any conclusions. We’ve had several interim meetings where they have taken the time to 
discuss and educate everyone that is interested in how their approach works and why.  To-date, there 
are no alternatives being proposed resulting from those discussions - just more debate/discussion.  
What the management is declaring is that the time has come to move forward on this, one way or 
another.

	—Tom

---

From: Ladislav Lhotka <[email-masked]>
Date: Thu, 13 Aug 2015 22:15:39 +0200

> On 13 Aug 2015, at 22:03, Andy Bierman <[email-masked]> wrote:
> 
> 
> 
> On Thu, Aug 13, 2015 at 12:41 PM, Nadeau Thomas <[email-masked]> wrote:
> 
> 
> 

+1

I may be old-fashioned but I would actually prefer to have the discussion mainly in the mailing list.

Lada

>>> Join WebEx meeting
>>> Add this meeting to your calendar.
>>>  
>>> Can't join the meeting? Contact support.
>>>  

--
Ladislav Lhotka, CZ.NIC Labs
PGP Key ID: E74E8C0C

---

From: Andy Bierman <[email-masked]>
Date: Thu, 13 Aug 2015 13:32:42 -0700

On Thu, Aug 13, 2015 at 1:14 PM, Nadeau Thomas <[email-masked]>
wrote:

> is.  If the proposal is to constructively alter parts of their proposal,
> thats great too.  After we get consensus on

It seems somewhat irregular to declare that silence means agreement to
an individual submission (no WG charter, no WG draft).
There has not been a debate. There have been proposals,
and some people not even agreeing with the the problems.
There has been no response why:

  (1) YANG config=true|false is not good enough to filter, and why
        extra NP containers called <config> and <state> are even needed

  (2) YANG constraints written for config=true are not intended to
        be applied to config=false, yet that is exactly what is proposed
         with the replicated config under a <state> container

 (3)  Why a new operation called <get-operational> cannot be used to
       retrieve the actual value in use for /foo
       There is no guessing required to map 1 path to another.
       There is no additional cost for the 90% of devices that
       do not take a long time to apply intended config

I agree with Lada that consensus should be gauged by mailing list
statements (count the number of non-authors that approve or oppose).
This discussion should take place on the mailing list, not another virtual
interim that is outside normal business hours for most of us.

Andy

---

From: Nadeau Thomas <[email-masked]>
Date: Thu, 13 Aug 2015 16:44:00 -0400

> On Aug 13, 2015:4:32 PM, at 4:32 PM, Andy Bierman <[email-masked]> wrote:
> 
> 
> 
> On Thu, Aug 13, 2015 at 1:14 PM, Nadeau Thomas <[email-masked] <mailto:[email-masked]>> wrote:
> 
>> On Aug 13, 2015:4:03 PM, at 4:03 PM, Andy Bierman <[email-masked] <mailto:[email-masked]>> wrote:
>> 
>> 
>> 

	That is how we do the Yang 1.1 design team work right?  The mini-team
makes a recommendation and if no one objects, it goes forward.  Seems
like the same thing to me.  The point is that ample time has been given
for anyone to object.  There is still time now too - but we are limiting that
time so that the WG can move forward with or without this proposal.

> There has not been a debate.

	There have been several interim meetings and this was discussed
at now two full meetings. There have been ample opportunities for debate.

> There have been proposals,

	That was not the outcome of the last interim meeting. If others 
do not agree, then they need to speak up.

	—Tom

---

From: Ashesh Mishra <[email-masked]>
Date: Thu, 13 Aug 2015 14:12:35 -0700

I'm new to this IETF thing, but from my other experiences - silence means "I don't care". "Yes" means "yes".   

"Do nothing ... for now" is a perfectly good response to a proposal that isn't generating the expected interest. 

--
Ashesh

> On Aug 13, 2015, at 1:44 PM, Nadeau Thomas <[email-masked]> wrote:
> 
> 
>> On Thu, Aug 13, 2015 at 1:14 PM, Nadeau Thomas <[email-masked]> wrote:
>>>

---

From: Juergen Schoenwaelder <[email-masked]>
Date: Fri, 14 Aug 2015 00:32:00 +0200

On Thu, Aug 13, 2015 at 04:44:00PM -0400, Nadeau Thomas wrote:
> like the same thing to me.
>

A few things to clarify:

- There is no YANG 1.1 design team. There are virtual interim meetings
  that are open to everyone who wants to participate.  Yes, there is a
  core group of people who participate regularly and are deeply
  engaged. But this does not mean there is an official design team.

- There was WG consensus to work on YANG 1.1 and that consensus has
  become part of the charter of the NETMOD WG.

/js

---

From: Nadeau Thomas <[email-masked]>
Date: Tue, 18 Aug 2015 08:51:07 -0400

BTW Benoit’s note below and the WebEx should serve as the official notification to the WG that we will be having this interim meeting.  It was officially registered with the WG meeting tracker too.  Despite this, someone pointed out the other day that I’d not officially announced it.  Consider this the official announcement of the meeting on September 10, 2015. 

	The rough agenda is to discuss any and all alternatives to the Open Config proposal, and then compare/contrast the differences.  The goal of the meeting is to present a way forward to the WG between choosing to adopt this proposal or not, in whole or part, or to recommend in whole or part, the alternatives. 

	—Tom

> On Aug 7, 2015:11:21 AM, at 11:21 AM, Benoit Claise <[email-masked]> wrote:
> 
> Dear all,
> 
> First of (and let me repeat), I'm happy that the operators gathered and collectively worked on YANG models and related requirements.
> 
> The previous two interim meetings in June on the openconfig issues (draft-openconfig-netmod-opstate-01 <http://datatracker.ietf.org/doc/draft-openconfig-netmod-opstate/> and draft-openconfig-netmod-model-structure-00 <http://datatracker.ietf.org/doc/draft-openconfig-netmod-model-structure/>) were successful in the sense that the requirements are now understood.
> 
> Unfortunately, some key players were not in Prague and we could not finalize the discussion.
> How to represent the operational state is one important guidance from RFC 6087bis that we must be providing to all existing and future YANG models (and not only in the IETF). 
> 
> We need to bring closure on that topic, and this is the plan for that interim meeting in September.
> 
> http://datatracker.ietf.org/doc/draft-openconfig-netmod-opstate/ <http://datatracker.ietf.org/doc/draft-openconfig-netmod-opstate/> has been updated. Please comment on this version.
> Also, any alternate proposals must be prepared for that interim in September. They must be prepared with the same level of rigour as draft-openconfig-netmod-opstate., i.e. must have the same level of details.
>

---

From: Juergen Schoenwaelder <[email-masked]>
Date: Tue, 18 Aug 2015 16:19:33 +0200

Tom,

this may be a useful read...

https://www.ietf.org/iesg/statement/interim-meetings-2000-08-29.html

/js