Subject: Re: [netmod] yang 1.1 last call comment resolution

From: Randy Presuhn <[email-masked]>
Date: Mon, 9 Nov 2015 11:55:41 -0800 (GMT-08:00)

Hi -

>From: Martin Bjorklund <[email-masked]>
>Sent: Nov 9, 2015 10:27 AM
>To: [email-masked]
>Cc: [email-masked]
>Subject: Re: [netmod] yang 1.1 last call comment resolution
...
>> > - Old function: unique module names
>> >
>> >   I think the resolution is to adopt the compromise solution.
>> >
>> 
>> which was what?
>
>The (revised) proposal is:
>
>  The names of all standard modules and submodules MUST be unique.
>  Developers of enterprise modules are RECOMMENDED to choose names for
>  their modules that will have a low probability of colliding with
>  standard or other enterprise modules, e.g., by using the enterprise
>  or organization name as a prefix for the module name.  Witin a
>  server, all module names MUST be unique.

This doesn't make sense from the perspective of the RFC 2119
guidelines.  The choice between MUST and RECOMMENDED is effectively
governed by the question "would failure to comply with this
constraint prevent successful interoperation".  It's *not* a
question of whether the modules are "standard" (does that include
non-IETF efforts?) or "enterprise".  Either they're both "MUST"
or they're both "SHOULD/RECOMMENDED".

Randy

---

From: Andy Bierman <[email-masked]>
Date: Mon, 9 Nov 2015 12:18:41 -0800

On Mon, Nov 9, 2015 at 11:55 AM, Randy Presuhn <[email-masked]
> wrote:

> or they're both "SHOULD/RECOMMENDED".
I agree the first sentence is odd.
It does not include Experimental modules that bypass the WG process,
like the time-capability module.

NEW:

    Developers of YANG modules are RECOMMENDED to choose names for
    their modules that will have a low probability of colliding with
    standard or other enterprise modules, e.g., by using the enterprise
    or organization name as a prefix for the module name.  Within a
    server, all module names MUST be unique.

The YANG guidelines will say that any YANG module in
an RFC MUST have uniqueu module and submodule names.

 Randy

Andy

>
> _______________________________________________
> netmod mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/netmod
>

---

From: Martin Bjorklund <[email-masked]>
Date: Mon, 09 Nov 2015 22:12:15 +0100 (CET)

>     server, all module names MUST be unique.

Ok with me.

> an RFC MUST have uniqueu module and submodule names.

Ok.

/martin