Subject: [netmod] New top-level URN namespace for enterprise YANG module namespaces

From: Ing-Wher Chen <[email-masked]>
Date: Tue, 17 Nov 2015 16:06:26 +0000

Hello,

In the netmod meeting during IETF in Yokohama, there was a
discussion on putting in place a guideline and a shortcut to easily
create globally unique URNs as enterprise YANG module namespaces.
For details, please see
<https://www.ietf.org/proceedings/94/slides/slides-94-netmod-5.pdf> or 
<https://datatracker.ietf.org/doc/draft-chen-netmod-enterprise-yang-namespace/> .
The gist of the proposal is to create globally unique enterprise
YANG module namespaces by creating URNs based on registered
domain names (DNS names), in reverse, e.g. urn:com:example:... .

During the meeting, there was a suggestion to create a new top-level
URN namespace, e.g. "rdns", to which reverse DNSnames are appended.

With a brand new top-level URN namespace, the resulting
enterprise YANG module namespace pattern would be something
like "urn:rdns:com:example:...".

For the new top-level URN namespace, are there any objections 
to using "rdns"?

Thanks,
Helen

---

From: Mahesh Jethanandani <[email-masked]>
Date: Tue, 17 Nov 2015 08:13:44 -0800

> On Nov 17, 2015, at 8:06 AM, Ing-Wher Chen <[email-masked]> wrote:
> 
> to using "rdns”?

One would have to register the top-level URN namespace with IANA.

Mahesh Jethanandani
[email-masked]

---

From: Ing-Wher Chen <[email-masked]>
Date: Tue, 17 Nov 2015 16:18:44 +0000

Thanks for the reminder, Mahesh.

Yes, I understand that some work is necessary and
I am happy to do the leg work.  (I’ve started writing the document.)

Thanks,
Helen

From: Mahesh Jethanandani [mailto:[email-masked]]
Sent: Tuesday, November 17, 2015 11:14 AM
To: Ing-Wher Chen
Cc: [email-masked]
Subject: Re: [netmod] New top-level URN namespace for enterprise YANG module namespaces

On Nov 17, 2015, at 8:06 AM, Ing-Wher Chen <[email-masked]<mailto:[email-masked]>> wrote:

Mahesh Jethanandani
[email-masked]<mailto:[email-masked]>

---

From: Juergen Schoenwaelder <[email-masked]>
Date: Tue, 17 Nov 2015 17:41:21 +0100

> For the new top-level URN namespace, are there any objections 

I think you need to officially allocate such a namespace and I think
there is some kind of 'review board' that reviews allocation requests.
See RFC 3406 as a starting point. Existing registered namespaces
can be found here:

  http://www.iana.org/assignments/urn-namespaces/urn-namespaces.xhtml

/js

-- 
Juergen Schoenwaelder           Jacobs University Bremen gGmbH
Phone: +49 421 200 3587         Campus Ring 1 | 28759 Bremen | Germany
Fax:   +49 421 200 3103         <http://www.jacobs-university.de/>