Subject: [netmod] netmod-opstate-reqs: Are 2.A. and 4.C. the same thing ? (derived + non-derived)

From: "Sterne, Jason (Jason)" <[email-masked]>
Date: Tue, 3 Nov 2015 08:02:11 +0000

Hi all,

In reading through the netmod-opstate-reqs draft I see it is already noted that 5 seems to be a repeat of 4.a.

But isn't 4.C. also a repeat of 2.A. ?

2.A.:  The ability to retrieve the applied configuration and derived state nodes in a single protocol operation.

4.C.: Be able to retrieve both the derived and non-derived state aspects of operational state together.

Or am I missing some subtlety here ?

Jason

---

From: Randy Presuhn <[email-masked]>
Date: Tue, 3 Nov 2015 21:15:04 -0800 (GMT-08:00)

Hi -

> From: "Sterne, Jason (Jason)"
> Sent: Nov 3, 2015 12:02 AM
> To: "[email-masked]"
> Subject: [netmod] netmod-opstate-reqs: Are 2.A. and 4.C. the same thing ? (derived + non-derived)
...
> But isn’t 4.C. also a repeat of 2.A. ?
>
> 2.A.:  The ability to retrieve the applied configuration
> and derived state nodes in a single protocol operation.
>
 
It sounds to me like there are three different sets of information
here:
  - configuration data
  - operational state data that is a function of configuration data
    (it's ambiguous whether it is intended that "derived" means
    something can be computed using *only* configuration data as
    inputs or that additional inputs are possible)
  - operational state data that is not a function of configuration data
    (e.g., chassis temperature, input line voltage, door ajar)

Randy