Subject: Re: [netmod] whitespace characters

From: Randy Presuhn <[email-masked]>
Date: Wed, 30 Dec 2015 11:07:08 -0800 (GMT-08:00)

Hi -

>From: Ladislav Lhotka <[email-masked]>
>Sent: Dec 30, 2015 12:19 AM
>To: Randy Presuhn <[email-masked]>, NETMOD WG <[email-masked]>
>Subject: Re: [netmod] whitespace characters
>
>Randy Presuhn <[email-masked]> writes:
>
>> Hi -
>>
>> This got me thinking - would "U+202A U+202B" thus be a valid
>> argument, distinct from, say, "U+202B U+202A"?
>
>IMO they should be distinct. For "string" type, sec. 9.4.2 in 6020bis
>says that no Unicode normalization is performed. The same should
>probably be stated for string literals appearing in YANG modules.

Even given the semantics of U+202A (left-to-right embedding)?
I understand why they make a difference for strings in general,
but in an enum argument, cases like this seem rather pathological.

Randy

>Lada
>
>>
>> Randy
>>
>>
>> -----Original Message-----
>>>From: Ladislav Lhotka <[email-masked]>
>>>Sent: Dec 28, 2015 12:23 AM
>>>To: NETMOD WG <[email-masked]>
>>>Subject: [netmod] whitespace characters
>>>
>>>Hi,
>>>
>>>the definition of "enum" argument (sec. 9.6.4 in 6020bis) says:
>>>
>>>   The string MUST NOT be empty and MUST NOT have any leading or trailing
>>>   whitespace characters.
>>>
>>>It is not clear what "whitespace character" means. The ABNF indicates this:
>>>
>>>   WSP                 = SP / HTAB
>>>                         ; whitespace
>>>
>>>I think in the "enum" definition LF (and maybe also CR?) should also count as a whitespace character.
>>>
>>>Lada
>>>
>>>--
>>>Ladislav Lhotka, CZ.NIC Labs
>>>PGP Key ID: E74E8C0C
>>>
>>>
>>>
>>>
>>>_______________________________________________
>>>netmod mailing list
>>>[email-masked]
>>>https://www.ietf.org/mailman/listinfo/netmod
>>
>> _______________________________________________
>> netmod mailing list
>> [email-masked]
>> https://www.ietf.org/mailman/listinfo/netmod
>
>-- 
>Ladislav Lhotka, CZ.NIC Labs
>PGP Key ID: E74E8C0C

---

From: Ladislav Lhotka <[email-masked]>
Date: Wed, 30 Dec 2015 22:22:06 +0100

> On 30 Dec 2015, at 20:07, Randy Presuhn <[email-masked]> wrote:
> 
> Hi -
> 

Honestly, I don't know, this seems rather pathological in any case. I just checked programming languages that claim to have decent Unicode handling (Python 3, Haskell), and both consider those two strings non-equal. 

Lada