Subject: Re: [netmod] whitespace characters

From: Randy Presuhn <[email-masked]>
Date: Mon, 28 Dec 2015 10:01:44 -0800 (GMT-08:00)

Hi -

This got me thinking - would "U+202A U+202B" thus be a valid
argument, distinct from, say, "U+202B U+202A"?

Randy

-----Original Message-----
>From: Ladislav Lhotka <[email-masked]>
>Sent: Dec 28, 2015 12:23 AM
>To: NETMOD WG <[email-masked]>
>Subject: [netmod] whitespace characters
>
>Hi,
>
>the definition of "enum" argument (sec. 9.6.4 in 6020bis) says:
>
>   The string MUST NOT be empty and MUST NOT have any leading or trailing
>   whitespace characters.
>
>It is not clear what "whitespace character" means. The ABNF indicates this:
>
>   WSP                 = SP / HTAB
>                         ; whitespace
>
>I think in the "enum" definition LF (and maybe also CR?) should also count as a whitespace character.
>
>Lada
>
>--
>Ladislav Lhotka, CZ.NIC Labs
>PGP Key ID: E74E8C0C
>
>
>
>
>_______________________________________________
>netmod mailing list
>[email-masked]
>https://www.ietf.org/mailman/listinfo/netmod

---

From: Ladislav Lhotka <[email-masked]>
Date: Wed, 30 Dec 2015 09:19:45 +0100

> argument, distinct from, say, "U+202B U+202A"?

IMO they should be distinct. For "string" type, sec. 9.4.2 in 6020bis
says that no Unicode normalization is performed. The same should
probably be stated for string literals appearing in YANG modules.

Lada