Subject: Re: [netmod] YANG 1.1 conformance announcement

From: Ladislav Lhotka <[email-masked]>
Date: Thu, 03 Mar 2016 14:07:42 +0100

Andy Bierman <[email-masked]> writes:

> Hi,
>
> Buried in the many NETCONF-specific sections is a requirement to
> announce the YANG library info.  However this info is incomplete
> and sec. 5.6.5 needs to be changed because it assumes there is only
> 1 revision of the ietf-yang-library module possible.   The client cannot
> read the read the library to find out which revision of the library template
> to use.
>

This is because yang-library is really meta-data and requires special
treatment even if we pretend it is just another part of the data tree.

>
>
>
> 5.6.5.  Announcing Conformance Information in NETCONF
>
>    This document defines the following mechanism for announcing
>    conformance information.  Other mechanisms may be defined by future
>    specifications.
>
>    A NETCONF server announces the modules it implements by implementing
>    the YANG module "ietf-yang-library" defined in
>    [I-D.ietf-netconf-yang-library], and listing all implemented modules
>    in the "/modules-state/module" list.
>
>
> OLD:
>
>    The server also advertises the following capability in the <hello>
>    message (line-breaks and whitespaces are used for formatting reasons
>    only):
>
>      urn:ietf:params:netconf:capability:yang-library:1.0?
>        module-set-id=<id>
>
>    The parameter "module-set-id" has the same value as the leaf
>    "/modules-state/module-set-id" from "ietf-yang-library".  This
>    parameter MUST be present.
>
> NEW:
>
>    The server also advertises the following capability in the <hello>
>    message (line-breaks and whitespaces are used for formatting reasons
>    only):
>
>      urn:ietf:params:netconf:capability:yang-library:1.0?
>        revision=<date>&module-set-id=<id>
>
>    The parameter "revision" has the same value as the revision
>    date of the "ietf-yang-library" implemented by the server. This
>  parameter MUST be present.
>

I agree.

But what about RESTCONF? How can a client learn which revision of
yang-library data the server uses?

Lada

>
> The parameter "module-set-id" has the same value as the leaf
> "/modules-state/module-set-id" from "ietf-yang-library". This parameter
> MUST be present.
>
>
>
> Andy
> _______________________________________________
> netmod mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/netmod

-- 
Ladislav Lhotka, CZ.NIC Labs
PGP Key ID: E74E8C0C

---

From: Martin Bjorklund <[email-masked]>
Date: Mon, 07 Mar 2016 09:31:23 +0100 (CET)

> >  parameter MUST be present.

Yes, this is a good enhancement.  I will apply this change.

/martin