Subject: [netmod] I-D Action: draft-ietf-netmod-syslog-model-07.txt

From: [email-masked]
Date: Sun, 20 Mar 2016 08:10:06 -0700

A New Internet-Draft is available from the on-line Internet-Drafts directories.
This draft is a work item of the NETCONF Data Modeling Language of the IETF.

        Title           : SYSLOG YANG Model
        Authors         : Clyde Wildes
                          Kiran Koushik
	Filename        : draft-ietf-netmod-syslog-model-07.txt
	Pages           : 34
	Date            : 2016-03-20

Abstract:
   This document describes a data model for the Syslog protocol which is
   used to convey event notification messages.

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-ietf-netmod-syslog-model/

There's also a htmlized version available at:
https://tools.ietf.org/html/draft-ietf-netmod-syslog-model-07

A diff from the previous version is available at:
https://www.ietf.org/rfcdiff?url2=draft-ietf-netmod-syslog-model-07

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org.

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

---

From: "Clyde Wildes (cwildes)" <[email-masked]>
Date: Sun, 20 Mar 2016 18:53:25 +0000

Hi,

This revision incorporates feedback from Martin Bjorklunk (19 comments) and Tom Petch (10 comments). Thanks to both of you for your valuable feedback!

Regarding Tom's comment - "4.1 What a lot of features?  Again, makes things more complex, more error prone - are they all really needed?": We started the draft two years ago and it has evolved from feedback received from all of the folks that appear in the Acknowledgements section. Please review the current draft where I believe that I address all of your comments except possibly this one. The tradeoff is to leave the feature specific functionality out of the draft and leave it to the implementations to add back through augmentation. That said most of the features that are called out have been implemented by at least two vendors, but not all, leading to the feature designation.

Thanks,

Clyde

On 3/20/16, 8:10 AM, "netmod on behalf of [email-masked]" <[email-masked] on behalf of [email-masked]> wrote:

>_______________________________________________
>netmod mailing list
>[email-masked]
>https://www.ietf.org/mailman/listinfo/netmod

---

From: t.petch <[email-masked]>
Date: Mon, 28 Mar 2016 18:09:54 +0100

----- Original Message -----
From: "Clyde Wildes (cwildes)" <[email-masked]>
To: <[email-masked]>
Cc: "Martin Bjorklund" <[email-masked]>; "t.petch"
<[email-masked]>; "Kiran Koushik Agrahara Sreenivasa (kkoushik)"
<[email-masked]>
Sent: Sunday, March 20, 2016 7:53 PM

> Hi,
>
> This revision incorporates feedback from Martin Bjorklunk (19
comments) and Tom Petch (10 comments). Thanks to both of you for your
valuable feedback!
>
> Regarding Tom's comment - "4.1 What a lot of features?  Again, makes
things more complex, more error prone - are they all really needed?": We
started the draft two years ago and it has evolved from feedback
received from all of the folks that appear in the Acknowledgements
section. Please review the current draft where I believe that I address
all of your comments except possibly this one. The tradeoff is to leave
the feature specific functionality out of the draft and leave it to the
implementations to add back through augmentation. That said most of the
features that are called out have been implemented by at least two
vendors, but not all, leading to the feature designation.

Clyde

Yeeees; I did a separate post on the topic thinking that an implementor
might share my concerns about the large number of possible variations in
an implementation when there were a large number of features, that
perhaps there should be guidelines about it, but it did not get any
traction.  It is one those issues where I think, in a year or two's
time, others might share my concern, but not yet:-(.

I don't doubt that the variation exists and needs modelling, just that
such use of 'features' may have unfortunate consequences - but I have no
alternative suggestion.

Tom Petch

> Thanks,
>
> Clyde
>
>
>
> On 3/20/16, 8:10 AM, "netmod on behalf of [email-masked]"

---

From: "Clyde Wildes (cwildes)" <[email-masked]>
Date: Mon, 28 Mar 2016 19:57:11 +0000

Tom,

I understand your concern with the complexity of the model. That said, as we progressed we encountered some vendors and some IETF RFC authors who requested that a particular feature of interest be included. We felt that we had to make features that were not implemented by two or more vendors a YANG feature to gain acceptance. Which is preferred in this case: augmentation to add features; deviation not-supported statements to remove features; or the use of feature statements? During early model development our YANG doctor advisor advocated using feature.

I read your post on "features - a Cartesian explosion" post. Note that in the case of the latest ietf-syslog model four of the features are nested such that they are not encountered unless a higher level feature is enabled. 

What would your preference be:
- remove the feature statements and ask vendors to supply deviation statements for those leaves not implemented
- remove all leaves conditioned by feature and ask vendors to supply annotated models with augmentation
- leave things as they are

It sounds like B would be your preference?

Thanks,

Clyde

---

From: Andy Bierman <[email-masked]>
Date: Mon, 28 Mar 2016 13:32:34 -0700

On Mon, Mar 28, 2016 at 12:57 PM, Clyde Wildes (cwildes) <[email-masked]>
wrote:

> Tom,
>
> I understand your concern with the complexity of the model. That said, as
> we progressed we encountered some vendors and some IETF RFC authors who
> requested that a particular feature of interest be included. We felt that
> we had to make features that were not implemented by two or more vendors a
> YANG feature to gain acceptance. Which is preferred in this case:
> augmentation to add features; deviation not-supported statements to remove
> features; or the use of feature statements? During early model development
> our YANG doctor advisor advocated using feature.
>
> I read your post on "features - a Cartesian explosion" post. Note that in
> the case of the latest ietf-syslog model four of the features are nested
> such that they are not encountered unless a higher level feature is enabled.
>
> - remove the feature statements and ask vendors to supply deviation
> statements for those leaves not implemented
I agree with Tom.
IMO if the functionality is not supported by at least 2 vendors then
remove it from the standard.  The vendor can write a module
that augments the  base module.

Thanks,
> Clyde

Andy

---

From: "Kiran Koushik Agrahara Sreenivasa (kkoushik)" <[email-masked]>
Date: Mon, 28 Mar 2016 20:55:09 +0000

Hi Andy
We did solicit and incorporate feature support from at least 5+ vendors for this model.
The model represents a minimal common feature set. They are also hierarchical as Clyde noted below.

Thanks
Kiran

From: Andy Bierman <[email-masked]<mailto:[email-masked]>>
Date: Monday, March 28, 2016 at 3:32 PM
To: "Clyde Wildes (cwildes)" <[email-masked]<mailto:[email-masked]>>
Cc: "t.petch" <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>, Kiran Koushik Agrahara Sreenivasa <[email-masked]<mailto:[email-masked]>>
Subject: Re: [netmod] I-D Action: draft-ietf-netmod-syslog-model-07.txt

On Mon, Mar 28, 2016 at 12:57 PM, Clyde Wildes (cwildes) <[email-masked]<mailto:[email-masked]>> wrote:
Tom,

I agree with Tom.

Thanks,

Clyde

Andy

On 3/28/16, 10:09 AM, "t.petch" <[email-masked]<mailto:[email-masked]>> wrote:

>From: "Clyde Wildes (cwildes)" <[email-masked]<mailto:[email-masked]>>
>To: <[email-masked]<mailto:[email-masked]>>
>Cc: "Martin Bjorklund" <[email-masked]<mailto:[email-masked]>>; "t.petch"
><[email-masked]<mailto:[email-masked]>>; "Kiran Koushik Agrahara Sreenivasa (kkoushik)"
><[email-masked]<mailto:[email-masked]>>
>> On 3/20/16, 8:10 AM, "netmod on behalf of [email-masked]<mailto:[email-masked]>"
><[email-masked]<mailto:[email-masked]> on behalf of [email-masked]<mailto:[email-masked]>> wrote:
>>
>> >
>> >until the htmlized version and diff are available at tools.ietf.org<http://tools.ietf.org>.
>> >
>> >[email-masked]<mailto:[email-masked]>
_______________________________________________
netmod mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/netmod