Subject: [netmod] Fwd: Re: [Rtg-dt-yang-arch] I-D Action: draft-rtgyangdt-rtgwg-device-model-03.txt

From: Benoit Claise <[email-masked]>
Date: Fri, 4 Mar 2016 11:27:23 +0100

Dear all,

This draft is extremely important because it doesn't only cover routing 
information but it wants to impose a structure for all YANG models. 
Please review and comment.

Regards, Benoit
-------- Forwarded Message --------
Subject: 	Re: [Rtg-dt-yang-arch] I-D Action: 
draft-rtgyangdt-rtgwg-device-model-03.txt
Date: 	Thu, 25 Feb 2016 17:55:31 +0000
From: 	Jeff Tantsura <[email-masked]>
To: 	Lou Berger <[email-masked]>
CC: 	Routing Area YANG Architecture DT <[email-masked]>, 
Routing WG <[email-masked]>

Hi RTGWG,

Given the importance of the document, please do review and provide your comments, suggestions and in case you wouldn't support it as is  - what should be changed/missing.

Thanks!

Regards,
Jeff

> On Feb 23, 2016, at 6:40 PM, Lou Berger <[email-masked]> wrote:
>
>
> Hello,
>    This draft has been updated to use an emerging yang  capability
> called 'schema-mount' [1] which translates to a significant
> simplification.  To quote the draft:
>
>   Schema Mount enables a dramatic simplification of the presented
>   device model, particularly for "lower-end" devices which are unlikely
>   to support multiple network instances or logical network elements.
>   Should structural-mount/YSDL not be available, the more explicit tree
>   structure presented in earlier versions of this document will need to
>   be utilized.
>
> As it looks like there will soon be a netmod WG draft on schema mount,
> we think it's time to ask the WG to consider adopting our draft as a RTG
> WG draft.
>
> [1] There was a netmod interim on schema mount on Monday, see
> http://etherpad.tools.ietf.org:9000/p/netmod-interim-20160222
>
> Our slides from that meeting are available at
> https://www.ietf.org/proceedings/interim/2016/02/22/netmod/slides/slides-interim-2016-netmod-1-1.pptx
> and it gives a brief overview of the current draft.
>
> Lou (and co-authors)
> -------- Forwarded Message --------
> Subject:    I-D Action: draft-rtgyangdt-rtgwg-device-model-03.txt
> Date:    Tue, 23 Feb 2016 18:29:51 -0800
> From:    [email-masked]
> Reply-To:    [email-masked]
> To:    [email-masked]
>
>
>
> A New Internet-Draft is available from the on-line Internet-Drafts directories.
>
>
>        Title           : Network Device YANG Organizational Models
>        Authors         : Acee Lindem
>                          Lou Berger
>                          Dean Bogdanovic
>                          Christan Hopps
>    Filename        : draft-rtgyangdt-rtgwg-device-model-03.txt
>    Pages           : 36
>    Date            : 2016-02-23
>
> Abstract:
>   This document presents an approach for organizing YANG models in a
>   comprehensive structure that may be used to configure and operate
>   network devices.  The structure is itself represented as a YANG
>   model, with all of the related component models logically organized
>   in a way that is operationally intuitive, but this model is not
>   expected to be implemented.  The identified component modules are
>   expected to be defined and implemented on common network devices.
>
>   This document also defines two modules that can be used to model the
>   logical and virtual resource representations that may be present on a
>   network device.  Examples of common industry terms for logical
>   resource representations are Logical Systems or Routers.  Examples of
>   of common industry terms for virtual resource representations are
>   Virtual Routing and Forwarding (VRF) instances and Virtual Switch
>   Instances (VSIs).
>
>   This document is derived from work submitted to the IETF by members
>   of the informal OpenConfig working group of network operators and is
>   a product of the Routing Area YANG Architecture design team.
>
>
> The IETF datatracker status page for this draft is:
> https://datatracker.ietf.org/doc/draft-rtgyangdt-rtgwg-device-model/
>
> There's also a htmlized version available at:
> https://tools.ietf.org/html/draft-rtgyangdt-rtgwg-device-model-03
>
> A diff from the previous version is available at:
> https://www.ietf.org/rfcdiff?url2=draft-rtgyangdt-rtgwg-device-model-03
>
>
> Please note that it may take a couple of minutes from the time of submission
> until the htmlized version and diff are available at tools.ietf.org.
>
> Internet-Drafts are also available by anonymous FTP at:
> ftp://ftp.ietf.org/internet-drafts/
>
> _______________________________________________
> I-D-Announce mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/i-d-announce
> Internet-Draft directories: http://www.ietf.org/shadow.html
> or ftp://ftp.ietf.org/ietf/1shadow-sites.txt
>
>
>
>
> _______________________________________________
> rtgwg mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/rtgwg

_______________________________________________
Rtg-dt-yang-arch mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/rtg-dt-yang-arch
.

---

From: Juergen Schoenwaelder <[email-masked]>
Date: Fri, 4 Mar 2016 11:33:44 +0100

Is the rtgyangdt chartered to define a structure that potentially
affects all YANG models produced in the IETF?

/js

On Fri, Mar 04, 2016 at 11:27:23AM +0100, Benoit Claise wrote:
> Given the importance of the document, please do review and provide your 
> comments, suggestions and in case you wouldn't support it as is  - what 
> should be changed/missing.
> 
> Thanks!
> 
> Regards,
> Jeff
> 

> netmod mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/netmod

-- 
Juergen Schoenwaelder           Jacobs University Bremen gGmbH
Phone: +49 421 200 3587         Campus Ring 1 | 28759 Bremen | Germany
Fax:   +49 421 200 3103         <http://www.jacobs-university.de/>

---

From: Kent Watsen <[email-masked]>
Date: Fri, 4 Mar 2016 12:49:40 +0000

We're already on it.  This draft was discussed on the NETMOD virtual interim meeting last week.  It is what is spurring the schema mount drafts and discussions of late.  

Thanks,
Kent

> On Mar 4, 2016, at 5:33 AM, Juergen Schoenwaelder <[email-masked]> wrote:
>

---

From: Lou Berger <[email-masked]>
Date: Fri, 04 Mar 2016 07:58:23 -0500

...and schema mount enables *avoiding* a restrictive model that will impact 
all models. Which is why it's such an important construct.

Lou

On March 4, 2016 7:50:20 AM Kent Watsen <[email-masked]> wrote:

>
> We're already on it.  This draft was discussed on the NETMOD virtual 
> interim meeting last week.  It is what is spurring the schema mount drafts 
> and discussions of late.
>
> Thanks,
> Kent
>
>> On Mar 4, 2016, at 5:33 AM, Juergen Schoenwaelder 
>> <[email-masked]> wrote:
>>

---

From: Juergen Schoenwaelder <[email-masked]>
Date: Fri, 4 Mar 2016 14:24:57 +0100

I do not know what 'we are already on it' means. I am aware of [1] and
it says:

    [...] Although this is a concern across the entire scope of YANG
    models, this design team is focused on the question of providing
    an architecture for the protocols and functionality contained
    inside the Routing Area.

I understand that there are valuable discussions in NETMOD that were
triggered by this work of this design team, e.g., how to deal with
virtual (routing) instances. I am less clear when it comes to the
definition of a general 'uebermodel' for network devices that affects
all YANG models (in the IETF or even beyond). Who is charted to define
such a model?

/js

[1] http://wiki.tools.ietf.org/area/rtg/trac/wiki/RtgYangArchDT

---

From: t.petch <[email-masked]>
Date: Thu, 10 Mar 2016 12:25:12 +0000

----- Original Message -----
From: "Juergen Schoenwaelder" <[email-masked]>
To: "Benoit Claise" <[email-masked]>
Cc: <[email-masked]>; "NETMOD Working Group"
<[email-masked]>
Sent: Friday, March 04, 2016 10:33 AM
Subject: Re: [netmod] Fwd: Re: [Rtg-dt-yang-arch] I-D Action:
draft-rtgyangdt-rtgwg-device-model-03.txt

> affects all YANG models produced in the IETF?

Even if it were so chartered, I question the competence of it to do so.
The vast majority of managed devices in the world are not network
devices (for any widely used management architecture).  One of the
weaknesses of SNMP is that it started life as routing only, and had all
the other managed devices added later so the structure has never been
quite right for the common case (unless you are only concerned with the
routing area).

This I-D does make it clear how limited it is
"we consider network devices that support protocols
   and functions defined within the IETF Routing Area"
so it is clearly excluding most managed devices.

It is understandable, if unfortunate, that SNMP suffers from having
started out with a limited remit.  It would be unforgiveable to build
that limitation into YANG.

Tom Petch

---

From: "Acee Lindem (acee)" <[email-masked]>
Date: Thu, 10 Mar 2016 15:38:34 +0000

Hey Tom, 

>that limitation into YANG.

One of the primary YANG Routing Design Team work items is to advance
mechanisms (structural mount or YSDL) to allow placement of IETF YANG
modules at different levels of the device hierarchy dependent on the
requirements of that device.  I think this is consistent with making YANG
and, even the IETF data models, reusable for any class of the device.
However, the device targeted in the device model draft is, in fact, a
carrier class networking device. I believe it would be foolish to try and
define a “one size fits all” device model.

Thanks,
Acee