Subject: Re: [netmod] call for consensus to adopt draft-wilton-netmod-intf-ext-yang as NETMOD WG draft

From: Ladislav Lhotka <[email-masked]>
Date: Wed, 2 Mar 2016 15:44:42 +0100

> On 01 Mar 2016, at 00:07, Kent Watsen <[email-masked]> wrote:
> 
> 
> The chairs were just reviewing notes and realized that this thread never closed properly.
> 
> Juergen has some concerns regarding realistic milestones, that were never addressed.  Robert, can you please try to address Juergen’s concerns now?
> 
> Also, there were only a two responses before indicating willingness to review the draft as it progresses (thanks Dan and Martin).  Can others that support this draft and willing to review this draft say so?

Sorry I haven't responded earlier. I support adopting this document as a WG item, and I will review it.

Lada

> 
> Thanks,
> Netmod Chairs
> 
> 
> From: netmod <[email-masked]> on behalf of Kent Watsen <[email-masked]>
> Date: Tuesday, December 15, 2015 at 11:48 AM
> To: "[email-masked]" <[email-masked]>
> Subject: [netmod] call for consensus to adopt draft-wilton-netmod-intf-ext-yang as NETMOD WG draft
> 
> 
> The minutes for IETF 94 show that there was in-room support for adopting draft-wilton-netmod-intf-ext-yang as a WG draft.   The minutes also show that this decision would be confirmed on the mailing list, which I am doing now.  
> 
> Should we move to adopt draft-wilton-netmod-intf-ext-yang as a WG item and correspondingly add this to the WG charter as a milestone?  Please comment by Tuesday, December 22, 2015 at 9AM EST at which time the WG Chairs will gauge whether or not there is consensus to move forward with the document.
> 
> Thanks,
> Kent
> 
> 
> _______________________________________________
> netmod mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/netmod

--
Ladislav Lhotka, CZ.NIC Labs
PGP Key ID: E74E8C0C

---

From: Robert Wilton <[email-masked]>
Date: Wed, 2 Mar 2016 16:00:51 +0000

Hi Kent,

Re-reading Juergen's email, I think that his main concern was whether 
there would be sufficient reviewers of this draft.  It is slightly 
tricky because this draft is covering configuration that I believe many 
network device vendors require and support to make their devices 
function in a sensible fashion, but are not standardized anywhere 
because until YANG came along there has been little need to do so (since 
the features don't generally need to inter-operate between devices).

In terms of milestones, I agree with Juergen, that it is really the 
cross reviews from other device vendors that is most important. I.e. to 
confirm that these configuration knobs are generally applicable to a 
broad set of devices.  So I would think that the next steps would 
consist of:
  - confirmation that this configuration is generally common across vendors.
  - check whether there is any other common interface level 
configuration that is missing and should also be covered.
  - see if it is possible to agree on some more concrete default values 
for some of the settings.
  - see if there is any additional operational state that should also be 
made available.  I think that it is likely that some needs to be added.
  - see if any further explanation or documentation of the defaults 
described in this draft are required.

However, I don't think that this really should end up being a large YANG 
module, or that it should take a particularly long time to standardize, 
presuming that we can get the reviews and agreement of course.

Does that help clarify your/Juergen's concerns?

Thanks,
Rob

On 29/02/2016 23:07, Kent Watsen wrote:
> Juergen has some concerns regarding realistic milestones, that were 
> never addressed.  Robert, can you please try to address Juergen’s 
> concerns now?
>
> Also, there were only a two responses before indicating willingness to 
> review the draft as it progresses (thanks Dan and Martin).  Can others 
> that support this draft and willing to review this draft say so?
>
> Thanks,
> Netmod Chairs
>
>
> From: netmod <[email-masked] 
> <mailto:[email-masked]>> on behalf of Kent Watsen 
> <[email-masked] <mailto:[email-masked]>>
> To: "[email-masked] <mailto:[email-masked]>" <[email-masked] 
> <mailto:[email-masked]>>
> Subject: [netmod] call for consensus to adopt 
> draft-wilton-netmod-intf-ext-yang as NETMOD WG draft
>
>
> The minutes for IETF 94 show that there was in-room support for 
> adopting draft-wilton-netmod-intf-ext-yang as a WG draft.   The 
> minutes also show that this decision would be confirmed on the mailing 
> list, which I am doing now.
>
> Should we move to adopt draft-wilton-netmod-intf-ext-yang as a WG item 
> and correspondingly add this to the WG charter as a milestone?  Please 
> comment by Tuesday, December 22, 2015 at 9AM EST at which time the WG 
> Chairs will gauge whether or not there is consensus to move forward 
> with the document.
>
> Thanks,
> Kent
>
>
>
>

---

From: "Zhuangyan (Yan)" <[email-masked]>
Date: Tue, 8 Mar 2016 03:25:36 +0000

Sorry for the late response. It took some time to review this draft and models.  And Yes, I support adopting this document as a WG item.

To me, the common model is something useful. There perhaps some overlaps in Ethernet-like model with things in IEEE. If yes, we’ll see how to cooperate.

Best Regards,

Yan

发件人: netmod [mailto:[email-masked]] 代表 Kent Watsen
发送时间: 2016年3月1日 7:07
收件人: [email-masked]
主题: Re: [netmod] call for consensus to adopt draft-wilton-netmod-intf-ext-yang as NETMOD WG draft

Thanks,
Netmod Chairs

From: netmod <[email-masked]<mailto:[email-masked]>> on behalf of Kent Watsen <[email-masked]<mailto:[email-masked]>>
Date: Tuesday, December 15, 2015 at 11:48 AM
To: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Subject: [netmod] call for consensus to adopt draft-wilton-netmod-intf-ext-yang as NETMOD WG draft

Thanks,
Kent

---

From: "Romascanu, Dan (Dan)" <[email-masked]>
Date: Tue, 8 Mar 2016 12:06:02 +0000

Hi,

Concerning cooperation with the IEEE, we have in place a mechanism of communication between the IETF and IEEE 802. Mahesh Jethanadani and myself are involved. The key thing is to send information about important milestones (like Last Calls) to the IEEE, it can be done via email, no need for formal liaison messages. If we identify tougher issues (like duplication, or inconsistencies) we can set small shared teams to work things out.

Regards,

Dan

From: netmod [mailto:[email-masked]] On Behalf Of Zhuangyan (Yan)
Sent: Tuesday, March 08, 2016 5:26 AM
To: Kent Watsen; [email-masked]
Subject: Re: [netmod] call for consensus to adopt draft-wilton-netmod-intf-ext-yang as NETMOD WG draft

Best Regards,

Yan

发件人: netmod [mailto:[email-masked]] 代表 Kent Watsen
发送时间: 2016年3月1日 7:07
收件人: [email-masked]<mailto:[email-masked]>
主题: Re: [netmod] call for consensus to adopt draft-wilton-netmod-intf-ext-yang as NETMOD WG draft

Thanks,
Netmod Chairs

Thanks,
Kent

---

From: Athanasios Kyparlis <[email-masked]>
Date: Tue, 8 Mar 2016 19:01:08 +0000

Sorry for the delayed response. I support adopting this document as a WG item and I will participate in further reviews. 

Thanks,
Athanasios Kyparlis

-----Original Message-----
From: netmod [mailto:[email-masked]] On Behalf Of Ladislav Lhotka
Sent: Wednesday, March 2, 2016 9:45 AM
To: Kent Watsen <[email-masked]>
Cc: [email-masked]
Subject: Re: [netmod] call for consensus to adopt draft-wilton-netmod-intf-ext-yang as NETMOD WG draft

Lada