Subject: [netmod] yang-next

From: Kent Watsen <[email-masked]>
Date: Fri, 11 Mar 2016 02:12:58 +0000

All,

I see too many emails go by where someone has an idea that they’d like to get into a future version of YANG, and keep wishing that there were an easy way to capture these feature requests.  With that in mind I created a new Github repository called "yang-next”.    This repository is not for a draft, yet, its current existence is solely to have a publicly editable issue tracker.   Please feel free to add all your good ideas (just one idea per issue please) here: https://github.com/netmod-wg/yang-next/issues.

Cheers,
Kent

---

From: "Alexander Clemm (alex)" <[email-masked]>
Date: Fri, 11 Mar 2016 02:29:08 +0000

How about calling it YANGNG?
Cheers
--- Alex

From: netmod [mailto:[email-masked]] On Behalf Of Kent Watsen
Sent: Thursday, March 10, 2016 6:13 PM
To: [email-masked]
Subject: [netmod] yang-next

All,

Cheers,
Kent

---

From: Kent Watsen <[email-masked]>
Date: Fri, 11 Mar 2016 02:40:13 +0000

I was just thinking about how we always talk about yang-1.1, yang-1.2, yang-2.0, so I figured yang-next  ;)

From: "Alexander Clemm (alex)" <[email-masked]<mailto:[email-masked]>>
Date: Thursday, March 10, 2016 at 9:29 PM
To: Kent Watsen <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Subject: RE: yang-next

From: netmod [mailto:[email-masked]] On Behalf Of Kent Watsen
Sent: Thursday, March 10, 2016 6:13 PM
To: [email-masked]<mailto:[email-masked]>
Subject: [netmod] yang-next

All,

Cheers,
Kent

---

From: Martin Bjorklund <[email-masked]>
Date: Fri, 11 Mar 2016 11:17:49 +0100 (CET)

Hi,

Kent Watsen <[email-masked]> wrote:
> 
> All,
> 
> I see too many emails go by where someone has an idea that they’d like
> to get into a future version of YANG, and keep wishing that there were
> an easy way to capture these feature requests.  With that in mind I
> created a new Github repository called "yang-next”.  This repository
> is not for a draft, yet, its current existence is solely to have a
> publicly editable issue tracker.  Please feel free to add all your
> good ideas (just one idea per issue please) here:
> https://github.com/netmod-wg/yang-next/issues.

I think it is a good idea to capture ideas like this, but I also think
that such ideas should be discussed on the ML.  But maybe that's what
you meant.

/martin

---

From: t.petch <[email-masked]>
Date: Fri, 11 Mar 2016 12:10:09 +0000

One of my comments on syslog was that it had 10 features.  Assuming that
each can be present or absent, that would seem to allow over 1000
different possible implementations, almost all of which will likely
never be seen in the field.

And yet, if there are 1000 possible implementations, does not that mean
having to code 1000 different paths, having to test 1000 different
possibilities, never having two interworking boxes unless they are the
same model with the same software level from the same manufacturer?

It is so easy to add 'feature' to a YANG model; is some restraint called
for?

Tom Petch

---

From: Kent Watsen <[email-masked]>
Date: Fri, 11 Mar 2016 15:23:46 +0000

>that such ideas should be discussed on the ML.  But maybe that's what

My thought is to defer any discussion on the ML until we actually want to start working on yang-next.  That said, it would be good to ensure that any issues posted in the interim are suitably captured; that what’s being asked for is clearly understood.   Of course, we could at a later point in time reach out to the github userid to ask for a clarification and, in the case of no response, either do our best or drop it.  To me, it is sufficient to just capture the ideas, with no discussion happening until later and then, of course, they would be on the ML.

Thanks,
Kent

---

From: Lou Berger <[email-masked]>
Date: Fri, 11 Mar 2016 11:11:34 -0500

I tried and failed to  the repo to email events to the list.

If anyone knows how to do this, please send mail to [email-masked].

Thanks,
Lou

On 3/11/2016 5:17 AM, Martin Bjorklund wrote:
> that such ideas should be discussed on the ML.