Subject: [netmod] Broadband Forum questions about announcing capabilities

From: William Lupton <[email-masked]>
Date: Fri, 11 Mar 2016 10:14:26 +0000

All,

BBF has a question about how to announce capabilities. This is illustrated by a specific example but it’s a general question. There is some overlap with past “Broadband Forum questions on RFC 6087bis <https://mailarchive.ietf.org/arch/msg/netmod/T72fHGcPOj4H7zLDvR3yj9iKWB0>” and “Restricting interface name maximum length and character set <https://mailarchive.ietf.org/arch/msg/netmod/8cHqqp8r4RJR1uSpJ_x2T-XkTOQ>” threads.

Here’s the example. We have a list of profiles and we want the server to be able to indicate the maximum number of supported profiles. The two ways that we have considered doing this are:
Add a leaf that indicates the maximum number of supported profiles.
Use a deviation to indicate max-elements on the profile list.

We have got the impression from the RFCs and past discussion (cited above) that NETMOD’s preferred approach is the first one, and you would not approve of the second one. Is that correct? Any other thoughts?

Note that use of deviations in this way is not contravening RFC 6020bis’s “deviations MUST never be part of a published standard” because our published YANG will not include deviations. We would be using them only in the sense that they would be the recommended way for an implementation to announce its capabilities. Strictly (in the example given above) this is a deviation from the standard because an unspecified max-elements statement defaults to “unbounded”.

Thanks,
William Lupton

---

From: "Bogaert, Bart (Nokia - BE)" <[email-masked]>
Date: Fri, 11 Mar 2016 10:43:00 +0000

Hi,

It is my understanding that “narrowing” the possibilities (e.g. range) of a leaf is acceptable and even the Best Practices document RFC6087bis-05 suggests this in section 5.19.  So why would this approach not be approved? These limitations could be the result of e.g. memory constraints of the box and one might want to expose this to the client accepting configurations changes in case the target device would temporarily not be available (some kind of pre-provisioning by the NETCONF client running on a network management platform).

Best regards - Vriendelijke groeten,

Bart Bogaert

System Architect Data-Centric SW Architectures 

Fixed Networks - Broadband Access BU,  Nokia

Contact number +32 3 2408310 (+32 477 673952)

From: netmod [mailto:[email-masked]] On Behalf Of EXT William Lupton
Sent: 11 March 2016 11:14
To: [email-masked]
Subject: [netmod] Broadband Forum questions about announcing capabilities

All,

BBF has a question about how to announce capabilities. This is illustrated by a specific example but it’s a general question. There is some overlap with past “Broadband Forum questions on RFC 6087bis <https://mailarchive.ietf.org/arch/msg/netmod/T72fHGcPOj4H7zLDvR3yj9iKWB0> ” and “Restricting interface name maximum length and character set <https://mailarchive.ietf.org/arch/msg/netmod/8cHqqp8r4RJR1uSpJ_x2T-XkTOQ> ” threads.

1.	Add a leaf that indicates the maximum number of supported profiles.
2.	Use a deviation to indicate max-elements on the profile list.

Thanks,

William Lupton