Subject: Re: [netmod] WG Last Call: draft-ietf-netmod-syslog-model-06

From: t.petch <[email-masked]>
Date: Tue, 8 Mar 2016 17:48:05 +0000

I have reviewed this and do not believe it is ready for publication.

- draft appears in several places

- TBD occurs in one

- it would seem that there are two modules in this I-D but only one is
registered in s.7

- in s.7 I read
        prefix: syslog reference:
which I found odd - ah, it means
        prefix: syslog
        reference:
formatting could be better.

- VRF I know what it means but do not know if your definition is the
same as mine - is there a definition anywhere in an RFC to reference?

- s.3
" The following digram shows syslog messages
   flowing from a message producer, through the group level suppression
   filter, and if passed by the group filter to message distributors
where
   further suppression filtering can take place."
Well yes, I see a digram of message producer and message distributors
but no group level suppression filter (which would, I suppose, make it a
trigram)

- s.3.1 what is the merit of using this explanation of the module as
opposed to the standard one?

 - enumeration {selector-severity-operator-config}?
   string {selector-match-processing-config}?

spill over the line (many times) which reflects the fact that they are
looooong - I think that this does not aid understanding nor accuracy of
implementation

4.1   prefix syslogtypes;
again, long, especially for a prefix

WG Chairs - who are they at present?  I have lost track:-)

4.1 What a lot of features?  Again, makes things more complex, more
error prone - are they all really needed?

I have to get into the detail of the module.

Tom Petch

----- Original Message -----
From: "Lou Berger" <[email-masked]>
To: "netmod WG" <[email-masked]>
Cc: <[email-masked]>; <[email-masked]>
Sent: Monday, February 29, 2016 8:50 PM
Subject: [netmod] WG Last Call: draft-ietf-netmod-syslog-model-06

> All,
> This starts a two-week working group last call on
> draft-ietf-netmod-syslog-model-06.
>
> The working group last call ends on March 14. Please send your
comments
> to the netmod mailing list.
>
> Positive comments, e.g., "I've reviewed this document and
> believe it is ready for publication", are welcome!
> This is useful and important, even from authors.
>
> Thank you,
> Netmod Chairs
>
> _______________________________________________
> netmod mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/netmod

---

From: Lou Berger <[email-masked]>
Date: Thu, 10 Mar 2016 16:57:59 -0500

All,
    It looks like we've already received sufficient comments that
indicate that the document isn't ready for publication.  Given the
comments, we're looking to the authors to address comments received and
any more that may be forthcoming.  We're ending a little early to give
the authors extra time before the meeting cut-off to address comments in
a draft update that, hopefully, can be discussed in BA. 

Thank you,

Lou (and Kent)

On 2/29/2016 3:50 PM, Lou Berger wrote:
> The working group last call ends on March 14. Please send your comments

---

From: "Clyde Wildes (cwildes)" <[email-masked]>
Date: Thu, 10 Mar 2016 22:21:01 +0000

Lou,

We are working on a revision to the document to address the concerns that Martin and Tom raised.

There is one issue that I need to raise to the Netmod chairs for advice: all our drafts since the original draft have "Intended status: Informational" at the top of the draft. Martin indicated that this should be "Intended status: Standards Track" and that the WG will have to authorize this change in status. Please advise.

Thanks,

Clyde