Subject: [netmod] instance-identifier format

From: Michal Vaško <[email-masked]>
Date: Tue, 06 Sep 2016 10:15:55 +0200

Hi,
instance-identifier lexical representation requires (in both YANG 1.0 and YANG 1.1) every node name in it to be qualified with a namespace, but the grammar defines "instance-identifier" to be made out of "node-identifier" among others, which has the prefix optional. So which one is correct?

Kind regards,
Michal Vasko

---

From: Martin Bjorklund <[email-masked]>
Date: Tue, 06 Sep 2016 11:40:03 +0200 (CEST)

Michal Vaško <[email-masked]> wrote:
> Hi,
> instance-identifier lexical representation requires (in both YANG
> 1.0 and YANG 1.1) every node name in it to be qualified with a
> namespace, but the grammar defines "instance-identifier" to be made
> out of "node-identifier" among others, which has the prefix
> optional. So which one is correct?

The text provides more strict rules than the grammar.  These rules
need to be followed.

/martin