Subject: [netmod] New revision of draft-wu-opsawg-service-model-explained

From: "Adrian Farrel" <[email-masked]>
Date: Wed, 7 Sep 2016 10:43:31 +0100

Hi,

[Copying NETMOD, but suggest all discussions are held on OPSAWG list]

We updated our document to (hopefully) make some stuff clearer...

- We are not trying to piss on draft-ietf-netmod-yang-model-classification!
   Actually, that is an important reference, but its approach is slightly 
   different. We have beefed up our discussion of the relationship with that
   draft. Our belief is that the two drafts are complementary and that our
   work should not delay the completion of the NETMOD draft.

- The distinction between a "service model" and a "service model" (sic) has
   become unclear. We have introduced the terms "customer service model"
   and "service delivery model", explained what these are, and shown mappings
   of other work to these terms. We would propose, if these terms are clear 
   and acceptable, that new work adopt these terms, but we do not suggest
   that it is necessary to go and change existing mature work.

- There was some discussion around "what do you mean by a service?" We
   have tried to tidy our text about this, but could probably use help.

As always, comments, rotten fruit, and constructive input would be welcome.

Cheers,
Adrian (for the authors)
--
Support an author and your imagination.
Tales from the Wood - Eighteen new fairy tales.
More Tales from the Wood - Eighteen more new fairy tales.
https://www.feedaread.com/profiles/8604/
http://www.amazon.co.uk/Tales-Wood-Adrian-Farrel/dp/1786100924
Or buy from me direct.

> A New Internet-Draft is available from the on-line Internet-Drafts
directories.
> 
>         Title           : Service Models Explained
> 
> Abstract:
>    The IETF has produced a considerable number of data models in the
>    YANG modelling language.  The majority of these are used to model
>    devices and they allow access for configuration and to read
>    operational status.
> 
>    A small number of YANG models are used to model services (for
>    example, the Layer Three Virtual Private Network Service Model
>    produced by the L3SM working group).
> 
>    This document briefly sets out the scope of and purpose of an IETF
>    service model, and it shows where a service model might fit into a
>    Software Defined Networking architecture or deployment.
> 
> The IETF datatracker status page for this draft is:
> https://datatracker.ietf.org/doc/draft-wu-opsawg-service-model-explained/

---

From: "Scharf, Michael (Nokia - DE)" <[email-masked]>
Date: Thu, 8 Sep 2016 12:02:56 +0000

Hi all,

In general, I believe that distinguishing between different terms for "service model" is useful.

Actually, I would suggest to align the terminology in draft-ietf-l3sm-l3vpn-service-model accordingly, e.g., by using the term "Customer Service Model" in the L3SM WG. For instance, the title of draft-ietf-l3sm-l3vpn-service-model-12 "YANG Data Model for L3VPN service delivery" is quite inconsistent with the use of the term "service delivery" in draft-wu-opsawg-service-model-explained. It would be good to avoid confusion.

Despite the discussion in https://www.ietf.org/mail-archive/web/opsawg/current/msg04486.html, the draft still contains the wording "all of the parameters". I continue to believe that a wording such as "the parameters" would be more consistent with the rest of the document talking about operator-specific augmentations etc.

The document, in particular in Section 6.1, could better distinguish between the terms "module" and "model", if an alignment with draft-ietf-netmod-yang-model-classification is the objective. One example where the terminology is not entirely consistent is the sentence "add an additional example of a Network Service YANG model as shown in Figure 4". That figure actually shows modules.

Apparently Section 6.4 refers to MEF 55. I wonder why the specification MEF 55 is not referenced. Also, I believe the terminology in Section 6.4 may have to be reviewed. For instance, MEF apparently uses the term reference points ("Management Interface Reference Point") instead of "interface" in MEF 55. 

Editorial nit: s/to/two/ in "The service model may divided into to categories"

Michael

-----Original Message-----
From: netmod [mailto:[email-masked]] On Behalf Of Adrian Farrel
Sent: Wednesday, September 07, 2016 11:44 AM
To: [email-masked]
Cc: [email-masked]; [email-masked]
Subject: [netmod] New revision of draft-wu-opsawg-service-model-explained

Hi,

Cheers,
Adrian (for the authors)

directories.
> https://datatracker.ietf.org/doc/draft-wu-opsawg-service-model-explained/

_______________________________________________
netmod mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/netmod

---

From: "Adrian Farrel" <[email-masked]>
Date: Thu, 8 Sep 2016 13:43:47 +0100

Hi Michael,

Thanks for the helpful email.

> Actually, I would suggest to align the terminology in
draft-ietf-l3sm-l3vpn-service-
> model accordingly, e.g., by using the term "Customer Service Model" in the
L3SM
> WG. For instance, the title of draft-ietf-l3sm-l3vpn-service-model-12 "YANG
Data
> Model for L3VPN service delivery" is quite inconsistent with the use of the
term
> "service delivery" in draft-wu-opsawg-service-model-explained. It would be
> good to avoid confusion.

Yes.
Although we added text to draft-wu-opsawg-service-model-explained to explain the
terminology mapping, I think you're right that it would be even better to avoid
the need.

So that is an issue to take to L3SM (or the IETF last call of
draft-ietf-l3sm-l3vpn-service-model)

> Despite the discussion in https://www.ietf.org/mail-
> archive/web/opsawg/current/msg04486.html, the draft still contains the wording
> "all of the parameters". I continue to believe that a wording such as "the
> parameters" would be more consistent with the rest of the document talking
> about operator-specific augmentations etc.

My bad dropping that email.
I'll go back and respond on that thread.

> The document, in particular in Section 6.1, could better distinguish between
the
> terms "module" and "model", if an alignment with draft-ietf-netmod-yang-
> model-classification is the objective. One example where the terminology is
not
> entirely consistent is the sentence "add an additional example of a Network
> Service YANG model as shown in Figure 4". That figure actually shows modules.

Nice point. Does anyone have a reference for the definition of model and module
in the YANG context (or I can search :-)

> Apparently Section 6.4 refers to MEF 55. I wonder why the specification MEF 55
is
> not referenced. Also, I believe the terminology in Section 6.4 may have to be
> reviewed. For instance, MEF apparently uses the term reference points
> ("Management Interface Reference Point") instead of "interface" in MEF 55.

Thanks for the pointer. It is hard to search all of the MEF documents (public
and private) to find a figure.
I will add the reference and clear up the language.

> Editorial nit: s/to/two/ in "The service model may divided into to categories"

Ack

Cheers,
Adrian

---

From: "Scharf, Michael (Nokia - DE)" <[email-masked]>
Date: Thu, 8 Sep 2016 12:47:19 +0000

is
> > not referenced. Also, I believe the terminology in Section 6.4 may 
> > have to be reviewed. For instance, MEF apparently uses the term 
> > reference points ("Management Interface Reference Point") instead of "interface" in MEF 55.

> Thanks for the pointer. It is hard to search all of the MEF documents (public and private) to find a figure.

MEF 55 is public: https://www.mef.net/Assets/Technical_Specifications/PDF/MEF_55.pdf

Michael

---

From: Qin Wu <[email-masked]>
Date: Mon, 12 Sep 2016 02:01:43 +0000

the
> terms "module" and "model", if an alignment with 
> draft-ietf-netmod-yang- model-classification is the objective. One 
> example where the terminology is
not
> entirely consistent is the sentence "add an additional example of a 
> Network Service YANG model as shown in Figure 4". That figure actually shows modules.

Nice point. Does anyone have a reference for the definition of model and module in the YANG context (or I can search :-)

[Qin]: The difference between data model and module is very subtle. E.g., In some case one model includes more than one module.
See these two detailed definition in the section 3 of rfc7950
https://tools.ietf.org/html/rfc7950#section-3