Subject: [netmod] [Editorial Errata Reported] RFC7317 (4795)

From: RFC Errata System <[email-masked]>
Date: Mon, 5 Sep 2016 03:21:06 -0700 (PDT)

The following errata report has been submitted for RFC7317,
"A YANG Data Model for System Management".

--------------------------------------
You may review the report below and at:
http://www.rfc-editor.org/errata_search.php?rfc=7317&eid=4795

--------------------------------------
Type: Editorial
Reported by: Kaja Mohideen <[email-masked]>

Section: 5

Original Text
-------------
typedef crypt-hash {
       type string {
         pattern
           'RFCORIGINAL_TEXT$.*'
         + '|$[a-zA-Z0-9./]{1,8}$[a-zA-Z0-9./]{22}'
         + '|$(rounds=\d+$)?[a-zA-Z0-9./]{1,16}$[a-zA-Z0-9./]{43}'
         + '|$(rounds=\d+$)?[a-zA-Z0-9./]{1,16}$[a-zA-Z0-9./]{86}';
       }

Corrected Text
--------------
typedef crypt-hash {
  type string {
    pattern
        '$0$.*'
      + '|$1$[a-zA-Z0-9./]{1,8}$[a-zA-Z0-9./]{22}'
      + '|$5$(rounds=\d+$)?[a-zA-Z0-9./]{1,16}$[a-zA-Z0-9./]{43}'
      + '|$6$(rounds=\d+$)?[a-zA-Z0-9./]{1,16}$[a-zA-Z0-9./]{86}';
  }

Notes
-----
Character $ has special meaning in regular expression.

Instructions:
-------------
This erratum is currently posted as "Reported". If necessary, please
use "Reply All" to discuss whether it should be verified or
rejected. When a decision is reached, the verifying party (IESG)
can log in to change the status and edit the report, if necessary. 

--------------------------------------
RFC7317 (draft-ietf-netmod-system-mgmt-16)
--------------------------------------
Title               : A YANG Data Model for System Management
Publication Date    : August 2014
Author(s)           : A. Bierman, M. Bjorklund
Category            : PROPOSED STANDARD
Source              : NETCONF Data Modeling Language
Area                : Operations and Management
Stream              : IETF
Verifying Party     : IESG

---

From: Martin Bjorklund <[email-masked]>
Date: Mon, 05 Sep 2016 12:34:50 +0200 (CEST)

> "A YANG Data Model for System Management".

No, "$" is not special in the regular expression dialect used in YANG
(XML Schema).

/martin

---

From: Per Hedeland <[email-masked]>
Date: Mon, 5 Sep 2016 12:51:07 +0200

> No, "$" is not special in the regular expression dialect used in YANG

+1. And in fact the suggested change (lost in the above text, but
present in the html version), to use '\$' instead of '$', results in
invalid expressions according the XML Schema spec.

--Per

> /martin
> 
> _______________________________________________
> netmod mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/netmod
>

---

From: "Rasool, Kaja Mohideen (Nokia - IN)" <[email-masked]>
Date: Mon, 5 Sep 2016 10:25:07 +0000

Don't know the reason why - but the "Original Text" & "Corrected Text" in the email is not correct. Please see the report by opening the URL https://www.rfc-editor.org/errata_search.php?rfc=7317&eid=4795 

// Kaja

-----Original Message-----
From: RFC Errata System [mailto:[email-masked]] 
Sent: Monday, September 05, 2016 3:51 PM
To: [email-masked]; [email-masked]; [email-masked]; [email-masked]; [email-masked]; [email-masked]
Cc: Rasool, Kaja Mohideen (Nokia - IN) <[email-masked]>; [email-masked]; [email-masked]
Subject: [Editorial Errata Reported] RFC7317 (4795)

Section: 5

Original Text
-------------
typedef crypt-hash {
       type string {
         pattern
           'RFCORIGINAL_TEXT$.*'

Corrected Text
--------------
typedef crypt-hash {
  type string {
    pattern
        '$0$.*'

Notes
-----

Instructions:
-------------

---

From: "Rasool, Kaja Mohideen (Nokia - IN)" <[email-masked]>
Date: Mon, 5 Sep 2016 15:46:09 +0000

Ah! Didn't realize that XML Schema version of RegEx considers the whole element and doesn't have anchors.

Thanks for clarifying.

// Kaja

-----Original Message-----
From: Per Hedeland [mailto:[email-masked]] 
Sent: Monday, September 05, 2016 4:21 PM
To: Martin Bjorklund <[email-masked]>; [email-masked]
Cc: [email-masked]; [email-masked]; Rasool, Kaja Mohideen (Nokia - IN) <[email-masked]>
Subject: Re: [netmod] [Editorial Errata Reported] RFC7317 (4795)

On 2016-09-05 12:34, Martin Bjorklund wrote:
>> The following errata report has been submitted for RFC7317, "A YANG 
>> Data Model for System Management".
>>

+1. And in fact the suggested change (lost in the above text, but
present in the html version), to use '\$' instead of '$', results in invalid expressions according the XML Schema spec.

--Per

---

From: Megan Ferguson <[email-masked]>
Date: Tue, 13 Sep 2016 15:22:59 -0700

All,

Regarding the oddity in the body of the notification message from the RFC Errata System (sent 2016-09-05), i.e., the replacement of "$0" with "RFCORIGINAL_TEXT", we will fix this error in the mail generation system.

As far as the erratum itself, we note that it is accurately displayed (and marked as "Rejected") on 
https://www.rfc-editor.org/errata_search.php?rfc=7317&eid=4795.

Thank you.

RFC Editor/mf