Subject: [netmod] DSDL plugin in pyang

From: Ladislav Lhotka <[email-masked]>
Date: Fri, 25 Nov 2016 15:33:29 +0100

Hi,

for users of $subj: I modified the plugin so that it now immediately refuses to process modules of yang-version greater than 1. Supporting some of the YANG 1.1 features (new XPath functions, leafref handling) would require massive changes and I cannot do them now - I am not even sure it is worth the effort given that other instance data validators are available.

Lada
 
--
Ladislav Lhotka, CZ.NIC Labs
PGP Key ID: E74E8C0C

---

From: Ladislav Lhotka <[email-masked]>
Date: Tue, 29 Nov 2016 14:39:48 +0100

Hi William,

apart from yang2dsdl, I have personal experience with these two instance validation tools:

* yanglint - written in C, supports both XML and JSON instance encoding

  https://github.com/CESNET/libyang

* yangson - written in Python, supports only JSON

  https://github.com/CZ-NIC/yangson
  installation: pip install yangson
  manual page: http://yangson.readthedocs.io/en/latest/cmdline.html

Lada

William Lupton <[email-masked]> writes:

> Are you able to provide a list (either privately or via the NETMOD list) of other instance data validators that are available and cover YANG 1.1 features? Tx, W.
>
>> On 25 Nov 2016, at 14:33, Ladislav Lhotka <[email-masked]> wrote:
>> 
>> Hi,
>>