Subject: [netmod] syslog-model-11 single buffer vs list

From: "Sterne, Jason (Nokia - CA)" <[email-masked]>
Date: Mon, 14 Nov 2016 05:54:11 +0000

Hi Clyde,

Somewhere in the past couple of revisions we dropped multiple memory buffers.  Version 8 (and a number of versions before that) had a list of buffers in the YANG (but it wasn't in the pyang tree).  But then version 9 onwards seem to have a single buffer.

Can we put that back to a list ? Implementations that only support a single buffer can easily fit into a model that supports multiple buffers, but the other way around doesn't work very well.   I think it was accidently dropped due to some confusion over some "if-feature" comments from Tom P at one point.

(note - also add (s) to buffer to make it buffer(s) in a couple of places in section 3).

Regards,
Jason

-----Original Message-----
From: netmod [mailto:[email-masked]] On Behalf Of Clyde Wildes (cwildes)
Sent: Monday, November 14, 2016 8:52
To: [email-masked]; [email-masked]
Cc: [email-masked]
Subject: Re: [netmod] I-D Action: draft-ietf-netmod-syslog-model-11.txt

Hi,

This draft addresses Phil Shafer’s comments and also removes references to TLS for now.

Thanks,

Clyde

On 11/13/16, 3:47 PM, "netmod on behalf of [email-masked]" <[email-masked] on behalf of [email-masked]> wrote:

    A New Internet-Draft is available from the on-line Internet-Drafts directories.
    This draft is a work item of the NETCONF Data Modeling Language of the IETF.
    
            Title           : A YANG Data Model for Syslog Configuration
            Authors         : Clyde Wildes
                              Kiran Koushik
    	Filename        : draft-ietf-netmod-syslog-model-11.txt
    	Pages           : 33
    	Date            : 2016-11-13
    
    Abstract:
       This document describes a data model for the configuration of syslog.

    The IETF datatracker status page for this draft is:
    https://datatracker.ietf.org/doc/draft-ietf-netmod-syslog-model/
    
    There's also a htmlized version available at:
    https://tools.ietf.org/html/draft-ietf-netmod-syslog-model-11
    
    A diff from the previous version is available at:
    https://www.ietf.org/rfcdiff?url2=draft-ietf-netmod-syslog-model-11

    Please note that it may take a couple of minutes from the time of submission
    until the htmlized version and diff are available at tools.ietf.org.
    
    Internet-Drafts are also available by anonymous FTP at:
    ftp://ftp.ietf.org/internet-drafts/
    
    _______________________________________________
    netmod mailing list
    [email-masked]
    https://www.ietf.org/mailman/listinfo/netmod

_______________________________________________
netmod mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/netmod

---

From: "Clyde Wildes (cwildes)" <[email-masked]>
Date: Mon, 14 Nov 2016 16:42:57 +0000

Hi Jason,

Buffer was a subject of discussion on the netmod list most recently by Tom Petch who raised some questions. In an e-mail on 2016/5/6 Tom said:

“The description of log-buffer confuses me.  The buffer is circular in nature so there is only one of them; but it is a list keyed on 'name' so there are lots of them.  This leaf configures the amount number of log messages that can be stored in the local memory logging buffer, so there is only one of them. Or....?”

In the same e-mail Tom also commented on the complexity of the current model:

“My comment was more on the complexity that results from having so many options. Other models are worse - some of the routing ones I find unintelligible as a result - but I raised the issue on this model because it is being discussed on this list where (almost) all the expertise in these matters resides to see if anyone else would bite.”

In a reaction to Tom’s comments, I tried to simplify by changing the buffers list back to a leaf in draft 09. In retrospect this was a mistake. Note that AFAIK buffer is currently implemented by only two vendors: Cisco and Alcatel-Lucent-Nokia.

The Cisco implementation has one buffer and specifies the limit as the total buffer size in bytes.

The Alcatel-Lucent-Nokia implementation has multiple buffers and specifies the limit in total messages.

If we make buffers a list, we still have three features in the model and the necessity for implementations that support only one buffer to augment the model to specify a max-elements statement. The three features are:

  feature buffer-action {
    description
      "This feature indicates that the local memory logging buffer
       action is supported.";
  }

  feature buffer-limit-bytes {
    description
      "This feature indicates that the local memory logging buffer
       is limited in size using a limit expressed in bytes.";
  }

  feature buffer-limit-messages {
    description
      "This feature indicates that the local memory logging buffer
       is limited in size using a limit expressed in number of log
       messages.";
  }

Does it make sense to simplify the model by removing the buffer action along with the three features required and have vendors who implement buffer add it to the model through augmentation? 

A Netmod group consensus would be helpful here.

Thanks,

Clyde

On 11/13/16, 9:54 PM, "Sterne, Jason (Nokia - CA)" <[email-masked]> wrote:

    Hi Clyde,

    
    
    Regards,
    Jason
    
    -----Original Message-----
    From: netmod [mailto:[email-masked]] On Behalf Of Clyde Wildes (cwildes)
    Sent: Monday, November 14, 2016 8:52
    To: [email-masked]; [email-masked]
    Cc: [email-masked]
    Subject: Re: [netmod] I-D Action: draft-ietf-netmod-syslog-model-11.txt
    
    Hi,

    Thanks,
    
    Clyde

        
        
        Abstract:

---

From: "Sterne, Jason (Nokia - CA)" <[email-masked]>
Date: Tue, 15 Nov 2016 03:58:53 +0000

Hi Clyde,

Most implementations probably have limits in the # of files, remote destinations, etc they will support.  If vendors decide to augment the model to add max-elements then they'd do it for a number of the lists here.  That doesn't seem like a big deal.  But trying to fit into a model with 1 buffer would require complete augmentation of the entire buffer destination.  So if we do keep buffer I really think it should be a list.

On the other hand I'm fine with removing both buffer and user sessions (similar reasoning for both -> they are supported by 2 vendors and each does it differently). Then vendors can just augment for those types of destinations.  The other types have broader support/applicability.

Here is how we left off with the table (view this with fixed width font):

>        Feature              Nokia   Brocade  Ciena  Cisco IOS/XE  Cisco IOS/XR  Cisco NXOS  Juniper JunOS  Linux Rsyslog  Comments
>log-input-transports                                                                                              x
>log-action console             x        x                 x              x           x            x               x
>log-action buffer              x                          x              x
>log-action file                x                          x              x           x            x               x
>log-action remote              x        x       x         x              x           x            x               x
>log-action terminal                                       x              x           x                            x
>log-action session             x                                                                  x
>feature buffer-limit-bytes                               x              x
>feature buffer-limit-messages  x
>feature file-limit-size                                   x              x                        x
>feature file-limit-duration    x                          x                                       x
>feature
> terminal-facility-device-logging
>feature
> session-facility-user-logging                                                                    x
>feature select-sev-compare     x                          x                                                       x
>feature select-match           x                          x                                       x               x
>feature structured-data                                                                           x               x     Required because of RFC 5424
>feature signed-messages                                                                                           x     Required because of RFC 5848
>

Regards,
Jason

-----Original Message-----
From: Clyde Wildes (cwildes) [mailto:[email-masked]]
Sent: Tuesday, November 15, 2016 1:43
To: Sterne, Jason (Nokia - CA) <[email-masked]>; [email-masked]
Subject: Re: syslog-model-11 single buffer vs list

Hi Jason,

  feature buffer-action {
    description

Thanks,

Clyde

On 11/13/16, 9:54 PM, "Sterne, Jason (Nokia - CA)" <[email-masked]<mailto:[email-masked]>> wrote:

    Hi Clyde,

    Regards,
    Jason

    -----Original Message-----
    From: netmod [mailto:[email-masked]] On Behalf Of Clyde Wildes (cwildes)
    Sent: Monday, November 14, 2016 8:52
    To: [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>
    Cc: [email-masked]<mailto:[email-masked]>
    Subject: Re: [netmod] I-D Action: draft-ietf-netmod-syslog-model-11.txt

    Hi,

    Thanks,

    Clyde

    On 11/13/16, 3:47 PM, "netmod on behalf of [email-masked]<mailto:[email-masked]>" <[email-masked] on behalf of [email-masked]<mailto:[email-masked][email-masked]>> wrote:

        Abstract:

        _______________________________________________
        netmod mailing list
        [email-masked]<mailto:[email-masked]>
        https://www.ietf.org/mailman/listinfo/netmod

    _______________________________________________
    netmod mailing list
    [email-masked]<mailto:[email-masked]>
    https://www.ietf.org/mailman/listinfo/netmod

---

From: "Clyde Wildes (cwildes)" <[email-masked]>
Date: Tue, 15 Nov 2016 21:00:51 +0000

Hi Jason,

I presented the latest draft ietf-syslog model last night in the Netmod session and mentioned that you had requested that I restore buffers to a list. No one raised any objections so I will do that in the next model update.

Thanks,

Clyde

From: "Sterne, Jason (Nokia - CA)" <[email-masked]>
Date: Monday, November 14, 2016 at 7:58 PM
To: "Clyde Wildes (cwildes)" <[email-masked]>, "[email-masked]" <[email-masked]>
Subject: RE: syslog-model-11 single buffer vs list

Hi Clyde,

Regards,
Jason

-----Original Message-----
From: Clyde Wildes (cwildes) [mailto:[email-masked]]
Sent: Tuesday, November 15, 2016 1:43
To: Sterne, Jason (Nokia - CA) <[email-masked]>; [email-masked]
Subject: Re: syslog-model-11 single buffer vs list

Hi Jason,

  feature buffer-action {
    description

Thanks,

Clyde

    Hi Clyde,

    Regards,
    Jason

    -----Original Message-----
    From: netmod [mailto:[email-masked]] On Behalf Of Clyde Wildes (cwildes)
    Sent: Monday, November 14, 2016 8:52
    To: [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>
    Cc: [email-masked]<mailto:[email-masked]>
    Subject: Re: [netmod] I-D Action: draft-ietf-netmod-syslog-model-11.txt

    Hi,

    Thanks,

    Clyde

        Abstract: