Subject: Re: [netmod] WG Last Call for draft-ietf-netmod-acl-model-08 (until Oct 5, 2016)

From: Dean Bogdanovic <[email-masked]>
Date: Sun, 13 Nov 2016 11:02:37 +0900

Adrian,

Sorry for not replying earlier. Your email fell through the cracks. 

> On Sep 21, 2016, at 5:55 PM, Adrian Pan <[email-masked]> wrote:
> 
> I have reviewed draft-ietf-netmod-acl-model-08 and I am considering to implement the data model in the draft, while I found below issue:
> - Operator is able to configure the matches of ace different from the acl-type, i.e ace configured with ipv6 matches while the “acl-type” is configured as ipv4 in the acl, this is not aligned with the model design intention.

The acl-type provides implicit specification of the match criteria. Authors wanted to enable support for mixed type acl (example mac and ip) in the same list. And let the vendors determine based on their platform and what is supported how to implement the model.

Dean

>  
> Thanks
> Adrian
> From: netmod [mailto:[email-masked]] On Behalf Of Kent Watsen
> Sent: Wednesday, September 21, 2016 4:46 AM
> To: [email-masked]
> Subject: [netmod] WG Last Call for draft-ietf-netmod-acl-model-08 (until Oct 5, 2016)
>  
>  
> This is a notice to start a two-week NETMOD WG last call for the document:
>  
>                Network Access Control List (ACL) YANG Data Model
>                https://tools.ietf.org/html/draft-ietf-netmod-acl-model-08 <https://tools.ietf.org/html/draft-ietf-netmod-acl-model-08>
>  
> Please indicate your support or concerns by Wednesday, October 5, 2016.
>  
> We are particularly interested in statements of the form:
>   * I have reviewed draft-ietf-netmod-acl-model-08 and found no issues.
>   * I have reviewed draft-ietf-netmod-acl-model-08 and found the following issues: ...
>  
> As well as:
>  * I have implemented the data model in draft-ietf-netmod-acl-model-08.
>   * I am implementing the data model in draft-ietf-netmod-acl-model-08.
>   * I am considering to implement the data model in draft-ietf-netmod-acl-model-08.
>   * I am not considering to implement the data model in draft-ietf-netmod-acl-model-08.
>  
> Thank you,
> NETMOD WG Chairs
>  
>  
> _______________________________________________
> netmod mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/netmod

---

From: Mahesh Jethanandani <[email-masked]>
Date: Fri, 18 Nov 2016 22:56:34 +0900

> On Nov 13, 2016, at 11:02 AM, Dean Bogdanovic <[email-masked]> wrote:
> 
> Adrian,
> 
>> On Sep 21, 2016, at 5:55 PM, Adrian Pan <[email-masked] <mailto:[email-masked]>> wrote:
>> 

I do not understand “implicit specification of the match criteria". Say the acl-type is specified as ipv6, and the user configures a ipv4 address in the ACL, how does it help the platform?

I agree with Adrian that a more intuitive use of the acl-type would be to check whether the address being configured matches the type and reject the configuration if it does not.

> 
> Dean
> 
>>  
>> Thanks
>> Adrian
>> From: netmod [mailto:[email-masked] <mailto:[email-masked]>] On Behalf Of Kent Watsen
>> To: [email-masked] <mailto:[email-masked]>
>> [email-masked] <mailto:[email-masked]>
>> https://www.ietf.org/mailman/listinfo/netmod <https://www.ietf.org/mailman/listinfo/netmod>
> 

Mahesh Jethanandani
[email-masked]