Subject: Re: [netmod] I-D Action: draft-ietf-netmod-schema-mount-03.txt

From: Martin Bjorklund <[email-masked]>
Date: Tue, 01 Nov 2016 08:51:53 +0100 (CET)

Hi,

"Acee Lindem (acee)" <[email-masked]> wrote:
> Hi Lada, Martin, 
> 
> With respect to the restriction in section 3.1, I think it would be better
> to support paths that relative either to the mount point or to the
> absolute device root If not, how will we support device list interface
> references? 

Can you elaborate on the use case a bit?

/martin

> 
> Thanks,
> Acee 
> 
> On 10/31/16, 10:13 AM, "netmod on behalf of [email-masked]"
> <[email-masked] on behalf of [email-masked]> wrote:
> 
> >
> >A New Internet-Draft is available from the on-line Internet-Drafts
> >directories.
> >This draft is a work item of the NETCONF Data Modeling Language of the
> >IETF.
> >
> >        Title           : YANG Schema Mount
> >        Authors         : Martin Bjorklund
> >                          Ladislav Lhotka
> >	Filename        : draft-ietf-netmod-schema-mount-03.txt
> >	Pages           : 24
> >	Date            : 2016-10-31
> >
> >Abstract:
> >   This document defines a mechanism to combine YANG modules into the
> >   schema defined in other YANG modules.
> >
> >
> >The IETF datatracker status page for this draft is:
> >https://datatracker.ietf.org/doc/draft-ietf-netmod-schema-mount/
> >
> >There's also a htmlized version available at:
> >https://tools.ietf.org/html/draft-ietf-netmod-schema-mount-03
> >
> >A diff from the previous version is available at:
> >https://www.ietf.org/rfcdiff?url2=draft-ietf-netmod-schema-mount-03
> >
> >
> >Please note that it may take a couple of minutes from the time of
> >submission
> >until the htmlized version and diff are available at tools.ietf.org.
> >
> >Internet-Drafts are also available by anonymous FTP at:
> >ftp://ftp.ietf.org/internet-drafts/
> >
> >_______________________________________________
> >netmod mailing list
> >[email-masked]
> >https://www.ietf.org/mailman/listinfo/netmod
> 
> _______________________________________________
> netmod mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/netmod
>

---

From: "Acee Lindem (acee)" <[email-masked]>
Date: Tue, 1 Nov 2016 11:21:30 +0000

>Can you elaborate on the use case a bit?

Let’s say you want to schema mount a model, e.g., ietf-routing, and it has
references to interfaces using the interface-ref from ietf-interfaces (RFC
7223). Is this possible?

Thanks,
Acee

---

From: Ladislav Lhotka <[email-masked]>
Date: Tue, 1 Nov 2016 12:38:56 +0100

> On 1 Nov 2016, at 12:21, Acee Lindem (acee) <[email-masked]> wrote:
> 
> 
> 

It is possible if ietf-interface and ietf-routing are part of the same (mounted) schema. If you want to have, e.g., a global list of interfaces and refer to it from a mounted schema (routing instance), then it is not supported by schema mount - and it could hardly be because modules such as ietf-routing do not have the information where they can possibly be mounted.

It is probably necessary, as in the logical-devices example, to include ietf-interfaces in the mounted schema, and handle the relationship between the global and mounted interface list outside the data model.

Ideas how to handle this formally would certainly be appreciated.

Lada 

--
Ladislav Lhotka, CZ.NIC Labs
PGP Key ID: E74E8C0C

---

From: "Acee Lindem (acee)" <[email-masked]>
Date: Tue, 1 Nov 2016 16:21:23 +0000

On 11/1/16, 7:38 AM, "Ladislav Lhotka" <[email-masked]> wrote:

>It is possible if ietf-interface and ietf-routing are part of the same
>(mounted) schema. If you want to have, e.g., a global list of interfaces
>and refer to it from a mounted schema (routing instance), then it is not
>supported by schema mount - and it could hardly be because modules such
>as ietf-routing do not have the information where they can possibly be
>mounted.
>
>It is probably necessary, as in the logical-devices example, to include
>ietf-interfaces in the mounted schema, and handle the relationship
>between the global and mounted interface list outside the data model.
>

I think we need to be able to handle either an absolute path or one
relative to the mount point. I can see how this is going to be difficult
since the models don’t support this today.

Thanks,
Acee

---

From: Ladislav Lhotka <[email-masked]>
Date: Wed, 02 Nov 2016 15:26:43 +0100

> since the models don’t support this today.

We need to consider two cases:

1. Routing instances that refer to a global list of interfaces.

2. Logical/virtual devices as in Appendix A that refer to local/mounted interfaces.

Even if we invent some means for specifying paths starting from the
global root, I don't see how we could cover both 1 and 2 in the same
module.

Lada