Subject: [netmod] Key Strings in ietf-key-chain operational state

From: "Acee Lindem (acee)" <[email-masked]>
Date: Wed, 30 Nov 2016 21:37:21 +0000

In the days of MIBs, we used to omit key strings from the data that would be returned. This was ostensibly done for security purposes. We did the same for the operational state returned for keystring in key-chain-entries. I'm now thinking this was a mistake. Rather, it would seem that one could use RFC 6536 rules to accomplish this at a more granular level.

Note that the model also support keystring encryption as described in RFC 5649.

Thanks,
Acee

---

From: Mahesh Jethanandani <[email-masked]>
Date: Wed, 30 Nov 2016 14:25:00 -0800

Acee,

This is something we ran into with ietf-keystore model also. The thoughts are that key strings should never leave the device. If anything most devices have tamper proof capability (FIPS 140-2) to wipe the keys out if tampered with or exported. So exporting the string, encrypted, even with NACM would defy that.

> On Nov 30, 2016, at 1:37 PM, Acee Lindem (acee) <[email-masked]> wrote:
> 
> In the days of MIBs, we used to omit key strings from the data that would be returned. This was ostensibly done for security purposes. We did the same for the operational state returned for keystring in key-chain-entries. I’m now thinking this was a mistake. Rather, it would seem that one could use RFC 6536 rules to accomplish this at a more granular level. 
> 
> _______________________________________________
> netmod mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/netmod

Mahesh Jethanandani
[email-masked]

---

From: "Acee Lindem (acee)" <[email-masked]>
Date: Wed, 30 Nov 2016 22:33:45 +0000

Hi Mahesh,

From: Mahesh Jethanandani <[email-masked]<mailto:[email-masked]>>
Date: Wednesday, November 30, 2016 at 5:25 PM
To: Acee Lindem <[email-masked]<mailto:[email-masked]>>
Cc: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Subject: Re: [netmod] Key Strings in ietf-key-chain operational state

Acee,

So, what we have today would with the key strings omitted from the operational state would be consistent with the direction for the ietf-keystore model. Correct?

How will this be enforced when we have an applied-config datastore?

Thanks,
Acee

On Nov 30, 2016, at 1:37 PM, Acee Lindem (acee) <[email-masked]<mailto:[email-masked]>> wrote:

Thanks,
Acee

_______________________________________________
netmod mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/netmod

Mahesh Jethanandani
[email-masked]<mailto:[email-masked]>

---

From: Mahesh Jethanandani <[email-masked]>
Date: Wed, 30 Nov 2016 18:36:49 -0800

> On Nov 30, 2016, at 2:33 PM, Acee Lindem (acee) <[email-masked]> wrote:
> 
> 

That is correct. Kent can correct me, but we are still trying to figure how to model it in YANG and in the datastores (<applied> and <operational-state>).

> 
> Thanks,
> Acee 
> 
> 
> 
> 
> 
> 
>> On Nov 30, 2016, at 1:37 PM, Acee Lindem (acee) <[email-masked] <mailto:[email-masked]>> wrote:
>> 
>> [email-masked] <mailto:[email-masked]>
>> https://www.ietf.org/mailman/listinfo/netmod <https://www.ietf.org/mailman/listinfo/netmod>
> 
> Mahesh Jethanandani
> [email-masked] <mailto:[email-masked]>
> 
> 
> 

Mahesh Jethanandani
[email-masked]

---

From: Mahesh Jethanandani <[email-masked]>
Date: Wed, 30 Nov 2016 18:36:49 -0800

> On Nov 30, 2016, at 2:33 PM, Acee Lindem (acee) <[email-masked] <mailto:[email-masked]>> wrote:
> 
> 

Mahesh Jethanandani