Subject: [netmod] A question about data tree

From: Daixinning <[email-masked]>
Date: Mon, 5 Dec 2016 05:38:12 +0000

Hi,

RFC7950 has defined a terminology "data tree", shown as below:
   o  data tree: An instantiated tree of any data modeled with YANG,
      e.g., configuration data, state data, combined configuration and
      state data, RPC or action input, RPC or action output, or
      notification.

I have a question on this issue, that is,
Whether the content of the <config> node in <edit-config> is a "data tree", and does it need to follow the constraints of the "data tree" (e.g., The container node exists an most one instance in the data tree).
For example, the netconf message content is like this

<edit-config>
    <target><running/></target>
    <config>
        <system xmlns=" urn:ietf:params:xml:ns:yang:ietf-system">
            <contact>[email-masked]</contact>
        </system>
        <system xmlns=" urn:ietf:params:xml:ns:yang:ietf-system">
            <hostname>Ubuntu-test-01</hostname>
        </system>
    </config>
</edit-config>

These two <system> tags is disobeyed the constraint or not?

Thanks.

---

From: Martin Bjorklund <[email-masked]>
Date: Mon, 05 Dec 2016 11:49:47 +0100 (CET)

Hi,

Daixinning <[email-masked]> wrote:
> Whether the content of the <config> node in <edit-config> is a "data
> tree"

No, the "config" is modelled as "anyxml" so it just an "XML blob".

>, and does it need to follow the constraints of the "data tree"
> (e.g., The container node exists an most one instance in the data
> tree).

No.

/martin

---

From: Daixinning <[email-masked]>
Date: Tue, 6 Dec 2016 00:21:10 +0000

OK, thanks a lot.

-----邮件原件-----
发件人: Martin Bjorklund [mailto:[email-masked]] 
发送时间: 2016年12月5日 18:50
收件人: Daixinning
抄送: [email-masked]
主题: Re: [netmod] A question about data tree

Hi,

Daixinning <[email-masked]> wrote:
> I have a question on this issue, that is, Whether the content of the 
> <config> node in <edit-config> is a "data tree"

No.

/martin