Subject: [netmod] top-level mandatory nodes

From: Ladislav Lhotka <[email-masked]>
Date: Fri, 16 Dec 2016 12:48:56 +0100

Hi,

6087bis says in sec. 5.10:

  Top-level database data definitions MUST NOT be mandatory.

It think this makes sense only for config=true nodes. It is absolutely OK to have mandatory top-level state data, and some published modules already have them, e.g. ietf-yang-library.

Also, I wonder - should the text use "datastore" rather than "database"?

Lada
 
--
Ladislav Lhotka, CZ.NIC Labs
PGP Key ID: E74E8C0C

---

From: Juergen Schoenwaelder <[email-masked]>
Date: Fri, 16 Dec 2016 14:24:25 +0100

> Also, I wonder - should the text use "datastore" rather than "database"?

We should not use the term 'database'. I do no think 'datastore' is
the appropriate replacement. Since this document talks about YANG, I
think the proper terms are data tree and schema tree (or any other
terms that the YANG specification defines).

/js

-- 
Juergen Schoenwaelder           Jacobs University Bremen gGmbH
Phone: +49 421 200 3587         Campus Ring 1 | 28759 Bremen | Germany
Fax:   +49 421 200 3103         <http://www.jacobs-university.de/>

---

From: Ladislav Lhotka <[email-masked]>
Date: Fri, 16 Dec 2016 14:36:50 +0100

> On 16 Dec 2016, at 14:24, Juergen Schoenwaelder <[email-masked]> wrote:
> 

Right - I think the following should do:

OLD

NEW

  Top-level data nodes that represent configuration MUST NOT be mandatory.

Lada

---

From: Juergen Schoenwaelder <[email-masked]>
Date: Fri, 16 Dec 2016 14:40:32 +0100

>   Top-level data nodes that represent configuration MUST NOT be mandatory.

There are a few more occurances of the word 'database' that should all
be rewritten to use YANG terminology.

/js