Subject: Re: [netmod] AD review of draft-ietf-netmod-syslog-model-20

From: "Clyde Wildes (cwildes)" <[email-masked]>
Date: Thu, 1 Mar 2018 15:29:53 +0000

Kent,

I published a new draft that fixes the last two points.

Thanks,

Clyde

From: Kent Watsen <[email-masked]>
Date: Wednesday, February 28, 2018 at 10:11 AM
To: Mahesh Jethanandani <[email-masked]>
Cc: Clyde Wildes <[email-masked]>, "t.petch" <[email-masked]>, Yaron Sheffer <[email-masked]>, Ron Bonica <[email-masked]>, NETMOD Working Group <[email-masked]>, "Benoit Claise (bclaise)" <[email-masked]>
Subject: Re: [netmod] AD review of draft-ietf-netmod-syslog-model-20

[+benoit]

Mahesh,

That's fine, if we want to put the RFC Editor note into the Introduction, I see that you did the same in the ACL draft.  But there still remains the use of IP addresses (not hostnames) in examples and, if we're fixing that, let's please also fix the typo in the title of Section 1.4.

Clyde, can you please post a v23 that fixes these last two points?

Thanks,
Kent  // shepherd

On 2/23/18, 1:05 PM, "Mahesh Jethanandani" <[email-masked]<mailto:[email-masked]>> wrote:

Kent,

On Feb 23, 2018, at 8:02 AM, Kent Watsen <[email-masked]<mailto:[email-masked]>> wrote:

Hi Clyde,

Looking at your diff, I see that you aligned the Usage Example text and artwork by making the artwork use the IP address from the text, but you should've instead used the hostname in both locations.  Please see section 3.6 here: https://www.ietf.org/standards/ids/checklist<https://urldefense.proofpoint.com/v2/url?u=https-3A__www.ietf.org_standards_ids_checklist&d=DwMFAg&c=HAkYuh63rsuhr6Scbfh0UjBXeMK-ndb3voDTXcWzoCI&r=9zkP0xnJUvZGJ9EPoOH7Yhqn2gsBYaGTvjISlaJdcZo&m=N9LJpCJBafHdUNdSOe63fe4yTYxK-wmVz_DgH1cnKjM&s=JrRJ2H8Pa9954dNFWzFQ0xW4hCYHxwnrMtFTBVZyvZI&e=>.

Also, I see that you moved the Editorial Note to Section 1.4 (along with a typo in the title, ooops).  This is fine, I guess, though I was thinking instead about something like a top-level "RFC Editor Considerations" near the end [hmmm, a budding BCP? ;)].  Actually, I wish you had explained that the text was not in the Abstract, but in a "<note>" element, and it was just a rendering issue.  It's actually common to use the <note> element for this purpose (sorry for not recognizing it before). Please also either fix the typo or, better, move the section back to the <note> element.

I had recommended the move of the note from abstract section to the end of the Introduction section. Abstracts cannot have cross-references in them, which the note had. And that was one of the OPS-DIR comments too.

Kent // shepherd

===== original message =====

Kent, Tom, Yaron, and Ron,

A new version of the draft-ietf-netmod-syslog-model has been published that addresses your concerns.

Thanks,

Clyde

On 2/20/18, 9:06 AM, "netmod on behalf of Kent Watsen" <[email-masked]<mailto:[email-masked]> on behalf of [email-masked]<mailto:[email-masked]>> wrote:

Kent

You illustrate beautifully the problem I would like a solution to.

The current thinking AFAICT is that tree-diagrams

should be an Informative Reference.

Therefore, the RFC Editor will not hold publication until an RFC number

is assigned.

Therefore, a note asking the I-D reference to be updated to reflect the

assigned RFC number is null - the RFC can be published with the

reference as an i-d and not as an RFC which is what I expect the RFC

Editor to do.

QED

   Except I know that this draft will be stuck in MISREF state and tree-diagrams

   will in fact be assigned an RFC number by the time this draft is published.

   K.

Note that this is not the case of a Normative i-d reference being buried

in the YANG module and not being.noticed by the RFC Editor; that problem

I am content with.

Tom Petch

Please also address these issues when posting -21 to address Benoit's

   issues.  Please post -21 ASAP as Benoit has already placed this draft on

   the IESG telechat in a couple weeks.

Thanks,

Kent // shepherd

On 2/14/18, 8:18 AM, "netmod on behalf of Benoit Claise"

   <[email-masked]<mailto:[email-masked]><mailto:[email-masked]> on behalf of

   [email-masked]<mailto:[email-masked]><mailto:[email-masked]>> wrote:

Dear all,

- the draft is NMDA compliant, right? It should be mentioned.

Ex: draft-ietf-netmod-rfc7223bis-03, in the abstract and intro

  The YANG model in this document conforms to the Network Management

  Datastore Architecture defined in

   I-D.ietf-netmod-revised-datastores.

- As mentioned in the writeup, [I-D.ietf-netmod-yang-tree-diagrams]

   should be an informative reference, not normative.

- Editorial:

OLD:

This draft addresses the common leafs

NEW:

This document addresses the common leafs

Please publish a new version asap.

In the mean time, I'm sending this draft to IETF LC.

Regards, Benoit

   ------------------------------------------------------------------------

   --------

_______________________________________________

netmod mailing list

[email-masked]<mailto:[email-masked]>

https://urldefense.proofpoint.com/v2/url?u=https-3A__www.ietf.org_mailman_listinfo_netmod&d=DwICaQ&c=HAkYuh63rsuhr6Scbfh0UjBXeMK-ndb3voDTXcWzoCI&r=9zkP0xnJUvZGJ9EPoOH7Yhqn2gsBYaGTvjISlaJdcZo&m=cJ7MVnQVc1hgxpVF7oYiVn6Rbm-Qf2dDyrfYhL-s9io&s=u0Hn9GkO-B0jUGm1MnIQ4x4AgIZNXHBIaZhTPmt3dC8&e=

   _______________________________________________

   netmod mailing list

   [email-masked]<mailto:[email-masked]>

   https://urldefense.proofpoint.com/v2/url?u=https-3A__www.ietf.org_mailman_listinfo_netmod&d=DwIGaQ&c=HAkYuh63rsuhr6Scbfh0UjBXeMK-ndb3voDTXcWzoCI&r=9zkP0xnJUvZGJ9EPoOH7Yhqn2gsBYaGTvjISlaJdcZo&m=vELsmeOQEHNm4fcyJJKG7EpwwzMBGc-MHvHhSPWRzro&s=jSGwP16XlM6ntMKUF3bkCAwRfRtRwATdly2BlUtx2RA&e=

_______________________________________________
netmod mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/netmod<https://urldefense.proofpoint.com/v2/url?u=https-3A__www.ietf.org_mailman_listinfo_netmod&d=DwMFAg&c=HAkYuh63rsuhr6Scbfh0UjBXeMK-ndb3voDTXcWzoCI&r=9zkP0xnJUvZGJ9EPoOH7Yhqn2gsBYaGTvjISlaJdcZo&m=N9LJpCJBafHdUNdSOe63fe4yTYxK-wmVz_DgH1cnKjM&s=UjOEtJcF00aJzZs5hrqaIqWHebO11ugEeMcESrcmX30&e=>

Mahesh Jethanandani
[email-masked]<mailto:[email-masked]>

---

From: Kent Watsen <[email-masked]>
Date: Thu, 1 Mar 2018 16:06:38 +0000

Thanks Clyde.

Benoit, it's ready now.

Kent // shepherd

On 3/1/18, 10:29 AM, "Clyde Wildes (cwildes)" <[email-masked]<mailto:[email-masked]>> wrote:

Kent,

Thanks,

Clyde

[+benoit]

Mahesh,

Thanks,
Kent  // shepherd

Kent,

Hi Clyde,

Kent // shepherd

Thanks,

Clyde

Kent

is assigned.

Editor to do.

QED

   K.

I am content with.

Tom Petch

Thanks,

Kent // shepherd

Dear all,

- Editorial:

OLD:

NEW:

Regards, Benoit

   --------

netmod mailing list

   netmod mailing list

Mahesh Jethanandani