Subject: [netmod] Status update on <draft-wu-netmod-yang-xml-doc-conventions-01>

From: Qin Wu <[email-masked]>
Date: Wed, 30 May 2018 01:39:42 +0000

Hi, WG:
We have made an update Documentation Conventions for Expressing YANG in XML I-D based on last meeting discussion.
The changes include:
1. Add JSON support.
2. Add objectives section 
3. Consolidate Mandatory Boilerplate for both leaf node and metadata annotation.
4. Move complex case to Appendix.
5. Better Align abstract and introduction section with objectives sections.
The diff is:
https://www.ietf.org/rfcdiff?url2=draft-wu-netmod-yang-xml-doc-conventions-01
We believe the v-(01) address all the comments in last meeting and can serve a good basis to move to the next step.
Thanks. Further Comments and suggestions are welcome.

-Qin
-----邮件原件-----
发件人: [email-masked] [mailto:[email-masked]] 
发送时间: 2018年5月30日 9:17
收件人: Benoit Claise; Qin Wu; Adrian Farrel; Benoît Claise
主题: New Version Notification for draft-wu-netmod-yang-xml-doc-conventions-01.txt

A new version of I-D, draft-wu-netmod-yang-xml-doc-conventions-01.txt
has been successfully submitted by Qin Wu and posted to the IETF repository.

Name:		draft-wu-netmod-yang-xml-doc-conventions
Revision:	01
Title:		Documentation Conventions for Expressing YANG in XML
Document date:	2018-05-29
Group:		Individual Submission
Pages:		10
URL:            https://www.ietf.org/internet-drafts/draft-wu-netmod-yang-xml-doc-conventions-01.txt
Status:         https://datatracker.ietf.org/doc/draft-wu-netmod-yang-xml-doc-conventions/
Htmlized:       https://tools.ietf.org/html/draft-wu-netmod-yang-xml-doc-conventions-01
Htmlized:       https://datatracker.ietf.org/doc/html/draft-wu-netmod-yang-xml-doc-conventions
Diff:           https://www.ietf.org/rfcdiff?url2=draft-wu-netmod-yang-xml-doc-conventions-01

Abstract:
   Many documents that define YANG modules also include artwork examples
   presented in XML/JSON.

   IETF documentation has specific limits on line length and some
   artwork examples such as XML examples have to include line wraps that
   would not normally be allowed according to the XML representation
   rules of RFC7950 and RFC7952.The same applies to JSON.

   This document lays out documentation conventions that allow YANG
   examples to be presented in IETF documentation when XML/JSON encoded
   YANG data instance would otherwise exceed the maximum line length and
   provide consistent XML/JSON encoded YANG data node instance example
   within an Internet-Draft or RFC.  There are no implications in this
   document for YANG parsers: this document does not change the rules
   for presenting YANG models or for encoding YANG in data files or in
   the wire.

Please note that it may take a couple of minutes from the time of submission until the htmlized version and diff are available at tools.ietf.org.

The IETF Secretariat

---

From: Juergen Schoenwaelder <[email-masked]>
Date: Wed, 30 May 2018 07:34:11 +0200

I think the title of the document is misleading. The convention for
expressing YANG in XML is called YIN, defined in RFC 7950. There are
other phrases that I find misleading, for example, Automatic
Generation of Valid XML From Examples. For me, the example is the XML
(or JSON) and what you call an example is the encoding of an XML in
the RFC format and what you define is an RFC format qencoding and a
decoding function. Perhaps it helps to properly define the terminology
you use and then to go through the document to make sure terms are
used consistently.

/js

On Wed, May 30, 2018 at 01:39:42AM +0000, Qin Wu wrote:
> _______________________________________________
> netmod mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/netmod

-- 
Juergen Schoenwaelder           Jacobs University Bremen gGmbH
Phone: +49 421 200 3587         Campus Ring 1 | 28759 Bremen | Germany
Fax:   +49 421 200 3103         <https://www.jacobs-university.de/>

---

From: Qin Wu <[email-masked]>
Date: Wed, 30 May 2018 05:41:31 +0000

Good point, we will fix terminologies issues in the next update. 
Thanks, Juergen.

-Qin
-----邮件原件-----
发件人: Juergen Schoenwaelder [mailto:[email-masked]] 
发送时间: 2018年5月30日 13:34
收件人: Qin Wu
抄送: [email-masked]
主题: Re: [netmod] Status update on <draft-wu-netmod-yang-xml-doc-conventions-01>

I think the title of the document is misleading. The convention for expressing YANG in XML is called YIN, defined in RFC 7950. There are other phrases that I find misleading, for example, Automatic Generation of Valid XML From Examples. For me, the example is the XML (or JSON) and what you call an example is the encoding of an XML in the RFC format and what you define is an RFC format qencoding and a decoding function. Perhaps it helps to properly define the terminology you use and then to go through the document to make sure terms are used consistently.

/js

On Wed, May 30, 2018 at 01:39:42AM +0000, Qin Wu wrote:
> https://www.ietf.org/rfcdiff?url2=draft-wu-netmod-yang-xml-doc-convent
> ions-01 We believe the v-(01) address all the comments in last meeting 
> and can serve a good basis to move to the next step.
> 主题: New Version Notification for 
> draft-wu-netmod-yang-xml-doc-conventions-01.txt
> 
>

---

From: "dingxiaojian (A)" <[email-masked]>
Date: Thu, 31 May 2018 03:14:51 +0000

Agree with Jurgen, I think what need to be emphasized is how machine parse the data should not be changed,in draft-wu-netmod-yang-xml-doc-conventions, what is required is additional encoding and decoding mechanism to make data better fit into RFC and I-D.

Xiaojian

-----Original Message-----
From: netmod [mailto:[email-masked]] On Behalf Of Juergen Schoenwaelder
Sent: Wednesday, May 30, 2018 1:34 PM
To: Qin Wu <[email-masked]>
Cc: [email-masked]
Subject: Re: [netmod] Status update on <draft-wu-netmod-yang-xml-doc-conventions-01>

/js

---

From: Qin Wu <[email-masked]>
Date: Thu, 31 May 2018 03:21:27 +0000

This is exactly what we proposed in v-(02) , 
https://www.ietf.org/rfcdiff?url2=draft-wu-netmod-yang-xml-doc-conventions-02

Regarding machine parsing data, please see last paragraph of abstract:
"
   There are no implications in this
   document for YANG parsers: this document does not change the rules
   for presenting YANG models or for encoding YANG in data files or in
   the wire.
"
This has already been highlighted in v-(00).

-Qin
-----邮件原件-----
发件人: dingxiaojian (A) 
发送时间: 2018年5月31日 11:15
收件人: Juergen Schoenwaelder; Qin Wu
抄送: [email-masked]
主题: RE: [netmod] Status update on <draft-wu-netmod-yang-xml-doc-conventions-01>

Xiaojian

-----Original Message-----
From: netmod [mailto:[email-masked]] On Behalf Of Juergen Schoenwaelder
Sent: Wednesday, May 30, 2018 1:34 PM
To: Qin Wu <[email-masked]>
Cc: [email-masked]
Subject: Re: [netmod] Status update on <draft-wu-netmod-yang-xml-doc-conventions-01>

/js

---

From: Juergen Schoenwaelder <[email-masked]>
Date: Thu, 31 May 2018 06:55:21 +0200

What is a 'YANG parser'? For me, a YANG parser is something that parses
YANG, i.e., not an XML or JSON parser.

/js

---

From: Qin Wu <[email-masked]>
Date: Thu, 31 May 2018 05:43:31 +0000

YANG parser in this document context is XML/JSON parser for YANG defined data, in my understanding.
Not sure this is right term or whether there is any better term. We will figure it out. Thanks.

-Qin
-----邮件原件-----
发件人: Juergen Schoenwaelder [mailto:[email-masked]] 
发送时间: 2018年5月31日 12:55
收件人: Qin Wu
抄送: dingxiaojian (A); [email-masked]
主题: Re: [netmod] Status update on <draft-wu-netmod-yang-xml-doc-conventions-01>

What is a 'YANG parser'? For me, a YANG parser is something that parses YANG, i.e., not an XML or JSON parser.

/js

On Thu, May 31, 2018 at 03:21:27AM +0000, Qin Wu wrote:
> ions-02
> 主题: RE: [netmod] Status update on 
> <draft-wu-netmod-yang-xml-doc-conventions-01>
> 
> Subject: Re: [netmod] Status update on 
> <draft-wu-netmod-yang-xml-doc-conventions-01>
> 
> > ions-01 We believe the v-(01) address all the comments in last 
> > meeting and can serve a good basis to move to the next step.
> > A new version of I-D,