Subject: [netmod] NMDA DataStore Read-Only / Write-able programmability

From: Rohit R Ranade <[email-masked]>
Date: Thu, 3 May 2018 10:10:53 +0000

Hi All,

Currently I see in the NMDA RFC, that whether a data-store is write-able or read-only is mentioned in the RFC sections, but not in the YANG module. So user cannot know if write-able or not by looking at the NMDA Yang modules .

For example <intended> and <operational> are read-only. So the NETCONF <edit-data> cannot be done on these data-stores.

"If an <edit-data> operation is invoked on a non-writable
   datastore, then an error is returned, as specified in
   "ietf-netconf-nmda"" ==> How can ietf-netconf-nmda know at run-time whether a data-store supports write or not ? Hard-code ? How to handle for new data-stores which use the dynamic identity  ?

With Regards,
Rohit R Ranade

---

From: Juergen Schoenwaelder <[email-masked]>
Date: Thu, 3 May 2018 12:30:27 +0200

On Thu, May 03, 2018 at 10:10:53AM +0000, Rohit R Ranade wrote:
> Hi All,
> 
> Currently I see in the NMDA RFC, that whether a data-store is write-able or read-only is mentioned in the RFC sections, but not in the YANG module. So user cannot know if write-able or not by looking at the NMDA Yang modules ..
> 

For well-known datastores, the properties are fixed. A server
implementation will know that <intended> and <operational> is not
writable and clients may know as well. There was some discussion to
expose more datastore metadata at runtime (I think the discussion was
more in the context of the yang library) but this was then left for
future work in order to finish the NMDA work quickly.

/js

-- 
Juergen Schoenwaelder           Jacobs University Bremen gGmbH
Phone: +49 421 200 3587         Campus Ring 1 | 28759 Bremen | Germany
Fax:   +49 421 200 3103         <https://www.jacobs-university.de/>