Subject: Re: [netmod] Query about draft-ietf-netconf-rfc7895bis-06 - Part -2

From: Rohit R Ranade <[email-masked]>
Date: Wed, 9 May 2018 05:45:46 +0000

Hi All,

Continuing with the below queries.

5.  For a module like "ietf-netconf-notifications", which implements only notifications. I think this module is not suitable to be put in any of the data-stores. So a separate module-set has to be prepared for such modules but not included in any data-store. Is it correct ?
6. Similar logic will apply to any module which only defines "rpc" statements also I think. Whether need to update the yang-library draft text mentioning these two scenarios ?

With Regards,
Rohit R Ranade

From: Rohit R Ranade
Sent: 09 May 2018 08:01
To: [email-masked]
Subject: [netmod] Query about draft-ietf-netconf-rfc7895bis-06

Hi All,

1.       "import-only-module" is currently under the "module-set" list. How does the client benefit by learning which module-set imports which modules ?

2.       Whether we can keep the "import-only-module" as a sibling to module-set. And let it list all the imported modules.

3.  Section 3 mentions the text  "A common use case is the operational state datastore schema which is a
  superset of the schema used by conventional configuration datastores. ". ==> I think it should be "maybe a superset" based on Point 3 of "Objectives" section.

4.       Also I feel the text about "netconf-capability-change" notification based on yang-library checksum should be moved to the NETCONF NMDA draft.  Is it not more suitable there ?

With Regards,
Rohit R Ranade

---

From: Juergen Schoenwaelder <[email-masked]>
Date: Wed, 9 May 2018 08:12:01 +0200

> 6. Similar logic will apply to any module which only defines "rpc" statements also I think. Whether need to update the yang-library draft text mentioning these two scenarios ?

RFC 8342 says that the XPath context for notifications, rpc, and
actions is the operational state of the server. For actions, RFC 8342
is even more explicit (since they are bound to a data node, which btw
can also be true for some notifications): RFC 8342 says that actions
are always invoked in the context of the operational state
datastore.

/js

-- 
Juergen Schoenwaelder           Jacobs University Bremen gGmbH
Phone: +49 421 200 3587         Campus Ring 1 | 28759 Bremen | Germany
Fax:   +49 421 200 3103         <https://www.jacobs-university.de/>