Subject: [netmod] YANG schema mount - any early implementations?

From: Hayden Brown <[email-masked]>
Date: Thu, 12 Jul 2018 05:55:32 +0000

Hello everyone,

I have been following with interest the progress of the development of the YANG schema mount proposed RFC.

I was wondering if anybody within the working group mailing list might know of any early implementations of the current draft schema mount mechanism?

I understand that the schema mount proposal is still effectively in a state of flux, but I am curious as to whether there are there any publicly visible implementations or deployments of schema mount on a NETCONF or RESTCONF server that those interested could experiment with (e.g. to aid in client development)?

Thanks and regards,

Hayden

---

From: Hayden Brown <[email-masked]>
Date: Mon, 30 Jul 2018 23:27:26 +0000

Hi everyone,

I just wanted to ask if it would be possible to clarify the intentions around some of the wording of the draft schema mount standard (Rev-10). In particular, regarding entries of the /schema-mounts/mount-points list.

My interpretation is that the intended use of the /schema-mounts/mount-points list entries are to specify the parent modules that contain a mount point. Following on from this, the client should use the YANG library instance to determine which schema options can be mounted at the root of a mount point. This seems consistent with the examples of Appendix A of the draft standard.

In this email I wanted to highlight the following sections of the draft RFC below. In my view they seem to me to be somewhat ambiguous, in implying that the mount-point list entries specify the *child* module (sub-schema):

>From https://datatracker.ietf.org/doc/draft-ietf-netmod-schema-mount/?include_text=1
Section 3.3 - Page 7
> The "/schema-mounts" container has the "mount-point" list as one of its children. Every entry of this list refers through its key to a mount point and specifies the mounted schema.

Section 3.3 - Page 8
> An entry of the "mount-point" list can specify the mounted schema in two different ways, "inline" or "shared-schema".

Section 9 - Page 13
> A mount point defines a place in the node hierarchy where other data models may be attached. A server that implements a module with a mount point populates the /schema-mounts/mount-point list with detailed information on which data models are mounted at each mount point.

Section 9 - Page 14
list mount-point {
    key "module label";
    description
    "Each entry of this list specifies a schema for a particular mount point.

The wording makes me wonder if these passages might actually just be "left-over" context from earlier revisions of the draft standard (Revision 8 and prior) -- effectively referring back to the schema-mount 'use-schema' list.

I do of course acknowledge that it is entirely possible that I've misinterpreted the wording of the passages above, however if that is the case, I suspect I may not be the only one in future.
Many thanks for your time on this matter.

Best regards,
Hayden

On 20/07/2018 8:09 PM, Juergen Schoenwaelder wrote:

On Wed, Jul 11, 2018 at 09:43:32AM +1200, hayden wrote:

I understand that the schema mount proposal is still effectively in a

state of flux, but are there any publicly visible implementations or

deployments of a NETCONF or RESTCONF server that those interested could

experiment with (e.g. to aid in client development)?

State of flux? It is past WG last call and IETF last call.

https://datatracker.ietf.org/doc/draft-ietf-netmod-schema-mount/history/

/js