Subject: [netmod] Thoughts on draft-clemm-netmod-nmda-diff

From: Joe Clarke <[email-masked]>
Date: Fri, 20 Jul 2018 09:52:21 -0400

I just had a chance to finish reading this.  The in-person meeting group
seems to strongly support this work, and I agree.

Coming from a serviceability standpoint, I find this might serve as a
precursor to a VCS-like "blame log".  Would it be reasonable to include
identifiers as to who (or what) made the change and when?  Sorry if this
was raised at the mic today.  I came to the room a bit late.

Joe

---

From: Qin Wu <[email-masked]>
Date: Fri, 20 Jul 2018 15:26:24 +0000

Add two additional thoughts,
(1) I hope NMDA datastore can be used to compare one datastore at two different timepoints, so I am not sure source and target defined in the model are enough to support this case.
(2) NMDA Base events defined in (https://tools.ietf.org/html/draft-wu-netconf-base-notification-nmda-01 can leverage NMDA diff to perform NMDA data validation, right now it is up to the server to detect validation event, but now we might rely on NMDA diff to decide which object is missing, what failed objects are. NMDA diff becomes a good tool.
On the other hand, user might want to know when applied configuration start, when applied configuration complete, based on this to see when to perform NMDA diff. To address this, we might consider two or three new notifications
In the draft-wu-netconf-base-notification-nmda-01 to help to decide when to use NDMA diff

-Qin
-----邮件原件-----)
发件人: netmod [mailto:[email-masked]] 代表 Joe Clarke
发送时间: 2018年7月20日 21:52
收件人: [email-masked]
主题: [netmod] Thoughts on draft-clemm-netmod-nmda-diff

I just had a chance to finish reading this.  The in-person meeting group seems to strongly support this work, and I agree.

Coming from a serviceability standpoint, I find this might serve as a precursor to a VCS-like "blame log".  Would it be reasonable to include identifiers as to who (or what) made the change and when?  Sorry if this was raised at the mic today.  I came to the room a bit late.

Joe

_______________________________________________
netmod mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/netmod