Subject: [netmod] Smart filters for YANG-Push

From: Alexander Clemm <[email-masked]>
Date: Mon, 2 Jul 2018 23:37:02 +0000

Hello Netmod Working Group,

we have just submitted a new draft on Smart Filters for Push Updates: https://tools.ietf.org/html/draft-clemm-netmod-push-smart-filters-00

This draft supersedes  draft-clemm-netconf-push-smart-filters-ps that recently expired.  The draft involves the definition of  a YANG data model that allows to define more advanced filters than the ones defined with YANG-Push, specifically filters that can take into account values of data nodes as well as state.  This allows to define filters for thresholds, recent high-water marks, and more.  It is also a building block for network automation, providing the event portion for many types of Event-Condition-Action-based control loops.  The draft at this point contains little more than the motivation and problem statement; the actual YANG data model is still to be defined; however, we felt it would be good to have a placeholder posted so we can have discussions in Montreal.

--- Alex (on behalf of coauthors: Eric, Xiufeng, Igor, Tianran, Walker, Henk)

---

From: Balazs Lengyel <[email-masked]>
Date: Tue, 3 Jul 2018 17:53:46 +0200

Hello,

You should make the new filter types separate chapters, to make
them more visible.

threshold crossing alert:

I would rather say you have a single filter with a raise and
clear condition. You never really want a threshold filter
without a paired clear filter

this should be connected to an alarm based on
draft-ietf-ccamp-alarm-module. You should have the possibility
of raising an alarm when the threshold is passed.

the term counter filter is confusing as it invokes the idea of
a gauge (a filter based on counting something) instead of a
reverse filter

mention that smart filters will obviously place a load on the
server. Can they be rejected/suspended/resumed like a
subscription.

regards Balazs

On 7/3/2018 1:37 AM, Alexander Clemm
wrote:

we have just submitted a new draft on Smart
Filters for Push Updates:
https://tools.ietf.org/html/draft-clemm-netmod-push-smart-filters-00

This draft supersedes
draft-clemm-netconf-push-smart-filters-ps that recently
expired.  The draft involves the definition of  a YANG data
model that allows to define more advanced filters than the
ones defined with YANG-Push, specifically filters that can
take into account values of data nodes as well as state.  This
allows to define filters for thresholds, recent high-water
marks, and more.  It is also a building block for network
automation, providing the event portion for many types of
Event-Condition-Action-based control loops.  The draft at this
point contains little more than the motivation and problem
statement; the actual YANG data model is still to be defined;
however, we felt it would be good to have a placeholder posted
so we can have discussions in Montreal.

--- Alex (on behalf of coauthors: Eric,
Xiufeng, Igor, Tianran, Walker, Henk)

_______________________________________________
netmod mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/netmod

--
Balazs Lengyel Ericsson Hungary Ltd.
Senior Specialist
Mobile: +36-70-330-7909 email: [email-masked]

---

From: Alexander Clemm <[email-masked]>
Date: Tue, 3 Jul 2018 21:12:39 +0000

Hi Balazs,

thank you for your suggestion!  Brief responses inline.

--- Alex

From: Balazs Lengyel [mailto:[email-masked]]
Sent: Tuesday, July 03, 2018 8:54 AM
To: Alexander Clemm <[email-masked]>; [email-masked]
Cc: [email-masked]
Subject: Re: [netmod] Smart filters for YANG-Push

Hello,

You should make the new filter types separate chapters, to make them more visible.

  *   I would rather say you have a single filter with a raise and clear condition. You never really want a threshold filter without a paired clear filter
<ALEX> Agree on TCA needing to have both threshold and hysteresis threshold.  </ALEX>

  *   this should be connected to an alarm based on draft-ietf-ccamp-alarm-module. You should have the possibility of raising an alarm when the threshold is passed.
<ALEX> Need to check it out </ALEX>

  *   the term counter filter is confusing as it invokes the idea of a gauge (a filter based on counting something) instead of a reverse filter
<ALEX> Actually, this is a miswording.  What was meant is not a filter on counters, but a second filter to alternate with the first, analogous to threshold crossing alerts (with hysteresis, or "counter" threshold).  Will need to rephrase this to clarify.  <ALEX>

  *   mention that smart filters will obviously place a load on the server. Can they be rejected/suspended/resumed like a subscription.
<ALEX> Yes, load is a valid concern, this is also mentioned in the security concerns.  Haven't thought about whether suspend/resume makes sense; the ability to reject, yes certainly, and should be mentioned.  Thanks!
</ALEX>

regards Balazs

On 7/3/2018 1:37 AM, Alexander Clemm wrote:
Hello Netmod Working Group,

netmod mailing list

[email-masked]<mailto:[email-masked]>

--

Senior Specialist

Mobile: +36-70-330-7909              email: [email-masked]<mailto:[email-masked]>