Subject: Re: [netmod] Quirky YANG

From: "Reshad Rahman (rrahman)" <[email-masked]>
Date: Wed, 3 Oct 2018 21:41:22 +0000

Are YD reviews optional for IETF YANG modules? I assumed it was mandatory.

On 2018-10-03, 12:11 PM, "netmod on behalf of tom petch" <[email-masked] on behalf of [email-masked]> wrote:

    I wonder if anyone else on this list has looked at
     https://datatracker.ietf.org/doc/draft-ietf-softwire-yang/
    currently in IETF Last Call.
    
    It provides management for three tunnel types, Lw4o6, MAP-E and MAP-T
    betweeen CPE and Border Relay.  It defines a CPE module, a BR module and
    a module of common definitions.
    
    It does not provide identities for the three tunnel types; rather, where
    it augments "/if:interfaces/if:interface" it specifies
        when "if:type = 'ianaift:tunnel'";
    which to me says that a MAP-E (e.g.) specific object will get added to
    each and every tunnel of whatever type, which seems excessive.
    
    Second, it defines four features, softwire-ce:algorithm (i.e.
    MAP-E/MAP-T) and softwire-ce:binding (i.e. Lw4o6) in the CPE module and
    then again softwire-br:algorithm and softwire-br:binding in the BR
    module.  It is unclear to me, from the I-D, whether support is for MAP-T
    and MAP-E; or either MAP-T or MAP-E - I find the I-D ambiguous on that
    point - but I would have expected there to be either two - Lw4o6 and
    MAP-ET - or three - Lw4o6, MAP-E and MAP-T features, not four; and for
    the features to be defined, along with tunnel identities, in the common
    module.
    
    Odd, IMHO.
    
    Tom Petch
    
    _______________________________________________
    netmod mailing list
    [email-masked]
    https://www.ietf.org/mailman/listinfo/netmod

---

From: Mahesh Jethanandani <[email-masked]>
Date: Wed, 3 Oct 2018 16:38:18 -0700

> On Oct 3, 2018, at 2:41 PM, Reshad Rahman (rrahman) <[email-masked]> wrote:
> 

Here is what it says on the YD page:

All YANG documents will be passed by a YANG doctor reviewer before they will be approved by the IESG. The YANG doctor review must be done after the Working Group Last Call and before the IETF Last Call. ADs and WG chairs responsible on I-Ds that include YANG documents should ask the OPS ADs for a review as soon as the document completed WGLC. Failing that request, the review will be conducted during the IETF Last Call.

Mahesh Jethanandani
[email-masked]

---

From: "Reshad Rahman (rrahman)" <[email-masked]>
Date: Wed, 3 Oct 2018 23:51:35 +0000

Thanks Mahesh. So the IESG is supposed to ask for YD review at this point for draft-ietf-softwire-yang?

From: Mahesh Jethanandani <[email-masked]>
Date: Wednesday, October 3, 2018 at 7:38 PM
To: "Reshad Rahman (rrahman)" <[email-masked]>
Cc: tom petch <[email-masked]>, "[email-masked]" <[email-masked]>, YANG Doctors <[email-masked]>
Subject: Re: [yang-doctors] [netmod] Quirky YANG

On Oct 3, 2018, at 2:41 PM, Reshad Rahman (rrahman) <[email-masked]<mailto:[email-masked]>> wrote:

Mahesh Jethanandani
[email-masked]<mailto:[email-masked]>

---

From: Mahesh Jethanandani <[email-masked]>
Date: Wed, 3 Oct 2018 17:14:45 -0700

[Adding softwire chairs, document shepherd, and AD, and moving netmod to Bcc]

Yes.

> On Oct 3, 2018, at 4:51 PM, Reshad Rahman (rrahman) <[email-masked]> wrote:
> 
>   <>
>> On Oct 3, 2018, at 2:41 PM, Reshad Rahman (rrahman) <[email-masked] <mailto:[email-masked]>> wrote:
>>  
> [email-masked] <mailto:[email-masked]>
Mahesh Jethanandani
[email-masked]