Subject: [netmod] YANG module security considerations template - TLS reference

From: Martin Bjorklund <[email-masked]>
Date: Mon, 01 Oct 2018 09:19:10 +0200 (CEST)

Hi,

In their review of draft-ietf-netconf-nmda-restconf, the IESG
suggested we update the reference to TLS from RFC 5246 to RFC 8446
(which obsoletes 5246).

This update needs to be done to the template available at
https://trac.ietf.org/trac/ops/wiki/yang-security-guidelines

(it is not quite clear who is repsonsible for this template; maybe
that should be clarified on the page)

/martin

---

From: "Acee Lindem (acee)" <[email-masked]>
Date: Mon, 1 Oct 2018 14:25:24 +0000

Agreed - although I'm not sure who has control over the template either. 

For drafts that are in-progress, IDNITs will flag this obsolete reference and, for at least one of the drafts I'm an editor, I've already made the update.

Thanks,
Acee 

On 10/1/18, 3:19 AM, "netmod on behalf of Martin Bjorklund" <[email-masked] on behalf of [email-masked]> wrote:

    Hi,

    

    /martin
    
    _______________________________________________
    netmod mailing list
    [email-masked]
    https://www.ietf.org/mailman/listinfo/netmod

---

From: Kent Watsen <[email-masked]>
Date: Mon, 1 Oct 2018 18:31:51 +0000

Benoit is the progenitor of the template.  I took it to be an "AD thing"
has since passed to Ignas.

Kent

-----Original Message-----
From: "Acee Lindem (acee)" <[email-masked]>
Date: Monday, October 1, 2018 at 10:25 AM
To: Martin Bjorklund <[email-masked]>, "[email-masked]" <[email-masked]>, "[email-masked]" <[email-masked]>, "[email-masked]" <[email-masked]>
Subject: Re: [netmod] YANG module security considerations template - TLS reference
Resent-From: <[email-masked]>
Resent-To: <[email-masked]>, <[email-masked]>, <[email-masked]>, <[email-masked]>
Resent-Date: Monday, October 1, 2018 at 10:25 AM

Thanks,
Acee 

    Hi,

    This update needs to be done to the template available at
    https://urldefense.proofpoint.com/v2/url?u=https-3A__trac.ietf.org_trac_ops_wiki_yang-2Dsecurity-2Dguidelines&d=DwIGaQ&c=HAkYuh63rsuhr6Scbfh0UjBXeMK-ndb3voDTXcWzoCI&r=9zkP0xnJUvZGJ9EPoOH7Yhqn2gsBYaGTvjISlaJdcZo&m=54lt0_rCJTvXEIWmFXsdUNDbzJIkrJ86K-IveL1QoG4&s=9uZWNJN6weNKKk7ABnZ-yFVkwdZxZzQOSm9bSXwT1SQ&e=

    /martin
    
    _______________________________________________
    netmod mailing list
    [email-masked]
    https://urldefense.proofpoint.com/v2/url?u=https-3A__www.ietf.org_mailman_listinfo_netmod&d=DwIGaQ&c=HAkYuh63rsuhr6Scbfh0UjBXeMK-ndb3voDTXcWzoCI&r=9zkP0xnJUvZGJ9EPoOH7Yhqn2gsBYaGTvjISlaJdcZo&m=54lt0_rCJTvXEIWmFXsdUNDbzJIkrJ86K-IveL1QoG4&s=QhZGZPVsGhr3-uPQZRPyHFcBYz59K2QZxenbb7Ly7L8&e=

---

From: Lou Berger <[email-masked]>
Date: Mon, 01 Oct 2018 14:50:39 -0400

At this point I think it's mature enough to be a yang DR or NETMOD wg thing?

Thoughts, objections?

Lou

----------
On October 1, 2018 2:32:34 PM Kent Watsen <[email-masked]> wrote:

> ?-----Original Message-----
> To: Martin Bjorklund <[email-masked]>, "[email-masked]" 
> <[email-masked]>, "[email-masked]" <[email-masked]>, 
> "[email-masked]" <[email-masked]>
> For drafts that are in-progress, IDNITs will flag this obsolete reference 
> and, for at least one of the drafts I'm an editor, I've already made the 
> update.
>
> Thanks,
> Acee
>
> On 10/1/18, 3:19 AM, "netmod on behalf of Martin Bjorklund" 
> <[email-masked] on behalf of [email-masked]> wrote:
>
>     Hi,
>

---

From: "Acee Lindem (acee)" <[email-masked]>
Date: Mon, 1 Oct 2018 18:58:11 +0000

Agreed. I think we should have a couple designated experts (similar to what we have with IANA registries) that would have editorial authority and could field suggestions for updates (e.g., for example from the Security ADs).

Thanks,
Acee

On 10/1/18, 2:50 PM, "Lou Berger" <[email-masked]> wrote:

    Thoughts, objections?
    
    Lou

    ----------