Subject: Re: [netmod] New Version Notification for draft-wu-netmod-factory-default-01.txt

From: Qin Wu <[email-masked]>
Date: Fri, 19 Oct 2018 13:57:04 +0000

Thanks Balazs for the update,
To netmod chairs:
May I request  the chairs to set up the "replaced by" information for this drafts so that people know the link relation between Netconf draft and this netmod one.
Many thanks!

-Qin
发件人: netmod [mailto:[email-masked]] 代表 Balázs Lengyel
发送时间: 2018年10月19日 20:47
收件人: [email-masked]
主题: [netmod] Fwd: New Version Notification for draft-wu-netmod-factory-default-01.txt

Hello,

A new version of I-D, draft-wu-netmod-factory-default-01.txt has been uploaded. Changes include:
Removed impacts to <copy-config> as the reset-datastore  RPC can anyway do the same thing.
Explained the difference between startup and factory-default datastores
Small corrections.

regards Balazs

-------- Forwarded Message --------
Subject:

New Version Notification for draft-wu-netmod-factory-default-01.txt

Date:

Fri, 19 Oct 2018 05:30:05 -0700

From:

[email-masked]<mailto:[email-masked]>

To:

Ye Niu <[email-masked]><mailto:[email-masked]>, Qin Wu <[email-masked]><mailto:[email-masked]>, Balazs Lengyel <[email-masked]><mailto:[email-masked]>

A new version of I-D, draft-wu-netmod-factory-default-01.txt
has been successfully submitted by Balazs Lengyel and posted to the
IETF repository.

Name: draft-wu-netmod-factory-default
Revision: 01
Title: Factory default Setting
Document date: 2018-10-19
Group: Individual Submission
Pages: 10
URL: https://www.ietf.org/internet-drafts/draft-wu-netmod-factory-default-01.txt
Status: https://datatracker.ietf.org/doc/draft-wu-netmod-factory-default/
Htmlized: https://tools.ietf.org/html/draft-wu-netmod-factory-default-01
Htmlized: https://datatracker.ietf.org/doc/html/draft-wu-netmod-factory-default
Diff: https://www.ietf.org/rfcdiff?url2=draft-wu-netmod-factory-default-01

Abstract:
This document defines a method to reset a YANG datastore to its
factory-default content. The reset operation may be used e.g. during
initial zero-touch configuration or when the existing configuration
has major errors, so re-starting the configuration process from
scratch is the best option.

A new reset-datastore RPC is defined. Several methods of documenting
the factory-default content are specified.

Optionally a new "factory-default-running" read-only datastore is
defined, that contains the data that will be copied over to the
running datastore at reset.

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org.

The IETF Secretariat

--

Balazs Lengyel                       Ericsson Hungary Ltd.

Senior Specialist

Mobile: +36-70-330-7909              email: [email-masked]<mailto:[email-masked]>

---

From: Kent Watsen <[email-masked]>
Date: Fri, 19 Oct 2018 19:25:21 +0000

Hi Qin,

AFIACT, the “replaces” button is only available for adopted (i.e., “-ietf”) documents.

Kent

On 10/19/18, 9:57 AM, "netmod on behalf of Qin Wu" <[email-masked]<mailto:[email-masked]> on behalf of [email-masked]<mailto:[email-masked]>> wrote:

-Qin

Hello,

regards Balazs

-------- Forwarded Message --------
Subject:

Date:

From:

To:

Name: draft-wu-netmod-factory-default
Revision: 01
Title: Factory default Setting
Document date: 2018-10-19
Group: Individual Submission
Pages: 10
URL: https://www.ietf.org/internet-drafts/draft-wu-netmod-factory-default-01.txt<https://urldefense.proofpoint.com/v2/url?u=https-3A__www.ietf.org_internet-2Ddrafts_draft-2Dwu-2Dnetmod-2Dfactory-2Ddefault-2D01.txt&d=DwMGaQ&c=HAkYuh63rsuhr6Scbfh0UjBXeMK-ndb3voDTXcWzoCI&r=9zkP0xnJUvZGJ9EPoOH7Yhqn2gsBYaGTvjISlaJdcZo&m=lN4On6tddSJuD7FhhE4Z_5wiyOhbnGKWuoTuZYXZoUc&s=acBl8iF7KqPRXfHWMtZ_gycSRbDgGZs4udLKBZ8hYgA&e=>
Status: https://datatracker.ietf.org/doc/draft-wu-netmod-factory-default/<https://urldefense.proofpoint.com/v2/url?u=https-3A__datatracker.ietf.org_doc_draft-2Dwu-2Dnetmod-2Dfactory-2Ddefault_&d=DwMGaQ&c=HAkYuh63rsuhr6Scbfh0UjBXeMK-ndb3voDTXcWzoCI&r=9zkP0xnJUvZGJ9EPoOH7Yhqn2gsBYaGTvjISlaJdcZo&m=lN4On6tddSJuD7FhhE4Z_5wiyOhbnGKWuoTuZYXZoUc&s=hL_PofyocMVTjM_3dOElInskqqruTzJb_R_McGMs-yY&e=>
Htmlized: https://tools.ietf.org/html/draft-wu-netmod-factory-default-01<https://urldefense.proofpoint.com/v2/url?u=https-3A__tools.ietf.org_html_draft-2Dwu-2Dnetmod-2Dfactory-2Ddefault-2D01&d=DwMGaQ&c=HAkYuh63rsuhr6Scbfh0UjBXeMK-ndb3voDTXcWzoCI&r=9zkP0xnJUvZGJ9EPoOH7Yhqn2gsBYaGTvjISlaJdcZo&m=lN4On6tddSJuD7FhhE4Z_5wiyOhbnGKWuoTuZYXZoUc&s=J1ImBBOH0wfBj3-nljkTdoA8ouakpuGK_xnTu-SDZdg&e=>
Htmlized: https://datatracker.ietf.org/doc/html/draft-wu-netmod-factory-default<https://urldefense.proofpoint.com/v2/url?u=https-3A__datatracker.ietf.org_doc_html_draft-2Dwu-2Dnetmod-2Dfactory-2Ddefault&d=DwMGaQ&c=HAkYuh63rsuhr6Scbfh0UjBXeMK-ndb3voDTXcWzoCI&r=9zkP0xnJUvZGJ9EPoOH7Yhqn2gsBYaGTvjISlaJdcZo&m=lN4On6tddSJuD7FhhE4Z_5wiyOhbnGKWuoTuZYXZoUc&s=sl_7BlMfOuj9wreLDGnNuBnYctrWHtMMnV35810XF68&e=>
Diff: https://www.ietf.org/rfcdiff?url2=draft-wu-netmod-factory-default-01<https://urldefense.proofpoint.com/v2/url?u=https-3A__www.ietf.org_rfcdiff-3Furl2-3Ddraft-2Dwu-2Dnetmod-2Dfactory-2Ddefault-2D01&d=DwMGaQ&c=HAkYuh63rsuhr6Scbfh0UjBXeMK-ndb3voDTXcWzoCI&r=9zkP0xnJUvZGJ9EPoOH7Yhqn2gsBYaGTvjISlaJdcZo&m=lN4On6tddSJuD7FhhE4Z_5wiyOhbnGKWuoTuZYXZoUc&s=ZPLUIAfnMxvWu6XpD19ZOaIj919rPjyAEW5NOxzNuCQ&e=>

Abstract:

The IETF Secretariat

--

Senior Specialist