Subject: [netmod] draft-wu-netmod-factory-default-01: Actually resetting the device to factory defaults

From: "Carey, Timothy (Nokia - US)" <[email-masked]>
Date: Tue, 6 Nov 2018 04:41:16 +0000

Hi,

In the IETF 103 meeting a comment was made that using the reset-datastore RPC doesn't actually reset the device to factory settings.

I would like to suggest that this RPC when applied to the start-up store have the capability to actually reset the device the factory settings.

This might require a device reboot to finalize the action but we do need an option that I can actually place the device in a configuration
That resembles the device when it first arrives from the "factory". I would believe this would be the main use case for this type of reset-datastore operation.

Did I misunderstand the comment?

BR,
Tim

---

From: Ebben Aries <[email-masked]>
Date: Tue, 6 Nov 2018 16:55:23 +0700

> Did I misunderstand the comment?

Correct - I haven't read this draft yet but it sounds like the focus so
far is specific to default datastore configuration only which imo is
very close to an edit/load of an implementation specific default
configuration + commit action

Resetting an entire device to factory defaults involves many more things
such as wiping the filesystem (or portions of) e.g. logs, scripts,
user-added files, etc.. in addition

So to your point, I agree - the scope should be expanded to entire
device factory defaults

/ebben