Subject: [netmod] Query about Schema Mount "config" leaf

From: Rohit R Ranade <[email-masked]>
Date: Fri, 21 Dec 2018 12:01:06 +0000

Hi All,

        +--ro mount-point* [module label]
           +--ro module                 yang:yang-identifier
           +--ro label                  yang:yang-identifier
           +--ro config?                boolean

1.       When reading the schema mount draft it is not clear for which use-case, the "config" being false will be helpful for ?

2.       If there are modules with config true nodes mounted, how can the data-nodes of those mounted modules be instantiated if the config leaf is false ?

With Regards,
Rohit

---

From: Robert Wilton <[email-masked]>
Date: Fri, 21 Dec 2018 12:11:03 +0000

Hi Rohit,

Are you familiar with either of the LNE or NI model drafts?

https://datatracker.ietf.org/doc/draft-ietf-rtgwg-lne-model/

https://datatracker.ietf.org/doc/draft-ietf-rtgwg-ni-model/

I believe both of these drafts were driving some of the key schema mount 
requirements, and may provide useful examples of the use cases.

On 21/12/2018 12:01, Rohit R Ranade wrote:
>            +--ro *config*?                boolean
> 1..When reading the schema mount draft it is not clear for which 
> use-case, the “config” being false will be helpful for ?
>
Section 3 of the LNE draft writes about the use of this config leaf.

> 2..If there are modules with config true nodes mounted, how can the 
> data-nodes of those mounted modules be instantiated if the config leaf 
> is false ?
>
There will likely be separate direct YANG management protocol access to 
the mounted data (e.g. for a mounted LNE) that would allow the 
configuration to be manipulated.

Thanks,
Rob

> With Regards,
>
> Rohit
>
>
> _______________________________________________
> netmod mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/netmod

---

From: Rohit R Ranade <[email-masked]>
Date: Mon, 24 Dec 2018 03:29:45 +0000

OK, got the reference.
I felt it would have been better to mention why this "config" leaf has been defined in this draft by citing a reference to other drafts as has been done for the rest of the leaves.
As a reader, I was left wondering as to why there should be a leaf that over-rides the actual "config" true definition of the mounted models. If indeed the goal is to allow only "read" access why not use the NACM way for it ?

With Regards,
Rohit

From: Robert Wilton [mailto:[email-masked]]
Sent: 21 December 2018 17:41
To: Rohit R Ranade <[email-masked]>; [email-masked]
Subject: Re: [netmod] Query about Schema Mount "config" leaf

Hi Rohit,

I believe both of these drafts were driving some of the key schema mount requirements, and may provide useful examples of the use cases.
On 21/12/2018 12:01, Rohit R Ranade wrote:
Hi All,

There will likely be separate direct YANG management protocol access to the mounted data (e.g. for a mounted LNE) that would allow the configuration to be manipulated.

Thanks,
Rob

With Regards,
Rohit

netmod mailing list

[email-masked]<mailto:[email-masked]>