Subject: [netmod] Schema Mount Terminology Clarification

From: Rohit R Ranade <[email-masked]>
Date: Wed, 12 Dec 2018 10:12:29 +0000

Hi,

1.       The term "data model" is used many times in this document, but it is not defined in this document but defined in RFC 7950. I think it should be added under the "following terms are defined in [RFC7950]" part.

2.       The term "This document allows mounting of complete data models only" is used in Section 1. I think here "complete data model" should be replaced by "schema tree" as it is more precise?

a)         RFC 7950 , schema tree: The definition hierarchy specified within a module

b)   RFC7950, data model: A data model describes how data is represented and accessed

3.       The "data model" term is used many times Eg: "LNE's data model", "share the same data model", "NI data model", "mounting one data model consisting of any number of YANG modules"   etc, sometimes using the term "data model" as a collection of YANG modules and sometimes for a single Yang module. I feel, where-ever we refer to single Module, we need to use the term "schema tree" and when we refer to collection of YANG modules, we can refer to as Data Model.. Please provide your opinions.

With Regards,
Rohit

---

From: Ladislav Lhotka <[email-masked]>
Date: Wed, 12 Dec 2018 11:44:02 +0100

Hi Rehat,

On Wed, 2018-12-12 at 10:12 +0000, Rohit R Ranade wrote:
> Hi,
>  
>  
> 1..       The term “data model” is used many times in this document, but it is
> not defined in this document but defined in RFC 7950. I think it should be
> added under the “following terms are defined in [RFC7950]” part.

The definition of "data model" in RFC 7950 is too informal. What is meant by it
in the schema mount document is basically "datastore schema" as defined in RFC
8342. Perhaps a better term would just be "schema".

>  
> 2..       The term “This document allows mounting of complete data models
> only” is used in Section 1. I think here “complete data model” should be
> replaced by “schema tree” as it is more precise?

No, "schema tree" is only for a single module, accrding to the definition in
7950. What is meant here is a schema of multiple modules, as defined by YANG
library.

> 3..       The “data model” term is used many times Eg: “LNE's data model”,
> “share the same data model”, “NI data model”, “mounting one data model
> consisting of any number of YANG modules”   etc, sometimes using the term
> “data model” as a collection of YANG modules and sometimes for a single Yang
> module. I feel, where-ever we refer to single Module, we need to use the term
> “schema tree” and when we refer to collection of YANG modules, we can refer to
> as Data Model.. Please provide your opinions.

This was my original idea, but maybe it is better to use "schema" or "datastore
schema" for the latter.

Lada

>  
> With Regards,
> Rohit  
> _______________________________________________
> netmod mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/netmod
-- 
Ladislav Lhotka
Head, CZ.NIC Labs
PGP Key ID: 0xB8F92B08A9F76C67

---

From: Rohit R Ranade <[email-masked]>
Date: Wed, 12 Dec 2018 11:08:16 +0000

Hi Lada,

Thank you for your response.
Please find some responses inline.

With Regards,
Rohit

-----Original Message-----
From: netmod [mailto:[email-masked]] On Behalf Of Ladislav Lhotka
Sent: 12 December 2018 16:14
To: [email-masked]
Subject: Re: [netmod] Schema Mount Terminology Clarification

Hi Rehat,

On Wed, 2018-12-12 at 10:12 +0000, Rohit R Ranade wrote:
> not defined in this document but defined in RFC 7950. I think it 
> should be added under the “following terms are defined in [RFC7950]” part.

The definition of "data model" in RFC 7950 is too informal. What is meant by it in the schema mount document is basically "datastore schema" as defined in RFC 8342. Perhaps a better term would just be "schema".

> only” is used in Section 1. I think here “complete data model” should 
> be replaced by “schema tree” as it is more precise?

No, "schema tree" is only for a single module, accrding to the definition in 7950. What is meant here is a schema of multiple modules, as defined by YANG library.
[Rohit R Ranade] I agree. Maybe "complete schema trees" is better as mounting sub-hierarchies is not in scope for this document. I see that it has been used in Section 1 in the below statement . 
" With the "uses" approach, the complete schema tree of "ietf-interfaces" would have to be wrapped in a grouping ...... "

> “data model” as a collection of YANG modules and sometimes for a 
> single Yang module. I feel, where-ever we refer to single Module, we 
> need to use the term “schema tree” and when we refer to collection of 
> YANG modules, we can refer to as Data Model.. Please provide your opinions.

This was my original idea, but maybe it is better to use "schema" or "datastore schema" for the latter.
[Rohit R Ranade] I agree that term "schema" is indeed better. 

Lada