Subject: Re: [netmod] Schema Mount with Inline Type

From: Ladislav Lhotka <[email-masked]>
Date: Wed, 02 Jan 2019 14:58:54 +0100

Hi Rohit,

Rohit R Ranade <[email-masked]> writes:

> Hi All,
>
>    module: ietf-yang-schema-mount
>      +--ro schema-mounts
>         +--ro namespace* [prefix]
>         |  +--ro prefix    yang:yang-identifier
>         |  +--ro uri?      inet:uri
>         +--ro mount-point* [module label]
>            +--ro module                 yang:yang-identifier
>            +--ro label                  yang:yang-identifier
>            +--ro config?                boolean
>            +--ro (schema-ref)
>               +--:(inline)
>               |  +--ro inline!
>               +--:(shared-schema)
>                  +--ro shared-schema!
>                     +--ro parent-reference*   yang:xpath1.0
>
> Any reason for not adding "parent-reference" for "inline" type ? What
> is the solution for the modules defined under such mount points to
> refer to parent schema ?

The inline case was intentionally designed with an impenetrable "mount
jail". Do you see any use case where parent references are needed and
the "shared-schema" strategy cannot be used?

Lada

>
> With Regards,
> Rohit
> _______________________________________________
> netmod mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/netmod

-- 
Ladislav Lhotka
Head, CZ.NIC Labs
PGP Key ID: 0xB8F92B08A9F76C67

---

From: Rohit R Ranade <[email-masked]>
Date: Thu, 3 Jan 2019 05:05:13 +0000

Hi,

I donot have a specific scenario as of now. But the scenario used in the draft is that a module which is mounted needs to refer to its parent-schema. I donot see how that is related to "mount point instances having shared-schema or different schema". 

If we look at the LNE draft, I think it avoids the "parent-reference" by having a " bind-lne-name" which binds the interface to the LNE and also creates a "system" configuration for that interface inside the LNE instance. So the interface references inside the mount jail get resolved.

So in future, if "inlined" schema needs to use parent-schema, it needs to use a "bind" mechanism to add entries from the module in parent-schema to the same module under mount-point ?

-----Original Message-----
From: Ladislav Lhotka [mailto:[email-masked]] 
Sent: 02 January 2019 19:29
To: Rohit R Ranade <[email-masked]>; [email-masked]
Subject: Re: [netmod] Schema Mount with Inline Type

Hi Rohit,

> is the solution for the modules defined under such mount points to 

The inline case was intentionally designed with an impenetrable "mount jail". Do you see any use case where parent references are needed and the "shared-schema" strategy cannot be used?

Lada

---

From: Ladislav Lhotka <[email-masked]>
Date: Fri, 04 Jan 2019 13:51:34 +0100

Rohit R Ranade <[email-masked]> writes:

> If we look at the LNE draft, I think it avoids the "parent-reference"
> by having a " bind-lne-name" which binds the interface to the LNE and
> also creates a "system" configuration for that interface inside the
> LNE instance. So the interface references inside the mount jail get
> resolved.

If I understand it correctly (maybe not), the "bind-lne-name" is used at
the level of Network Device to assign an interface to a configured
LNE. This information IMO is not meaningful inside the LNE itself. If it
is so, there is in fact no parent reference.

>
> So in future, if "inlined" schema needs to use parent-schema, it needs
> to use a "bind" mechanism to add entries from the module in
> parent-schema to the same module under mount-point ?

In my view, the inline case makes only sense in the split management
scenario where each mount jail is managed via a separate NC/RC
server. In this case it makes no sense to refer to data outside the
mount jail.

My standard complaint is that schema mount mixes up two rather different
concepts: the shared-schema case is a data modelling concept whereas the
inline case is more about combining instance data. This causes a lot of
complexity and confusion.

Lada

---

From: Rohit R Ranade <[email-masked]>
Date: Mon, 7 Jan 2019 02:03:56 +0000

-----Original Message-----
From: Ladislav Lhotka [mailto:[email-masked]] 
Sent: 04 January 2019 18:22
To: Rohit R Ranade <[email-masked]>; [email-masked]
Subject: RE: [netmod] Schema Mount with Inline Type

> LNE instance. So the interface references inside the mount jail get 

If I understand it correctly (maybe not), the "bind-lne-name" is used at the level of Network Device to assign an interface to a configured LNE. This information IMO is not meaningful inside the LNE itself. If it is so, there is in fact no parent reference.

> parent-schema to the same module under mount-point ?

In my view, the inline case makes only sense in the split management scenario where each mount jail is managed via a separate NC/RC server. In this case it makes no sense to refer to data outside the mount jail.

My standard complaint is that schema mount mixes up two rather different
concepts: the shared-schema case is a data modelling concept whereas the inline case is more about combining instance data. This causes a lot of complexity and confusion.
[Rohit R Ranade] +1  

Lada