Subject: [netmod] Questions about yang models

From: Voica Maria Gavrilut <[email-masked]>
Date: Thu, 24 Jan 2019 10:15:34 +0000

Hello, 

I work now to output some configuration parameters in TSN-specific formats. I was able to obtain IEEE 802.1Qcw compliant formats, but I cannot export the topology or the routing in a similar manner. Could you help me please with some information?

1. To describe the global topology. I found the network-topology.yang model, but when I use the pyang tool to convert the yang model to python code I get the following warnings and error:
"
network-topology.yang:288: warning: XPath for "boolean(../underlay-topology[*]/node[./supporting-nodes/node-ref])" does not exist
network-topology.yang:320: warning: XPath for "boolean(../underlay-topology/link[./supporting-link])" does not exist
network-topology.yang:322: warning: XPath for "boolean(../node[./source/source-node])" does not exist
network-topology.yang:324: warning: XPath for "boolean(../node[./destination/dest-node])" does not exist
network-topology.yang:326: warning: XPath for "boolean(../node/termination-point[./source/source-tp])" does not exist
network-topology.yang:328: warning: XPath for "boolean(../node/termination-point[./destination/dest-tp])" does not exist
FATAL: pyangbind cannot build module that pyang has found errors with.

"
There is other updated and functional version of network-topology model? I was using both versions, from 2013-07-12 and 2013-07-15. 

2. To describe static determined routes. For routing I could not find any model for static routing, could someone help me please with a yang model that could be used for such type of routing? 

All best
Voica

---

From: Juergen Schoenwaelder <[email-masked]>
Date: Thu, 24 Jan 2019 11:51:53 +0100

Dear Voica Maria Gavrilut,

the IETF network topology model got published as part of RFC 8345 and
you may want to use that. In case you find problems with the model, you
should direct your questions to the i2rs working group as this is the
working group which created these models (and RFC 8345).

I am not sure I understand your second question but the IETF core
routing modules are published in RFC 8349. BTW, you can find an overview
of the IETF published YANG modules on wikipedia:

https://en.wikipedia.org/wiki/YANG#Usage_in_Standards-Track_Data_Models_of_the_IETF

Modules that you find in Internet Drafts are work in progress and
moving targets and they may have issues.

/js

On Thu, Jan 24, 2019 at 10:15:34AM +0000, Voica Maria Gavrilut wrote:
> _______________________________________________
> netmod mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/netmod

-- 
Juergen Schoenwaelder           Jacobs University Bremen gGmbH
Phone: +49 421 200 3587         Campus Ring 1 | 28759 Bremen | Germany
Fax:   +49 421 200 3103         <https://www.jacobs-university.de/>