Subject: [netmod] FW: Schema Mount Yang Library Update

From: Rohit R Ranade <[email-masked]>
Date: Mon, 14 Jan 2019 05:34:39 +0000

Hi Authors,

Any suggestions regarding the question in the below mail ?

With Regards,
Rohit

From: Rohit R Ranade
Sent: 28 December 2018 09:37
To: [email-masked]
Subject: Schema Mount Yang Library Update

Hi All,

For the shared-schema type, the draft mentions "all instances of the same mount point MUST have the same YANG library content identifier".

I think to achieve above condition, most vendors will plan to have only one YANG library instance for that mount-point.

If use multiple instances for Yang library, it is possible that the algorithm may generate a new content identifier for same data as per below statement in Yang library 1.1 draft:

"There is no requirement that the same information always results in the same "content-id" value."

If use single instance of Yang library, when a YANG library update happens, for which mount-point instance should a YANG library update notification be sent ?
What is the guideline for the implementers of this draft regarding this point?

With Regards,
Rohit

---

From: Ladislav Lhotka <[email-masked]>
Date: Mon, 14 Jan 2019 13:31:58 +0100

Hi Rohit,

I am sorry that nobody answered your question, but I don't feel
competent to do so because I don't like the way how the "shared-schema"
case is currently modeled in the first place. 

Lada

-- 
Ladislav Lhotka
Head, CZ.NIC Labs
PGP Key ID: 0xB8F92B08A9F76C67

---

From: Martin Bjorklund <[email-masked]>
Date: Mon, 14 Jan 2019 14:06:04 +0100 (CET)

Hi,

I think the only reasonable answer is that this behavior must not be
dependent on your implementation strategy so the answer must be the
same if you choose to use a shared YL or separate YLs.  Hence, if a
mount point's YL changes, the notif is sent from that instance.

/martin

Rohit R Ranade <[email-masked]> wrote:
> For the shared-schema type, the draft mentions "all instances of the
> same mount point MUST have the same YANG library content identifier".
> 
> I think to achieve above condition, most vendors will plan to have
> only one YANG library instance for that mount-point.
> 
> If use multiple instances for Yang library, it is possible that the
> algorithm may generate a new content identifier for same data as per
> below statement in Yang library 1.1 draft:
> 
> If use single instance of Yang library, when a YANG library update
> happens, for which mount-point instance should a YANG library update
> notification be sent ?

---

From: Rohit R Ranade <[email-masked]>
Date: Thu, 17 Jan 2019 03:42:03 +0000

Hi Martin,

If we use separate YLs for shared-schema, then during YL update there may be a small time gap, where-in all the YLs may not have generated the same content-id, violating one of the constraints for the shared-schema mount-point. 

On a separate note, a mount-point is mentioned as shared-schema, so that the Client can leverage this information to store the schema only once and use it for parsing the data for all mount-point instances. Is there any other reason ?

With Regards,
Rohit

-----Original Message-----
From: Martin Bjorklund [mailto:[email-masked]] 
Sent: 14 January 2019 18:36
To: Rohit R Ranade <[email-masked]>
Cc: [email-masked]; [email-masked]
Subject: Re: Schema Mount Yang Library Update

Hi,

I think the only reasonable answer is that this behavior must not be dependent on your implementation strategy so the answer must be the same if you choose to use a shared YL or separate YLs.  Hence, if a mount point's YL changes, the notif is sent from that instance.

/martin