Subject: [netmod] yang-next meeting at IETF 104?

From: Andy Bierman <[email-masked]>
Date: Mon, 14 Jan 2019 09:07:20 -0800

Hi,

Is there any interest in 1 or more side meetings at the next IETF to
discuss the yang-next issue list, towards the goal of determining the
problem space in scope for YANG 1.2?

Those of us who would need to make travel plans would appreciate it
if meetings like this were scheduled ASAP instead of ALAP ;-)

Andy

---

From: Martin Bjorklund <[email-masked]>
Date: Mon, 14 Jan 2019 18:10:30 +0100 (CET)

Hi,

> problem space in scope for YANG 1.2?

I am interested in this.  I prefer a meeting during the week; my plan
is to arrive Sunday afternoon.

/martin

---

From: Robert Wilton <[email-masked]>
Date: Mon, 14 Jan 2019 17:19:29 +0000

I would also be interested.  During the week would also be best. Friday 
morning could also be a possibility depending on whether there are 
sessions scheduled.

Thanks,
Rob

On 14/01/2019 17:10, Martin Bjorklund wrote:
> _______________________________________________
> netmod mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/netmod
> .
>

---

From: Kent Watsen <[email-masked]>
Date: Mon, 14 Jan 2019 19:45:09 +0000

I'm interested as well.

PS: I've been too busy to setup a virtual meeting for us to finish the review of the YANG-next items in the GitHub tracker.  But things are just beginning to free up a little for me now.  Would folks like to have a meeting before 104 to finish that review?

Kent // contributor

-----Original Message-----
From: netmod <[email-masked]> on behalf of Robert Wilton <[email-masked]>
Date: Monday, January 14, 2019 at 12:19 PM
To: Martin Bjorklund <[email-masked]>, "[email-masked]" <[email-masked]>
Cc: NETMOD Working Group <[email-masked]>
Subject: Re: [netmod] yang-next meeting at IETF 104?

Thanks,
Rob

On 14/01/2019 17:10, Martin Bjorklund wrote:
> https://urldefense.proofpoint.com/v2/url?u=https-3A__www.ietf.org_mailman_listinfo_netmod&d=DwIGaQ&c=HAkYuh63rsuhr6Scbfh0UjBXeMK-ndb3voDTXcWzoCI&r=9zkP0xnJUvZGJ9EPoOH7Yhqn2gsBYaGTvjISlaJdcZo&m=BfGnjYejrGjQ93xAzY1pzA9M9wXXY7rNFeWy3dKZXWc&s=fNOa2UIOMhNDcO3nFEFBdqQSdrQ-KaYNF2GaTgfRsgI&e=
> .
>

_______________________________________________
netmod mailing list
[email-masked]
https://urldefense.proofpoint.com/v2/url?u=https-3A__www.ietf.org_mailman_listinfo_netmod&d=DwIGaQ&c=HAkYuh63rsuhr6Scbfh0UjBXeMK-ndb3voDTXcWzoCI&r=9zkP0xnJUvZGJ9EPoOH7Yhqn2gsBYaGTvjISlaJdcZo&m=BfGnjYejrGjQ93xAzY1pzA9M9wXXY7rNFeWy3dKZXWc&s=fNOa2UIOMhNDcO3nFEFBdqQSdrQ-KaYNF2GaTgfRsgI&e=

---

From: Mahesh Jethanandani <[email-masked]>
Date: Tue, 15 Jan 2019 06:57:19 +1100

Hi Kent,

I think it makes sense to have a virtual meeting before 104. 

Mahesh Jethanandani
[email-masked]

> On Jan 15, 2019, at 6:45 AM, Kent Watsen <[email-masked]> wrote:
> 
> I'm interested as well.
>

---

From: Martin Bjorklund <[email-masked]>
Date: Mon, 14 Jan 2019 21:01:35 +0100 (CET)

Kent Watsen <[email-masked]> wrote:
> I'm interested as well.
> 
> PS: I've been too busy to setup a virtual meeting for us to finish the
> review of the YANG-next items in the GitHub tracker.  But things are
> just beginning to free up a little for me now.  Would folks like to
> have a meeting before 104 to finish that review?

I think that's what the side meeting would do - review the current
items to see what makes sense.

/martin

---

From: Kent Watsen <[email-masked]>
Date: Mon, 14 Jan 2019 22:27:12 +0000

> items to see what makes sense.

Sure, but perhaps the in-person time would be better spent analyzing the results of the reviews?  Recall that we're trying to score each item on three axis: importance, complexity, backward-compatibility.

Current results here:  https://github.com/netmod-wg/yang-next/issues?q=is%3Aissue+is%3Aopen+sort%3Acreated-asc.

At the rate we were going (about 40% done), I imagine it taking 2-4 hours to score the remaining issues.  This may not be an issue if we can meet multiple times during the week but, if time is tight, I'd rather have this part done before we meet.

Kent // contributor

---

From: Andy Bierman <[email-masked]>
Date: Mon, 14 Jan 2019 15:32:10 -0800

On Mon, Jan 14, 2019 at 2:27 PM Kent Watsen <[email-masked]> wrote:

> Sure, but perhaps the in-person time would be better spent analyzing the
> results of the reviews?  Recall that we're trying to score each item on
> three axis: importance, complexity, backward-compatibility.
>
>
I agree with this approach.  It is too easy to get
bogged down on how a solution might work (or worse, let's compare
2 or 3 different solutions right now) and never finish the issue list.

There are spot solutions in progress (e.g., on-change
notification,  yang-data)
that might be much better handled with robust generalized solutions in YANG.
I have some concern that a patchwork of optional extensions is worse for
end-users
in the long-term, than a new YANG language version.

Current results here:
> https://github.com/netmod-wg/yang-next/issues?q=is%3Aissue+is%3Aopen+sort%3Acreated-asc
> .
>
> At the rate we were going (about 40% done), I imagine it taking 2-4 hours
> to score the remaining issues.  This may not be an issue if we can meet
> multiple times during the week but, if time is tight, I'd rather have this
> part done before we meet.
>
> Kent // contributor
>
>
>

Andy

---

From: Ladislav Lhotka <[email-masked]>
Date: Tue, 15 Jan 2019 09:23:42 +0100

> problem space in scope for YANG 1.2?

Yes, I would be interested. I have no preferences in terms of timing.

Lada

-- 
Ladislav Lhotka
Head, CZ.NIC Labs
PGP Key ID: 0xB8F92B08A9F76C67

---

From: "Reshad Rahman (rrahman)" <[email-masked]>
Date: Tue, 15 Jan 2019 20:28:45 +0000

I am interested in attending the virtual meeting(s) and the in-person meeting in Prague (Monday-Thursday preferably).

    

    
    Kent // contributor