Subject: Re: [netmod] I-D Action: draft-ietf-netmod-artwork-folding-03.txt

From: Kent Watsen <[email-masked]>
Date: Mon, 17 Jun 2019 17:38:41 +0000

I just posted an Editorial update that only touches the non-normative script to add a -q (quiet) flag.  Here's the diff: https://tools.ietf.org/rfcdiff?url2=draft-ietf-netmod-artwork-folding-04.txt <https://tools.ietf.org/rfcdiff?url2=draft-ietf-netmod-artwork-folding-04.txt>.

Separately, it's been more than two weeks since the below message.   There has been no comments on #2 below, and so the chairs can more forward with the publishing request now?

Kent // author (recused chair)

> On May 30, 2019, at 10:41 AM, Kent Watsen <[email-masked]> wrote:
> 
> 
> This update reflects the changes discussed during the Last Call plus the following additional changes:
> 
>   1) s/see if any/ensure at least one/  (EDITORIAL: sounded too casual before)
>   2) s/MUST NOT precede a space (' ') character/MUST NOT be on top of a space (' ') character/  (TECHNICAL: see below)
>   3) wrapped the script with <CODE BEGINS> and <CODE ENDS> (EDITORIAL, per idnits)
> 
> Regarding #2, this change was made after I examined the algorithm more carefully.  It would be good for others to confirm this rather critical change.
> 
> Thanks,
> Kent // contributor
> 
> 
> 
>> On May 30, 2019, at 10:30 AM, [email-masked] <mailto:[email-masked]> wrote:
>> 
>> 
>> A New Internet-Draft is available from the on-line Internet-Drafts directories.
>> This draft is a work item of the Network Modeling WG of the IETF.
>> 
>>        Title           : Handling Long Lines in Inclusions in Internet-Drafts and RFCs
>>        Authors         : Kent Watsen
>>                          Adrian Farrel
>>                          Qin Wu
>> 	Filename        : draft-ietf-netmod-artwork-folding-03.txt
>> 	Pages           : 25
>> 	Date            : 2019-05-30
>> 
>> Abstract:
>>   This document defines two strategies for handling long lines in
>>   width-bounded text content.  One strategy is based on the historic
>>   use of a single backslash ('\') character to indicate where line-
>>   folding has occurred, with the continuation occurring with the first
>>   non-space (' ') character on the next line.  The second strategy
>>   extends the first strategy by adding a second backslash character to
>>   identify where the continuation begins and thereby able to handle
>>   cases not supported by the first strategy.  Both strategies use a
>>   self-describing header enabling automated reconstitution of the
>>   original content.
>> 
>> 
>> The IETF datatracker status page for this draft is:
>> https://datatracker.ietf.org/doc/draft-ietf-netmod-artwork-folding/ <https://datatracker.ietf.org/doc/draft-ietf-netmod-artwork-folding/>
>> 
>> There are also htmlized versions available at:
>> https://tools.ietf.org/html/draft-ietf-netmod-artwork-folding-03
>> https://datatracker.ietf.org/doc/html/draft-ietf-netmod-artwork-folding-03
>> 
>> A diff from the previous version is available at:
>> https://www.ietf.org/rfcdiff?url2=draft-ietf-netmod-artwork-folding-03
>> 
>> 
>> Please note that it may take a couple of minutes from the time of submission
>> until the htmlized version and diff are available at tools.ietf.org.
>> 
>> Internet-Drafts are also available by anonymous FTP at:
>> ftp://ftp.ietf.org/internet-drafts/
>> 
>> _______________________________________________
>> netmod mailing list
>> [email-masked]
>> https://www.ietf.org/mailman/listinfo/netmod
> 
> _______________________________________________
> netmod mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/netmod

---

From: "Adrian Farrel" <[email-masked]>
Date: Mon, 17 Jun 2019 19:16:34 +0100

Kent, 

Thanks for the work.

I had a clear understanding of what "precede a space" means.

I struggle to understand what "on top of" means in a stream of characters. I
wondered whether you were referring to vertical placement on the page (the
text is talking about columns), but that seems crazy!

Do you mean that the fold must not be occupied by a space character?

I think the question is whether it is easier to describe a fold happening
between characters or at a character slot.

The original text used the "between characters" approach. If you prefer to
say you fold at a column, that's fine, but probably "on top of" isn't as
clear as "the column at which we fold must not contain a space".

Best,

Adrian

From: netmod <[email-masked]> On Behalf Of Kent Watsen
Sent: 17 June 2019 18:39
To: [email-masked]
Subject: Re: [netmod] I-D Action: draft-ietf-netmod-artwork-folding-03.txt

I just posted an Editorial update that only touches the non-normative script
to add a -q (quiet) flag.  Here's the diff:
https://tools.ietf.org/rfcdiff?url2=draft-ietf-netmod-artwork-folding-04.txt
.

Separately, it's been more than two weeks since the below message.   There
has been no comments on #2 below, and so the chairs can more forward with
the publishing request now?

 

On May 30, 2019, at 10:41 AM, Kent Watsen <[email-masked]
<mailto:[email-masked]> > wrote:

This update reflects the changes discussed during the Last Call plus the
following additional changes:

  1) s/see if any/ensure at least one/  (EDITORIAL: sounded too casual
before)

  2) s/MUST NOT precede a space (' ') character/MUST NOT be on top of a
space (' ') character/  (TECHNICAL: see below)

  3) wrapped the script with <CODE BEGINS> and <CODE ENDS> (EDITORIAL, per
idnits)

Regarding #2, this change was made after I examined the algorithm more
carefully.  It would be good for others to confirm this rather critical
change.

Thanks,

Kent // contributor

On May 30, 2019, at 10:30 AM, [email-masked]
<mailto:[email-masked]>  wrote:

A New Internet-Draft is available from the on-line Internet-Drafts
directories.
This draft is a work item of the Network Modeling WG of the IETF.

       Title           : Handling Long Lines in Inclusions in
Internet-Drafts and RFCs
       Authors         : Kent Watsen
                         Adrian Farrel
                         Qin Wu
   Filename        : draft-ietf-netmod-artwork-folding-03.txt
       Pages           : 25
       Date            : 2019-05-30

Abstract:

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-ietf-netmod-artwork-folding/

_______________________________________________
netmod mailing list
[email-masked] <mailto:[email-masked]> 
https://www.ietf.org/mailman/listinfo/netmod

_______________________________________________
netmod mailing list
[email-masked] <mailto:[email-masked]> 
https://www.ietf.org/mailman/listinfo/netmod

---

From: Kent Watsen <[email-masked]>
Date: Mon, 17 Jun 2019 18:53:19 +0000

Hi Adrian,

Text suggestions welcomed.   

What needs to be expressed is that a space character cannot occupy the column where the end-of-line '\' is to placed, as doing so would push that space character to the beginning of the next line, which the unfolding logic would subsequently delete, thinking that it was part of a user-placed "indent".  Makes sense?

Kent

> On Jun 17, 2019, at 2:16 PM, Adrian Farrel <[email-masked]> wrote:
> 
> Kent, 
> Thanks for the work.
>  
> I had a clear understanding of what “precede a space” means.
> I struggle to understand what “on top of” means in a stream of characters. I wondered whether you were referring to vertical placement on the page (the text is talking about columns), but that seems crazy!
> I think the question is whether it is easier to describe a fold happening between characters or at a character slot.
> The original text used the “between characters” approach. If you prefer to say you fold at a column, that’s fine, but probably “on top of” isn’t as clear as “the column at which we fold must not contain a space”.
>  
> Best,
> Adrian
>  
>  
>> On May 30, 2019, at 10:41 AM, Kent Watsen <[email-masked] <mailto:[email-masked]>> wrote:
>>  
>>  
>>> https://tools.ietf.org/html/draft-ietf-netmod-artwork-folding-03 <https://tools.ietf.org/html/draft-ietf-netmod-artwork-folding-03>
>>> https://datatracker.ietf.org/doc/html/draft-ietf-netmod-artwork-folding-03 <https://datatracker.ietf.org/doc/html/draft-ietf-netmod-artwork-folding-03>
>>> 
>>> https://www.ietf.org/rfcdiff?url2=draft-ietf-netmod-artwork-folding-03 <https://www.ietf.org/rfcdiff?url2=draft-ietf-netmod-artwork-folding-03>
>>> 
>>> 
>>> ftp://ftp.ietf.org/internet-drafts/ <ftp://ftp.ietf.org/internet-drafts/>
>>> 
>>> https://www.ietf.org/mailman/listinfo/netmod <https://www.ietf.org/mailman/listinfo/netmod>
>>  
>> https://www.ietf.org/mailman/listinfo/netmod <https://www.ietf.org/mailman/listinfo/netmod>

---

From: "Adrian Farrel" <[email-masked]>
Date: Mon, 17 Jun 2019 21:53:31 +0100

OK, we’re agreed on what we want to achieve, just not on the wording to describe it 😊

How about…

   1.  Determine where the fold will occur.  This location MUST be

       before or at the desired maximum column, and MUST NOT be chosen

       such that the character immediately after the fold is a space

       (' ') character.  If no such location can be found, then exit

       (this text content cannot be folded)

Best,

Adrian

From: Kent Watsen <[email-masked]> 
Sent: 17 June 2019 19:53
To: Adrian Farrel <[email-masked]>
Cc: [email-masked]
Subject: Re: [netmod] I-D Action: draft-ietf-netmod-artwork-folding-03.txt

Hi Adrian,

Kent

On Jun 17, 2019, at 2:16 PM, Adrian Farrel <[email-masked] <mailto:[email-masked]> > wrote:

Kent, 

Thanks for the work.

Best,

Adrian

From: netmod <[email-masked] <mailto:[email-masked]> > On Behalf Of Kent Watsen
Sent: 17 June 2019 18:39
To: [email-masked] <mailto:[email-masked]> 
Subject: Re: [netmod] I-D Action: draft-ietf-netmod-artwork-folding-03.txt

I just posted an Editorial update that only touches the non-normative script to add a -q (quiet) flag.  Here's the diff:  <https://tools.ietf.org/rfcdiff?url2=draft-ietf-netmod-artwork-folding-04.txt> https://tools.ietf.org/rfcdiff?url2=draft-ietf-netmod-artwork-folding-04.txt.

 

On May 30, 2019, at 10:41 AM, Kent Watsen < <mailto:[email-masked]> [email-masked]> wrote:

Thanks,

Kent // contributor

On May 30, 2019, at 10:30 AM,  <mailto:[email-masked]> [email-masked] wrote:

Abstract:

The IETF datatracker status page for this draft is:
 <https://datatracker.ietf.org/doc/draft-ietf-netmod-artwork-folding/> https://datatracker.ietf.org/doc/draft-ietf-netmod-artwork-folding/

There are also htmlized versions available at:
 <https://tools.ietf.org/html/draft-ietf-netmod-artwork-folding-03> https://tools.ietf.org/html/draft-ietf-netmod-artwork-folding-03
 <https://datatracker.ietf.org/doc/html/draft-ietf-netmod-artwork-folding-03> https://datatracker.ietf.org/doc/html/draft-ietf-netmod-artwork-folding-03

A diff from the previous version is available at:
 <https://www.ietf.org/rfcdiff?url2=draft-ietf-netmod-artwork-folding-03> https://www.ietf.org/rfcdiff?url2=draft-ietf-netmod-artwork-folding-03

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org <http://tools.ietf.org> .

Internet-Drafts are also available by anonymous FTP at:
 <ftp://ftp.ietf.org/internet-drafts/> ftp://ftp.ietf.org/internet-drafts/

_______________________________________________
netmod mailing list
 <mailto:[email-masked]> [email-masked]
 <https://www.ietf.org/mailman/listinfo/netmod> https://www.ietf.org/mailman/listinfo/netmod

_______________________________________________
netmod mailing list
 <mailto:[email-masked]> [email-masked]
 <https://www.ietf.org/mailman/listinfo/netmod> https://www.ietf.org/mailman/listinfo/netmod