Subject: [netmod] WG Last Call: draft-ietf-netmod-intf-ext-yang-07

From: Kent Watsen <[email-masked]>
Date: Wed, 10 Jul 2019 00:15:16 +0000

All,

This starts a twelve-day working group last call for draft-ietf-netmod-intf-ext-yang-07

The working group last call ends on July 21 (the day before the NETMOD 105 sessions).  Please send your comments to the working group mailing list.

Positive comments, e.g., "I've reviewed this document and believe it is ready for publication", are welcome!  This is useful and important, even from authors.

Thank you,
NETMOD Chairs

---

From: "Acee Lindem (acee)" <[email-masked]>
Date: Wed, 10 Jul 2019 13:08:47 +0000

I have reviewed the subject document and support publication. I have the following comment:

  Perhaps ietf-interface-ethernet-like module ethlike:ethernet-like/ethlike:statistics could include a subset of the counters from RFC 3635. I say a subset since some of these counters are a bit archaic given the state of the technology and judgement should be applied on which to include.

  Thanks,
Acee 

On 7/9/19, 8:16 PM, "netmod on behalf of Kent Watsen" <[email-masked] on behalf of [email-masked]> wrote:

    All,

    
    
    Thank you,
    NETMOD Chairs
    _______________________________________________
    netmod mailing list
    [email-masked]
    https://www.ietf.org/mailman/listinfo/netmod

---

From: "Rob Wilton (rwilton)" <[email-masked]>
Date: Wed, 17 Jul 2019 15:36:15 +0000

Hi Acee,

Thanks for the review, and apologies for the delayed reply.

Regarding your stats question, there was some effort to handle this as part of defining the Ethernet interface YANG (IEEE 802.3.2-2019) (https://github.com/YangModels/yang/tree/master/standard/ieee/published/802.3) that I was involved in the earlier parts of.  Please see the attached XLS that was my earlier effort to rationalize the different ethernet interfaces counters between RFC 7223, Ethernet YANG, Etherlike MIB, RMON MIBs, and the counters exposed in the 802.3 clause 30 management API.

For physical Ethernet interfaces (and anything that looks very similar to a physical Ethernet interface) then I think that we should be well covered by the combination of what is in ietf-interfaces, and IEEE 802.3.2.

There are also some counters that apply to all Ethernet-like interfaces (really anything using Ethernet framing, but not an Ethernet physical layer).  The only counter currently defined in this category is in-drop-unknown-dest-mac-pkts in ietf-interfaces-ethernet-like.  Arguably we could also add a drop counter for frames that could not be demuxed to a sub-interface because it didn't match any of the sub-interface match expressions.

There was one set of counters that 802.3.2 didn't want to include in their YANG module which related to the histogram frame statistics.  E.g. counters like the following (taken from IOS XR):

    Input pkts 65-127 bytes     = 0
    Input pkts 128-255 bytes    = 0
    Input pkts 256-511 bytes    = 0
    Input pkts 512-1023 bytes   = 0
    Input pkts 1024-1518 bytes  = 0
    Input pkts 1519-Max bytes   = 0

    Output pkts 65-127 bytes    = 0
    Output pkts 128-255 bytes   = 0
    Output pkts 256-511 bytes   = 0
    Output pkts 512-1023 bytes  = 0
    Output pkts 1024-1518 bytes = 0
    Output pkts 1519-Max bytes  = 0

The 802.3 YANG WG had two issues with including counters like these:
(1) They didn't really want to define histogram counter values for MTUs that are above the officially sanctioned MTU of 1514/1518 in the Ethernet specification, even though a lot of hardware supports up to 9K+.
(2) The bucket ranges, at least once you get past the "512-1023" bucket, seem to somewhat vary by ASIC vendor.
(3) IEEE 802.3 has a well defined internal management API (802.3 clause 30), and these histogram counters are not currently defined as part of that internal management API.  Extending the internal 802.3 management API seems tricky due to point (1) and (2) above.

There was a suggestion in the 802.3 discussions that these counters could be defined in an IETF YANG module (skirting the IEEE concerns about maximum MTUs).  The proposal was to allow the operational data to return a list of bucket entries, where each entry defines the inclusive range of the bucket, and a count of the pkts that matched the bucket range (in either the ingress or egress direction).  This list would sit alongside a RECOMMENDATION of what bucket sizes to use, basically doubling each time up to the MTU, with some consideration around the 1514/1518/1522 boundary, but allowing freedom for a device to accurately return the histogram ranges actually supported by the hardware.

However, I'm not sure it is worth delaying these drafts to add these counters in now, particularly because there are dependencies on them.  Possibly best done as future work?  Do you, or anyone else in the WG have an opinion on this?

Thanks,
Rob

-----Original Message-----
From: netmod <[email-masked]> On Behalf Of Acee Lindem (acee)
Sent: 10 July 2019 14:09
To: Kent Watsen <[email-masked]>; [email-masked]
Subject: Re: [netmod] WG Last Call: draft-ietf-netmod-intf-ext-yang-07

  Thanks,
Acee 

    All,

    
    
    Thank you,
    NETMOD Chairs