Subject: Re: [netmod] I-D Action: draft-ietf-netmod-artwork-folding-06.txt

From: Lou Berger <[email-masked]>
Date: Wed, 10 Jul 2019 17:40:39 -0400

Hi Kent, Authors,

Sorry for the delay in processing this.  WRT your comments, see below:

On 6/27/2019 5:35 PM, Kent Watsen wrote:
>
> This update primarily regards the non-normative script:
>
>     - renamed to "rfcfold"
>     - now only uses sed one-liners
>     - auto-detects if platforms `[g]sed` and `pcregrep` are present and
>        suitable, outputting an error message if not.
>     - cleans up the temporary directory if exits for any reason
>     - improved error message around the script not implementing the
>       force-fold logic.
>
>     Special thanks to Eric Auerswald for supplying the pull requests
>     for much of the above!
>
>
> Outside the updates to the script:
>
>     - renamed 9.3:
>           OLD: Example Showing Smart Folding
>           NEW: Example Showing "Smart" Folding
>
>     - renamed Appendix A:
>           OLD: POSIX Shell Script: rfcfold
>           NEW: POSIX Shell Script
>
>
> My only comments are:
>
>     1) the script itself doesn't name itself "rfcfold" anywhere.
>             - albeit, the "name" attribute in the XML is set to "rfcfold".

I think adding a name would be good -- but this is a non-blocking comment.

>
>     2) if the script is expected to be distributed, we may want/need to
>         add a copyright statement and/or a pointer to its GitHub repo.
>
>
I believe the trust requires a specific license in all code segments in 
RFCs, see https://trustee.ietf.org/license-info/IETF-TLP-5.htm section 
4.  I think this needs to be added before the document can be submitted 
for publication.

Thanks,

Lou

(as Shepherd)

> Thanks,
> Kent
>
>
>> On Jun 27, 2019, at 5:20 PM, [email-masked] 
>> <mailto:[email-masked]> wrote:
>>
>>
>> A New Internet-Draft is available from the on-line Internet-Drafts 
>> directories.
>> This draft is a work item of the Network Modeling WG of the IETF.
>>
>>        Title           : Handling Long Lines in Inclusions in 
>> Internet-Drafts and RFCs
>>        Authors         : Kent Watsen
>>                          Adrian Farrel
>>                          Qin Wu
>> Filename        : draft-ietf-netmod-artwork-folding-06.txt
>> Pages           : 26
>> Date            : 2019-06-27
>>
>> Abstract:
>>   This document defines two strategies for handling long lines in
>>   width-bounded text content.  One strategy is based on the historic
>>   use of a single backslash ('\') character to indicate where line-
>>   folding has occurred, with the continuation occurring with the first
>>   non-space (' ') character on the next line.  The second strategy
>>   extends the first strategy by adding a second backslash character to
>>   identify where the continuation begins and thereby able to handle
>>   cases not supported by the first strategy.  Both strategies use a
>>   self-describing header enabling automated reconstitution of the
>>   original content.
>>
>>
>> The IETF datatracker status page for this draft is:
>> https://datatracker.ietf.org/doc/draft-ietf-netmod-artwork-folding/
>>
>> There are also htmlized versions available at:
>> https://tools.ietf.org/html/draft-ietf-netmod-artwork-folding-06
>> https://datatracker.ietf.org/doc/html/draft-ietf-netmod-artwork-folding-06
>>
>> A diff from the previous version is available at:
>> https://www.ietf.org/rfcdiff?url2=draft-ietf-netmod-artwork-folding-06
>>
>>
>> Please note that it may take a couple of minutes from the time of 
>> submission
>> until the htmlized version and diff are available at tools.ietf.org.
>>
>> Internet-Drafts are also available by anonymous FTP at:
>> ftp://ftp.ietf.org/internet-drafts/
>>
>> _______________________________________________
>> netmod mailing list
>> [email-masked]
>> https://www.ietf.org/mailman/listinfo/netmod
>
>
> _______________________________________________
> netmod mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/netmod

---

From: Kent Watsen <[email-masked]>
Date: Thu, 11 Jul 2019 02:34:23 +0000

Hi Lou (shepherd),

The requested updates have been pushed to GitHub, as can be seen by the commit diff: https://github.com/netmod-wg/artwork-folding/commit/24a1b25abd4d33c2ac07f09b1daa8725b5061f4c <https://github.com/netmod-wg/artwork-folding/commit/24a1b25abd4d33c2ac07f09b1daa8725b5061f4c>.

-07 will be posted to Datatracker when the submission window reopens (or sooner, if you request an exception).

PS: Erik and I are listed as copyright holders, in addition to IETF Trust, as seemed to be expected by (4c) in the link you provided.  Please let me know if any adjustments are needed. 

Thanks,
Kent (as an author)

> On Jul 10, 2019, at 5:40 PM, Lou Berger <[email-masked]> wrote:
> 
> Hi Kent, Authors,
> 
> I believe the trust requires a specific license in all code segments in RFCs, see https://trustee.ietf.org/license-info/IETF-TLP-5.htm <https://trustee.ietf.org/license-info/IETF-TLP-5.htm> section 4.  I think this needs to be added before the document can be submitted for publication.  
> 
> Thanks,
> 
> Lou 
> 
> (as Shepherd)
> 
> 
> 
>> Thanks,
>> Kent
>> 
>> 
>>> On Jun 27, 2019, at 5:20 PM, [email-masked] <mailto:[email-masked]> wrote:
>>> 
>>> 
>>> A New Internet-Draft is available from the on-line Internet-Drafts directories.
>>>        Title           : Handling Long Lines in Inclusions in Internet-Drafts and RFCs
>>>        Authors         : Kent Watsen
>>>                          Adrian Farrel
>>>                          Qin Wu
>>> https://datatracker.ietf.org/doc/draft-ietf-netmod-artwork-folding/ <https://datatracker.ietf.org/doc/draft-ietf-netmod-artwork-folding/>
>>> 
>>> https://tools.ietf.org/html/draft-ietf-netmod-artwork-folding-06 <https://tools.ietf.org/html/draft-ietf-netmod-artwork-folding-06>
>>> https://datatracker.ietf.org/doc/html/draft-ietf-netmod-artwork-folding-06 <https://datatracker.ietf.org/doc/html/draft-ietf-netmod-artwork-folding-06>
>>> 
>>> https://www.ietf.org/rfcdiff?url2=draft-ietf-netmod-artwork-folding-06 <https://www.ietf.org/rfcdiff?url2=draft-ietf-netmod-artwork-folding-06>
>>> 
>>> 
>>> Please note that it may take a couple of minutes from the time of submission
>>> ftp://ftp.ietf.org/internet-drafts/ <ftp://ftp.ietf.org/internet-drafts/>
>>> 
>>> [email-masked] <mailto:[email-masked]>
>>> https://www.ietf.org/mailman/listinfo/netmod <https://www.ietf.org/mailman/listinfo/netmod>
>> 
>> 
>> 
>> [email-masked] <mailto:[email-masked]>
>> https://www.ietf.org/mailman/listinfo/netmod <https://www.ietf.org/mailman/listinfo/netmod>

---

From: Lou Berger <[email-masked]>
Date: Thu, 11 Jul 2019 05:46:30 -0400

Hi Kent,

Thanks for this.  I think 4d is suggesting putting the rfc number in the 
comment block too, but having it where it is may be sufficient - you can 
add it now or see if there's a request for this later.

I'll ask Ignas (our AD) if he wants it submitted now or once the ID gate 
reopens.

Lou

----------
On July 10, 2019 10:34:54 PM Kent Watsen <[email-masked]> wrote:

> Hi Lou (shepherd),
>
> The requested updates have been pushed to GitHub, as can be seen by the 
> commit diff: 
> https://github.com/netmod-wg/artwork-folding/commit/24a1b25abd4d33c2ac07f09b1daa8725b5061f4c 
> <https://github.com/netmod-wg/artwork-folding/commit/24a1b25abd4d33c2ac07f09b1daa8725b5061f4c>.
>
> PS: Erik and I are listed as copyright holders, in addition to IETF Trust, 
> as seemed to be expected by (4c) in the link you provided.  Please let me 
> know if any adjustments are needed.
>
> Thanks,
> Kent (as an author)
>
>
>
>> RFCs, see https://trustee.ietf.org/license-info/IETF-TLP-5.htm 
>> <https://trustee.ietf.org/license-info/IETF-TLP-5.htm> section 4.  I think 
>> this needs to be added before the document can be submitted for publication.
>> 
>> Thanks,
>> 
>> Lou
>> 
>> (as Shepherd)
>> 
>> 
>> 
>>> Thanks,
>>> Kent
>>> 
>>> 
>>>> <https://datatracker.ietf.org/doc/draft-ietf-netmod-artwork-folding/>
>>>> 
>>>> <https://tools.ietf.org/html/draft-ietf-netmod-artwork-folding-06>
>>>> <https://datatracker.ietf.org/doc/html/draft-ietf-netmod-artwork-folding-06>
>>>> 
>>>> <https://www.ietf.org/rfcdiff?url2=draft-ietf-netmod-artwork-folding-06>
>>>> 
>>>> 
>>>> <https://www.ietf.org/mailman/listinfo/netmod>
>>> 
>>> 
>>> 
>>> <https://www.ietf.org/mailman/listinfo/netmod>