Subject: [netmod] Instance-data-format -additional simplified format to define content schema

From: Balázs Lengyel <[email-masked]>
Date: Mon, 22 Jul 2019 20:13:07 +0000

Hello,

At the IETF 105 Netmod meeting it was stated that the flexible solution to
define the context schema inline (requested earlier on the mailing list) is
quite complex, so a fourth simpler method to define content schema inline is
needed.

The fourth method would add one more choice to “choice content-schema-spec
“

case simplified-inline {

  leaf-list module  {

    type string {

       pattern '.+@\d{4}-\d{2}-\d{2}\.yang';

     }

     description “The list of content defining YANG 

       modules including the revision date for each. 

       Usage of this leaf-list implies the modules are 

       used without any deviations and with all features 

       supported.”;

  }

}

An example instant data example could be:

<instance-data-set xmlns="urn:...:ietf-yang-instance-data">

  <name>read-only-acm-rules</name>

  <module>[email-masked]</module>

  <module>[email-masked]</module>
  <revision>
    <date>1776-07-04</date>
    <description>Initial version</description>
  </revision>
  <description>Access control rules for a read-only role.</description>
  <content-data>...

Do you like it ? Adding this case are you OK with the content-schema-spec
definition?

Regards Balazs

---

From: "Rob Wilton (rwilton)" <[email-masked]>
Date: Tue, 23 Jul 2019 21:47:04 +0000

Hi Balazs,

Yes, I think this looks good to me.

Thanks,
Rob

From: netmod <[email-masked]> On Behalf Of Balázs Lengyel
Sent: 22 July 2019 16:13
To: [email-masked]' <[email-masked]>
Subject: [netmod] Instance-data-format -additional simplified format to define content schema

Hello,
At the IETF 105 Netmod meeting it was stated that the flexible solution to define the context schema inline (requested earlier on the mailing list) is quite complex, so a fourth simpler method to define content schema inline is needed.
The fourth method would add one more choice to "choice content-schema-spec   "

case simplified-inline {
  leaf-list module  {
    type string {
     description "The list of content defining YANG
       supported.";
  }
}

An example instant data example could be:
<instance-data-set xmlns="urn:...:ietf-yang-instance-data">
  <name>read-only-acm-rules</name>
  <module>[email-masked]</module<mailto:[email-masked]%3c/module>>

  <module>[email-masked]</module<mailto:[email-masked]%3c/module>>

  <revision>

    <date>1776-07-04</date>

  </revision>

  <content-data>...

Do you like it ? Adding this case are you OK with the content-schema-spec definition?
Regards Balazs