Subject: [netmod] 🔔 CoRE Working Group Adoption call for draft-veillette-core-yang-library-05.txt

From: Carsten Bormann <[email-masked]>
Date: Thu, 11 Jul 2019 15:44:38 +0200

RFC 8525 defines a YANG data model for information about the YANG modules, datastores, and datastore schemas used by a network management server.   This data model is based on string representations of YANG identifiers.

To be more useful in a constrained environment (CoRECONF/COMI), it is useful to have a YANG data model that can employ the efficiency of SIDs (draft-ietf-core-sid).  draft-veillette-core-yang-library-05.txt provides a straightforward translation of RFC 8525 to SID-based identification, with some legacy support removed and some other efficiencies added.  This specification complements the three other CoRECONF specifications draft-ietf-core-yang-cbor, draft-ietf-core-sid, and draft-ietf-core-comi, which we hope to ship soon.

This starts a one-week working group adoption call.
This is a formal call for adoption of this draft as a WG document of the CoRE WG.
If you have read the draft and support adopting it, please say so.
If you see a problem with adopting it as a WG document, please tell us.
For both, remember that WG adoption does not mean that we already have consensus on all the details(*), just that this is the right working document to address the issue (and that we should address the issue in the first place); you are encouraged to mention any issues that you already know.

This WGA call is CCed to the netconf and netmod working groups, as the expertise about YANG modules is focused there, as well as the yang-of-things non-WG mailing list.  Please respond to [email-masked], or exceptionally to [email-masked] (for off-list comments).

This formal WG adoption call runs until the end of July 18th.

Grüße, Carsten

(*) say, is the module-set index really limited to an 8-bit number?

---

From: Carsten Bormann <[email-masked]>
Date: Thu, 25 Jul 2019 00:44:00 -0400

So this was a very thin response on a WG adoption call on the mailing list, but given the sense of the room on Tuesday, I think we can accept this as a WG draft.
We do have the WG last call as another formal opportunity to stop this if it turns out this can be done in a way that preserves full compatibility with RFC 8525.

We are now waiting for a final WGLC-ready I-D version of yang-cbor (one internal author review is outstanding), and then will WGLC the whole cluster (yang-cbor, sid, comi, core-yang-library) in the CoRE WG with a CC to the CCs of this mail.
This WGLC will not go through without a number of high-quality reviews.

Grüße, Carsten

> On Jul 11, 2019, at 09:44, Carsten Bormann <[email-masked]> wrote:
>