Subject: [netmod] Last Call: <draft-ietf-netmod-artwork-folding-07.txt> (Handling Long Lines in Inclusions in Internet-Drafts and RFCs) to Best Current Practice

From: The IESG <[email-masked]>
Date: Tue, 30 Jul 2019 13:42:53 -0700

The IESG has received a request from the Network Modeling WG (netmod) to
consider the following document: - 'Handling Long Lines in Inclusions in
Internet-Drafts and RFCs'
  <draft-ietf-netmod-artwork-folding-07.txt> as Best Current Practice

The IESG plans to make a decision in the next few weeks, and solicits final
comments on this action. Please send substantive comments to the
[email-masked] mailing lists by 2019-08-13. Exceptionally, comments may be
sent to [email-masked] instead. In either case, please retain the beginning of
the Subject line to allow automated sorting.

Abstract

   This document defines two strategies for handling long lines in
   width-bounded text content.  One strategy is based on the historic
   use of a single backslash ('\') character to indicate where line-
   folding has occurred, with the continuation occurring with the first
   non-space (' ') character on the next line.  The second strategy
   extends the first strategy by adding a second backslash character to
   identify where the continuation begins and thereby able to handle
   cases not supported by the first strategy.  Both strategies use a
   self-describing header enabling automated reconstitution of the
   original content.

The file can be obtained via
https://datatracker.ietf.org/doc/draft-ietf-netmod-artwork-folding/

IESG discussion can be tracked via
https://datatracker.ietf.org/doc/draft-ietf-netmod-artwork-folding/ballot/

No IPR declarations have been submitted directly on this I-D.

---

From: Paul Kyzivat <[email-masked]>
Date: Wed, 31 Jul 2019 11:55:49 -0400

Note: I just noticed this work for the first time, and I don't follow 
netmod. But I find the subject interesting and relevant, so I took a 
look at it. I have a couple of comments/concerns:

1) Section 6.2 recommends only using double backslash folding if single 
backslash folding doesn't work. But all the examples in section 9 
violate this.

2) Regarding forced folding in section 8.2.1: step 1 (Determine where 
the fold will occur) could benefit from some elaboration regarding lines 
that require forced folding. In particular, when an input line flagged 
for forced folding ends in backslash, then it must indeed be folded 
before the last character, while in all other cases it can be folded at 
any position prior to the max line length. (While this is obvious if you 
think about it, some might miss this.)

Also, there should be examples of forced folding.

	Thanks,
	Paul

On 7/30/19 4:42 PM, The IESG wrote:
> _______________________________________________
> IETF-Announce mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/ietf-announce
>

---

From: Kent Watsen <[email-masked]>
Date: Wed, 31 Jul 2019 19:41:24 +0000

Hi Paul,

Thanks for your comments!

> 1) Section 6.2 recommends only using double backslash folding if single backslash folding doesn't work. But all the examples in section 9 violate this.

True, but these example illustrate the algorithm itself, and so seem okay, or is your suggestion to add text stating this?

FWIW, the `rfcfold` script in the appendix of the draft was used on all the examples in Section 9.  By default, the `rfcfold` script follows the recommendation (i.e., single before double), but also accepts a command-line option to specify the folding strategy to use.  For the examples in section 9, this command-line option  was used.

> 2) Regarding forced folding in section 8.2.1: step 1 (Determine where the fold will occur) could benefit from some elaboration regarding lines that require forced folding. In particular, when an input line flagged for forced folding ends in backslash, then it must indeed be folded before the last character, while in all other cases it can be folded at any position prior to the max line length. (While this is obvious if you think about it, some might miss this.)

Your comment goes to step 1, are you suggesting a modification such as the following?

OLD
    1. Determine where the fold will occur. This location MUST be before or at the desired maximum column.

NEW
    1. Determine where the fold will occur. This location MUST be before or at the desired maximum column.  In the case of a forced folding, the location MUST be before or at the end of the line.

> Also, there should be examples of forced folding.

Agreed.

Kent // co-author