Subject: [netmod] Instance data and annotations

From: "Joe Clarke (jclarke)" <[email-masked]>
Date: Mon, 22 Jul 2019 18:46:29 +0000

I’ve had a chance to digest the question asked in the meeting about should the last-modified and entity-tag should be defined in the instance data draft.

I feel they should be removed and moved to a separate draft.  First, the draft doesn’t present a use case for these.  There is already an overall timestamp field, which provides last-modified for the set itself.  Finally, think of 8040 and yang-data.  Having to pull in the instance data draft just to get these annotations seems wasteful.

Joe

---

From: Ladislav Lhotka <[email-masked]>
Date: Mon, 22 Jul 2019 15:10:02 -0400

On Mon, 2019-07-22 at 18:46 +0000, Joe Clarke (jclarke) wrote:
> I’ve had a chance to digest the question asked in the meeting about should the
> last-modified and entity-tag should be defined in the instance data draft.
> 
> I feel they should be removed and moved to a separate draft.  First, the draft
> doesn’t present a use case for these.  There is already an overall timestamp
> field, which provides last-modified for the set itself.  Finally, think of
> 8040 and yang-data.  Having to pull in the instance data draft just to get
> these annotations seems wasteful.

Agreed. I simply don't see entity-tag and last-modified as something generally
useful. Out of the nine use cases mentioned in the draft, only two of them (UC5
and UC7) can potentially make use of them.

Lada  

> 
> Joe
> _______________________________________________
> netmod mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/netmod
-- 
Ladislav Lhotka
Head, CZ.NIC Labs
PGP Key ID: 0xB8F92B08A9F76C67