Subject: Re: [netmod] [Technical Errata Reported] RFC7950 (5784)

From: Qin Wu <[email-masked]>
Date: Wed, 17 Jul 2019 08:11:41 +0000

What about "0.50000000"? based on original text, is it legal or illegal?
It seem original text exclude the case where one digit before or after the decimal point?

-Qin
-----邮件原件-----
发件人: netmod [mailto:[email-masked]] 代表 Juergen Schoenwaelder
发送时间: 2019年7月17日 15:50
收件人: RFC Errata System <[email-masked]>
抄送: [email-masked]; [email-masked]; [email-masked]
主题: Re: [netmod] [Technical Errata Reported] RFC7950 (5784)

I do not see why the original text makes 0.5 or 0.0 illegal.

/js

On Tue, Jul 16, 2019 at 08:52:52PM -0700, RFC Errata System wrote:
> The following errata report has been submitted for RFC7950, "The YANG 
> 1.1 Data Modeling Language".
> 
> --------------------------------------
> You may review the report below and at:
> https://www.rfc-editor.org/errata/eid5784
> 
> --------------------------------------
> Type: Technical
> Reported by: Qin WU <[email-masked]>
> 
> Section: 9.3.2
> 
> Original Text
> -------------
> Leading and trailing zeros are prohibited, subject to the rule that 
> there MUST be at least one digit before and after the decimal point.
> The value zero is represented as "0.0".
> 
> 
> 
> 
> Corrected Text
> --------------
> Leading zeros before the first digit and trailing zeros after the last 
> digit are prohibited, subject to the rule that there MUST be at least 
> one digit before and after the decimal point.  The value zero is 
> represented as "0.0".
> 
> Notes
> -----
> Based on the rule in the orginal text, the value such as "0.5","0.0" is illegal. So I think the intention of the original text is to make sure the leading zeros before the first digit and the trailing zero after the last digit are prohibited.
> 
> Instructions:
> -------------
> This erratum is currently posted as "Reported". If necessary, please 
> use "Reply All" to discuss whether it should be verified or rejected. 
> When a decision is reached, the verifying party can log in to change 
> the status and edit the report, if necessary.
> 
> --------------------------------------
> RFC7950 (draft-ietf-netmod-rfc6020bis-14)
> --------------------------------------
> Title               : The YANG 1.1 Data Modeling Language
> Publication Date    : August 2016
> Author(s)           : M. Bjorklund, Ed.
> Category            : PROPOSED STANDARD
> Source              : Network Modeling
> Area                : Operations and Management
> Stream              : IETF
> Verifying Party     : IESG
> 
> _______________________________________________
> netmod mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/netmod

-- 
Juergen Schoenwaelder           Jacobs University Bremen gGmbH
Phone: +49 421 200 3587         Campus Ring 1 | 28759 Bremen | Germany
Fax:   +49 421 200 3103         <https://www.jacobs-university.de/>

_______________________________________________
netmod mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/netmod

---

From: Juergen Schoenwaelder <[email-masked]>
Date: Wed, 17 Jul 2019 10:45:56 +0200

The text starts with the general case and says "Leading and trailing
zeros are prohibited", which seems to cover 0.50000000. The text then
handles the special rule that there needs to be at least one digit
before and after the decimal point. I think all is fine.

/js

---

From: Qin Wu <[email-masked]>
Date: Wed, 17 Jul 2019 08:58:32 +0000

Understand, the problem lies at "and" that is used in " one digit before and after the decimal point ", that is to say it only focus on the case that has two digits, one is before decimal point, the other digit is after decimal such as "5.06", but doesn't cover the case where "one digit before or after the decimal point ", that’s why I think the case 0.500000 is not covered. We should prohibit trailing zeros in “0.5000000”.

-----邮件原件-----
发件人: Juergen Schoenwaelder [mailto:[email-masked]]
发送时间: 2019年7月17日 16:46
收件人: Qin Wu <[email-masked]>
抄送: RFC Errata System <[email-masked]>; [email-masked]; [email-masked]; [email-masked]
主题: Re: [netmod] [Technical Errata Reported] RFC7950 (5784)

The text starts with the general case and says "Leading and trailing zeros are prohibited", which seems to cover 0.50000000. The text then handles the special rule that there needs to be at least one digit before and after the decimal point. I think all is fine.

/js

> 收件人: RFC Errata System <[email-masked]<mailto:[email-masked]>>

> 抄送: [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>

> > The following errata report has been submitted for RFC7950, "The

> > YANG

> > Reported by: Qin WU <[email-masked]<mailto:[email-masked]>>

> > Leading zeros before the first digit and trailing zeros after the

> > last digit are prohibited, subject to the rule that there MUST be at

> > least one digit before and after the decimal point.  The value zero

> > is represented as "0.0".

> > [email-masked]<mailto:[email-masked]>

> [email-masked]<mailto:[email-masked]>

--

---

From: "Rob Wilton (rwilton)" <[email-masked]>
Date: Wed, 17 Jul 2019 09:19:57 +0000

Hi Qin,

I also find the current RFC text quite understandable and correct.

The “and” is required to disallow “.0” and “0.” as valid canonical forms.  I.e. in the canonical form there MUST always be at least one digit (which could be 0) before the decimal point and then must be at least one digit (which could be 0) after the decimal point.  Otherwise, there must be no leading or trailing 0’s.  So, none of  “.0”, “0.”, “00.0”, “0.00” and “00.00” are in the canonical form, and should be represented as “0.0” instead; similarly none of “.1”, “1.”, “01.0”, “1.00” and “01.00” are in the canonical form and should be represented as “1.0” instead.

Thanks,
Rob

From: netmod <[email-masked]> On Behalf Of Qin Wu
Sent: 17 July 2019 09:59
To: Juergen Schoenwaelder <[email-masked]>
Cc: [email-masked]; [email-masked]; [email-masked]; RFC Errata System <[email-masked]>
Subject: [netmod] 答复: [Technical Errata Reported] RFC7950 (5784)

-----邮件原件-----
发件人: Juergen Schoenwaelder [mailto:[email-masked]]
发送时间: 2019年7月17日 16:46
收件人: Qin Wu <[email-masked]<mailto:[email-masked]>>
抄送: RFC Errata System <[email-masked]<mailto:[email-masked]>>; [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>
主题: Re: [netmod] [Technical Errata Reported] RFC7950 (5784)

/js

--