Subject: Re: [netmod] [netconf] WG Last Call: draft-ietf-netmod-factory-default-05

From: Qin Wu <[email-masked]>
Date: Tue, 19 Nov 2019 06:41:27 +0000

发件人: Joe Clarke (jclarke) [mailto:[email-masked]]
发送时间: 2019年11月18日 8:31
收件人: Qin Wu <[email-masked]>
抄送: Kent Watsen <[email-masked]>; [email-masked]; [email-masked]
主题: Re: [netmod] [netconf] WG Last Call: draft-ietf-netmod-factory-default-05

On Nov 17, 2019, at 10:29, Qin Wu <[email-masked]<mailto:[email-masked]>> wrote:

Done, Kent.
https://datatracker.ietf.org/doc/draft-ietf-netmod-factory-default/?include_text=1
Thanks for follow up.

Hey, Qin.  I see you removed the ZTP reference.  I saw the conversation, and you still have the text about resetting other processes.  That said, you still have an informative reference to RFC8572.

[Qin]: Yes, resetting processes or restarting node did cover ZTP part, from Martin’s comment, I feel we don’t need to tie resetting process with RFC8572, since RFC8572 actually focuses on SZTP.
Actually we may have a lot of legacy ZTP mechanism we can leverage, I am not sure which reference I should stick to. Make sense?

More importantly, though, how do you see this practically being implemented?  With an ops dir hat, I’m walking through Section 2, and sending a factory-reset RPC to a device.  The device immediately resets <running> to default and <operational> to some similar default state.  The device has become unreachable within the network.  A reboot or other reset is optional to implement, so as an operator I’m not really sure what to expect at this point.

[Qin]:I am not sure we should make restart or reboot as mandatory after factory-reset rpc, I think factory-reset rpc affects kernel level, it will be good not to restart the node, if it touches hardware level, it is be important to reboot or restart the node. Another angle we can have is if factory-reset rpc is executed in the trust environment, it may be not necessary to restart the node or root.

Typically (well, at least for me), I’m either going to do a factory reset today through the console (if I’m going to RMA or otherwise decommission the device) in which case I don’t care if it’s reachable on the network; or I use a remote “write erase” then reload to prepare the device for a re-bootstrap.  For this latter use case I see the RPC being valuable, but I’d need to know that the device will reload or otherwise re-prepare itself for bootstrapping.  In a multi-vendor environment some consistency there would be useful.

I would think that practically an implementor would reboot the device after receiving and executing this RPC?  I admit that perhaps in virtual cases, a reload may not be required, but I wonder if some operational considerations are needed to let vendors know how best to go about implementing this for best results.
[Qin]: See above, may close to the example you raised above, let me know if you want to add some text in security section or somewhere else to address your comments. The proposal is appreciated.

Joe

-Qin
发件人: Kent Watsen [mailto:[email-masked]]
发送时间: 2019年11月16日 5:16
收件人: [email-masked]<mailto:[email-masked]>
抄送: [email-masked]<mailto:[email-masked]>
主题: Re: [netconf] WG Last Call: draft-ietf-netmod-factory-default-05

Today ends the two-week Last Call, which passed.  Thank you everyone who participated.

Qin, I'll start the shepherd writeup after -07 has been posted addressing the Last Call comments.

Kent // shepherd

On Nov 1, 2019, at 10:57 AM, Kent Watsen <[email-masked]<mailto:[email-masked]>> wrote:

This begins a two-week Working Group Last Call (WGLC) on draft-ietf-netmod-factory-default-05.  The WGLC ends on Nov 15 (two days before the NETMOD 106 session).  Please send your comments to the working group mailing list.

Positive comments, e.g., "I've reviewed this document and believe it is ready for publication", are welcome!  This is useful and important, even from authors.  Objections, concerns, and suggestions are also welcomed at this time.

Thank you,
NETMOD Chairs

_______________________________________________
netmod mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/netmod

---

From: "Joe Clarke (jclarke)" <[email-masked]>
Date: Tue, 19 Nov 2019 09:20:26 +0000

It does.  You should remove the informative reference.

Here’s my use case.  I have a switch that has a config (including a management IP [OOB or IB]).  When I send it the factory-default RPC, I now have a switch in the network I cannot reach.  It continues to run, but with a factory default config (which doesn’t include the management IP).  I now have a problem.  Sure, the switch may not need to reboot.  It might immediately do DHCP and begin a bootstrap workflow.  It may need a reboot to do that.

What I was asking is does it make sense to add some Operational Considerations text to let implementors and operators know about these types of things and encourage them (vendors in particular) to do think about how they will implement factory-default to ensure that these types of processes can be restarted without additional user intervention?

Joe