Subject: Re: [netmod] [netconf] WG Last Call: draft-ietf-netmod-factory-default-05

From: Qin Wu <[email-masked]>
Date: Sun, 17 Nov 2019 15:29:06 +0000

Done, Kent.
https://datatracker.ietf.org/doc/draft-ietf-netmod-factory-default/?include_text=1
Thanks for follow up.

-Qin
发件人: Kent Watsen [mailto:[email-masked]]
发送时间: 2019年11月16日 5:16
收件人: [email-masked]
抄送: [email-masked]
主题: Re: [netconf] WG Last Call: draft-ietf-netmod-factory-default-05

Today ends the two-week Last Call, which passed.  Thank you everyone who participated.

Qin, I'll start the shepherd writeup after -07 has been posted addressing the Last Call comments.

Kent // shepherd

On Nov 1, 2019, at 10:57 AM, Kent Watsen <[email-masked]<mailto:[email-masked]>> wrote:

This begins a two-week Working Group Last Call (WGLC) on draft-ietf-netmod-factory-default-05.  The WGLC ends on Nov 15 (two days before the NETMOD 106 session).  Please send your comments to the working group mailing list.

Positive comments, e.g., "I've reviewed this document and believe it is ready for publication", are welcome!  This is useful and important, even from authors.  Objections, concerns, and suggestions are also welcomed at this time.

Thank you,
NETMOD Chairs

---

From: "Joe Clarke (jclarke)" <[email-masked]>
Date: Mon, 18 Nov 2019 00:30:37 +0000

On Nov 17, 2019, at 10:29, Qin Wu <[email-masked]<mailto:[email-masked]>> wrote:

Done, Kent.

Hey, Qin.  I see you removed the ZTP reference.  I saw the conversation, and you still have the text about resetting other processes.  That said, you still have an informative reference to RFC8572.

More importantly, though, how do you see this practically being implemented?  With an ops dir hat, I’m walking through Section 2, and sending a factory-reset RPC to a device.  The device immediately resets <running> to default and <operational> to some similar default state.  The device has become unreachable within the network.  A reboot or other reset is optional to implement, so as an operator I’m not really sure what to expect at this point.

Typically (well, at least for me), I’m either going to do a factory reset today through the console (if I’m going to RMA or otherwise decommission the device) in which case I don’t care if it’s reachable on the network; or I use a remote “write erase” then reload to prepare the device for a re-bootstrap.  For this latter use case I see the RPC being valuable, but I’d need to know that the device will reload or otherwise re-prepare itself for bootstrapping.  In a multi-vendor environment some consistency there would be useful.

I would think that practically an implementor would reboot the device after receiving and executing this RPC?  I admit that perhaps in virtual cases, a reload may not be required, but I wonder if some operational considerations are needed to let vendors know how best to go about implementing this for best results.

Joe

-Qin
发件人: Kent Watsen [mailto:[email-masked]]
发送时间: 2019年11月16日 5:16
收件人: [email-masked]<mailto:[email-masked]>
抄送: [email-masked]<mailto:[email-masked]>
主题: Re: [netconf] WG Last Call: draft-ietf-netmod-factory-default-05

Kent // shepherd

Thank you,
NETMOD Chairs

_______________________________________________
netmod mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/netmod