Subject: Re: [netmod] I-D Action: draft-ietf-netmod-factory-default-08.txt

From: Qin Wu <[email-masked]>
Date: Thu, 5 Dec 2019 03:37:29 +0000

v-08 is posted to address comments received from YANG doctor review and additional comments from Joe.
The diff is:
https://www.ietf.org/rfcdiff?url2=draft-ietf-netmod-factory-default-08

-Qin
-----邮件原件-----
发件人: I-D-Announce [mailto:[email-masked]] 代表 [email-masked]
发送时间: 2019年12月5日 11:36
收件人: [email-masked]
抄送: [email-masked]
主题: I-D Action: draft-ietf-netmod-factory-default-08.txt

A New Internet-Draft is available from the on-line Internet-Drafts directories.
This draft is a work item of the Network Modeling WG of the IETF.

        Title           : Factory Default Setting
        Authors         : Qin Wu
                          Balazs Lengyel
                          Ye Niu
	Filename        : draft-ietf-netmod-factory-default-08.txt
	Pages           : 11
	Date            : 2019-12-04

Abstract:
   This document defines a method to reset a server to its factory-
   default content.  The reset operation may be used, e.g., when the
   existing configuration has major errors so re-starting the
   configuration process from scratch is the best option.

   A new factory-reset RPC is defined.  When resetting a datastore, all
   previous configuration settings will be lost and replaced by the
   factory-default content.

   A new optional "factory-default" read-only datastore is defined, that
   contains the data that will be copied over to the running datastore
   at reset.

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-ietf-netmod-factory-default/

There are also htmlized versions available at:
https://tools.ietf.org/html/draft-ietf-netmod-factory-default-08
https://datatracker.ietf.org/doc/html/draft-ietf-netmod-factory-default-08

A diff from the previous version is available at:
https://www.ietf.org/rfcdiff?url2=draft-ietf-netmod-factory-default-08

Please note that it may take a couple of minutes from the time of submission until the htmlized version and diff are available at tools.ietf.org.

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

_______________________________________________
I-D-Announce mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/i-d-announce
Internet-Draft directories: http://www.ietf.org/shadow.html or ftp://ftp.ietf.org/ietf/1shadow-sites.txt

---

From: "Joe Clarke (jclarke)" <[email-masked]>
Date: Thu, 5 Dec 2019 15:39:02 +0000

On Dec 4, 2019, at 22:37, Qin Wu <[email-masked]<mailto:[email-masked]>> wrote:

Thanks, Qin.  But this isn’t actually what I had in mind.  I was suggesting text targeted at implementors but also warning operators along the lines of:

Operators should be aware that since all read-write datastores are immediately reset to factor default, the device will become unreachable on the network.  One should understand how a given vendor’s device will behave after the RPC is executed.  Implementors SHOULD reboot the device or otherwise restart processes needed to bootstrap it.

I realize Jürgen(?) or others had problems with calling out bootstrapping, but I do think some explicit advice is required so all parties are aware what the impact of executing the RPC would have.

Joe

-Qin
-----邮件原件-----
发件人: I-D-Announce [mailto:[email-masked]] 代表 [email-masked]<mailto:[email-masked]>
发送时间: 2019年12月5日 11:36
收件人: [email-masked]<mailto:[email-masked]>
抄送: [email-masked]<mailto:[email-masked]>
主题: I-D Action: draft-ietf-netmod-factory-default-08.txt

Abstract:

Please note that it may take a couple of minutes from the time of submission until the htmlized version and diff are available at tools.ietf.org<http://tools.ietf.org>.

_______________________________________________
I-D-Announce mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/i-d-announce
Internet-Draft directories: http://www.ietf.org/shadow.html or ftp://ftp.ietf.org/ietf/1shadow-sites.txt
_______________________________________________
netmod mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/netmod

---

From: Martin Bjorklund <[email-masked]>
Date: Thu, 05 Dec 2019 16:48:25 +0100 (CET)

Hi,

"Joe Clarke (jclarke)" <[email-masked]> wrote:
>  On Dec 4, 2019, at 22:37, Qin Wu <[email-masked]> wrote:
> 
> Thanks, Qin. But this isn’t actually what I had in mind. I was suggesting text targeted at
> implementors but also warning operators along the lines of:
> 
> Operators should be aware that since all read-write datastores are
> immediately reset to 
> factor default, the device will become unreachable on the network.

s/will/may/

( and s/factor/factory/ )

> One should
> understand how a given vendor’s device will behave after the RPC is executed.

Perhaps s/One should/It is important to/?

> Implementors SHOULD reboot the device or otherwise restart processes needed to
> bootstrap it.
> 
> I realize Jürgen(?) or others had problems with calling out
> bootstrapping, but I do think
> some explicit advice is required so all parties are aware what the
> impact of executing the 
> RPC would have.

I had concerns with the previous text about bootstrapping, but I think
that your proposed text above is fine.

/martin

>  Please note that it may take a couple of minutes from the time of submission until the
>  htmlized version and diff are available at tools.ietf.org.
> 
>  Internet-Draft directories: http://www.ietf.org/shadow.html or
>  ftp://ftp.ietf.org/ietf/1shadow-sites.txt
>  [email-masked]

---

From: "Joe Clarke (jclarke)" <[email-masked]>
Date: Thu, 5 Dec 2019 15:52:16 +0000

> On Dec 5, 2019, at 10:48, Martin Bjorklund <[email-masked]> wrote:
> 
> Hi,
> 

Thanks for the clarification and corrections.

Joe