Subject: [netmod] RFC 6991bis: Abridged-instance-identifier

From: Balázs Lengyel <[email-masked]>
Date: Fri, 6 Dec 2019 13:47:37 +0000

Hello.

The following type was proposed to me. Would it be interesting  for others?

In some cases were the length of the identifier matters this can be useful
e.g. on a user interface or in an SNMP packet.

typedef abridged-instance-identifier {

    type string ;

    description "An instance-identifier in which the prefix is not repeated.

      The prefix is omitted where ever the last included prefix is the  

      same as the one that would be present for the current data-node. 

      The original instance-identifier syntax would be 

        /ex:system/ex:user[ex:name='fred']/other:type

      The corresponding abridged-instance-identifier format is

        /ex:system/user[name='fred']/other:type";

  }    

Regards Balazs

-- 

Balazs Lengyel                    Senior Specialist
Ericsson Hungary Ltd. 

Mobile: +36-70-330-7909              email: [email-masked]

---

From: Robert Varga <[email-masked]>
Date: Mon, 16 Dec 2019 10:53:58 +0100

On 06/12/2019 14:47, Balázs Lengyel wrote:
> In some cases were the length of the identifier matters this can be
> useful e.g. on a user interface or in an SNMP packet.
> 
>  
> 
>  
> 

Well, this smells a bit like a layering violation :) RFC7951 already
does something similar without requiring a definition of a new type
(https://tools.ietf.org/html/rfc7951#section-6.11).

Perhaps RFC7950bis (or rather, its XML companion if the split ever
happens) should allow for such abbreviated syntax?

Regards,
Robert