Subject: [netmod] ID submission YANG validation errors?

From: Christian Hopps <[email-masked]>
Date: Wed, 22 Jan 2020 09:40:48 -0500

I've just submitted a YANG module draft and received what i think to be a bogus validation error:

  https://datatracker.ietf.org/doc/draft-ietf-lsr-yang-isis-reverse-metric/

It's saying it can't find the ietf-isis module. Has anyone else experienced this issue with referencing draft modules? It seems broken that we can't refer to works-in-progress, inside our works-in-progress.

Thanks,
Chris.

---

From: "Acee Lindem (acee)" <[email-masked]>
Date: Wed, 22 Jan 2020 16:23:33 +0000

Also, the YANG validator tool is broken - https://www.yangcatalog.org/yangvalidator/

On 1/22/20, 9:41 AM, "netmod on behalf of Christian Hopps" <[email-masked] on behalf of [email-masked]> wrote:

    
    
    Thanks,
    Chris.

---

From: Mahesh Jethanandani <[email-masked]>
Date: Wed, 22 Jan 2020 14:29:16 -0800

> On Jan 22, 2020, at 6:40 AM, Christian Hopps <[email-masked]> wrote:
> 
> 

Yes, I experience this error all the time. In this case I am referencing published IEEE models in YangModels GitHub location. If my local validation passes, I just ignore these errors:

yanglint 0.14.80: yanglint --verbose -p {rfclib} -p {draftlib} -p {tmplib} {model} -i:
err : Data model "ieee802-dot1q-types" not found.
err : Importing "ieee802-dot1q-types" module into "ietf-if-l3-vlan" failed.
err : Module "ietf-if-l3-vlan" parsing failed.
err : Importing "ietf-if-l3-vlan" module into "ietf-routing-policy" failed.
err : Module "ietf-routing-policy" parsing failed.
err : Importing "ietf-routing-policy" module into "ietf-bgp" failed.
err : Module "ietf-bgp" parsing failed.

> 
> Thanks,
> Chris.
> _______________________________________________
> netmod mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/netmod

Mahesh Jethanandani
[email-masked]

---

From: Christian Hopps <[email-masked]>
Date: Wed, 22 Jan 2020 17:50:46 -0500

I've sent some mail previously to random lists (codesprint, xml2rfc..) and Henrik, but I've not heard back. Does anyone know what the official path to reporting problems with the yang validation setup is?

Thanks,
Chris.

> On Jan 22, 2020, at 5:29 PM, Mahesh Jethanandani <[email-masked]> wrote:
> 
> 
>

---

From: Benoit Claise <[email-masked]>
Date: Thu, 23 Jan 2020 17:42:08 +0100

Fixed, thanks to Miroslav, in cc.
Yangvalidator is working now, and correctly saying that there are no 
errors.
Datatracker is still not using the yangvalidator API to validate modules 
and therefore it is saying that there are errors.
This task is on our todo list.

If you find more issues like the one below, open an issue:
https://github.com/YangCatalog
(or https://github.com/YangCatalog/bottle-yang-extractor-validator)

Regards, Benoit