Subject: Re: [netmod] error: "Data model 'XXX' not found" during yang validation.

From: Qin Wu <[email-masked]>
Date: Tue, 19 May 2020 01:00:58 +0000

I think It is the datatracker pyang tool’s bug, ieee-dot1Q-types is YANG model from other SDO and  not integrated during compilation.
If you run pyang check locally, this issue is gone.
-Qin
发件人: netmod [mailto:[email-masked]] 代表 Dmytro Shytyi
发送时间: 2020年5月18日 23:14
收件人: netmod <[email-masked]>
主题: [netmod] error: "Data model 'XXX' not found" during yang validation.

Hello netmod participants!

How we should address an import of modules produced by non IETF community? Was it already discussed? (If yes, I'm sorry to dublicate... Could you please send me some links?)

In the  uCPE draft https://datatracker.ietf.org/doc/draft-shytyi-opsawg-vysm/?include_text=1 we are reffering/including multiple different RFCs and drafts produced by IETF community such as:

   o  ietf-interfaces

   o  ietf-ip

   o  ietf-logical-network-element

   o  ietf-network

   o  ietf-network-instance

   o  ietf-ietf-network-topology

   o  ietf-routing-types

   o  ietf-te-topology

   o  ietf-te-topology-sf

   o  ietf-te-types

   o  ietf-yang-schema-mount
And everything went good until we imported the ieee-dot1Q-types module... (to support VLANs on the NIs)

yanglint SO 1.6.7: yanglint --verbose -p {rfclib} -p {draftlib} -p {tmplib} {model} -i:

err : Data model "ieee-dot1Q-types" not found.

err : Importing "ieee-dot1Q-types" module into "ietf-ucpe-ni-properties" failed.
Thank you!
______________
Dmytro SHYTYI

---

From: Dmytro Shytyi <[email-masked]>
Date: Tue, 19 May 2020 17:20:52 +0200

Hello Qin,

Thank you for your response!

______________
Dmytro SHYTYI

---- On Tue, 19 May 2020 03:00:58 +0200 Qin Wu <[email-masked]> wrote ----

-Qin

发件人: netmod [mailto:mailto:[email-masked]] 代表  Dmytro Shytyi
 发送时间: 2020年5月18日 23:14
 收件人: netmod <mailto:[email-masked]>
 主题: [netmod] error: "Data model 'XXX' not found" during yang validation.

 

How we should address an import of modules produced by non IETF community? Was it already discussed? (If yes, I'm sorry to dublicate... Could you please send me
 some links?)

In the  uCPE draft https://datatracker.ietf.org/doc/draft-shytyi-opsawg-vysm/?include_text=1 we
 are reffering/including multiple different RFCs and drafts produced by IETF community such as:

   o  ietf-interfaces

   o  ietf-ip

   o  ietf-network

   o  ietf-network-instance

   o  ietf-routing-types

   o  ietf-te-topology

   o  ietf-te-topology-sf

   o  ietf-te-types

   o  ietf-yang-schema-mount

 

Thank you!

______________
 Dmytro SHYTYI