Subject: [netmod] Question on multiple content match nodes in subtree filter

From: Qin Wu <[email-masked]>
Date: Fri, 12 Jun 2020 08:08:49 +0000

Hi, folks:
Suppose we have multiple content match nodes, however these content match nodes are not sibling nodes, instead, they are child nodes of each sibling node,

Should we see Multiple content match nodes (i.e., sibling nodes) being logically
combined in an "AND" expression or in an "OR" expression? Depending on the answer, here are two usage example:
<rpc message-id="101"  xmlns="urn:ietf:params:xml:ns:netconf:base:1.0" >
<get>
  <filter type="subtree">
    <top>
      <interfaces>
        <interface>
            <ipv4>
              <forwarding>false</forwarding>
                              <enable/>
                              <mtu/>
            </ipv4>
            <ipv6>
              <mtu>1000</mtu>
                              <enable/>
                              <forwarding/>
            </ipv6
          </ipv6>
        </interface>
      </interfaces>
    </top>
  </filter>
</get>
</rpc>
In this example, <mtu> and <forwarding> leaf are child node of <ipv4> container node and <ipv6> container node respectively,
<ipv4> container node and <ipv6> container node are sibling nodes.

The RPC-reply could have two options,
Option A: both <forwarding> under <ipv4> container and <mtu> under <ipv6> container are matched,
<rpc-reply message-id="101"  xmlns="urn:ietf:params:xml:ns:netconf:base:1.0" >
<data xmlns="urn:ietf:params:xml:ns:netconf:base:1.0">
 <top>
  <interfaces>
    <interface>
           <ipv4>
            <enable>true</enable>
       <forwarding>false</forwarding>
       <mtu>1400</mtu>
           </ipv4>
           <ipv6>
            <enable>true</enable>
            <forwarding>true</forwarding>
            <mtu>1000</mtu>
           </ipv6>
    </interface>
   </interfaces>
  </top>
</data>
</rpc-reply>
Option B: only <mtu> under <ipv6> container is matched and <forwarding> under <ipv4> is not matched
<rpc-reply message-id="101"  xmlns="urn:ietf:params:xml:ns:netconf:base:1.0" >
<data xmlns="urn:ietf:params:xml:ns:netconf:base:1.0">
 <top>
  <interfaces>
    <interface>
           <ipv6>
            <enable>true</enable>
            <forwarding>true</forwarding>
            <mtu>1000</mtu>
           </ipv6>
    </interface>
   </interfaces>
  </top>
</data>
</rpc-reply>
Are these RPC-reply correct? How do we see the matching relation between these content matches nodes?

-Qin

---

From: tom petch <[email-masked]>
Date: Tue, 16 Jun 2020 09:05:07 +0000

mpls-base-yang has got hung up on a MUST is RFC8349 which requires augmenting modules to add a leaf 'destination-address'.  The authors say that MPLS does not have destination addresses so this is a fault in RFC8349 and they plan to raise an erratum to change it.

I am keen for mpls-base-yang to progress so thought I would give the WG advance warning so when the erratum arrives it can be speedily processed.

Tom Petch