Subject: Re: [netmod] YANG versioning issue #48 (interpreting revision labels)

From: "Sterne, Jason (Nokia - CA/Ottawa)" <[email-masked]>
Date: Mon, 22 Jun 2020 18:03:45 +0000

forgot to add NETMOD...

From: Sterne, Jason (Nokia - CA/Ottawa)
Sent: Monday, June 22, 2020 2:03 PM
To: Reshad Rahman (rrahman) <[email-masked]>; Joe Clarke (jclarke) <[email-masked]>
Subject: YANG versioning issue #48 (interpreting revision labels)

Hi all (and particularly Reshad and Joe),

wrt github issue #48:
https://github.com/netmod-wg/yang-ver-dt/issues/48

module-versioning says this:

   All revision labels that match the pattern for the "version"
   typedef in the ietf-yang-semver YANG module MUST be interpreted as
   YANG semantic version numbers.

yang-semver says this:

   Other version schemes MUST NOT use version strings that match this
   same pattern.  For example, they may choose to use leading characters
   to distinguish themselves from YANG semver.

I'd propose we remove that text from both documents. We've decided to use an extension to identify the revision-label scheme in use by a module.

But we should probably add this to module-versioning:

Although an extension is used to identify which revision-label scheme is in use by a YANG module, any new YANG revision-label schemes being proposed SHOULD try to avoid patterns that are very similar to other previously existing standardized schemes. Being able to identify a YANG revision-label scheme by looking at the revision-label value is a useful property.

Jason

---

From: "Reshad Rahman (rrahman)" <[email-masked]>
Date: Mon, 22 Jun 2020 19:25:37 +0000

From: "Sterne, Jason (Nokia - CA/Ottawa)" <[email-masked]>
Date: Monday, June 22, 2020 at 2:04 PM
To: "Reshad Rahman (rrahman)" <[email-masked]>, "Joe Clarke (jclarke)" <[email-masked]>, "[email-masked]" <[email-masked]>
Subject: RE: YANG versioning issue #48 (interpreting revision labels)

forgot to add NETMOD…

wrt github issue #48:

<RR> Yes we had agreed to remove the above.

yang-semver says this:

Although an extension is used to identify which revision-label scheme is in use by a YANG module, any new YANG revision-label schemes being proposed SHOULD try to avoid patterns that are very similar to other previously existing standardized schemes. Being able to identify a YANG revision-label scheme by looking at the revision-label value is a useful property.
<RR> Let’s discuss in tomorrow’s weekly meeting. Not sure yet this is the right recommendation.

Regards,
Reshad.

Jason