Subject: Re: [netmod] I-D Action: draft-ietf-netmod-rfc6991-bis-03.txt

From: Vladimir Vassilev <[email-masked]>
Date: Mon, 6 Jul 2020 14:23:26 +0200

Hi,

This version (-03) of the draft has not updated the 
[email-masked] module name while the revision is 
updated to 2020-06-26 (same goes for ietf-inet-types). This causes the 
ietf.org validation to fail for all active drafts that directly or 
indirectly import ietf-yang-types.

The validation tools do not catch that problem for 
draft-ietf-netmod-rfc6991-bis-03 itself. Only when it is imported. And 
looking into the output of the validation script:
...

draft-ietf-netmod-rfc6991-bis-03.txt:
...
  # read [email-masked] (CL)
...

Seems like the validation script is too smart and corrects the file name replacing 2019-11-04 with 2020-06-26 when extracting the modules from the RFC without error or warning message.

/Vladimir

On 26/06/2020 17.01, [email-masked] wrote:
> A New Internet-Draft is available from the on-line Internet-Drafts 
> directories.
> This draft is a work item of the Network Modeling WG of the IETF.
>
> Title : Common YANG Data Types
> Author : Juergen Schoenwaelder
> Filename : draft-ietf-netmod-rfc6991-bis-03.txt
> Pages : 48
> Date : 2020-06-26
>
> Abstract:
> This document introduces a collection of common data types to be used
> with the YANG data modeling language. This document obsoletes RFC
> 6991.
>
>
> The IETF datatracker status page for this draft is:
> https://datatracker.ietf.org/doc/draft-ietf-netmod-rfc6991-bis/
>

---

From: Juergen Schoenwaelder <[email-masked]>
Date: Mon, 6 Jul 2020 15:44:05 +0200

I have posted a new version to hopefully resolve this issue. The IETF
validation service says 'pyang: not found' (this already happened last
time).

/js

On Mon, Jul 06, 2020 at 02:23:26PM +0200, Vladimir Vassilev wrote:
> [email-masked] module name while the revision is updated to
> 2020-06-26 (same goes for ietf-inet-types). This causes the ietf.org
> validation to fail for all active drafts that directly or indirectly import
> ietf-yang-types.
> 
> _______________________________________________
> netmod mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/netmod

-- 
Juergen Schoenwaelder           Jacobs University Bremen gGmbH
Phone: +49 421 200 3587         Campus Ring 1 | 28759 Bremen | Germany
Fax:   +49 421 200 3103         <https://www.jacobs-university.de/>