Subject: Re: [netmod] rfc6991bis: loopback addresses

From: Qin Wu <[email-masked]>
Date: Fri, 31 Jul 2020 01:22:43 +0000

-----邮件原件-----
发件人: netmod [mailto:[email-masked]] 代表 Acee Lindem (acee)
发送时间: 2020年7月31日 5:06
收件人: Kent Watsen <[email-masked]>; Juergen Schoenwaelder <[email-masked]>
抄送: Carlos Pignataro (cpignata) <[email-masked]>; [email-masked]
主题: Re: [netmod] rfc6991bis: loopback addresses

Hi Kent,

On 7/30/20, 4:55 PM, "netmod on behalf of Kent Watsen" <[email-masked] on behalf of [email-masked]> wrote:

    > Thanks for pointing to the definitions in draft-nainar-mpls-lsp-ping-yang.
    > With that, your request is relatively clear now

    Looking at draft-nainar-mpls-lsp-ping-yang, the proposal is a “typedef” that constrains inet:ipv[46]-address so that it can only contain loopback address values.

    > and the question the WG
    > needs to answer is whether these types are common enough to warrant being
    > part of inet-types, i.e., are there any other places where these types
    > may be useful?

    I don’t think so, but I’m not a routing person.

I wouldn't think that an internal loopback address would be widely used. In fact, I checked our Cisco native models for IOS-XE and there is no such definition. 

[Qin]: I am not sure we are talking about loopback type or loopback address
See section 2.4 in draft-ietf-netmod-intf-ext-yang-10, 3 type loopbacks are defined:
1.Internal loopback
2.Line loopback
3.Loopback Connector
3 types loopback can be classified into local loopback and remote loopback.
I am not sure they are common, but we have some support for this. 

Thanks,
Acee

    > /js

    K.  // contributor
    _______________________________________________
    netmod mailing list
    [email-masked]
    https://www.ietf.org/mailman/listinfo/netmod

_______________________________________________
netmod mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/netmod

---

From: "Acee Lindem (acee)" <[email-masked]>
Date: Fri, 31 Jul 2020 10:21:59 +0000

Hi Qin, 

On 7/30/20, 9:23 PM, "Qin Wu" <[email-masked]> wrote:

    -----邮件原件-----
    发件人: netmod [mailto:[email-masked]] 代表 Acee Lindem (acee)
    发送时间: 2020年7月31日 5:06
    收件人: Kent Watsen <[email-masked]>; Juergen Schoenwaelder <[email-masked]>
    抄送: Carlos Pignataro (cpignata) <[email-masked]>; [email-masked]
    主题: Re: [netmod] rfc6991bis: loopback addresses

    Hi Kent,

This is the loopback address type - not the loopback interface type. Look at draft-nainar-mpls-lsp-ping-yang (the draft being discussed in the Email thread). 

Thanks,
Acee

    Thanks,
    Acee

        K.  // contributor