Subject: [netmod] rfc6991bis: yang:longitude, yang:latitude, yang:postal-code, yang:country-code

From: Juergen Schoenwaelder <[email-masked]>
Date: Fri, 17 Jul 2020 21:16:08 +0200

- It was suggested to add types for longitude, latitude, postal
    code, country-code. Do we go there or do we leave these for other
    modules to define? It seems such definitions should go into
    draft-ietf-netmod-geo-location.

  - Geo location is covered by draft-ietf-netmod-geo-location
    (so do nothing).

  - For country codes, there is ISO 3166, which defines two-letter,
    three-letter, and numeric country codes. I assume people wanted
    two-letter codes (as used in the DNS), i.e. they want DE and not
    DEU. But note that it is GB and not UK, i.e., what we commonly
    use in the DNS may not be exactly ISO 3166. (The devil is always
    in the details.)

  - For postal codes, it is unclear what the requirements are or what
    a proper definition for postal codes is. It is not entirely clear
    what the authoritative definition of the format of postal codes
    is, perhaps the Universal Postal Union.

  - Options: (i) do nothing or (ii) add a country code definition
    only or (iii) add both a country code definition and a postal
    code definition (which might be to some extend vague)

  - Proposal: do nothing
  
-- 
Juergen Schoenwaelder           Jacobs University Bremen gGmbH
Phone: +49 421 200 3587         Campus Ring 1 | 28759 Bremen | Germany
Fax:   +49 421 200 3103         <https://www.jacobs-university.de/>

---

From: Qin Wu <[email-masked]>
Date: Thu, 30 Jul 2020 15:00:00 +0000

Works for me, thanks.
-----邮件原件-----
发件人: Juergen Schoenwaelder [mailto:[email-masked]] 
发送时间: 2020年7月30日 22:03
收件人: Qin Wu <[email-masked]>
抄送: [email-masked]
主题: Re: [netmod] rfc6991bis: yang:longitude, yang:latitude, yang:postal-code, yang:country-code

But then perhaps draft-ietf-netmod-geo-location-05 needs to be updated or you need to use a grouping. I think we should not have overlapping work in different documents.

/js

On Thu, Jul 30, 2020 at 01:54:43PM +0000, Qin Wu wrote:
> That is a good option, but draft-ietf-netmod-geo-location-05 only define grouping, there is typedef for longitude and latitude, altitude. 
> 
> -Qin
> -----邮件原件-----
> 发件人: Juergen Schoenwaelder 
> [mailto:[email-masked]]
> 发送时间: 2020年7月30日 21:32
> 收件人: Qin Wu <[email-masked]>
> 抄送: [email-masked]
> 主题: Re: [netmod] rfc6991bis: yang:longitude, yang:latitude, 
> yang:postal-code, yang:country-code
> 
> But there is draft-ietf-netmod-geo-location-05... What about using the types defined in there?
> 
> /js
> 
> On Thu, Jul 30, 2020 at 01:28:17PM +0000, Qin Wu wrote:
> > See geolocation definition in draft-ietf-teas-yang-te-topo-22 which defines longitude and latitude, altitude.
> > I know it is beneficial for future document to import these types from rfc6991bis instead of from te topo model.
> > 
> > -Qin
> > -----邮件原件-----
> > 发件人: netmod [mailto:[email-masked]] 代表 Juergen 
> > Schoenwaelder
> > 发送时间: 2020年7月18日 3:16
> > 收件人: [email-masked]
> > 主题: [netmod] rfc6991bis: yang:longitude, yang:latitude, 
> > yang:postal-code, yang:country-code
> > 
> > _______________________________________________
> > netmod mailing list
> > [email-masked]
> > https://www.ietf.org/mailman/listinfo/netmod
> 
> --