Subject: [netmod] rfc6991bis: yang:xpath1.0

From: Juergen Schoenwaelder <[email-masked]>
Date: Fri, 17 Jul 2020 21:14:11 +0200

- How do we deal with xpath expressions in other encodings
    such as JSON. Do we assume an xpath context populated with
    module names such that module names can be used to qualify
    path expressions. This may need discussion and/or a new
    definition.

  - This interacts with the definition of node-instance-identifier.

  - Options: (i) Leave this definition as it is. (ii) Detail how this
    type work with encodings that use module names instead of prefixes
    to qualify names.

  - Proposal: ?

/js

-- 
Juergen Schoenwaelder           Jacobs University Bremen gGmbH
Phone: +49 421 200 3587         Campus Ring 1 | 28759 Bremen | Germany
Fax:   +49 421 200 3103         <https://www.jacobs-university.de/>

---

From: Ladislav Lhotka <[email-masked]>
Date: Mon, 20 Jul 2020 11:43:25 +0200

>     path expressions. This may need discussion and/or a new

XPath context is not only namespaces and prefixes. For example, are the extra functions from RFC 7950 permitted or not?

>   - This interacts with the definition of node-instance-identifier.

I think it is necessary to first redefine the lexical representation of instance-identifier in YANG.

>     type work with encodings that use module names instead of prefixes

I vote for (i), as long as a general solution is probably impossible.

Lada

> _______________________________________________
> netmod mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/netmod

-- 
Ladislav Lhotka 
Head, CZ.NIC Labs
PGP Key ID: 0xB8F92B08A9F76C67