Subject: [netmod] A ---- > B

From: tom petch <[email-masked]>
Date: Wed, 15 Jul 2020 15:50:42 +0000

TEAS yang has a mountain of augment and several I-D represent that graphically

+-----+          +-----+
I     I          I     I
I  A  I   -----> I  B  I
I     I          I     I
+-----+          +-----+
In some I-D this means A augments B
In other I-D this means B augments A
I would like consistency.  Is one approach more logical than the other?

Tom Petch

---

From: "Rob Wilton (rwilton)" <[email-masked]>
Date: Thu, 16 Jul 2020 18:16:57 +0000

[As an individual]

I would say that the diagram would represent A augments B, since A has a dependency on B.  From a quick search this also appears the direction that a dependency arrow is represented in UML, in case that matters.

But I could also see how others could see the relationship the other way round.

I agree that doing it consistently is helpful.

Regards,
Rob

> -----Original Message-----
> From: netmod <[email-masked]> On Behalf Of tom petch
> Sent: 15 July 2020 16:51
> To: NETMOD Working Group <[email-masked]>
> Subject: [netmod] A ---- > B
> 
> _______________________________________________
> netmod mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/netmod

---

From: tom petch <[email-masked]>
Date: Mon, 20 Jul 2020 09:00:08 +0000

From: Rob Wilton (rwilton) <[email-masked]>
Sent: 16 July 2020 19:16
[As an individual]

<tp>
Yes that is my instinct but it could be that I have been brainwashed by a load of I-D doing it that way and now I have one going the other way I find myself wondering.

Tom Petch

Regards,
Rob