Subject: [netmod] NETMOD YANG Version Discussions - meeting minutes Oct 27, 2020

From: "Sterne, Jason (Nokia - CA/Ottawa)" <[email-masked]>
Date: Tue, 27 Oct 2020 16:11:06 +0000

Hi all,

We discussed next steps for the 5 main versioning drafts:
- no plan to re-issue Versioning or Semver before IETF109
- re-issue Packages with editorial updates and some statements about usage of deviations in packages (Bo)
- re-issue Version Selection and Diff drafts (Joe)

The main discussion was around text for the Packages draft related to deviations (they should be avoiding in standard SDO Packages, more for implementations, akin to RFC7950 recommendations on deviations).

We raised an issue about where to document various versioning guidelines for YANG authors and SDOs. The YANG author guidelines RFC may not be the right place for Packages-related guidelines for example.

We should craft a liaison statement (at the IETF/NETMOD WG level)to 3GPP & ORAN about YANG deviations in packages (and other aspects of this versioning work ?)

Next week we'll plan IETF109 update slides.

Jason

---

From: "Sterne, Jason (Nokia - CA/Ottawa)" <[email-masked]>
Date: Tue, 27 Oct 2020 16:13:30 +0000

I forgot one important thing -> people from the author's group should review Bo's recent editorial changes to Packages as soon as possible. We want to get those into the upcoming update.

From: Sterne, Jason (Nokia - CA/Ottawa)
Sent: Tuesday, October 27, 2020 12:11 PM
To: [email-masked]
Subject: NETMOD YANG Version Discussions - meeting minutes Oct 27, 2020

Hi all,

Jason