Subject: Re: [netmod] Liaison statement to ORAN - v2

From: Balázs Lengyel <[email-masked]>
Date: Tue, 24 Nov 2020 16:04:05 +0000

Hello, 

Based on discussion here is version2 of the proposed liaison text:

Liaison text v2:

IETF NETMOD working group requests ORAN to avoid using deviations as part of its specification. When ORAN plans to reuse specifications from other standard bodies or industry groups it should not remove or change functionality.  If variations are needed compared to a base model, ORAN should ask the original group to include feature statements in the original YANG module.

As documented in https://tools.ietf.org/html/rfc7950#section-7.20.3  “... deviations MUST never be part of a published standard, since they are the mechanism for learning how implementations vary from the standards.”

As documented in  <https://tools.ietf.org/html/draft-ietf-netmod-yang-packages-01#section-5.8.1> https://tools.ietf.org/html/draft-ietf-netmod-yang-packages-01#section-5.8.1 the usage of deviations would prevent:

*	Vendors to claim conformance to both ORAN and 3GPP specifications (which are in some cases used as a base for the ORAN YANG models)
*	Vendors to implement their own deviations for the same YANG schema nodes
*	 

Note: The problems with deviations exists even if YANG modules are used without using YANG packages.

Regards Balazs

From: netmod <[email-masked]> On Behalf Of Jan Lindblad (jlindbla)
Sent: 2020. november 19., csütörtök 11:00
To: Balázs Lengyel <balazs.lengyel=[email-masked]>
Cc: Robert Petersen <[email-masked]>; Jacqueline Beaulac S <[email-masked]>; [email-masked]
Subject: Re: [netmod] Liaison statement to ORAN

Balázs, 

+1

I think this is an important message to O-RAN, and I know similar ideas have been up for discussions in other SDOs as well. I think your proposed way of conveying the message is good.  

Best Regards,

/jan

On 18 Nov 2020, at 09:09, Balázs Lengyel <balazs.lengyel=[email-masked] <mailto:balazs.lengyel=[email-masked]> > wrote:

Hello,

In connection to the draft  <https://tools.ietf.org/html/draft-ietf-netmod-yang-packages-01> https://tools.ietf.org/html/draft-ietf-netmod-yang-packages-01 I propose to send a liaison statement from IETF Netmod to ORAN.

The issue: 3GPP is standardizing a good number of YANG modules as part of the 3gpp TS 28.541 and 28.623 ( <https://protect2.fireeye.com/v1/url?k=de649d27-81ffa5c5-de64ddbc-86073b36ea28-bd22f142f9b85dd6&q=1&e=5a78b7c7-b77b-4866-87e7-f206e86f6f2b&u=https%3A%2F%2Fforge.3gpp.org%2Frep%2Fsa5%2FMnS%2Ftree%2FRel17-draft%2Fyang-models> https://forge.3gpp.org/rep/sa5/MnS/tree/Rel17-draft/yang-models). 

ORAN plans to re-use this models, but possibly refine them in some ways. They are considering using deviations to do this. 

E.g. change config=true schemas node to config=false. This creates problems as documented in  <https://tools.ietf.org/html/draft-ietf-netmod-yang-packages-01%23section-5.8.1> https://tools.ietf.org/html/draft-ietf-netmod-yang-packages-01#section-5.8.1

-   Deviations by an SDO (standard defining organization) prevent implementations from reporting their own deviations for the same nodes.

-   Deviations by an SDO prevent implementations from conforming to the standards specified by both SDOs.

To avoid these problems I propose to send the following text to ORAN:

“IETF NETMOD working group requests ORAN to avoid using deviations as part of its specification. As documented in  <https://tools.ietf.org/html/draft-ietf-netmod-yang-packages-01%23section-5.8.1> https://tools.ietf.org/html/draft-ietf-netmod-yang-packages-01#section-5.8.1 the usage of deviations would prevent:

*	Vendors to implement their own deviations for the same YANG schema nodes
*	Vendors to claim conformance to both ORAN and 3GPP specifications which are in some cases used as a base for the ORAN YANG models

Note: These problems with deviations exists even if YANG modules are used without using YANG packages.

Regards Balazs

-- 

Balazs Lengyel                    Senior Specialist                       Ericsson Hungary Ltd. 

Mobile: +36-70-330-7909              email:  <mailto:[email-masked]> [email-masked]

_______________________________________________
netmod mailing list
 <mailto:[email-masked]> [email-masked]
 <https://www.ietf.org/mailman/listinfo/netmod> https://www.ietf.org/mailman/listinfo/netmod

---

From: Scott Mansfield <[email-masked]>
Date: Tue, 24 Nov 2020 16:29:52 +0000

Thanks Balázs, 

Editorial:  The group is call O-RAN Alliance and should be abbreviated O-RAN.

So..  suggestions including boiler plate…

<liaison>

>From Groups     netmod

>From Contact     Scott Mansfield

To Group             O-RAN Alliance (SDFG, WG1, WG4, WG5, WG9)

To Contacts        Brian Daly: [email-masked] <mailto:[email-masked]> ; Xiaofei Xu: [email-masked] <mailto:[email-masked]> ; Paul Smith, [email-masked] <mailto:[email-masked]> ; Jinri Huang, [email-masked] <mailto:[email-masked]> ; Anil Umesh [email-masked] <mailto:[email-masked]> ; Shankar Venkataraman [email-masked] <mailto:[email-masked]> ; Mohamad Yassin [email-masked] <mailto:[email-masked]> ; Kunihiko Teshima [email-masked] <mailto:[email-masked]> ; Elena Myhre [email-masked] <mailto:[email-masked]> ; Abdellah Tazi [email-masked] <mailto:[email-masked]> ; Dechao Zhang [email-masked] <mailto:[email-masked]> ; Reza Vaez-Ghaemi [email-masked] <mailto:[email-masked]> 

Cc OPS ad, netmod wg

Response Contact            [email-masked]

Technical Contact             [email-masked]

Purpose               For information

Attachments      

Body

IETF NETMOD working group requests O-RAN avoid using deviations as part of its specification. When O-RAN plans to reuse specifications from other standard bodies or industry groups it should not remove or change functionality.  If variations are needed compared to a base model, O-RAN should ask the original group to include feature statements in the original YANG module.

*	Vendors to claim conformance to both O-RAN and 3GPP specifications (which are in some cases used as a base for the O-RAN YANG models)
*	Vendors to implement their own deviations for the same YANG schema nodes

Note: The problems with deviations exists even if YANG modules are used without YANG packages.

</liaison>

Regards,

-scott.

From: netmod <[email-masked]> On Behalf Of Balázs Lengyel
Sent: Tuesday, November 24, 2020 11:04 AM
To: Jan Lindblad (jlindbla) <jlindbla=[email-masked]>; Balázs Lengyel <balazs.lengyel=[email-masked]>
Cc: Robert Petersen <[email-masked]>; Jacqueline Beaulac S <[email-masked]>; [email-masked]
Subject: Re: [netmod] Liaison statement to ORAN - v2

Hello, 

Liaison text v2:

 

Regards Balazs

From: netmod <[email-masked] <mailto:[email-masked]> > On Behalf Of Jan Lindblad (jlindbla)
Sent: 2020. november 19., csütörtök 11:00
To: Balázs Lengyel <balazs.lengyel=[email-masked] <mailto:balazs.lengyel=[email-masked]> >
Cc: Robert Petersen <[email-masked] <mailto:[email-masked]> >; Jacqueline Beaulac S <[email-masked] <mailto:[email-masked]> >; [email-masked] <mailto:[email-masked]> 
Subject: Re: [netmod] Liaison statement to ORAN

Balázs, 

+1

Best Regards,

/jan

Hello,

Regards Balazs

--