Subject: [netmod] Liaison statement to ORAN

From: Balázs Lengyel <[email-masked]>
Date: Wed, 18 Nov 2020 08:09:41 +0000

Hello,

In connection to the draft
https://tools.ietf.org/html/draft-ietf-netmod-yang-packages-01 I propose to
send a liaison statement from IETF Netmod to ORAN.

The issue: 3GPP is standardizing a good number of YANG modules as part of
the 3gpp TS 28.541 and 28.623
(https://forge.3gpp.org/rep/sa5/MnS/tree/Rel17-draft/yang-models). 

ORAN plans to re-use this models, but possibly refine them in some ways.
They are considering using deviations to do this. 

E.g. change config=true schemas node to config=false. This creates problems
as documented in
https://tools.ietf.org/html/draft-ietf-netmod-yang-packages-01#section-5.8.1
<https://tools.ietf.org/html/draft-ietf-netmod-yang-packages-01%23section-5.
8.1> 

-   Deviations by an SDO (standard defining organization) prevent
implementations from reporting their own deviations for the same nodes.

-   Deviations by an SDO prevent implementations from conforming to the
standards specified by both SDOs.

To avoid these problems I propose to send the following text to ORAN:

“IETF NETMOD working group requests ORAN to avoid using deviations as part
of its specification. As documented in
https://tools.ietf.org/html/draft-ietf-netmod-yang-packages-01#section-5.8.1
<https://tools.ietf.org/html/draft-ietf-netmod-yang-packages-01%23section-5.
8.1>  the usage of deviations would prevent:

*	Vendors to implement their own deviations for the same YANG schema
nodes
*	Vendors to claim conformance to both ORAN and 3GPP specifications
which are in some cases used as a base for the ORAN YANG models

Note: These problems with deviations exists even if YANG modules are used
without using YANG packages.

Regards Balazs

-- 

Balazs Lengyel                    Senior Specialist
Ericsson Hungary Ltd. 

Mobile: +36-70-330-7909              email: [email-masked]

---

From: Mahesh Jethanandani <[email-masked]>
Date: Wed, 18 Nov 2020 10:01:36 -0800

Hi Balazs,

Do you have an example of where O-RAN is trying to deviate a 3GPP model? I would agree that for O-RAN to deviate a model would be a problem, and that it should be left to vendors to decide if they want to deviate the 3GPP model.

> On Nov 18, 2020, at 12:09 AM, Balázs Lengyel <balazs.lengyel=[email-masked]> wrote:
> 
> Hello,
> In connection to the draft https://tools.ietf.org/html/draft-ietf-netmod-yang-packages-01 <https://tools.ietf.org/html/draft-ietf-netmod-yang-packages-01> I propose to send a liaison statement from IETF Netmod to ORAN.
>  
> The issue: 3GPP is standardizing a good number of YANG modules as part of the 3gpp TS 28.541 and 28.623 (https://forge.3gpp.org/rep/sa5/MnS/tree/Rel17-draft/yang-models <https://forge.3gpp.org/rep/sa5/MnS/tree/Rel17-draft/yang-models>). 
> ORAN plans to re-use this models, but possibly refine them in some ways. They are considering using deviations to do this. 
> E.g. change config=true schemas node to config=false. This creates problems as documented in https://tools.ietf.org/html/draft-ietf-netmod-yang-packages-01#section-5.8.1 <https://tools.ietf.org/html/draft-ietf-netmod-yang-packages-01%23section-5.8.1>
>  
> -   Deviations by an SDO (standard defining organization) prevent implementations from reporting their own deviations for the same nodes.
> -   Deviations by an SDO prevent implementations from conforming to the standards specified by both SDOs.
>  
> “IETF NETMOD working group requests ORAN to avoid using deviations as part of its specification. As documented in https://tools.ietf.org/html/draft-ietf-netmod-yang-packages-01#section-5.8.1 <https://tools.ietf.org/html/draft-ietf-netmod-yang-packages-01%23section-5.8.1> the usage of deviations would prevent:
> Vendors to implement their own deviations for the same YANG schema nodes
> Vendors to claim conformance to both ORAN and 3GPP specifications which are in some cases used as a base for the ORAN YANG models
> Note: These problems with deviations exists even if YANG modules are used without using YANG packages.
> Regards Balazs
>  
> -- 
> Balazs Lengyel                    Senior Specialist                       Ericsson Hungary Ltd. 
> Mobile: +36-70-330-7909              email: [email-masked] <mailto:[email-masked]>
>  
> _______________________________________________
> netmod mailing list
> [email-masked] <mailto:[email-masked]>
> https://www.ietf.org/mailman/listinfo/netmod <https://www.ietf.org/mailman/listinfo/netmod>
Mahesh Jethanandani
[email-masked]

---

From: Balázs Lengyel <[email-masked]>
Date: Thu, 19 Nov 2020 09:22:11 +0000

Hello Mahesh,

I heard many discussions about this, but I can’t supply you with a specific example just now. I will ask if my colleagues working in ORAN can help.

Regards Balazs

From: Mahesh Jethanandani <[email-masked]> 
Sent: 2020. november 18., szerda 19:02
To: Balázs Lengyel <[email-masked]>
Cc: [email-masked]; Robert Petersen <[email-masked]>; Jacqueline Beaulac S <[email-masked]>
Subject: Re: [netmod] Liaison statement to ORAN

Hi Balazs,

On Nov 18, 2020, at 12:09 AM, Balázs Lengyel <balazs.lengyel=[email-masked] <mailto:balazs.lengyel=[email-masked]> > wrote:

Hello,

In connection to the draft  <https://tools.ietf.org/html/draft-ietf-netmod-yang-packages-01> https://tools.ietf.org/html/draft-ietf-netmod-yang-packages-01 I propose to send a liaison statement from IETF Netmod to ORAN.

The issue: 3GPP is standardizing a good number of YANG modules as part of the 3gpp TS 28.541 and 28.623 ( <https://protect2.fireeye.com/v1/url?k=f08a6b09-af11524a-f08a2b92-861fcb972bfc-d3713e17a0e10674&q=1&e=c0b7de7e-d7ca-4671-b5cc-cecfc1b188d5&u=https%3A%2F%2Fforge.3gpp.org%2Frep%2Fsa5%2FMnS%2Ftree%2FRel17-draft%2Fyang-models> https://forge.3gpp.org/rep/sa5/MnS/tree/Rel17-draft/yang-models). 

E.g. change config=true schemas node to config=false. This creates problems as documented in  <https://tools.ietf.org/html/draft-ietf-netmod-yang-packages-01%23section-5.8.1> https://tools.ietf.org/html/draft-ietf-netmod-yang-packages-01#section-5.8.1

“IETF NETMOD working group requests ORAN to avoid using deviations as part of its specification. As documented in  <https://tools.ietf.org/html/draft-ietf-netmod-yang-packages-01%23section-5.8.1> https://tools.ietf.org/html/draft-ietf-netmod-yang-packages-01#section-5.8.1 the usage of deviations would prevent:

*	Vendors to implement their own deviations for the same YANG schema nodes
*	Vendors to claim conformance to both ORAN and 3GPP specifications which are in some cases used as a base for the ORAN YANG models

Regards Balazs

-- 

Mobile: +36-70-330-7909              email:  <mailto:[email-masked]> [email-masked]

_______________________________________________
netmod mailing list
 <mailto:[email-masked]> [email-masked]
 <https://www.ietf.org/mailman/listinfo/netmod> https://www.ietf.org/mailman/listinfo/netmod

Mahesh Jethanandani

[email-masked] <mailto:[email-masked]>

---

From: "Jan Lindblad (jlindbla)" <[email-masked]>
Date: Thu, 19 Nov 2020 09:59:53 +0000

Balázs,

+1
I think this is an important message to O-RAN, and I know similar ideas have been up for discussions in other SDOs as well. I think your proposed way of conveying the message is good.

Best Regards,
/jan

On 18 Nov 2020, at 09:09, Balázs Lengyel <balazs.lengyel=[email-masked]<mailto:balazs.lengyel=[email-masked]>> wrote:

Hello,
In connection to the draft https://tools.ietf.org/html/draft-ietf-netmod-yang-packages-01 I propose to send a liaison statement from IETF Netmod to ORAN.

The issue: 3GPP is standardizing a good number of YANG modules as part of the 3gpp TS 28.541 and 28.623 (https://forge.3gpp.org/rep/sa5/MnS/tree/Rel17-draft/yang-models).
ORAN plans to re-use this models, but possibly refine them in some ways. They are considering using deviations to do this.
E.g. change config=true schemas node to config=false. This creates problems as documented in https://tools.ietf.org/html/draft-ietf-netmod-yang-packages-01#section-5.8.1<https://tools.ietf.org/html/draft-ietf-netmod-yang-packages-01%23section-5.8.1>

“IETF NETMOD working group requests ORAN to avoid using deviations as part of its specification. As documented in https://tools.ietf.org/html/draft-ietf-netmod-yang-packages-01#section-5.8.1<https://tools.ietf.org/html/draft-ietf-netmod-yang-packages-01%23section-5.8.1> the usage of deviations would prevent:

--
Balazs Lengyel                    Senior Specialist                       Ericsson Hungary Ltd.
Mobile: +36-70-330-7909              email: [email-masked]<mailto:[email-masked]>

_______________________________________________
netmod mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/netmod