Subject: [netmod] RFC8808 factory default - use if booting without a running ?

From: "Sterne, Jason (Nokia - CA/Ottawa)" <[email-masked]>
Date: Thu, 19 Nov 2020 17:51:05 +0000

Hi all,

RFC8808 talks about a use-case where a network element first comes from the factory.

Would it also make sense to use the factory default configuration in a scenario where a device reboots but can't find the startup datastore?  (i.e. no file, or corrupted file).  I think that might often be a way that a booting system would determine that it is actually in a 'new from the factory" situation.

Jason

---

From: Andy Bierman <[email-masked]>
Date: Thu, 19 Nov 2020 10:23:21 -0800

On Thu, Nov 19, 2020 at 9:51 AM Sterne, Jason (Nokia - CA/Ottawa) <
[email-masked]> wrote:

> Would it also make sense to use the factory default configuration in a
> scenario where a device reboots but can't find the startup datastore?
> (i.e. no file, or corrupted file).  I think that might often be a way that
> a booting system would determine that it is actually in a 'new from the
> factory" situation.
>
>
>

Yes -- our server has that option (for several years).
The server can reboot with the factory default config if booting the saved
config fails.

Jason

Andy

> _______________________________________________
> netmod mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/netmod
>