Subject: Re: [netmod] I-D Action: draft-ietf-netmod-geo-location-05.txt

From: Christian Hopps <[email-masked]>
Date: Wed, 11 Nov 2020 16:26:07 -0500

https://datatracker.ietf.org/doc/draft-ietf-netmod-geo-location/ <https://datatracker.ietf.org/doc/draft-ietf-netmod-geo-location/>

indicates status is Revised ID needed which I believe was addressed by the below publication.

Thanks,
Chris.

> On Jul 29, 2020, at 6:37 AM, [email-masked] wrote:
> 
> 
> A New Internet-Draft is available from the on-line Internet-Drafts directories.
> This draft is a work item of the Network Modeling WG of the IETF.
> 
>        Title           : A YANG Grouping for Geographic Locations
>        Author          : Christian Hopps
> 	Filename        : draft-ietf-netmod-geo-location-05.txt
> 	Pages           : 25
> 	Date            : 2020-07-29
> 
> Abstract:
>   This document defines a generic geographical location object YANG
>   grouping.  The geographical location grouping is intended to be used
>   in YANG models for specifying a location on or in reference to the
>   Earth or any other astronomical object.
> 
> 
> The IETF datatracker status page for this draft is:
> https://datatracker.ietf.org/doc/draft-ietf-netmod-geo-location/
> 
> There are also htmlized versions available at:
> https://tools.ietf.org/html/draft-ietf-netmod-geo-location-05
> https://datatracker.ietf.org/doc/html/draft-ietf-netmod-geo-location-05
> 
> A diff from the previous version is available at:
> https://www.ietf.org/rfcdiff?url2=draft-ietf-netmod-geo-location-05
> 
> 
> Please note that it may take a couple of minutes from the time of submission
> until the htmlized version and diff are available at tools.ietf.org.
> 
> Internet-Drafts are also available by anonymous FTP at:
> ftp://ftp.ietf.org/internet-drafts/
> 
> 
> _______________________________________________
> netmod mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/netmod
>

---

From: Kent Watsen <[email-masked]>
Date: Thu, 12 Nov 2020 00:36:25 +0000

Chris updated the draft per comments from Tom Petch received during the WGLC back in March (yes, it’s been that long).

Tom, can you review the updates to see if all your concerns were addressed?

Thanks,
Kent  // as Shepherd

> On Nov 11, 2020, at 4:26 PM, Christian Hopps <[email-masked]> wrote:
> 
>> On Jul 29, 2020, at 6:37 AM, [email-masked] <mailto:[email-masked]> wrote:
>> 
>>

---

From: Dmytro Shytyi <[email-masked]>
Date: Tue, 17 Nov 2020 19:42:25 +0100

Dear participants of netmod WG,

Would it be interesting (?) if I update the next draft https://tools.ietf.org/html/draft-shytyi-netmod-vysm-02 with: 

   o  ieee-dot1Q-types
   o  ietf-interfaces
   o  ietf-ip
   o  ietf-logical-network-element
   o  ietf-network
   o  ietf-network-instance
   o  ietf-ietf-network-topology
   o  ietf-routing-types
   o  ietf-te-topology
   o  ietf-te-topology-sf 

   o  ietf-te-types
   o  ietf-yang-schema-mount
   o  The YANG modules introduced in this document:
      *  ietf-ucpe-lne-properties
      *  ietf-ucpe-lt-virtual-link-id
      *  ietf-ucpe-ni-properties
      *  ietf-ucpe-node-type

All compatible modules and schema is presented in the github repository https://github.com/dmytroshytyi/ucpe-ietf

+ @Mahesh 

    After interesting disscution I tend to add  the deviation of these yang models (https://github.com/dmytroshytyi/ucpe-ietf/blob/master/submodules/etsi-nfv-vnf-deviation.yang) and (https://github.com/dmytroshytyi/ucpe-ietf/blob/master/submodules/etsi-nfv-common-deviation.yang) + make a leafref "vnfd" under "/lne:logical-network-elements/lne:logical-network-element/logical-network-element-properties/". You migth find the details in the github repo above.

     About these modules: If my approach to add these yang modules (with small modification described below) seems incorrect, may you please suggest how can I integrate them in the existing set of yang modules?

mofidification of https://github.com/dmytroshytyi/ucpe-ietf/blob/master/submodules/etsi-nfv-common-deviation.yang

submodule etsi-nfv-common-deviation {

yang-version 1.1;

//DEVIATION BEGIN;

belongs-to ietf-ucpe-lne-properties {

prefix ucpe;

}

//DEVIATION END;

mofidification of  https://github.com/dmytroshytyi/ucpe-ietf/blob/master/submodules/etsi-nfv-vnf-deviation.yang

submodule etsi-nfv-vnf-deviation {

yang-version 1.1;

//DEVIATION BEGIN;

belongs-to ietf-ucpe-lne-properties {

prefix nfv;

}

include etsi-nfv-common-deviation;

//DEVIATION END;

______________
Dmytro SHYTYI

---

From: tom petch <[email-masked]>
Date: Fri, 20 Nov 2020 11:37:24 +0000

From: Kent Watsen <[email-masked]>
Sent: 12 November 2020 00:36

<tp>

The YANG contact should include WG Web and WG List and Editor

dates need updating but probably best left to the RFC Editor

RFC8126 proposes the term 'group' for the top level rather than 'new category'

s.6.3 has XXX rather than XXXX

I note that the YANG module requires 'earth' but the text is always 'the earth' probably worth an explanatory note in the text

I am curious why the YANG module uses tilde to bracket geodetic-system

Tom Petch

Thanks,
Kent  // as Shepherd

On Nov 11, 2020, at 4:26 PM, Christian Hopps <[email-masked]<mailto:[email-masked]>> wrote:

Thanks,
Chris.

On Jul 29, 2020, at 6:37 AM, [email-masked]<mailto:[email-masked]> wrote:

Abstract:

_______________________________________________
netmod mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/netmod