Subject: Re: [OAUTH-WG] [oauth] WG kickoff

From: Peter Saint-Andre <[email-masked]>
Date: Tue, 02 Jun 2009 14:17:41 -0600

On 5/30/09 5:54 AM, Hubert Le Van Gong wrote:
> +1 on splitting the spec into 2 documents.
> Also since we did have consensus that the 2-legged scenario (browser-less?) is
> to be considered, it would fit nicely into the doc #2, wouldn't it?

So several people are in favor of splitting the spec into two documents.
Does anyone else (such as, say, the document editor? :) have an opinion
in the matter?

Peter

- --
Peter Saint-Andre
https://stpeter.im/

---

From: Bill Smith <[email-masked]>
Date: Tue, 02 Jun 2009 13:54:16 -0700

Split.

On Jun 2, 2009, at 1:17 PM, Peter Saint-Andre wrote:

> -----BEGIN PGP SIGNED MESSAGE-----
> Hash: SHA1
>
> -----BEGIN PGP SIGNATURE-----
> Version: GnuPG v1.4.8 (Darwin)
> Comment: Using GnuPG with Mozilla - http://enigmail.mozdev.org
>
> iEYEARECAAYFAkoliOUACgkQNL8k5A2w/vy2WwCgrE86dlVfDEJ/eJoGF6C1PUbN
> drUAniNiEpI9TzF0Va11UaXgdcQB5AL0
> =jq5W
> -----END PGP SIGNATURE-----
> _______________________________________________
> OAuth mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/oauth

---

From: John Panzer <[email-masked]>
Date: Tue, 2 Jun 2009 17:25:17 -0700

+1 to splitting.

-- 
--
John Panzer / Blogger
[email-masked] / abstractioneer.org / @jpanzer

---

From: Eran Hammer-Lahav <[email-masked]>
Date: Tue, 2 Jun 2009 20:11:19 -0700

I believe I was the one who originally suggested it :-)

Most of the work I put in the last draft was to enable just that.

EHL

On 6/2/09 1:17 PM, "Peter Saint-Andre" <[email-masked]> wrote:

Peter

- --
Peter Saint-Andre
https://stpeter.im/

---

From: Richard Barnes <[email-masked]>
Date: Tue, 02 Jun 2009 23:24:42 -0400

The current draft is a good start, but I think some of Section 4 (the 
mechanism section) needs to move toward Section 3 (the protocol section).

Namely, the logical interactions (who gives what to whom) can be defined 
in the abstract, as the parameters and computations currently are. 
Section 4 (or the other draft) would then specify how the data get moved 
in HTTP.

--Richard

Eran Hammer-Lahav wrote:
> ------------------------------------------------------------------------
>

---

From: Peter Saint-Andre <[email-masked]>
Date: Tue, 02 Jun 2009 21:31:21 -0600

> Most of the work I put in the last draft was to enable just that.

Well, then, I think we're on track. :)

Peter

- --
Peter Saint-Andre
https://stpeter.im/

---

From: Eran Hammer-Lahav <[email-masked]>
Date: Wed, 3 Jun 2009 09:26:12 -0700

The entire spec is HTTP specific. Section 3 is about signing HTTP requests.
Section 4 is about getting tokens via HTTP and a browser.

Section 3 answers: How to make authenticated HTTP requests with two sets of
credentials?

Section 4 answers: Hot to obtain a set of token credentials (currently
limited to a single method using a browser)?

I am not clear what you think should be moved around but I think we should
define the specs in terms of what questions they answer.

EHL