Subject: [OAUTH-WG] xAuth use in OAuth2.0?

From: Jitesh Bhate <[email-masked]>
Date: Wed, 12 Jan 2011 16:22:07 -0500

Is there any provision  in OAuth2.0 specs. to use xAuth to exchange a username and password for an OAuth access token?
Something twitter does using OAuth 1.0 http://dev.twitter.com/pages/xauth

Regards
Jitesh

---

From: Aaron Parecki <[email-masked]>
Date: Wed, 12 Jan 2011 14:08:34 -0800

Jitesh,

See section 5.1.2<http://tools.ietf.org/html/draft-ietf-oauth-v2-11#section-5.1.2>of
the Draft 11 spec which provides a way to exchange the resource
owner's
username and password for an access token. This is probably what you're
looking for.

Aaron

On Wed, Jan 12, 2011 at 1:22 PM, Jitesh Bhate <[email-masked]>wrote:

>
>
> Is there any provision  in OAuth2.0 specs. to use xAuth to exchange a
> username and password for an OAuth access token?
>
> _______________________________________________
> OAuth mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/oauth
>
>

---

From: Jitesh Bhate <[email-masked]>
Date: Wed, 12 Jan 2011 17:12:40 -0500

Perfect ! Thanks Aaron

From: Aaron Parecki [mailto:[email-masked]]
Sent: Wednesday, January 12, 2011 5:09 PM
To: [email-masked]
Cc: Jitesh Bhate
Subject: Re: [OAUTH-WG] xAuth use in OAuth2.0?

Jitesh,

See section 5.1.2<http://tools.ietf.org/html/draft-ietf-oauth-v2-11#section-5.1.2> of the Draft 11 spec which provides a way to exchange the resource owner's username and password for an access token. This is probably what you're looking for.

Aaron

On Wed, Jan 12, 2011 at 1:22 PM, Jitesh Bhate <[email-masked]<mailto:[email-masked]>> wrote:

Regards
Jitesh

_______________________________________________
OAuth mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/oauth