Subject: [OAUTH-WG] JSON Web Token (JWT) draft -01

From: Mike Jones <[email-masked]>
Date: Wed, 5 Jan 2011 02:31:20 +0000

Draft -01 of the JSON Web Token (JWT) specification<http://self-issued.info/docs/draft-jones-json-web-token.html> is now available.  This version incorporates the consensus decisions reached at the Internet Identity Workshop.  The remaining open issues and to-do items are documented in Section 12<http://self-issued.info/docs/draft-jones-json-web-token-01.html#TBD>.  As a reminder, the suggested pronunciation of JWT is the same as the English word "jot".

The draft is available at these locations:
  - http://www.ietf.org/internet-drafts/draft-jones-json-web-token-01.txt
  - http://www.ietf.org/internet-drafts/draft-jones-json-web-token-01.xml
  - http://self-issued.info/docs/draft-jones-json-web-token-01.html
  - http://self-issued.info/docs/draft-jones-json-web-token-01.txt
  - http://self-issued.info/docs/draft-jones-json-web-token-01.xml
  - http://self-issued.info/docs/draft-jones-json-web-token.html (will point to new versions as they are posted)
  - http://self-issued.info/docs/draft-jones-json-web-token.txt (will point to new versions as they are posted)
  - http://self-issued.info/docs/draft-jones-json-web-token.xml (will point to new versions as they are posted)
  - http://svn.openid.net/repos/specifications/json_web_token/1.0/ (Subversion repository, with html, txt, and html versions available)

The decisions reached at IIW are documented here:

  - JSON Token Spec Results at IIW:  http://self-issued.info/?p=361

  - JSON Token Encryption Spec Results at IIW:  http://self-issued.info/?p=378

  - JSON Token Naming Spec Results at IIW:  http://self-issued.info/?p=386
  - JSON Public Key Spec Results at IIW:  http://self-issued.info/?p=390

This announcement is also posted here:
  - http://self-issued.info/?p=446

Thanks to all who provided the input that led to this draft!  Feedback is highly welcome.

                                                                -- Mike

---

From: Hannes Tschofenig <[email-masked]>
Date: Mon, 10 Jan 2011 11:04:20 +0200

I was wondering whether there is some running code available as well? 

On Jan 5, 2011, at 4:31 AM, Mike Jones wrote:

> Draft -01 of the JSON Web Token (JWT) specification is now available.  This version incorporates the consensus decisions reached at the Internet Identity Workshop.  The remaining open issues and to-do items are documented in Section 12.  As a reminder, the suggested pronunciation of JWT is the same as the English word "jot".
>  
> _______________________________________________
> OAuth mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/oauth

---

From: Mike Jones <[email-masked]>
Date: Mon, 10 Jan 2011 16:52:02 +0000

Not that I'm aware of at present, but I expect that to change shortly.

				-- Mike

-----Original Message-----
From: Hannes Tschofenig [mailto:[email-masked]] 
Sent: Monday, January 10, 2011 1:04 AM
To: Mike Jones
Cc: Hannes Tschofenig; [email-masked]
Subject: Re: [OAUTH-WG] JSON Web Token (JWT) draft -01

On Jan 5, 2011, at 4:31 AM, Mike Jones wrote:

>   - http://svn.openid.net/repos/specifications/json_web_token/1.0/ 
> (Subversion repository, with html, txt, and html versions available)
>  
>                                                                 -- 
> Mike _______________________________________________
> OAuth mailing list
> [email-masked]