Subject: [OAUTH-WG] Fwd: New Version Notification for draft-hunt-oauth-chain-00

From: Phil Hunt <[email-masked]>
Date: Tue, 1 Mar 2011 12:33:59 -0800

After talking to some folks about OAuth protected services being able to connect to other REST based OAuth protected services, it occurred to me that some form of "chaining" is required to support scenarios that are essentially message buses.  The document specifies a new grant type which enables an OAuth client that has an oauth_token from its client, to request a new access token for another oauth protected server (which may or may not be in another OAuth "domain").

Your feedback and contributions greatly appreciated.

Phil
[email-masked]

Begin forwarded message:

> From: IETF I-D Submission Tool <[email-masked]>
> Date: March 1, 2011 12:29:07 PM PST
> To: [email-masked]
> Subject: New Version Notification for draft-hunt-oauth-chain-00 
> 
> 
> A new version of I-D, draft-hunt-oauth-chain-00.txt has been successfully submitted by Phil Hunt and posted to the IETF repository.
> 
> Filename:	 draft-hunt-oauth-chain
> Revision:	 00
> Title:		 Chain Grant Type for OAuth2
> Creation_date:	 2011-03-01
> WG ID:		 Independent Submission
> Number_of_pages: 10
> 
> Abstract:
> This specification defines a method by which an OAuth protected
> service, can use a received oauth token from its client, to in turn,
> act as a client and access another OAuth protected service in a
> 'chained' profile.
> 
> 
> 
> The IETF Secretariat.
> 
>

---

From: Phil Hunt <[email-masked]>
Date: Tue, 1 Mar 2011 16:24:04 -0800

For those interested in the chain grant proposal, I have posted more details on my blog: 
  http://independentidentity.blogspot.com/2011/03/oauth-new-chain-grant-type.html

Phil
[email-masked]

On 2011-03-01, at 12:33 PM, Phil Hunt wrote:

> _______________________________________________
> OAuth mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/oauth