Subject: [OAUTH-WG] editorial comment on section 2 of bearer token draft

From: Ron Monzillo <[email-masked]>
Date: Fri, 11 Mar 2011 09:35:00 -0500

http://tools.ietf.org/html/draft-ietf-oauth-v2-bearer-03

the doc's stated purpose is to describe "how to use bearer tokens when 
accessing OAuth 2.0 protected resources".

but then in section 2 and 2.1, it describes how clients make 
"authenticated token requests"; which can be read as an authenticated  
request for a (e.g., access) token, where, imv, what is being described 
is the use of a (bearer) token to access a protected resource.

Ron

---

From: Mike Jones <[email-masked]>
Date: Thu, 31 Mar 2011 18:19:49 +0000

This text has been revised accordingly in draft 04.  Thanks for the feedback.

				-- Mike

-----Original Message-----
From: Ron Monzillo [mailto:[email-masked]] 
Sent: Friday, March 11, 2011 6:35 AM
To: OAuth WG; Mike Jones
Subject: editorial comment on section 2 of bearer token draft

the doc's stated purpose is to describe "how to use bearer tokens when accessing OAuth 2.0 protected resources".

but then in section 2 and 2.1, it describes how clients make "authenticated token requests"; which can be read as an authenticated request for a (e.g., access) token, where, imv, what is being described is the use of a (bearer) token to access a protected resource.

Ron