Subject: [OAUTH-WG] Agenda Proposal

From: Hannes Tschofenig <[email-masked]>
Date: Thu, 17 Mar 2011 20:29:20 +0200

Open Authentication Protocol WG
==============================-

FRIDAY, April 1, 2011
Vienna/Madrid Room

Chairs: Hannes Tschofenig/Blaine Cook

Agenda
------

1) Agenda Bashing (Chairs)

2) Discussion of Working Group Last Call Comments (Chairs/Mike Jones)
http://datatracker.ietf.org/doc/draft-ietf-oauth-v2/
http://datatracker.ietf.org/doc/draft-ietf-oauth-v2-bearer/
http://datatracker.ietf.org/doc/draft-ietf-oauth-saml2-bearer/

3) OAuth Security (Thorsten)
http://datatracker.ietf.org/doc/draft-lodderstedt-oauth-security/

4) OAuth JSON Encoding (Mike Jones)
http://tools.ietf.org/html/draft-jones-json-web-token-01

5) OAuth Use Cases (Zachary Zeltsan)
https://datatracker.ietf.org/doc/draft-zeltsan-oauth-use-cases/

6) Re-Chartering Discussion (Chairs)

---

From: Anthony Nadalin <[email-masked]>
Date: Thu, 17 Mar 2011 18:53:33 +0000

Is it possible to add these to the mix?

http://www.ietf.org/id/draft-jones-simple-web-discovery-00.txt

and also the  http://self-issued.info/docs/draft-jones-oauth-jwt-bearer-00.txt 

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Hannes Tschofenig
Sent: Thursday, March 17, 2011 11:29 AM
To: [email-masked]
Subject: [OAUTH-WG] Agenda Proposal

FRIDAY, April 1, 2011
Vienna/Madrid Room

Agenda
------

2) Discussion of Working Group Last Call Comments (Chairs/Mike Jones) http://datatracker.ietf.org/doc/draft-ietf-oauth-v2/
http://datatracker.ietf.org/doc/draft-ietf-oauth-v2-bearer/
http://datatracker.ietf.org/doc/draft-ietf-oauth-saml2-bearer/

_______________________________________________
OAuth mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/oauth

---

From: Eran Hammer-Lahav <[email-masked]>
Date: Thu, 17 Mar 2011 11:56:20 -0700

Re: draft-jones-simple-web-discovery

While I don't have an objections to this document being presented and discussed at the meeting, I want to point that this has absolutely nothing to do with this working group and if the IETF community has an interest in pursuing it, it does not belong in this working group.

EHL

> From: [email-masked] [mailto:[email-masked]] On Behalf
> Of Anthony Nadalin
> Sent: Thursday, March 17, 2011 11:54 AM
> To: Hannes Tschofenig; [email-masked]
> Subject: Re: [OAUTH-WG] Agenda Proposal
>

---

From: [email-masked]
Date: Thu, 17 Mar 2011 20:38:56 +0000

Hi Hannes,

Security will be presented by Mark an myself.

Regards,
Torsten.
Gesendet mit BlackBerry® Webmail von Telekom Deutschland  

-----Original Message-----
From: Hannes Tschofenig <[email-masked]>
Sender: [email-masked]
Date: Thu, 17 Mar 2011 20:29:20 
To: [email-masked]<[email-masked]>
Subject: [OAUTH-WG] Agenda Proposal

FRIDAY, April 1, 2011
Vienna/Madrid Room

Agenda
------

---

From: Anthony Nadalin <[email-masked]>
Date: Thu, 17 Mar 2011 22:41:27 +0000

I think it does for example how one might discover the authorization service and this would be a forum to see if others also do or not.

-----Original Message-----
From: Eran Hammer-Lahav [mailto:[email-masked]] 
Sent: Thursday, March 17, 2011 11:56 AM
To: Anthony Nadalin; Hannes Tschofenig; [email-masked]
Subject: RE: [OAUTH-WG] Agenda Proposal

EHL

> and also the  
> http://self-issued.info/docs/draft-jones-oauth-jwt-bearer-
> 00.txt
> 
> Of Hannes Tschofenig

---

From: Eran Hammer-Lahav <[email-masked]>
Date: Thu, 17 Mar 2011 15:57:48 -0700

This proposal goes far beyond just solving any discovery needs for OAuth. It also directly competes with existing (deployed) proposals. This group is not the right forum to discuss and design a generally applicable discovery solution for the web. Once discovery is added to our charter (any discovery is currently out of scope), we can figure out if there are existing solutions to utilize, if we want to create a specialized solution for OAuth, or if a general purpose solution is needed (and does not already exist in a published standard).

If a general purpose solution is the direction to go, this is not the venue to develop it.

So again, presenting this at the meeting is fine, but beyond that, this working group is not chartered nor equipped to develop this technology for general purpose. In addition, the right way to present SWD to this WG is via an example of how OAuth might be using it, and not any direct discussion of the merits of the actual proposal - that belongs on the Apps-discuss list until another forum is identified or created.

EHL

> From: Anthony Nadalin [mailto:[email-masked]]
> Sent: Thursday, March 17, 2011 3:41 PM
> To: Eran Hammer-Lahav; Hannes Tschofenig; [email-masked]
> I think it does for example how one might discover the authorization service
> and this would be a forum to see if others also do or not.
> 
> While I don't have an objections to this document being presented and
> discussed at the meeting, I want to point that this has absolutely nothing to
> do with this working group and if the IETF community has an interest in
> pursuing it, it does not belong in this working group.
> 
> EHL
>

---

From: Peter Saint-Andre <[email-masked]>
Date: Thu, 17 Mar 2011 17:35:19 -0600

+1.

Discussion on the apps-discuss list would be welcome:

https://www.ietf.org/mailman/listinfo/apps-discuss

On 3/17/11 4:57 PM, Eran Hammer-Lahav wrote:
> This proposal goes far beyond just solving any discovery needs for
> OAuth. It also directly competes with existing (deployed) proposals.
> This group is not the right forum to discuss and design a generally
> applicable discovery solution for the web. Once discovery is added to
> our charter (any discovery is currently out of scope), we can figure
> out if there are existing solutions to utilize, if we want to create
> a specialized solution for OAuth, or if a general purpose solution is
> needed (and does not already exist in a published standard).
> 
> So again, presenting this at the meeting is fine, but beyond that,
> this working group is not chartered nor equipped to develop this
> technology for general purpose. In addition, the right way to present
> SWD to this WG is via an example of how OAuth might be using it, and
> not any direct discussion of the merits of the actual proposal - that
> belongs on the Apps-discuss list until another forum is identified or
> created.
> 
> EHL
> 
>> -----Original Message----- From: Anthony Nadalin
>> [mailto:[email-masked]] Sent: Thursday, March 17, 2011 3:41
>> PM To: Eran Hammer-Lahav; Hannes Tschofenig; [email-masked] 
>> I think it does for example how one might discover the
>> authorization service and this would be a forum to see if others
>> also do or not.
>> 
>> -----Original Message----- From: Eran Hammer-Lahav
>> [mailto:[email-masked]] Sent: Thursday, March 17, 2011 11:56
>> AM To: Anthony Nadalin; Hannes Tschofenig; [email-masked] Subject:
>> RE: [OAUTH-WG] Agenda Proposal
>> 
>> While I don't have an objections to this document being presented
>> and discussed at the meeting, I want to point that this has
>> absolutely nothing to do with this working group and if the IETF
>> community has an interest in pursuing it, it does not belong in
>> this working group.
>> 
>> EHL
>> 
>>> -----Original Message----- From: [email-masked]
>>> [mailto:[email-masked]] On Behalf Of Anthony Nadalin 
>>> Sent: Thursday, March 17, 2011 11:54 AM To: Hannes Tschofenig;
>>> [email-masked] Subject: Re: [OAUTH-WG] Agenda Proposal
>>> 
>>> -----Original Message----- From: [email-masked]
>>> [mailto:[email-masked]] On Behalf Of Hannes Tschofenig 
>>> Sent: Thursday, March 17, 2011 11:29 AM To: [email-masked] 
>>> Open Authentication Protocol WG ==============================-
>>> 
>>> FRIDAY, April 1, 2011 Vienna/Madrid Room
>>> 
>>> Agenda ------
>>> 2) Discussion of Working Group Last Call Comments (Chairs/Mike
>>> Jones) http://datatracker.ietf.org/doc/draft-ietf-oauth-v2/ 
>>> _______________________________________________ OAuth mailing
>>> list [email-masked] https://www.ietf.org/mailman/listinfo/oauth
>>> 
>>> 
>>>

---

From: Anthony Nadalin <[email-masked]>
Date: Fri, 18 Mar 2011 02:35:19 +0000

You need to chill a little instead of just jumping on people w/o understanding. First I did not say that I wanted to discuss a general discovery mechanism, as my example was limited to OAuth usage not the generic case.

-----Original Message-----
From: Eran Hammer-Lahav [mailto:[email-masked]] 
Sent: Thursday, March 17, 2011 3:58 PM
To: Anthony Nadalin; Hannes Tschofenig; [email-masked]
Subject: RE: [OAUTH-WG] Agenda Proposal

EHL

> I think it does for example how one might discover the authorization 
> service and this would be a forum to see if others also do or not.
> 
> discussed at the meeting, I want to point that this has absolutely 
> nothing to do with this working group and if the IETF community has an 
> interest in pursuing it, it does not belong in this working group.
> 
> EHL
> 
> > From: [email-masked] [mailto:[email-masked]] On 
> > Behalf Of Anthony Nadalin

---

From: Hannes Tschofenig <[email-masked]>
Date: Fri, 18 Mar 2011 20:21:38 +0200

Hi Tony, 

please make sure that draft-jones-oauth-jwt-bearer-00.txt  is submitted before the working group session starts. 

Ciao
Hannes

---

From: Anthony Nadalin <[email-masked]>
Date: Fri, 18 Mar 2011 18:31:26 +0000

Will do as I think the system opens back up on the 28th

-----Original Message-----
From: Hannes Tschofenig [mailto:[email-masked]] 
Sent: Friday, March 18, 2011 11:22 AM
To: Anthony Nadalin
Cc: Hannes Tschofenig; [email-masked]
Subject: Re: [OAUTH-WG] Agenda Proposal

Hi Tony, 

Ciao
Hannes