Subject: [OAUTH-WG] (late) feedback on draft-ietf-oauth-v2-13.txt

From: Paul Madsen <[email-masked]>
Date: Tue, 22 Mar 2011 15:16:40 -0400

In Section 6. Refreshing an Access Token 
(http://tools.ietf.org/html/draft-ietf-oauth-v2-13#section-6) the text

refresh_token
          REQUIRED.  The refresh token issued along the access token being refreshed.

seems both somewhat contorted and somewhat misleading

Suggest  'along' --> 'along with' or 'along side'

Even with the above change, the access token being refreshed may well 
not be the same as that originally issued with the refresh token (ie the 
first in the chain of access tokens issued 'off' the refresh token)

Suggest   'The refresh token associated with the access token being 
refreshed'

paul

---

From: Eran Hammer-Lahav <[email-masked]>
Date: Fri, 25 Mar 2011 00:08:43 -0700

How about:

            REQUIRED. The refresh token issued to the client.

EHL

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On Behalf
> Of Paul Madsen
> Sent: Tuesday, March 22, 2011 12:17 PM
> To: [email-masked]
> Subject: [OAUTH-WG] (late) feedback on draft-ietf-oauth-v2-13.txt
> 
> Even with the above change, the access token being refreshed may well not
> be the same as that originally issued with the refresh token (ie the first in the
> chain of access tokens issued 'off' the refresh token)
> 
> _______________________________________________
> OAuth mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/oauth