Subject: Re: [OAUTH-WG] Native Client Extension

From: Skylar Woodward <[email-masked]>
Date: Mon, 23 May 2011 13:44:58 -0700

Just for the record, I spoke with Marius just now and they'll be using Eran's suggested URN for this (as well as 'oob' as a non-complient alias):

	urn:ietf:wg:oauth:2.0:oob

Still remains to be codified in some way as an official suggestion. Would this belong in the core spec?

skylar

On Jan 28, 2011, at 11:24 AM, Marius Scurtescu wrote:

> On Fri, Jan 28, 2011 at 10:25 AM, Eran Hammer-Lahav <[email-masked]> wrote:
>> -12 3.1.1:
>> 
>>   The redirection URI MUST be an absolute URI and MAY include a query
>>   component, which MUST be retained by the authorization server when
>>   adding additional query parameters.
>> 
>> 'oob' is not an absolute URI.
> 
> Good point, I missed the absolute part. Thanks for pointing this out.
> 
> Let me think about it, the URN you suggested is a good start.
> 
> Marius
> _______________________________________________
> OAuth mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/oauth

---

From: Marius Scurtescu <[email-masked]>
Date: Mon, 23 May 2011 13:46:59 -0700

> Still remains to be codified in some way as an official suggestion. Would this belong in the core spec?

Working on an extensions right now, should be done in a few days (I
keep saying that).

Marius