Subject: Re: [OAUTH-WG] OAuth2 and clients without browsers

From: Andrew Arnott <[email-masked]>
Date: Tue, 26 Jul 2011 10:18:28 -0600

Trying a different DL...

--
Andrew Arnott
"I [may] not agree with what you have to say, but I'll defend to the death
your right to say it." - S. G. Tallentyre

On Wed, Jul 20, 2011 at 6:38 AM, Andrew Arnott <[email-masked]>wrote:

> The recent OAuth 2 specs seem to omit the scenario of a client that cannot
> host or invoke a browser but could display a URL to the user and ask the
> user to enter a PIN.  Was this an intentional omission?  If I am correct,
> this forces those clients to continue to use OAuth 1.0, which is not only
> less desirable but it will limit which services they can access.
>
> Thoughts?
> --
> Andrew Arnott
> "I [may] not agree with what you have to say, but I'll defend to the death
> your right to say it." - S. G. Tallentyre
>

---

From: Eran Hammer-Lahav <[email-masked]>
Date: Tue, 26 Jul 2011 10:06:29 -0700

I believe Google is working on a proposal for an oob URI value to use as the redirection URI.

EHL

On Jul 26, 2011, at 9:18, "Andrew Arnott" <[email-masked]<mailto:[email-masked]>> wrote:

Trying a different DL...

--
Andrew Arnott
"I [may] not agree with what you have to say, but I'll defend to the death your right to say it." - S. G. Tallentyre

On Wed, Jul 20, 2011 at 6:38 AM, Andrew Arnott <<mailto:[email-masked]>[email-masked]<mailto:[email-masked]>> wrote:
The recent OAuth 2 specs seem to omit the scenario of a client that cannot host or invoke a browser but could display a URL to the user and ask the user to enter a PIN.  Was this an intentional omission?  If I am correct, this forces those clients to continue to use OAuth 1.0, which is not only less desirable but it will limit which services they can access.

Thoughts?
--
Andrew Arnott
"I [may] not agree with what you have to say, but I'll defend to the death your right to say it." - S. G. Tallentyre

_______________________________________________
OAuth mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/oauth

---

From: Marius Scurtescu <[email-masked]>
Date: Tue, 26 Jul 2011 18:29:34 -0400

I think you are describing the device profile:
http://tools.ietf.org/html/draft-recordon-oauth-v2-device-00

Is that correct?

Marius

On Tue, Jul 26, 2011 at 12:18 PM, Andrew Arnott <[email-masked]> wrote:
> [email-masked]

---

From: Andrew Arnott <[email-masked]>
Date: Wed, 27 Jul 2011 08:46:14 -0600

Yes, thank you.  I'm glad there's already a spec for this.
--
Andrew Arnott
"I [may] not agree with what you have to say, but I'll defend to the death
your right to say it." - S. G. Tallentyre