Subject: [OAUTH-WG] TLS 1.2

From: Rob Richards <[email-masked]>
Date: Fri, 12 Aug 2011 15:56:33 -0400

The latest draft shows TLS 1.2 as a MUST (sections 3.1 and 3.2). Based 
on a thread about this from last year I was under the impression that it 
was going to be relaxed to a SHOULD with most likely TLS 1.0 (or 
posssibly SSLv3) as a MUST. I think it's a bit unrealistic to require 
1.2 when many systems out there can't support it. IMO this is going to 
be a big stumbling block for people to implement a compliant OAuth 
system. Even PCI doesn't require 1.2.

Rob

---

From: Rob Richards <[email-masked]>
Date: Tue, 16 Aug 2011 15:36:26 -0400

I wanted to follow up on this and see if there was any consideration to 
relaxing this requirement. Can someone actually point me to a compliant 
implementation using TLS 1.2 because after looking at a number of them, 
I have yet to find one that does.

Rob

On 8/12/11 3:56 PM, Rob Richards wrote:
> on a thread about this from last year I was under the impression that 
> it was going to be relaxed to a SHOULD with most likely TLS 1.0 (or 
> _______________________________________________
> OAuth mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/oauth
>

---

From: Justin Richer <[email-masked]>
Date: Tue, 16 Aug 2011 15:48:36 -0400

As I recall, the logic of the group here was something like:

"We want transport-layer encryption, so let's grab the latest version of
that around, which looks to be TLS 1.2"

With that logic in mind, this relaxation makes sense to me. Does anyone
remember this requirement differently?

 -- Justin 
    (who admittedly couldn't tell the difference between SSL and TLS)

---

From: Eran Hammer-Lahav <[email-masked]>
Date: Tue, 16 Aug 2011 12:55:16 -0700

We should relax it. Just need someone to propose new language.

EHL

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On Behalf
> Of Justin Richer
> Sent: Tuesday, August 16, 2011 12:49 PM
> To: Rob Richards
> Cc: [email-masked]
> Subject: Re: [OAUTH-WG] TLS 1.2
> 
> "We want transport-layer encryption, so let's grab the latest version of that
> around, which looks to be TLS 1.2"
> 
> > I wanted to follow up on this and see if there was any consideration
> > to relaxing this requirement. Can someone actually point me to a
> > compliant implementation using TLS 1.2 because after looking at a
> > number of them, I have yet to find one that does.
> >
> > Rob
> >
> > > The latest draft shows TLS 1.2 as a MUST (sections 3.1 and 3.2).
> > > Based on a thread about this from last year I was under the
> > > impression that it was going to be relaxed to a SHOULD with most
> > > likely TLS 1.0 (or posssibly SSLv3) as a MUST. I think it's a bit
> > > unrealistic to require
> > > 1.2 when many systems out there can't support it. IMO this is going
> > > to be a big stumbling block for people to implement a compliant
> > > OAuth system. Even PCI doesn't require 1.2.
> > >
> > > Rob

---

From: Peter Saint-Andre <[email-masked]>
Date: Tue, 16 Aug 2011 14:04:35 -0600

How's this?

   The authorization server MUST support Transport Layer Security
   (at the time of this writing, the latest version is specified in
   [RFC5246]). It MAY support additional transport-layer mechanisms
   meeting its security requirements.

-- 
Peter Saint-Andre
https://stpeter.im/

---

From: Phillip Hunt <[email-masked]>
Date: Tue, 16 Aug 2011 13:30:24 -0700

+1

Phil

---

From: Rob Richards <[email-masked]>
Date: Tue, 16 Aug 2011 16:34:28 -0400

After dealing with a few companies' security teams over the spec, I 
don't think it should be allowed too much room for interpretation and 
needs to be spelled out clearly. They would most likely interpret that 
as requiring the latest version of TLS at the time of implementation.

Maybe something more along the lines of:

The authorization server SHOULD support TLS 1.2 as defined in [RFC5246] 
but at a minimum MUST support TLS 1.0 as defined in [RFC2246], and MAY 
support additional transport-layer mechanisms meeting its security 
requirements.

---

From: Eran Hammer-Lahav <[email-masked]>
Date: Thu, 18 Aug 2011 11:31:44 -0700

> From: Rob Richards [mailto:[email-masked]]
> Sent: Tuesday, August 16, 2011 1:34 PM

> The authorization server SHOULD support TLS 1.2 as defined in [RFC5246] but
> at a minimum MUST support TLS 1.0 as defined in [RFC2246], and MAY

How about:

The authorization server MUST support TLS 1.0 ([RFC2246]), SHOULD support TLS 1.2 ([RFC5246]) and its future replacements, and MAY support additional transport-layer mechanisms meeting its security requirements.

EHL

---

From: Rob Richards <[email-masked]>
Date: Thu, 18 Aug 2011 15:46:07 -0400

> The authorization server MUST support TLS 1.0 ([RFC2246]), SHOULD support TLS 1.2 ([RFC5246]) and its future replacements, and MAY support additional transport-layer mechanisms meeting its security…

That works

Rob

---

From: "Lu, Hui-Lan (Huilan)" <[email-masked]>
Date: Thu, 18 Aug 2011 15:49:22 -0500

+1

Huilan

> From: [email-masked] [mailto:[email-masked]] On Behalf Of Rob
> Richards
> Sent: Thursday, August 18, 2011 3:46 PM
> To: Eran Hammer-Lahav
> Cc: [email-masked]
> > The authorization server MUST support TLS 1.0 ([RFC2246]), SHOULD support TLS
> 1.2 ([RFC5246]) and its future replacements, and MAY support additional transport-
> layer mechanisms meeting its security requirements.
> >
> > EHL
> >
> >
> 
> That works
> 
> Rob