Subject: [OAUTH-WG] OAuth 2.0 Bearer Token Specification Draft -12

From: Mike Jones <[email-masked]>
Date: Thu, 27 Oct 2011 21:01:59 +0000

Draft 12 of the OAuth 2.0 Bearer Token Specification<http://self-issued.info/docs/draft-ietf-oauth-v2-bearer.html> has been published.  I believe that the chairs will be submitting this version to the IESG.  It contains the following changes:

  *   Made non-normative editorial changes that Hannes Tschofenig requested be applied prior to forwarding the specification to the IESG.
  *   Added rationale for the choice of the b64token syntax.
  *   Added rationale stating that receivers are free to parse the scope attribute using a standard quoted-string parser, since it will correctly process all legal scope values.
  *   Added additional active working group contributors to the Acknowledgements section.

The draft is available at these locations:

*         http://tools.ietf.org/html/draft-ietf-oauth-v2-bearer-12

*         http://www.ietf.org/internet-drafts/draft-ietf-oauth-v2-bearer-12.pdf

*         http://www.ietf.org/internet-drafts/draft-ietf-oauth-v2-bearer-12.txt

*         http://www.ietf.org/internet-drafts/draft-ietf-oauth-v2-bearer-12.xml

*         http://self-issued.info/docs/draft-ietf-oauth-v2-bearer-12.html

*         http://self-issued.info/docs/draft-ietf-oauth-v2-bearer-12.pdf

*         http://self-issued.info/docs/draft-ietf-oauth-v2-bearer-12.txt

*         http://self-issued.info/docs/draft-ietf-oauth-v2-bearer-12.xml

*         http://self-issued.info/docs/draft-ietf-oauth-v2-bearer.html (will point to new versions as they are posted)

*         http://self-issued.info/docs/draft-ietf-oauth-v2-bearer.pdf (will point to new versions as they are posted)

*         http://self-issued.info/docs/draft-ietf-oauth-v2-bearer.txt (will point to new versions as they are posted)

*         http://self-issued.info/docs/draft-ietf-oauth-v2-bearer.xml (will point to new versions as they are posted)

*         http://svn.openid.net/repos/specifications/oauth/2.0/ (Subversion repository, with html, pdf, txt, and html versions available)

                                                                -- Mike

---

From: Hannes Tschofenig <[email-masked]>
Date: Fri, 28 Oct 2011 00:21:46 +0300

Thank you Mike for your work on the specification and to get the feedback incorporated before the deadline. 

On Oct 28, 2011, at 12:01 AM, Mike Jones wrote:

> Draft 12 of the OAuth 2.0 Bearer Token Specification has been published.  I believe that the chairs will be submitting this version to the IESG.  It contains the following changes:
> 	• Made non-normative editorial changes that Hannes Tschofenig requested be applied prior to forwarding the specification to the IESG.
> 	• Added rationale for the choice of the b64token syntax.
> 	• Added rationale stating that receivers are free to parse the scope attribute using a standard quoted-string parser, since it will correctly process all legal scopevalues.
> 	• Added additional active working group contributors to the Acknowledgements section.
>  
> ·         http://tools.ietf.org/html/draft-ietf-oauth-v2-bearer-12
> ·         http://www.ietf.org/internet-drafts/draft-ietf-oauth-v2-bearer-12.pdf
> ·         http://www.ietf.org/internet-drafts/draft-ietf-oauth-v2-bearer-12.txt
> ·         http://www.ietf.org/internet-drafts/draft-ietf-oauth-v2-bearer-12.xml
> ·         http://self-issued.info/docs/draft-ietf-oauth-v2-bearer-12.html
> ·         http://self-issued.info/docs/draft-ietf-oauth-v2-bearer-12.pdf
> ·         http://self-issued.info/docs/draft-ietf-oauth-v2-bearer-12.txt
> ·         http://self-issued.info/docs/draft-ietf-oauth-v2-bearer-12.xml
> ·         http://self-issued.info/docs/draft-ietf-oauth-v2-bearer.html (will point to new versions as they are posted)
> ·         http://self-issued.info/docs/draft-ietf-oauth-v2-bearer.pdf (will point to new versions as they are posted)
> ·         http://self-issued.info/docs/draft-ietf-oauth-v2-bearer.txt (will point to new versions as they are posted)
> ·         http://self-issued.info/docs/draft-ietf-oauth-v2-bearer.xml (will point to new versions as they are posted)
> ·         http://svn.openid.net/repos/specifications/oauth/2.0/ (Subversion repository, with html, pdf, txt, and html versions available)
>  
>                                                                 -- Mike
>  
> _______________________________________________
> OAuth mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/oauth