Subject: [OAUTH-WG] delete access tokens?

From: "Bart Wiegmans" <[email-masked]>
Date: Tue, 29 Nov 2011 11:32:11 +0100

Hello everybody, again.

This is just me pushing a random idea, but what if you specified that
clients could ask for access token invalidation by making a DELETE
request to the token endpoint?

Bart Wiegmans

---

From: "Lodderstedt, Torsten" <[email-masked]>
Date: Tue, 29 Nov 2011 14:08:50 +0100

Hi Bart,

I think this would be a truly RESTful approach. The group discussed this topic several months ago and consensus was to use another endpoint for token revocation (== deletion). Pls. take a look onto http://tools.ietf.org/html/draft-lodderstedt-oauth-revocation-02.

regards,
Torsten.

Von: Bart Wiegmans [mailto:[email-masked]]
Gesendet: Dienstag, 29. November 2011 11:32
An: oauth WG
Betreff: [OAUTH-WG] delete access tokens?

Hello everybody, again.

This is just me pushing a random idea, but what if you specified that clients could ask for access token invalidation by making a DELETE request to the token endpoint?

Bart Wiegmans