Subject: [OAUTH-WG] MAC Cookies

From: Eran Hammer-Lahav <[email-masked]>
Date: Sat, 19 Nov 2011 08:33:18 -0700

I would like to drop the cookies support defined in the MAC document due to lack of interest from the browser vendors. At this point it is most likely going to be an unimplemented proposal. If there is interest in the future, it can be proposed in a separate document. This will allow us to bring this work to a quick conclusion.

Any objections?

EHL

---

From: Peter Wolanin <[email-masked]>
Date: Wed, 23 Nov 2011 19:57:30 -0500

No objection from me, but it's too bad the browser vendors aren't interested.

-Peter

On Sat, Nov 19, 2011 at 10:33 AM, Eran Hammer-Lahav <[email-masked]> wrote:
> I would like to drop the cookies support defined in the MAC document due to
> lack of interest from the browser vendors. At this point it is most likely
> going to be an unimplemented proposal. If there is interest in the future,
> it can be proposed in a separate document. This will allow us to bring this
> work to a quick conclusion.
>
>
>
> Any objections?
>
>
>
> EHL
>
>
> _______________________________________________
> OAuth mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/oauth
>

-- 
Peter M. Wolanin, Ph.D.      : Momentum Specialist,  Acquia. Inc.
[email-masked] : 781-313-8322

"Get a free, hosted Drupal 7 site: http://www.drupalgardens.com"

---

From: Phil Hunt <[email-masked]>
Date: Wed, 23 Nov 2011 23:35:56 -0800

Eran,

I see value (at least for servers) in having browser and HTTP clients work with common tokens (e.g. MAC) - even though the mechanism for exchange may vary.

I had an email exchange with Harry Halpin. He suggests cross posting to the w3c public-identity list.

They are discussing web cryptography and MAC tokens may be an important use case.

Phil

@independentid
www.independentid.com
[email-masked]

---

From: Eran Hammer-Lahav <[email-masked]>
Date: Thu, 24 Nov 2011 10:19:40 -0700

MAC tokens are a solution, not a use case :-)

As for reaching out, I'll leave it to the chairs to decide how to want to proceed.

EHL

> -----Original Message-----
> From: Phil Hunt [mailto:[email-masked]]
> Sent: Wednesday, November 23, 2011 11:36 PM
> To: Peter Wolanin
> Cc: Eran Hammer-Lahav; Ben Adida; OAuth WG; Adam Barth
> ([email-masked])
> Subject: Re: [OAUTH-WG] MAC Cookies
> 
> Eran,
> 
> I see value (at least for servers) in having browser and HTTP clients work with
> common tokens (e.g. MAC) - even though the mechanism for exchange may
> vary.
> 
> >> I would like to drop the cookies support defined in the MAC document
> >> due to lack of interest from the browser vendors. At this point it is
> >> most likely going to be an unimplemented proposal. If there is
> >> interest in the future, it can be proposed in a separate document.
> >> This will allow us to bring this work to a quick conclusion.
> >>
> >>
> >>
> >> Any objections?
> >>
> >>
> >>
> >> EHL
> >>
> >>