Subject: Re: [OAUTH-WG] question about the b64token syntax in draft-ietf-oauth-v2-bearer

From: "Manger, James H" <[email-masked]>
Date: Sun, 11 Mar 2012 21:05:25 +1100

+1

--
James Manger

----- Reply message -----From: "Mike Jones" <[email-masked]> Date: Sun, Mar 11, 2012 4:50 am Subject: [OAUTH-WG] question about the b64token syntax in draft-ietf-oauth-v2-bearer To: "Paul Madsen" <[email-masked]>, "Brian Campbell" <[email-masked]> Cc: "oauth" <[email-masked]>

I plan to make the change to the example access token value tomF_9.B5f-4.1JqM before Monday’s submission deadline, per the requests for b64token syntax clarification. I’m also considering adding an access token response example, pre the requests in this thread. I would propose adding the following new text for this in a new Section 4 (before the current Security Considerations). This is largely parallel to what is done in Section 5.1 of the MAC spec.

4. Example Access Token Response

Typically a bearer token is returned to the client as part of an OAuth 2.0 [I-D.ietf-oauth-v2] access token response. An example of such as response is:

HTTP/1.1 200 OK

Content-Type: application/json;charset=UTF-8

Cache-Control: no-store

Pragma: no-cache

{

"access_token":"mF_9.B5f-4.1JqM",

"token_type":"Bearer",

"expires_in":3600,

"refresh_token":"tGzv3JOkF0XG5Qx2TlKWIA"

}

Please send either +1s or objections to this text by mid-day Monday. Unless I receive several +1s, to be conservative at this point, I will not be including it in Monday’s draft.

-- Mike

---

From: Paul Madsen <[email-masked]>
Date: Sun, 11 Mar 2012 07:18:56 -0400

+1

On 3/11/12 6:05 AM, Manger, James H wrote:
> +1
>
> --
> James Manger
>
> ----- Reply message -----From: "Mike Jones"<[email-masked]>  Date: Sun, Mar 11, 2012 4:50 am Subject: [OAUTH-WG] question about the b64token syntax in draft-ietf-oauth-v2-bearer To: "Paul Madsen"<[email-masked]>, "Brian Campbell"<[email-masked]>  Cc: "oauth"<[email-masked]>
>
> _______________________________________________
> OAuth mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/oauth