Subject: [OAUTH-WG] I-D Action: draft-ietf-oauth-v2-24.txt

From: [email-masked]
Date: Wed, 07 Mar 2012 21:42:18 -0800

A New Internet-Draft is available from the on-line Internet-Drafts directories. This draft is a work item of the Web Authorization Protocol Working Group of the IETF.

	Title           : The OAuth 2.0 Authorization Protocol
	Author(s)       : Eran Hammer
                          David Recordon
                          Dick Hardt
	Filename        : draft-ietf-oauth-v2-24.txt
	Pages           : 66
	Date            : 2012-03-07

   The OAuth 2.0 authorization protocol enables a third-party
   application to obtain limited access to an HTTP service, either on
   behalf of a resource owner by orchestrating an approval interaction
   between the resource owner and the HTTP service, or by allowing the
   third-party application to obtain access on its own behalf.  This
   specification replaces and obsoletes the OAuth 1.0 protocol described
   in RFC 5849.

A URL for this Internet-Draft is:
http://www.ietf.org/internet-drafts/draft-ietf-oauth-v2-24.txt

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

This Internet-Draft can be retrieved at:
ftp://ftp.ietf.org/internet-drafts/draft-ietf-oauth-v2-24.txt

---

From: Eran Hammer <[email-masked]>
Date: Wed, 7 Mar 2012 22:46:30 -0700

This draft is ready to go to IESG Review.

EH

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On Behalf
> Of [email-masked]
> Sent: Wednesday, March 07, 2012 9:42 PM
> To: [email-masked]
> Cc: [email-masked]
> Subject: [OAUTH-WG] I-D Action: draft-ietf-oauth-v2-24.txt
> 
> 
> A New Internet-Draft is available from the on-line Internet-Drafts directories.
> This draft is a work item of the Web Authorization Protocol Working Group of
> the IETF.
> 
> _______________________________________________
> OAuth mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/oauth

---

From: Stephen Farrell <[email-masked]>
Date: Thu, 08 Mar 2012 10:32:18 +0000

Thanks Eran,

A question...

Is this text in 3.1.2.5 correct?

    If third-party
    scripts are included, the client MUST NOT ensure that its own scripts
    (used to extract and remove the credentials from the URI) will
    execute first.

"MUST NOT ensure" is a really odd construct. Maybe s/NOT//?

S

---

From: Eran Hammer <[email-masked]>
Date: Thu, 8 Mar 2012 08:19:58 -0700

Yep. Forgot to drop the NOT. Want a new -25?

EH

> From: Stephen Farrell [mailto:[email-masked]]
> Sent: Thursday, March 08, 2012 2:32 AM
> To: Eran Hammer
> Cc: [email-masked]
> Subject: Re: [OAUTH-WG] I-D Action: draft-ietf-oauth-v2-24.txt
> 
> 
> Thanks Eran,
> 
> A question...
> 
> >> From: [email-masked] [mailto:[email-masked]] On
> >> Behalf Of [email-masked]
> >> This draft is a work item of the Web Authorization Protocol Working
> >> Group of the IETF.
> >>

---

From: Eran Hammer <[email-masked]>
Date: Thu, 8 Mar 2012 08:24:08 -0700

I pushed -25 just in case with this fix.