Subject: [OAUTH-WG] Agenda Proposal

From: Hannes Tschofenig <[email-masked]>
Date: Wed, 14 Mar 2012 22:14:55 +0200

Feedback appreciated!

Web Authorization Protocol WG 
=============================

THURSDAY, March 29, 2012
1300-1500 Afternoon Session I 

Room: 252A

Chairs: Hannes Tschofenig & Derek Atkins

1. Agenda Bashing, WG Status 
(+ Welcome Derek and Thank You Barry)

2. OAuth Threats Document (Torsten)
https://datatracker.ietf.org/doc/draft-ietf-oauth-v2-threatmodel/

3. OAuth Assertions (Mike)
https://datatracker.ietf.org/doc/draft-ietf-oauth-assertions/
https://datatracker.ietf.org/doc/draft-ietf-oauth-saml2-bearer/
https://datatracker.ietf.org/doc/draft-ietf-oauth-urn-sub-ns/

4. MAC Token (TBD)
https://datatracker.ietf.org/doc/draft-ietf-oauth-v2-http-mac/

5. Re-charter finalization (all)

See mail sent separately to the mailing list.

---

From: Barry Leiba <[email-masked]>
Date: Wed, 14 Mar 2012 16:23:06 -0400

> https://datatracker.ietf.org/doc/draft-ietf-oauth-v2-threatmodel/

I have been terribly remiss on this, so here's the thing:

- We have completed WGLC on this, and are awaiting my shepherd review
(which will include a recommendation for the remaining unresolved
issue).

- I will do this before I leave chairdom and head into the abyss that
is the IESG.

- Torsten, please let me know if there's anything outstanding that you
have to do; else it's all waiting for my action.

Unless I've missed something, this agenda item should be brief indeed.

Barry, two more weeks

---

From: Barry Leiba <[email-masked]>
Date: Wed, 14 Mar 2012 16:24:40 -0400

Oh, and...

> https://datatracker.ietf.org/doc/draft-ietf-oauth-v2-http-mac/

I believe that in Eran's last communication about this he said that he
does, after all, have the time and inclination to finish it, and would
like to.

b

---

From: Eran Hammer <[email-masked]>
Date: Wed, 14 Mar 2012 13:41:00 -0700

I'll see this one through. I have some open issues to sum on the list shortly which prevented me from getting a new draft submitted in time. Overall, we're pretty much done and in agreement. The next draft which should not be a major change, will be ready for WGLC. We can have this sent to the IESG by end of April.

EH

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On Behalf
> Of Barry Leiba
> Sent: Wednesday, March 14, 2012 1:25 PM
> To: Hannes Tschofenig
> Cc: [email-masked] WG
> Subject: Re: [OAUTH-WG] Agenda Proposal
> 
> Oh, and...
> 
> > 4. MAC Token (TBD)
> I believe that in Eran's last communication about this he said that he does,
> after all, have the time and inclination to finish it, and would like to.
> 
> b
> _______________________________________________
> OAuth mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/oauth

---

From: "Tschofenig, Hannes (NSN - FI/Espoo)" <[email-masked]>
Date: Thu, 15 Mar 2012 11:03:14 +0200

Thanks for the info, Barry. 

I would, however, like to find an additional co-author from the group to
ensure accelerated process

> Of ext Barry Leiba
> Sent: Wednesday, March 14, 2012 10:25 PM
> To: Hannes Tschofenig
> Cc: [email-masked] WG

---

From: Eran Hammer <[email-masked]>
Date: Thu, 15 Mar 2012 07:56:07 -0700

The only reason it is taking a long time is lack of WG feedback and total lack of attention from the chairs. If you are looking to improve delivery time, I would start by getting more involved and help drive issues to completion. Suggesting the problem is with the single author is unfounded and offensive.

EH

> Of Tschofenig, Hannes (NSN - FI/Espoo)
> Sent: Thursday, March 15, 2012 2:03 AM
> To: ext Barry Leiba; Hannes Tschofenig
> Cc: [email-masked]

---

From: Torsten Lodderstedt <[email-masked]>
Date: Mon, 26 Mar 2012 18:55:15 +0200

Hi Barry,

we incorporated all issues we were aware of in the last revision (esp. 
Tim Bray's review comments).

regards,
Torsten.

---

From: Michael Thomas <[email-masked]>
Date: Mon, 26 Mar 2012 09:57:37 -0700

As far as I know, none of my concerns were incorporated.

Mike

On 03/26/2012 09:55 AM, Torsten Lodderstedt wrote:
> Hi Barry,
>
> we incorporated all issues we were aware of in the last revision (esp. Tim Bray's review comments).
>
> regards,
> Torsten.
>

---

From: Barry Leiba <[email-masked]>
Date: Mon, 26 Mar 2012 13:00:07 -0400

> As far as I know, none of my concerns were incorporated.

Correct, and I will take care of that (or try to) in my shepherd review.

Barry