Subject: Re: [OAUTH-WG] OAUTH Report for IETF-83

From: "Derek Atkins" <[email-masked]>
Date: Fri, 30 Mar 2012 08:14:46 +0200

Yes, you are missing the meeting we had yesterday where it was discussed to be added to the charter.

-derek, WG Chair

Sent from my HTC on the Now Network from Sprint!

----- Reply message -----
From: "Eran Hammer" <[email-masked]>
Date: Fri, Mar 30, 2012 4:25 am
Subject: [OAUTH-WG] OAUTH Report for IETF-83
To: "William Mills" <[email-masked]>, "Derek Atkins" <[email-masked]>, "[email-masked]" <[email-masked]>, "[email-masked]" <[email-masked]>

---

From: "Derek Atkins" <[email-masked]>
Date: Fri, 30 Mar 2012 08:22:45 +0200

Correct.

SWD may or may not happen in this group. The important part is getting the right people in the same room to work on it.  If that is here, great. If that is in its own group, that's great too.  If it won't happen in another group and if people here are wanting it, then that would imply this is the right place.

We can discuss whether SWD is needed, but there was certainly interest in the WG meeting yesterday.

-derek

----- Reply message -----
From: "William Mills" <[email-masked]>
Date: Fri, Mar 30, 2012 1:26 am
Subject: [OAUTH-WG] OAUTH Report for IETF-83
To: "Eran Hammer" <[email-masked]>, "Derek Atkins" <[email-masked]>, "[email-masked]" <[email-masked]>, "[email-masked]" <[email-masked]>

---

From: Eran Hammer <[email-masked]>
Date: Thu, 29 Mar 2012 23:36:03 -0700

I’ve already asked for the audio / transcript / detailed notes of the meeting. All I have is your notes posted earlier. Unlike many in this WG, OAuth has nothing to do with my day job. Meetings are not a required part of the IETF process and serve only as input for the mailing list. The input provided isn’t very helpful.

Given my analysis below, what is missing in comparison to what was discussed? What other process is being followed to justify SWD becoming its own topic and not a technical topic to be discussed later?

EH

From: Derek Atkins [mailto:[email-masked]]
Sent: Thursday, March 29, 2012 11:15 PM
To: Eran Hammer; William Mills; [email-masked]; [email-masked]
Subject: Re: [OAUTH-WG] OAUTH Report for IETF-83

-derek, WG Chair

----- Reply message -----
From: "Eran Hammer" <[email-masked]<mailto:[email-masked]>>
Date: Fri, Mar 30, 2012 4:25 am
Subject: [OAUTH-WG] OAUTH Report for IETF-83
To: "William Mills" <[email-masked]<mailto:[email-masked]>>, "Derek Atkins" <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
The narrative so far:

The IETF has adopted host-meta as a general-purpose discovery mechanism in RFC 6415.
The OpenID Connect group, which utilizes OAuth but is out of scope for this WG, adopted SWD as its discovery mechanism.
The proposed charter references ‘OAuth Dynamic Client Registration Protocol’, which in turn references RFC 6415 as its discovery mechanism.

Am I missing a WG item or proposed draft which relies on SWD at this time? If I am, are these documents included in the proposed charter or are requested to be included (e.g. not SWT itself but other documents with dependencies on it)? In such documents, is SWD a required component which cannot be substituted with something else such as RFC 6415?

Here is how this process should work:

1.       The WG agrees on including a discovery related item in its charter. The dynamic client registration is a reasonable such item.

2.       The charter references an existing proposal as foundation.

3.       The WG begins discussing the proposed draft (which can happen at any time on the list as long as the chairs allow it).

4.       The WG discusses any required enabling technologies, their suitability, maturity, industry support, etc. In the case of dynamic registration, I expect the WG to discuss SWD (because it is the technology selected by the OpenID subset of this WG), host-meta (because it is an IETF proposed standard RFC), as well as other solutions (Link headers, other well-known URIs, etc.). The publication status of the proposed technologies is another factor.

5.       If an enabling technology is decided to be the most suitable, and is not available in normative reference form, the WG will discuss the best way to accomplish that. This includes identifying the right community, standards body, working group, etc. that is best to take on the work. If no suitable venue is found, the WG may decide to take on the work with very limited scope only to enable its own use cases.

I am not opposed to having this discussion, but why are *we* having it *now*, other than the OpenID Connect group, which has nothing to do with this WG, is stuck with the problem of finding a venue for this work, and are dumping it on our laps?

I do not recall this WG ever decided (or even *proposed*) to use SWD for any of its chartered items. When we have this discussion, I expect it to include a detailed examination of host-meta and other solutions *as equal* alternatives. The OpenID Connect group preference is a valid input as it covers some potential market share with OAuth deployment, but it is *far* from any significant deployment worthy of bypassing this evaluation.

Am I missing something here?

EH

From: William Mills [mailto:[email-masked]]<mailto:[mailto:[email-masked]]>
Sent: Thursday, March 29, 2012 4:26 PM
To: Eran Hammer; Derek Atkins; [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>
Subject: Re: [OAUTH-WG] OAUTH Report for IETF-83

On the SWD stuff there was general discussion about "is this the right place?", and there "were issues raised".  The question was also asked "well, where is the right place?" which got crickets.  It is exactly coming back to the list for discussion to sort out the right place.

________________________________
From: Eran Hammer <[email-masked]<mailto:[email-masked]>>
To: Derek Atkins <[email-masked]<mailto:[email-masked]>>; "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>; "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Sent: Thursday, March 29, 2012 8:44 AM
Subject: Re: [OAUTH-WG] OAUTH Report for IETF-83

Hi Derek,

Thanks for the notes. Is an audio recording available?

> -----Original Message-----
> From: [email-masked]<mailto:[email-masked]> [mailto:[email-masked]<mailto:[email-masked]>] On Behalf
> Of Derek Atkins
> Sent: Thursday, March 29, 2012 8:27 AM
> To: [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>
> Hi,
> OAUTH met earlier this afternoon in Afternoon Session I at 13h00 for a two
> hour session.  After introducing ourselves and welcoming me to the working
> group we thanked Barry and Blaine for their service.
>
> Torsten spoke about draft-ietf-oauth-v2-threatmodel.  This document has
> completed WG Last Call.  Torsten has applied changes based on the Last Call
> Comments and has published a new revision.  Barry promised to finish his
> PROTO Shepard review next week so we can send this document to the
> IESG.  He promises to take Mike Thomas' issues from the list into account and
> make sure that everyone is happy.
>
> [ I'd like to extend a personal thank you to Barry for continuing his role
>  as document shephard for this draft.  -- derek ]
>
> Next, Mike Jones spoke about the Assertions, SAML2 Bearer, and URN-Sub-
> NS drafts.  Except for one outstanding issue Mike believes these documents
> are ready for WGLC.  Consensus in the room was to take these three docs to
> WGLC, which the chairs will do by the end of next week.
>
> The MAC Token draft has languished while time was spent working on the
> core document.  Eran was not here, nor was he online, to talk about the
> status of the MAC Token draft.  There were only a few people in the room
> interested in reviewing the draft, which was not a clear consensus of
> interest, even though this document does solve a problem that the bearer
> tokens cannot.  The chairs will take it to the list to evaluate if there is enough
> interest to continue with this document.

As I've updated the list and chairs on multiple occasions, the draft is practically ready. There was some late arriving feedback which I did not get around to process. However, the main issue is lack of WG interest in this work. I am still planning to finish it by making very minor tweaks to the current draft, but would be very happy to make it an individual submission.

The MAC draft has largely been my personal project to date.

> In a related note, this document (as well as the v2-bearer document) is not
> available off the tools page even though it has not expired.  I have taken the
> action item to get that sorted out.
>
> Finally, we spent the majority of our time talking about rechartering based on
> the proposed charter sent to the list by Hannes a week or two ago.
> Consensus of the room was that there was enough interest to recharter
> based roughly on the proposed charter.  There was also consensus to include
> Simple Web Discovery (in addition to, and separate from, Dynamic Client
> Registration), although we will need to work with the ADs to make sure it
> gets handled in the appropriate WG and Area.
> Moreover, it's important to make sure the appropriate applications area
> participants get involved in the SWD work.

There is something very awkward about discussing SWD both in the context of this working group, and in the context of future OAuth discovery work. The idea of picking a discovery mechanism before the WG had a single discussion about what is included in discovery and what are the use cases and requirement is absurd.

There has not been consensus on the list for including SWD in the WG charter.

The only justification I have heard so far for this WG to be the SWD venue is that it's easy because the author and a few other people interested are already here. That's not a valid reason.

Any further work on SWD also requires the IETF to view it in light of RFC 6415 (host-meta) which is a proposed standard approved in October 2011. The IETF is not in the 'flavor of the month' business. Proper process requires discussion about the merits of redoing the host-meta work from scratch in a non-compatible way just because a handful of people 'like it better' with little technical justification.

Either way, this discussion does not belong here.

EH

_______________________________________________
OAuth mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/oauth