Subject: [OAUTH-WG] MAC Token draft

From: Eran Hammer <[email-masked]>
Date: Wed, 16 May 2012 01:41:38 +0000

I am stepping down from my role as editor of the MAC token specification. I do not intend to participate in this work moving forward. I will forward my notes to the next editor if requested.

EH

---

From: William Mills <[email-masked]>
Date: Wed, 16 May 2012 08:51:29 -0700 (PDT)

I think there is a need for a signed token style OAuth 2 scheme, and MAC fills this niche, although holder-of-key (as yet un-drafted) would also do this nicely.  Is MAC going to get picked up and driven to completion?  

Do others feel this token style (and security properties) are needed?  Or am I alone in this?

-bill

>________________________________
> From: Eran Hammer <[email-masked]>
>To: "[email-masked] WG ([email-masked])" <[email-masked]> 
>Sent: Tuesday, May 15, 2012 6:41 PM
>Subject: [OAUTH-WG] MAC Token draft
> 
>
> 
>_______________________________________________
>OAuth mailing list
>[email-masked]
>https://www.ietf.org/mailman/listinfo/oauth
>
>
>

---

From: Justin Richer <[email-masked]>
Date: Wed, 16 May 2012 11:58:10 -0400

I also think it's worthwhile. OAuth2 doesn't provide a way to do a 
signed-http-request in the way that OAuth1 does. I would definitely like 
to see this draft make its way to completion, but I don't have the 
crypto expertise to pick up editing it myself.

  -- Justin

On 05/16/2012 11:51 AM, William Mills wrote:
> I think there is a need for a signed token style OAuth 2 scheme, and 
> MAC fills this niche, although holder-of-key (as yet un-drafted) would 
> also do this nicely.  Is MAC going to get picked up and driven to 
> completion?
>
>     ------------------------------------------------------------------------
>     *From:* Eran Hammer <[email-masked]>
>     *To:* "[email-masked] WG ([email-masked])" <[email-masked]>
>     *Sent:* Tuesday, May 15, 2012 6:41 PM
>     *Subject:* [OAUTH-WG] MAC Token draft
>
>     I am stepping down from my role as editor of the MAC token
>     specification. I do not intend to participate in this work moving
>     forward. I will forward my notes to the next editor if requested.
>     EH
>
>     [email-masked] <mailto:[email-masked]>