Subject: [OAUTH-WG] FW: New Version Notification for draft-ietf-oauth-use-cases-02.txt

From: "Zeltsan, Zachary (Zachary)" <[email-masked]>
Date: Wed, 10 Oct 2012 16:29:46 +0000

On behalf of the co-authors I have posted the draft.

The main changes in the -02 version are the following:

·         Removal of the use case on re-delegation. (The case is too far from the present OAuth 2.0)

·         Clarification of the use case Device

·         Addition of a note for each use case that indicates whether the use case supported by OAuth 2.0

·         Update of the references

·         Inclusion of the references to the WG security documents in the Security Consideration section

Your comments are welcomed.

Particularly, the authors are looking for advice with the use of the example URLs. Following the guidance of RFC 2606,

we have used “example” as the top level domain name (e.g., example.com). This may mislead readers into thinking that all URLs belong to the same organization. A general note, stating that all sites ending with “example.com” do not necessarily belong to the same organization, is not sufficient (according to some readers). How to avoid the confusion?

Zachary

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]
Sent: Wednesday, October 10, 2012 11:46 AM
To: Zeltsan, Zachary (Zachary)
Cc: [email-masked]; [email-masked]
Subject: New Version Notification for draft-ietf-oauth-use-cases-02.txt

A new version of I-D, draft-ietf-oauth-use-cases-02.txt

has been successfully submitted by Zachary Zeltsan and posted to the

IETF repository.

Filename:        draft-ietf-oauth-use-cases

Revision:          02

Title:               OAuth Use Cases

Creation date: 2012-10-10

WG ID:             oauth

Number of pages: 24

URL:             http://www.ietf.org/internet-drafts/draft-ietf-oauth-use-cases-02.txt

Status:          http://datatracker.ietf.org/doc/draft-ietf-oauth-use-cases

Htmlized:        http://tools.ietf.org/html/draft-ietf-oauth-use-cases-02

Diff:            http://www.ietf.org/rfcdiff?url2=draft-ietf-oauth-use-cases-02

Abstract:

   This document lists the OAuth use cases.  The provided list is based

   on the Internet Drafts of the OAUTH working group and discussions on

   the group's mailing list.

The IETF Secretariat

---

From: Mike Jones <[email-masked]>
Date: Wed, 10 Oct 2012 16:36:34 +0000

You can use example.com, example.org, and example.net, if you think that would help.  We do that in the OpenID Connect specifications.

                                                            -- Mike

From: [email-masked] [mailto:[email-masked]] On Behalf Of Zeltsan, Zachary (Zachary)
Sent: Wednesday, October 10, 2012 9:30 AM
To: [email-masked] WG'
Subject: [OAUTH-WG] FW: New Version Notification for draft-ietf-oauth-use-cases-02.txt

Zachary

-----Original Message-----
From: [email-masked]<mailto:[email-masked]> [mailto:[email-masked]]<mailto:[mailto:[email-masked]]>
Sent: Wednesday, October 10, 2012 11:46 AM
To: Zeltsan, Zachary (Zachary)
Cc: [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>
Subject: New Version Notification for draft-ietf-oauth-use-cases-02.txt

IETF repository.

Revision:          02

Title:               OAuth Use Cases

WG ID:             oauth

Number of pages: 24

Abstract:

The IETF Secretariat

---

From: Barry Leiba <[email-masked]>
Date: Wed, 10 Oct 2012 12:46:00 -0400

> Particularly, the authors are looking for advice with the use of the example
> URLs. Following the guidance of RFC 2606,
>
> we have used “example” as the top level domain name (e.g., example.com).
> This may mislead readers into thinking that all URLs belong to the same
> organization. A general note, stating that all sites ending with
> “example.com” do not necessarily belong to the same organization, is not
> sufficient (according to some readers). How to avoid the confusion?

You're not using it as the top level domain name.  You're using it as
the second level domain name.  See below.

As Mike says, you can use .net and .org as well as .com.  You can also
use "example" truly as the top level domain (TLD).  You can use
"company1.example" and "company2.example" and
"big-university.example", and so on.

Barry

---

From: "Zeltsan, Zachary (Zachary)" <[email-masked]>
Date: Wed, 10 Oct 2012 16:56:56 +0000

Thank you, Barry and Mike:

I will make changes for the next version.

Zachary

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Barry Leiba
Sent: Wednesday, October 10, 2012 12:46 PM
To: Zeltsan, Zachary (Zachary)
Cc: [email-masked] WG
Subject: Re: [OAUTH-WG] FW: New Version Notification for draft-ietf-oauth-use-cases-02.txt

> we have used "example" as the top level domain name (e.g., example.com).
> "example.com" do not necessarily belong to the same organization, is not

Barry