Subject: [OAUTH-WG] Agenda for Atlanta Meeting

From: Hannes Tschofenig <[email-masked]>
Date: Fri, 5 Oct 2012 11:03:41 +0300

Hi all, 

here is an agenda proposal for the Atlanta IETF meeting: 
(The indicated names are proposals.)

------
Agenda:

1. Status Update, Agenda Bashing (Chairs)
2. Token Revocation (Thorsten)
3. Assertions (Brian + Mike)
4. OAuth Use Cases (Zachary)
5. JWT (Mike)
6. Security (Phil) 
7. Dynamic Client Registration (Thomas)
8. Roadmap
------

In the last item we would like to discuss the bigger picture of how to get OAuth 2.0 deployment improved. There are at least 2 parts to this, namely (a) what other specifications do we need to work on, and (b) how do we improve interoperability. 

Let us know whether you think that this fits your needs. 

Ciao
Hannes & Derek

PS: I am hoping to see daft updates of the WG items soon.

---

From: Torsten Lodderstedt <[email-masked]>
Date: Sat, 06 Oct 2012 19:07:25 +0200

fine for me

Am 05.10.2012 10:03, schrieb Hannes Tschofenig:
> _______________________________________________
> OAuth mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/oauth

---

From: Phil Hunt <[email-masked]>
Date: Sat, 6 Oct 2012 11:53:30 -0700

+1

Phil

---

From: "Zeltsan, Zachary (Zachary)" <[email-masked]>
Date: Sun, 7 Oct 2012 16:08:48 +0000

+1

Zachary

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Phil Hunt
Sent: Saturday, October 06, 2012 2:54 PM
To: Torsten Lodderstedt
Cc: [email-masked] WG
Subject: Re: [OAUTH-WG] Agenda for Atlanta Meeting

+1

Phil

---

From: "Richer, Justin P." <[email-masked]>
Date: Tue, 9 Oct 2012 19:54:50 +0000

Good for me, AS LONG AS we make absolutely SURE that we leave plenty of time for #8 on the agenda, to the point of cutting off and tabling other discussions ahead of time. There are a lot of ancillary documents in various states of use/neglect that shouldn't be left aside by the WG, and this is a good venue for all of that.

 -- Justin

---

From: Torsten Lodderstedt <[email-masked]>
Date: Wed, 10 Oct 2012 07:09:47 +0200

+1

"Richer, Justin P." <[email-masked]> schrieb:

>Good for me, AS LONG AS we make absolutely SURE that we leave plenty of
>time for #8 on the agenda, to the point of cutting off and tabling
>other discussions ahead of time. There are a lot of ancillary documents
>in various states of use/neglect that shouldn't be left aside by the
>WG, and this is a good venue for all of that.
>
> -- Justin
>
>>>> In the last item we would like to discuss the bigger picture of how
>to get OAuth 2.0 deployment improved. There are at least 2 parts to
>this, namely (a) what other specifications do we need to work on, and
>(b) how do we improve interoperability.
>>>>

---

From: Hannes Tschofenig <[email-masked]>
Date: Wed, 10 Oct 2012 11:52:56 +0300

Hi Justin, Hi Torsten,

We will take care of appropriate time management and agenda topics that 
have not seen enough presentation on the list will be postponed.

In fact, I am concerned about the progress with the use cases document 
and the dynamic client registration work. I have notified the authors of 
my concerns privately already.

Ciao
Hannes

On 10/10/2012 08:09 AM, Torsten Lodderstedt wrote:
>                 In the last item we would like to discuss the bigger
>                 picture of how to get OAuth 2.0 deployment improved.
>                 There are at least 2 parts to this, namely (a) what
>                 other specifications do we need to work on, and (b) how
>                 do we improve interoperability.
>
>                 ------------------------------------------------------------------------
>
>                 OAuth mailing list
>                 [email-masked]
>             ------------------------------------------------------------------------
>
>             OAuth mailing list
>             [email-masked]
>         ------------------------------------------------------------------------
>
>         OAuth mailing list
>         [email-masked]
>         ------------------------------------------------------------------------
>
>         OAuth mailing list
>         [email-masked]

---

From: "Richer, Justin P." <[email-masked]>
Date: Fri, 19 Oct 2012 19:10:34 +0000

On those lines, I've been asked to sign up as co-editor for the dynamic client registration document, and I'd be OK with that. There are a lot of little side documents that I'd like to see finalized (XML encoding, instance, UX, dynamic reg, chained auth, MAC). We can discuss details at either IIW or IETF -- but it's something that I'd definitely like to help see through how I can.

 -- Justin

On Oct 10, 2012, at 4:52 AM, Hannes Tschofenig wrote:

> Hi Justin, Hi Torsten,
> 
> We will take care of appropriate time management and agenda topics that have not seen enough presentation on the list will be postponed.
> 
> In fact, I am concerned about the progress with the use cases document and the dynamic client registration work. I have notified the authors of my concerns privately already.
> 
> Ciao
> Hannes
>

---

From: Phil Hunt <[email-masked]>
Date: Fri, 19 Oct 2012 12:43:09 -0700

I will be at iiw on tues/wed. 

Phil

---

From: Mike Jones <[email-masked]>
Date: Wed, 24 Oct 2012 20:09:05 +0000

One thing I'd like us to explicitly consider is to take JWT and the JWT Assertion Profile to working group last call.  That would make particular sense if the JOSE WG also takes the JOSE specs to WGLC at the same time, which I'm asking them to consider doing in Atlanta.

				Best wishes,
				-- Mike

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Hannes Tschofenig
Sent: Friday, October 05, 2012 1:04 AM
To: [email-masked] WG
Subject: [OAUTH-WG] Agenda for Atlanta Meeting

Hi all, 

------
Agenda:

1. Status Update, Agenda Bashing (Chairs) 2. Token Revocation (Thorsten) 3. Assertions (Brian + Mike) 4. OAuth Use Cases (Zachary) 5. JWT (Mike) 6. Security (Phil) 7. Dynamic Client Registration (Thomas) 8. Roadmap
------

Ciao
Hannes & Derek