Subject: [OAUTH-WG] Additional informative references for Assertions draft

From: Mike Jones <[email-masked]>
Date: Wed, 19 Dec 2012 21:33:32 +0000

I'd suggest adding informative references to the OAuth SAML and JWT Profile documents in the Assertions draft.  After this sentence of the Introduction:

In order to be implementable, companion specifications are necessary to provide the corresponding concrete instantiations.

I'd add the following:

For instance, the SAML 2.0 Bearer Assertion Profiles for OAuth 2.0 [draft-ietf-oauth-saml2-bearer] defines a concrete instantiation for SAML 2.0 tokens and JSON Web Token (JWT) Bearer Token Profiles for OAuth 2.0 [draft-ietf-oauth-jwt-bearer] defines a concrete instantiation for JWT tokens.

Doing that will help readers find the concrete instances from the abstract specification.

                                                            Thanks,
                                                            -- Mike

---

From: Justin Richer <[email-masked]>
Date: Wed, 19 Dec 2012 16:42:27 -0500

+1, cross references are a good thing when documents are split up.

On 12/19/2012 04:33 PM, Mike Jones wrote:
>
> I'd suggest adding informative references to the OAuth SAML and JWT 
> Profile documents in the Assertions draft.  After this sentence of the 
> Introduction:
>
> In order to be implementable, companion specifications are necessary 
> to provide the corresponding concrete instantiations.
>
> I'd add the following:
>
> For instance, the SAML 2.0 Bearer Assertion Profiles for OAuth 2.0 
> [draft-ietf-oauth-saml2-bearer] defines a concrete instantiation for 
> SAML 2.0 tokens and JSON Web Token (JWT) Bearer Token Profiles for 
> OAuth 2.0 [draft-ietf-oauth-jwt-bearer] defines a concrete 
> instantiation for JWT tokens.
>
> _______________________________________________
> OAuth mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/oauth

---

From: Mike Jones <[email-masked]>
Date: Wed, 19 Dec 2012 22:06:54 +0000

BTW, the SAML purists would probably point out that I should have written "SAML 2.0 assertions" - not "SAML 2.0 tokens" below. :)

From: Justin Richer [mailto:[email-masked]]
Sent: Wednesday, December 19, 2012 1:42 PM
To: Mike Jones
Cc: [email-masked] WG
Subject: Re: [OAUTH-WG] Additional informative references for Assertions draft

I'd add the following:

                                                            Thanks,
                                                            -- Mike

OAuth mailing list

[email-masked]<mailto:[email-masked]>

---

From: Brian Campbell <[email-masked]>
Date: Wed, 19 Dec 2012 16:01:04 -0700

+1 for the references

On Wed, Dec 19, 2012 at 3:06 PM, Mike Jones <[email-masked]> wrote:
> BTW, the SAML purists would probably point out that I should have written
> “SAML 2.0 assertions” – not “SAML 2.0 tokens” below. J
>
>
>
> I’d suggest adding informative references to the OAuth SAML and JWT Profile
> documents in the Assertions draft.  After this sentence of the Introduction:
>
>
>
> In order to be implementable, companion specifications are necessary to
> provide the corresponding concrete instantiations.
>
>
>
> I’d add the following:
>
>
>
> [draft-ietf-oauth-saml2-bearer] defines a concrete instantiation for SAML
> 2.0 tokens and JSON Web Token (JWT) Bearer Token Profiles for OAuth 2.0
> [draft-ietf-oauth-jwt-bearer] defines a concrete instantiation for JWT
> tokens.
>
>
>