Subject: [OAUTH-WG] Question on diff between draft31 and RFC6749

From: nov matake <[email-masked]>
Date: Mon, 7 Jan 2013 20:53:59 +0900

Hi all,

I couldn't understand why "their" became "the third party's" in the diff between draft31 and RFC6749 below.

===
Resource owners cannot revoke access to an individual third-party third party
without revoking access to all third-parties, third parties, and must do so by
changing their the third party's password.

(from http://tools.ietf.org/rfcdiff?difftype=--hwdiff&url2=rfc6749)
===

I read "their" as "resource owners'".
Is this typo, or am I missing some point?

Thanks

nov

---

From: Justin Richer <[email-masked]>
Date: Mon, 7 Jan 2013 10:00:38 -0500

I believe you're correct, Nov, and that this was potentially a mistake 
from the RFC editor. That sentence *should* be talking about the 
resource owner's password.

  -- Justin

On 01/07/2013 06:53 AM, nov matake wrote:
> Resource owners cannot revoke access to an individual third-party 
> *third party*
> without revoking access to all third-parties, *third parties,* and 
> must do so by
> changing their *the third party's* password.
>
> _______________________________________________
> OAuth mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/oauth

---

From: nov matake <[email-masked]>
Date: Tue, 8 Jan 2013 10:31:09 +0900

Thanks Justin,
I reported this errata at RFC errata report page.

On 2013/01/08, at 0:00, Justin Richer <[email-masked]> wrote:

> I believe you're correct, Nov, and that this was potentially a mistake from the RFC editor. That sentence *should* be talking about the resource owner's password. 
> 
>  -- Justin
>