Subject: [OAUTH-WG] Principal -> Subject in Assertions spec?

From: Mike Jones <[email-masked]>
Date: Wed, 16 Jan 2013 19:51:57 +0000

In writing the proposed interoperability text for the Assertions specification, I noticed that the Assertions spec uses the term "Principal" to refer to the subject of the assertion, whereas both the SAML and JWT profiles use the term "Subject" for this same concept.  I propose that at the same time we add the Interoperability statement, we also change the uses of the term "Principal" to "Subject" in the assertions spec so that it's terminology usage is more consistent with the two profile specs using it.

Thoughts?

                                                                -- Mike

---

From: "Richer, Justin P." <[email-masked]>
Date: Wed, 16 Jan 2013 20:07:18 +0000

+1, it's a non-normative terminology change that aligns it with related efforts. It should be a simple text replace operation.

 -- Justin

________________________________
From: [email-masked] [[email-masked]] on behalf of Mike Jones [[email-masked]]
Sent: Wednesday, January 16, 2013 2:51 PM
To: [email-masked]
Subject: [OAUTH-WG] Principal -> Subject in Assertions spec?

In writing the proposed interoperability text for the Assertions specification, I noticed that the Assertions spec uses the term “Principal” to refer to the subject of the assertion, whereas both the SAML and JWT profiles use the term “Subject” for this same concept.  I propose that at the same time we add the Interoperability statement, we also change the uses of the term “Principal” to “Subject” in the assertions spec so that it’s terminology usage is more consistent with the two profile specs using it.

Thoughts?

                                                                -- Mike

---

From: Torsten Lodderstedt <[email-masked]>
Date: Wed, 16 Jan 2013 22:40:08 +0100

+1 makes sense

Am 16.01.2013 um 21:07 schrieb "Richer, Justin P." <[email-masked]>:

> _______________________________________________
> OAuth mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/oauth