Subject: [OAUTH-WG] Additional Oauth Dynamic Client Registration Protocol Information

From: "Donald F Coffin" <[email-masked]>
Date: Wed, 20 Feb 2013 11:29:40 -0800

Justin,

I understand the current Client Registration request and response
information is based on the OPENID model for consistency, but has there been
any thought or discussion of adding the AS OAuth 2.0 endpoint URIs as part
of the registration response?  I believe the addition of the endpoint URIs
would make the dynamic client registration process truly a dynamic feature
of OAuth 2.0.

If the ability to discover the AS OAuth 2.0 endpoint URIs is being covered
by another IETF draft, I'd appreciate learning which current draft is being
worked on to achieve that result.

Best regards,

Don

Donald F. Coffin

Founder/CTO

REMI Networks

22751 El Prado Suite 6216

Rancho Santa Margarita, CA  92688-3836

Phone:      (949) 636-8571

Email:       [email-masked]

---

From: Mike Jones <[email-masked]>
Date: Wed, 20 Feb 2013 19:37:48 +0000

Hi Don,

Discovery is a process that happens before Registration, and that's the point at which you would return the AS (and registration!) endpoints to the Client.  The OAuth WG considered doing its own discovery work but ultimately decided to have that happen in the Apps Area WG instead, which is close to completing the WebFinger discovery specification.

If you want to see how OpenID Connect is performing discovery using WebFinger, including discovery of the AS endpoint, have a look at http://openid.net/specs/openid-connect-discovery-1_0.html.

                                                                Best wishes,
                                                                -- Mike

From: [email-masked] [mailto:[email-masked]] On Behalf Of Donald F Coffin
Sent: Wednesday, February 20, 2013 11:30 AM
To: Justin Richer
Cc: [email-masked]
Subject: [OAUTH-WG] Additional Oauth Dynamic Client Registration Protocol Information

Justin,

I understand the current Client Registration request and response information is based on the OPENID model for consistency, but has there been any thought or discussion of adding the AS OAuth 2.0 endpoint URIs as part of the registration response?  I believe the addition of the endpoint URIs would make the dynamic client registration process truly a dynamic feature of OAuth 2.0.

If the ability to discover the AS OAuth 2.0 endpoint URIs is being covered by another IETF draft, I'd appreciate learning which current draft is being worked on to achieve that result.

Best regards,
Don
Donald F. Coffin
Founder/CTO

REMI Networks

Phone:      (949) 636-8571
Email:       [email-masked]<mailto:[email-masked]>

---

From: Justin Richer <[email-masked]>
Date: Wed, 20 Feb 2013 14:50:06 -0500

Additionally, there is an individual draft that registers LRDD Link 
Types for discovery using LRDD and HostMeta:

http://tools.ietf.org/html/draft-wmills-oauth-lrdd-07

  -- Justin

On 02/20/2013 02:37 PM, Mike Jones wrote:
>
> Hi Don,
>
> Discovery is a process that happens before Registration, and that's 
> the point at which you would return the AS (and registration!) 
> endpoints to the Client.  The OAuth WG considered doing its own 
> discovery work but ultimately decided to have that happen in the Apps 
> Area WG instead, which is close to completing the WebFinger discovery 
> specification.
>
> If you want to see how OpenID Connect is performing discovery using 
> WebFinger, including discovery of the AS endpoint, have a look at 
> http://openid.net/specs/openid-connect-discovery-1_0.html.
>
> Best wishes,
>
> -- Mike
>
> *From:[email-masked] [mailto:[email-masked]] *On 
> Behalf Of *Donald F Coffin
> *Sent:* Wednesday, February 20, 2013 11:30 AM
> *To:* Justin Richer
> *Cc:* [email-masked]
> *Subject:* [OAUTH-WG] Additional Oauth Dynamic Client Registration 
> Protocol Information
>
> Justin,
>
> information is based on the OPENID model for consistency, but has 
> there been any thought or discussion of adding the AS OAuth 2.0 
> endpoint URIs as part of the registration response?  I believe the 
> addition of the endpoint URIs would make the dynamic client 
> registration process truly a dynamic feature of OAuth 2.0.
>
> If the ability to discover the AS OAuth 2.0 endpoint URIs is being 
> covered by another IETF draft, I'd appreciate learning which current 
> draft is being worked on to achieve that result.
>
> Best regards,
>
> Don
>
> Donald F. Coffin
>
> Founder/CTO
>
> REMI Networks
>
> <mailto:[email-masked]>
>

---

From: "Donald F Coffin" <[email-masked]>
Date: Wed, 20 Feb 2013 13:06:54 -0800

Mike,

Thanks for the information.

Best regards,

Don

Donald F. Coffin

Founder/CTO

REMI Networks

Phone:      (949) 636-8571

Email:        <mailto:[email-masked]>
[email-masked]

From: Mike Jones [mailto:[email-masked]] 
Sent: Wednesday, February 20, 2013 11:38 AM
To: Donald F Coffin; Justin Richer
Cc: [email-masked]
Subject: RE: [OAUTH-WG] Additional Oauth Dynamic Client Registration
Protocol Information

Hi Don,

Discovery is a process that happens before Registration, and that's the
point at which you would return the AS (and registration!) endpoints to the
Client.  The OAuth WG considered doing its own discovery work but ultimately
decided to have that happen in the Apps Area WG instead, which is close to
completing the WebFinger discovery specification.

                                                                Best wishes,

                                                                -- Mike

From: [email-masked] [mailto:[email-masked]] On Behalf Of
Donald F Coffin
Sent: Wednesday, February 20, 2013 11:30 AM
To: Justin Richer
Cc: [email-masked]
Subject: [OAUTH-WG] Additional Oauth Dynamic Client Registration Protocol
Information

Justin,

Best regards,

Don

Donald F. Coffin

Founder/CTO

REMI Networks

Phone:      (949) 636-8571

---

From: "Donald F Coffin" <[email-masked]>
Date: Wed, 20 Feb 2013 13:07:40 -0800

Justin,

Best regards,

Don

Donald F. Coffin

Founder/CTO

REMI Networks

Phone:      (949) 636-8571

From: Justin Richer [mailto:[email-masked]] 
Sent: Wednesday, February 20, 2013 11:50 AM
To: Mike Jones
Cc: Donald F Coffin; [email-masked]
Subject: Re: [OAUTH-WG] Additional Oauth Dynamic Client Registration
Protocol Information

Additionally, there is an individual draft that registers LRDD Link Types
for discovery using LRDD and HostMeta:

 -- Justin

Hi Don,

                                                                Best wishes,

                                                                -- Mike

Justin,

Best regards,

Don

Donald F. Coffin

Founder/CTO

REMI Networks

Phone:      (949) 636-8571