Subject: [OAUTH-WG] Support for SAML assertion reference formats in OAuth SAML Assertion profile

From: prateek mishra <[email-masked]>
Date: Wed, 13 Mar 2013 16:13:12 -0400

SAML supports a couple of SAML assertion reference formats, wherein 
assertions are passed by reference.

One format is the artifact, which can be carried by a 
<saml:artifact>thisisanartifact<saml:artifact> element

Another possibility is the SAML URI binding which supports references of 
the form (abcde is a SAML id)

GET https:example.com/SamlService?ID=abcde HTTP/1.1

My question is whether there is value in supporting these reference 
formats in the profile in place of a (verbose) SAML assertion..

- prateek

---

From: John Bradley <[email-masked]>
Date: Wed, 13 Mar 2013 16:17:10 -0400

It is a direct connection and not a browser redirect.  I don't think there is much value in supporting something like artifact.

On 2013-03-13, at 4:13 PM, prateek mishra <[email-masked]> wrote:

> SAML supports a couple of SAML assertion reference formats, wherein assertions are passed by reference.
> 
> One format is the artifact, which can be carried by a <saml:artifact>thisisanartifact<saml:artifact> element
> 
> Another possibility is the SAML URI binding which supports references of the form (abcde is a SAML id)
> 
> My question is whether there is value in supporting these reference formats in the profile in place of a (verbose) SAML assertion..
> 
> - prateek
> _______________________________________________
> OAuth mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/oauth

---

From: Brian Campbell <[email-masked]>
Date: Wed, 13 Mar 2013 16:56:31 -0400

I also don't think there's much value to it. Practically relative to the
additional complexity it'd bring along for the ride.

On Wed, Mar 13, 2013 at 4:17 PM, John Bradley <[email-masked]> wrote:

> It is a direct connection and not a browser redirect.  I don't think there
> is much value in supporting something like artifact.
>