Subject: [OAUTH-WG] Additional OAuth Feature Matrix questions intended to clarify extensions used

From: Mike Jones <[email-masked]>
Date: Wed, 13 Mar 2013 19:08:27 +0000

Having looked at the results yesterday, I'd appreciate it if each you that already supplied data about your implementations could also answer these additional questions.  All are intended to give more insight into extensions defined and used.  (In many cases, I recognize that your answers will be "none".)

What additional grant types are defined, and what do they do?
What scope values do you use, and what do they mean?

What additional authorization request parameters are defined, and what do they do?
What additional authorization response parameters are defined, and what do they do?
What additional authorization error parameters are defined, and what do they do?

What additional token request parameters are defined, and what do they do?
What additional token response parameters are defined, and what do they do?
What additional token error parameters are defined, and what do they do?

What additional refresh request parameters are defined, and what do they do?
What additional refresh response parameters are defined, and what do they do?
What additional refresh error parameters are defined, and what do they do?

What additional redirection endpoint parameters are defined, and what do they do?
What additional protocol endpoints are utilized, and what do they do?
What additional means of communicating resource errors are defined, and what do they do?

                                                            Thanks a bunch!
                                                            -- Mike

---

From: Mike Jones <[email-masked]>
Date: Wed, 13 Mar 2013 19:20:55 +0000

And one more question...

What additional response_type values do you define, and what do they do?

From: [email-masked] [mailto:[email-masked]] On Behalf Of Mike Jones
Sent: Wednesday, March 13, 2013 12:08 PM
To: Justin P. Richer; Chuck Mortimore; Todd W Lainhart ([email-masked]); Nov Matake; Bob Gregory ([email-masked]); Donald F Coffin ([email-masked]); Roland Hedberg; Brian Campbell
Cc: [email-masked]
Subject: [OAUTH-WG] Additional OAuth Feature Matrix questions intended to clarify extensions used

                                                            Thanks a bunch!
                                                            -- Mike