Subject: [OAUTH-WG] RFC 6455 Frame to Message Reassembly, Mux

From: Scott Morgan <[email-masked]>
Date: Thu, 7 Mar 2013 23:59:49 -0600

Hi Again,

   Again I am sorry if these comments are in the wrong place (email list).

I have been reading;
http://webtide.intalio.com/2012/10/jetty-9-updated-websocket-api/

I have been wondering how multiple multiple frame messages would share a
connection and get reassembled.   The specification doen't seem to mention
this;
Ie
Fancy multithreaded Client Sends 2 messages over a single socket;
    Frame A, part One of 20,000 leagues under the sea
    Frame B, part One of The Hobbit
    Frame C, part Two of 20,000 leagues under the sea
    Frame D, part Two of the Hobbit yea

How should the frames be identified as belonging to the Hobbit?
I suggest we use the masking key as a id, however I am not sure if it would
be unique enough.

Cheers,
Scott

---

From: Pat Patterson <[email-masked]>
Date: Thu, 7 Mar 2013 22:58:42 -0800

Hi Scott,

You are indeed in the wrong place. This is the OAuth (RFC 6749/50) mailing list. I think you want to be on this one: https://www.ietf.org/mailman/listinfo/hybi

Cheers,

Pat
--
Pat Patterson | Principal Developer Evangelist | 408-849-4681 | http://about.me/patpatterson

On Mar 7, 2013, at 9:59 PM, Scott Morgan wrote:

Hi Again,

I have been reading;

I have been wondering how multiple multiple frame messages would share a connection and get reassembled.   The specification doen't seem to mention this;
Ie

How should the frames be identified as belonging to the Hobbit?
I suggest we use the masking key as a id, however I am not sure if it would be unique enough.

Cheers,
Scott
_______________________________________________
OAuth mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/oauth