Subject: [OAUTH-WG] Fwd: New Version Notification for draft-hunt-oauth-scim-client-reg-00.txt

From: Phil Hunt <[email-masked]>
Date: Fri, 5 Jul 2013 12:17:50 -0700

FYI.  As discussed on the dynamic registration call, I have submitted an initial version of client registration based on a profile of OAuth and the SCIM provisioning API.

The draft attempts to work in parallel to the Dynamic Registration Draft (based on draft 12) and keeps many of the key features. It also defines a "Software" Assertion which allows organizations that publish software that is deployed in many environments (including cloud and enterprise) to work with developers and then have the client software be "recognized" by authorization servers in many different deployment environments.

The draft also defines a SCIM "Client" resource and its schema.

An outstanding issue that will have to be addressed in the SCIM WG is how they want to handle data value localization. So for the Human Readable data which needs to be localized from Dyn Reg, I've followed the same attribute naming format for now (using hashtags after the attribute name).

Phil

@independentid
www.independentid.com
[email-masked]

Begin forwarded message:

> From: [email-masked]
> Subject: New Version Notification for draft-hunt-oauth-scim-client-reg-00.txt
> Date: 5 July, 2013 11:41:34 AM PDT
> To: Phil Hunt <[email-masked]>, Anthony Nadalin <[email-masked]>, Morteza Ansari <[email-masked]>, Tony Nadalin <[email-masked]>
> 
> 
> A new version of I-D, draft-hunt-oauth-scim-client-reg-00.txt
> has been successfully submitted by Phil Hunt and posted to the
> IETF repository.
> 
> Filename:	 draft-hunt-oauth-scim-client-reg
> Revision:	 00
> Title:		 OAuth 2.0 SCIM Client Registration Profile
> Creation date:	 2013-07-05
> Group:		 Individual Submission
> Number of pages: 32
> URL:             http://www.ietf.org/internet-drafts/draft-hunt-oauth-scim-client-reg-00.txt
> Status:          http://datatracker.ietf.org/doc/draft-hunt-oauth-scim-client-reg
> Htmlized:        http://tools.ietf.org/html/draft-hunt-oauth-scim-client-reg-00
> 
> 
> Abstract:
>   This specification defines a SCIM endpoint used to register and
>   provision OAuth 2.0 clients to access a OAuth 2.0 protected service
>   API in a just-in-time fashion.  This draft profiles how a OAuth 2.0
>   client may use SCIM and OAuth 2.0 to manage its registration.
> 
> 
> 
> 
> The IETF Secretariat
>

---

From: "Richer, Justin P." <[email-masked]>
Date: Fri, 5 Jul 2013 21:20:24 +0000

Phil, thanks very much for writing this up and submitting it. As we had said on the design team call, I think it will make a lot of sense to keep both this draft and the existing dyn-reg in parallel as much as possible, and to abstract out elements with general applicability (like the software assertions / software ids components).

I look forward to moving ahead with both documents (or more, if we do abstract some pieces).

 -- Justin

On Jul 5, 2013, at 3:17 PM, Phil Hunt <[email-masked]<mailto:[email-masked]>> wrote:

Phil

@independentid
www.independentid.com<http://www.independentid.com/>
[email-masked]<mailto:[email-masked]>

Begin forwarded message:

From: [email-masked]<mailto:[email-masked]>
Subject: New Version Notification for draft-hunt-oauth-scim-client-reg-00.txt
Date: 5 July, 2013 11:41:34 AM PDT
To: Phil Hunt <[email-masked]<mailto:[email-masked]>>, Anthony Nadalin <[email-masked]<mailto:[email-masked]>>, Morteza Ansari <[email-masked]<mailto:[email-masked]>>, Tony Nadalin <[email-masked]<mailto:[email-masked]>>

Abstract:

The IETF Secretariat

_______________________________________________
OAuth mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/oauth