Subject: [OAUTH-WG] Dynamic Client Registration Requirements

From: Anthony Nadalin <[email-masked]>
Date: Tue, 20 Aug 2013 17:01:42 +0000

Here are some of our requirements for Dynamic Client Registration as we work through the various proposals:

1. Stateless server
2. Code flow support
3. Implicit flow support
4. Multi-tenant  support (single endpoint, multiple services)
5. internationalization
6. simple provisioning schema with schema extensibility 
7. self-assertion

---

From: "Tschofenig, Hannes (NSN - FI/Espoo)" <[email-masked]>
Date: Wed, 21 Aug 2013 16:28:10 +0000

Hi Tony, 

> 4. Multi-tenant  support (single endpoint, multiple services)

What does multiple services mean here in the context of dynamic client registration? 

> 5. Internationalization

Where do you see internationalization play a role here? 

> 6. simple provisioning schema with schema extensibility

I guess all of the schemas we use are extensible. Is there something in particular you worry about? 

> 7. self-assertion

I guess this refers to the ability of the client to upload configuration that has not been verified by anyone, i.e., the client asserts this information by itself. Right? 

Ciao
Hannes

---

From: Anthony Nadalin <[email-masked]>
Date: Wed, 21 Aug 2013 16:51:41 +0000

4. So when registration takes place it may be at a single endpoint, but that endpoint has to have enough info to figure out which virtual registration point it need to deal with, much like what we had to do in SCIM to support multi-tenants
5. any info sent to the registration endpoint need a way to figure out internationalization 
6. What has been proposed does not take into account the data model difference that you can have with schema, having the ability to replace schema/add elements is not schema extensibility, come over to the SCIM discussions 
7. It is verified by the person asserting it, so yes you have the concept.

-----Original Message-----
From: Tschofenig, Hannes (NSN - FI/Espoo) [mailto:[email-masked]] 
Sent: Wednesday, August 21, 2013 9:28 AM
To: Anthony Nadalin; oauth mailing list
Subject: RE: Dynamic Client Registration Requirements

Hi Tony, 

Ciao
Hannes