Subject: [OAUTH-WG] Dynamic Registration Plan: Your Feedback Needed!

From: Hannes Tschofenig <[email-masked]>
Date: Wed, 29 Jan 2014 04:04:52 +0000

Hi all,

as you have seen from the meeting minutes of our recent status chat it
is time to proceed with the dynamic client registration work.

The earlier version of the dynamic client registration document was
split into three parts, namely
  (1) the current working group draft containing only minimal
functionality,
  (2) a document describing meta-data, and
  (3) a document containing management functionality.

This change was made as outcome of the discussions we had more or less
over the last 9 months.

The latter two documents are individual submissions at this point. New
content is not available with the recent changes. So, it is one of those
document management issues.

I had a chat with Stephen about WG adoption of the two individual
submissions as WG items. It was OK for him given that it is a purely
document management action. However, before we turn the documents into
WG items we need your feedback on a number of issues:

1) Do you have concerns with the document split? Do you object or
approve it?
2) Is the separation of the functionality into these three documents
correct? Should the line be drawn differently?
3) Do you have comments on the documents overall?

We would like to receive high-level feedback within a week. We are also
eager to hear from implementers and other projects using the dynamic
client registration work (such as OpenID Connect, UMA, the
BlueButton/GreenButton Initiative, etc.)

For more detailed reviews please wait till we re-do the WGLC (which we
plan to do soon). We have to restart the WGLC due to discussions last
years and the resulting changes to these documents.

Ciao
Hannes & Derek

PS: Derek and I also think that Phil should become co-auhor of these
documents for his contributions.

---

From: Mike Jones <[email-masked]>
Date: Fri, 31 Jan 2014 01:03:07 +0000

First, I'll repeat what I said on the call that I agree that Phil should be a co-author.  I'll add him when I create the working group versions of the individual submission documents.  Thanks for your work on software assertions and client association, Phil!

As an editor, my preference would be to create working group -00 versions of the current individual submission documents first with no technical changes - just putting them under working group control and adding Phil as an author.  Then we can address any comments received in subsequent -01 versions.

Putting on my OpenID hat, I'll say that the current docs are compatible with OpenID Connect Dynamic Client Registration (http://openid.net/specs/openid-connect-registration-1_0.html), which is expected to be finalized next month.  Of course, there are several other profiles of OAuth Dynamic Client Registration and I won't try to speak for them.  That being said, since there were no technical changes from -14 to -15 - just refactoring - I would expect that their profiles would not have been broken either.

				-- Mike

-----Original Message-----
From: OAuth [mailto:[email-masked]] On Behalf Of Hannes Tschofenig
Sent: Tuesday, January 28, 2014 8:05 PM
To: [email-masked]
Subject: [OAUTH-WG] Dynamic Registration Plan: Your Feedback Needed!

Hi all,

as you have seen from the meeting minutes of our recent status chat it is time to proceed with the dynamic client registration work.

The earlier version of the dynamic client registration document was split into three parts, namely
  (1) the current working group draft containing only minimal functionality,
  (2) a document describing meta-data, and
  (3) a document containing management functionality.

This change was made as outcome of the discussions we had more or less over the last 9 months.

The latter two documents are individual submissions at this point. New content is not available with the recent changes. So, it is one of those document management issues.

I had a chat with Stephen about WG adoption of the two individual submissions as WG items. It was OK for him given that it is a purely document management action. However, before we turn the documents into WG items we need your feedback on a number of issues:

1) Do you have concerns with the document split? Do you object or approve it?
2) Is the separation of the functionality into these three documents correct? Should the line be drawn differently?
3) Do you have comments on the documents overall?

We would like to receive high-level feedback within a week. We are also eager to hear from implementers and other projects using the dynamic client registration work (such as OpenID Connect, UMA, the BlueButton/GreenButton Initiative, etc.)

For more detailed reviews please wait till we re-do the WGLC (which we plan to do soon). We have to restart the WGLC due to discussions last years and the resulting changes to these documents.

Ciao
Hannes & Derek

PS: Derek and I also think that Phil should become co-auhor of these documents for his contributions.

---

From: Eve Maler <[email-masked]>
Date: Thu, 30 Jan 2014 19:33:20 -0800

Hi Hannes-- The UMA Core spec currently points directly to the basic dynamic client reg doc with MAY statements, and is agnostic as to usage of the higher-order functions. (These turn into optional interop feature tests.) So I think it's fair to say that the split has no structural problems from an UMA perspective.

	Eve

On 28 Jan 2014, at 8:04 PM, Hannes Tschofenig <[email-masked]> wrote:

> _______________________________________________
> OAuth mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/oauth

Eve Maler                                  http://www.xmlgrrl.com/blog
+1 425 345 6756                         http://www.twitter.com/xmlgrrl