Subject: [OAUTH-WG] IETF #89 OAuth Meeting Notes

From: Hannes Tschofenig <[email-masked]>
Date: Wed, 05 Mar 2014 14:43:07 +0100

Hi all

here are the notes from the OAuth f2f meeting this week:
http://www.ietf.org/proceedings/89/minutes/minutes-89-oauth

They are rather short! If someone took some more detailed notes please
send us a mail.

Ciao
Hannes & Derek

---

From: [email-masked]
Date: Thu, 06 Mar 2014 08:38:10 +0000

Hi,

regarding dynamic client registration: it has been suggested to merge 
core and meta data, or at least move some elements (such as scopes) to 
the core spec. Would you please add this?

regards,
Torsten.

Am 05.03.2014 13:43, schrieb Hannes Tschofenig:
> Hi al
> _______________________________________________
> OAuth mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/oauth

---

From: Anthony Nadalin <[email-masked]>
Date: Thu, 6 Mar 2014 09:37:09 +0000

I'm not convinced that scope should be in core

-----Original Message-----
From: OAuth [mailto:[email-masked]] On Behalf Of [email-masked]
Sent: Thursday, March 6, 2014 12:38 AM
To: [email-masked]
Subject: Re: [OAUTH-WG] IETF #89 OAuth Meeting Notes

Hi,

regarding dynamic client registration: it has been suggested to merge core and meta data, or at least move some elements (such as scopes) to the core spec. Would you please add this?

regards,
Torsten.

---

From: Brian Campbell <[email-masked]>
Date: Thu, 6 Mar 2014 10:23:06 +0000

While I'm sure we can and will discuss the organization of the documents
for some
time, I wanted to reiterate that I believe the client credential management
part of this needs to be reevaluated (not just reorganized).

On Thu, Mar 6, 2014 at 9:37 AM, Anthony Nadalin <[email-masked]>wrote:

> regarding dynamic client registration: it has been suggested to merge core
> and meta data, or at least move some elements (such as scopes) to the core
> spec. Would you please add this?
>
> regards,
> Torsten.
>

---

From: Mike Jones <[email-masked]>
Date: Thu, 6 Mar 2014 13:18:41 +0000

I also disagree with moving "scope" into the core registration spec.  The metadata values in the core spec are those that are essential to use to achieve registration.  Those in the metadata spec are those that are useful in some applications but not needed by some others.  "scope" is of the second class.

				-- Mike

-----Original Message-----
From: OAuth [mailto:[email-masked]] On Behalf Of [email-masked]
Sent: Thursday, March 6, 2014 12:38 AM
To: [email-masked]
Subject: Re: [OAUTH-WG] IETF #89 OAuth Meeting Notes

Hi,

regards,
Torsten.

---

From: "Richer, Justin P." <[email-masked]>
Date: Thu, 6 Mar 2014 13:20:33 +0000

I would like everything from the metadata spec moved to core with the same optionality that it has in the two documents, in order to facilitate readability and ease of use for developers. I would be fine with having it in listed in two separate subsections.

Also, so it doesn't get lost, we should adopt the "jwks" metadata parameter from OIDC as well, to go alongside of jwks_uri.

 -- Justin

________________________________________
From: OAuth [[email-masked]] on behalf of [email-masked] [[email-masked]]
Sent: Thursday, March 06, 2014 3:38 AM
To: [email-masked]
Subject: Re: [OAUTH-WG] IETF #89 OAuth Meeting Notes

Hi,

regards,
Torsten.

---

From: Phil Hunt <[email-masked]>
Date: Thu, 6 Mar 2014 13:25:06 +0000

If metadata is optional i don't see the issue with it being in core. 

Then again i don't think metadata should be in a separate draft. 

Phil

> On Mar 6, 2014, at 13:18, Mike Jones <[email-masked]> wrote:
>

---

From: Anthony Nadalin <[email-masked]>
Date: Thu, 6 Mar 2014 13:55:20 +0000

+1  should not be merged

-----Original Message-----
From: Mike Jones 
Sent: Thursday, March 6, 2014 5:19 AM
To: Anthony Nadalin; [email-masked]; [email-masked]
Subject: RE: [OAUTH-WG] IETF #89 OAuth Meeting Notes

				-- Mike

-----Original Message-----
From: OAuth [mailto:[email-masked]] On Behalf Of [email-masked]
Sent: Thursday, March 6, 2014 12:38 AM
To: [email-masked]
Subject: Re: [OAUTH-WG] IETF #89 OAuth Meeting Notes

Hi,

regards,
Torsten.

---

From: Phil Hunt <[email-masked]>
Date: Thu, 6 Mar 2014 13:59:36 +0000

I'm getting the impression you don't want the particular meta data that's been specified. Hence why you want the separate spec.

What's the issue?  Maybe we should change the metadata?

I'd rather not see people do similar things that are done different ways. Whatever we do is already breaking for us, so nows the time to change it.

Phil

@independentid
www.independentid.com
[email-masked]