Subject: Re: [OAUTH-WG] Working Group Versions of Refactored OAuth Dynamic Client Registration Specs

From: Anthony Nadalin <[email-masked]>
Date: Thu, 6 Mar 2014 15:01:42 +0000

So the current core makes the registration_access_token  required and there are open registration endpoints, so this should be optional, there are also cases where the client_id is signed and that becomes the right to the registration endpoint

From: OAuth [mailto:[email-masked]] On Behalf Of Mike Jones
Sent: Friday, February 7, 2014 10:58 AM
To: [email-masked] list
Subject: [OAUTH-WG] Working Group Versions of Refactored OAuth Dynamic Client Registration Specs

There are now OAuth working group<http://datatracker.ietf.org/wg/oauth/> versions of the refactored OAuth Dynamic Client Registration specifications:

*         OAuth 2.0 Dynamic Client Registration Core Protocol

*         OAuth 2.0 Dynamic Client Registration Metadata

*         OAuth 2.0 Dynamic Client Registration Management Protocol

These versions address review comments by Phil Hunt and Tony Nadalin.  Phil is now also an author.  The data structures and messages used are the same as the previous versions<http://self-issued.info/?p=1171>.

The drafts are available at:

*         http://tools.ietf.org/html/draft-ietf-oauth-dyn-reg-16

*         http://tools.ietf.org/html/draft-ietf-oauth-dyn-reg-metadata-00

*         http://tools.ietf.org/html/draft-ietf-oauth-dyn-reg-management-00

HTML formatted versions are also available at:

*         https://self-issued.info/docs/draft-ietf-oauth-dyn-reg-16.html

*         https://self-issued.info/docs/draft-ietf-oauth-dyn-reg-metadata-00.html

*         https://self-issued.info/docs/draft-ietf-oauth-dyn-reg-management-00.html

                                                            -- Mike

P.S.  I also posted this notice at http://self-issued.info/?p=1180 and as @selfissued.

---

From: Anthony Nadalin <[email-masked]>
Date: Thu, 6 Mar 2014 16:00:56 +0000

Same is true for the registration_client_uri as I may not need/want this, should be optional

From: OAuth [mailto:[email-masked]] On Behalf Of Anthony Nadalin
Sent: Thursday, March 6, 2014 7:02 AM
To: Mike Jones; [email-masked] list
Subject: Re: [OAUTH-WG] Working Group Versions of Refactored OAuth Dynamic Client Registration Specs

From: OAuth [mailto:[email-masked]] On Behalf Of Mike Jones
Sent: Friday, February 7, 2014 10:58 AM
To: [email-masked]<mailto:[email-masked]> list
Subject: [OAUTH-WG] Working Group Versions of Refactored OAuth Dynamic Client Registration Specs

                                                            -- Mike

---

From: Phil Hunt <[email-masked]>
Date: Thu, 6 Mar 2014 16:25:00 +0000

Where is registration_client_uri  in the spec?

Phil

@independentid
www.independentid.com
[email-masked]

On 2014-03-06, at 4:00 PM, Anthony Nadalin <[email-masked]> wrote:

> There are now OAuth working group versions of the refactored OAuth Dynamic Client Registration specifications:
> ·         OAuth 2.0 Dynamic Client Registration Core Protocol
> ·         OAuth 2.0 Dynamic Client Registration Metadata
> ·         OAuth 2.0 Dynamic Client Registration Management Protocol
>  
> These versions address review comments by Phil Hunt and Tony Nadalin.  Phil is now also an author.  The data structures and messages used are the same as the previous versions.
>  
> ·         http://tools.ietf.org/html/draft-ietf-oauth-dyn-reg-16
> ·         http://tools.ietf.org/html/draft-ietf-oauth-dyn-reg-metadata-00
> ·         http://tools.ietf.org/html/draft-ietf-oauth-dyn-reg-management-00
>  
> ·         https://self-issued.info/docs/draft-ietf-oauth-dyn-reg-16.html
> ·         https://self-issued.info/docs/draft-ietf-oauth-dyn-reg-metadata-00.html
> ·         https://self-issued.info/docs/draft-ietf-oauth-dyn-reg-management-00.html
>  
>                                                             -- Mike
>  
> _______________________________________________
> OAuth mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/oauth

---

From: "Richer, Justin P." <[email-masked]>
Date: Thu, 6 Mar 2014 18:47:04 +0000

Neither registration_access_token nor registration_client_uri are mentioned in core-16. They're both required in the management draft, and it makes sense there. If you're not implementing the management draft (or you've got your own thing for that), then you don't return either of them.

 -- Justin

________________________________
From: OAuth [[email-masked]] on behalf of Anthony Nadalin [[email-masked]]
Sent: Thursday, March 06, 2014 11:00 AM
To: Anthony Nadalin; Mike Jones; [email-masked] list
Subject: Re: [OAUTH-WG] Working Group Versions of Refactored OAuth Dynamic Client Registration Specs

                                                            -- Mike