Subject: [OAUTH-WG] Shepherd Writeup for Dynamic Client Registration Draft

From: Hannes Tschofenig <[email-masked]>
Date: Tue, 08 Jul 2014 14:46:11 +0200

Hi all,

I am working on the shepherd writeup for the dynamic client registration
draft.

You can find the latest draft here:
https://github.com/hannestschofenig/tschofenig-ids/blob/master/shepherd-writeups/Writeup_OAuth_DynamicClientRegistration.txt

As you can see it is still incomplete.

I would need information about the implementation status.

Ciao
Hannes

---

From: Edmund Jay <[email-masked]>
Date: Tue, 15 Jul 2014 11:01:29 -0700

I've implemented registration as part of OpenID Connect.

server - https://connect.openid4.us/abop
client - https://connect.openid4.us/abrp

________________________________
 From: Hannes Tschofenig <[email-masked]>
To: "[email-masked]" <[email-masked]> 
Sent: Tuesday, July 8, 2014 5:46 AM
Subject: [OAUTH-WG] Shepherd Writeup for Dynamic Client Registration Draft

Hi all,

Ciao
Hannes

_______________________________________________
OAuth mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/oauth

---

From: Anthony Nadalin <[email-masked]>
Date: Tue, 15 Jul 2014 19:04:33 +0000

Is your implementation from the OpenID Connect specification of from the IETF specification

From: OAuth [mailto:[email-masked]] On Behalf Of Edmund Jay
Sent: Tuesday, July 15, 2014 11:01 AM
To: Hannes Tschofenig; [email-masked]
Subject: Re: [OAUTH-WG] Shepherd Writeup for Dynamic Client Registration Draft

________________________________
From: Hannes Tschofenig <[email-masked]<mailto:[email-masked]>>
To: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Sent: Tuesday, July 8, 2014 5:46 AM
Subject: [OAUTH-WG] Shepherd Writeup for Dynamic Client Registration Draft

Hi all,

Ciao
Hannes

_______________________________________________
OAuth mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/oauth

---

From: Edmund Jay <[email-masked]>
Date: Tue, 15 Jul 2014 12:15:51 -0700

It is from the OpenID Connect spec, but I believe the OpenID Connect spec is similar enough that it is compliant with the OAuth version.

________________________________
 From: Anthony Nadalin <[email-masked]>
To: Edmund Jay <[email-masked]>; Hannes Tschofenig <[email-masked]>; "[email-masked]" <[email-masked]> 
Sent: Tuesday, July 15, 2014 12:04 PM
Subject: RE: [OAUTH-WG] Shepherd Writeup for Dynamic Client Registration	Draft

From:OAuth [mailto:[email-masked]] On Behalf Of Edmund Jay
Sent: Tuesday, July 15, 2014 11:01 AM
To: Hannes Tschofenig; [email-masked]
Subject: Re: [OAUTH-WG] Shepherd Writeup for Dynamic Client Registration Draft

 
From:Hannes Tschofenig <[email-masked]>
To: "[email-masked]" <[email-masked]> 
Sent: Tuesday, July 8, 2014 5:46 AM
Subject: [OAUTH-WG] Shepherd Writeup for Dynamic Client Registration Draft

Hi all,

Ciao
Hannes

---

From: Justin Richer <[email-masked]>
Date: Tue, 15 Jul 2014 15:17:09 -0400

I've implemented the core dynamic registration draft and the management 
protocol draft (including read, update, and delete), both client side 
and server side, in MITREid Connect:

https://github.com/mitreid-connect/OpenID-Connect-Java-Spring-Server

We've been running this code in production at a number of organizations 
for several years, with dynamic registration being available (and used) 
for well over a year in all instances.

Our implementation includes support for initial access tokens (through a 
server configuration/extension), but it does not include an 
implementation of software statements.

And since it was asked on another thread: our implementation is also 
compliant with the OpenID Connect dynamic registration specification, 
since the two protocols are completely wire compatible by design. We 
have had both OpenID Connect and plain-OAuth clients use it.

We've also implemented the client-side of dynamic registration as part 
of this library:

https://github.com/jumbojett/OpenID-Connect-PHP/

  -- Justin