Subject: [OAUTH-WG] I-D Action: draft-ietf-oauth-introspection-04.txt

From: [email-masked]
Date: Tue, 23 Dec 2014 09:59:20 -0800

A New Internet-Draft is available from the on-line Internet-Drafts directories.
 This draft is a work item of the Web Authorization Protocol Working Group of the IETF.

        Title           : OAuth 2.0 Token Introspection
        Author          : Justin Richer
	Filename        : draft-ietf-oauth-introspection-04.txt
	Pages           : 13
	Date            : 2014-12-23

Abstract:
   This specification defines a method for a protected resource to query
   an OAuth 2.0 authorization server to determine the active state of an
   OAuth 2.0 token and to determine meta-information about this token.
   OAuth 2.0 deployments can use this method to convey information about
   the authorization context of the token from the authorization server
   to the protected resource.

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-ietf-oauth-introspection/

There's also a htmlized version available at:
http://tools.ietf.org/html/draft-ietf-oauth-introspection-04

A diff from the previous version is available at:
http://www.ietf.org/rfcdiff?url2=draft-ietf-oauth-introspection-04

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org.

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

---

From: "Richer, Justin P." <[email-masked]>
Date: Tue, 23 Dec 2014 18:02:31 +0000

This draft makes two changes:

 - Removal of the "resource_id" input parameter, whose purpose has been largely supplanted by requiring authorization to call the introspection endpoint. I also don't know of any implementations that make use of this parameter. If there's later consensus on defining more context on the way in, we can easily have an extension for that.

 - Re-shuffling of the examples out of an appendix and into the sections that they represent; it reads better this way.

 -- Justin

On Dec 23, 2014, at 12:59 PM, <[email-masked]> <[email-masked]> wrote:

> _______________________________________________
> OAuth mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/oauth

---

From: Thomas Broyer <[email-masked]>
Date: Wed, 24 Dec 2014 09:15:31 +0000

Hi,

A couple editorial remarks:

When introducing the first 2 examples, maybe merge the two paragraphs,
starting with "The following non-normative example shows …".

Similarly, you talk about line wraps for display purpose but the examples
don't need/use wrapping.

Other than that, ready to go to the RFC state if you ask me.

Le mar. 23 déc. 2014 19:02, Richer, Justin P. <[email-masked]> a écrit :

>  - Removal of the "resource_id" input parameter, whose purpose has been
> largely supplanted by requiring authorization to call the introspection
> endpoint. I also don't know of any implementations that make use of this
> parameter. If there's later consensus on defining more context on the way
> in, we can easily have an extension for that.
>
>  - Re-shuffling of the examples out of an appendix and into the sections
> that they represent; it reads better this way.
>
>  -- Justin
>

---

From: "Richer, Justin P." <[email-masked]>
Date: Wed, 24 Dec 2014 15:01:13 +0000

Thanks for the review, especially of the new text.

The "Following is a non-normative example" text is, in all cases, actually a preamble attached to the diagram/example section. In the plain text it renders as a separate paragraph, which is why it might look odd there.

I've removed the line wrapping comments in my working draft -- those were left over from previous examples, thanks for catching that. It's a small change that will get rolled up with whatever shepherd/AD comments come in at the next stage.

 -- Justin

On Dec 24, 2014, at 4:15 AM, Thomas Broyer <[email-masked]<mailto:[email-masked]>> wrote:

Hi,

When introducing the first 2 examples, maybe merge the two paragraphs, starting with "The following non-normative example shows …".

Similarly, you talk about line wraps for display purpose but the examples don't need/use wrapping.

Le mar. 23 déc. 2014 19:02, Richer, Justin P. <[email-masked]<mailto:[email-masked]>> a écrit :
This draft makes two changes:

 -- Justin

On Dec 23, 2014, at 12:59 PM, <[email-masked]<mailto:[email-masked]>> <[email-masked]<mailto:[email-masked]>> wrote:

> until the htmlized version and diff are available at tools.ietf.org<http://tools.ietf.org/>.
>
> [email-masked]<mailto:[email-masked]>

_______________________________________________
OAuth mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/oauth