Subject: Re: [OAUTH-WG] Fwd: [kitten] WGLC of draft-ietf-kitten-sasl-oauth-18

From: "Ebling, Sebastian" <[email-masked]>
Date: Fri, 2 Jan 2015 15:01:23 +0000

Hello,

There is a little typo in Section 3.2.2:
Replace "The URL for for a document" with "The URL for a document".

Section 3. contains
"2.  Server responds with a successful authentication.

   In the case where authorization fails the server sends an error
   result, then client MUST then send an additional message to the
   server in order to allow the server to finish the exchange."
There is a switch between authentication and authorization. Even if the access token represents authorization information I suggest to write "In the case where authentication fails" because it is more consistent here.

Section 3.2.2. introduces "oauth-configuration", the example in section 4.3 uses "openid-configuration".

Regards

Sebastian Ebling

Von: OAuth [mailto:[email-masked]] Im Auftrag von Bill Mills
Gesendet: Montag, 29. Dezember 2014 18:46
An: [email-masked]
Betreff: Re: [OAUTH-WG] Fwd: [kitten] WGLC of draft-ietf-kitten-sasl-oauth-18

No other comments on this?  Any "It's ready to go."?

On Monday, December 15, 2014 9:34 AM, Benjamin Kaduk <[email-masked]> wrote:

Hi all,

There may be some interested parties over here; please feel free to chime
in on this WGLC over on the kitten list.

-Ben

---------- Forwarded message ----------
Date: Mon, 15 Dec 2014 12:14:30 -0500
From: Benjamin Kaduk <[email-masked]>
To: [email-masked]
Cc: [email-masked]
Subject: [kitten] WGLC of draft-ietf-kitten-sasl-oauth-18

This message begins the fourth Working Group Last Call (WGLC) of "A set of
SASL Mechanisms for OAuth" <draft-ietf-kitten-sasl-oauth-18.txt>.  Due to
the overlap of the last call period with holidays, the duration of the
WGLC is extended to four weeks, so the WGLC will end on 12 January 2015.
The draft is available at:

https://tools.ietf.org/html/draft-ietf-kitten-sasl-oauth-18

Because the changes between -15 and -18 involve behavior changes,
including changes regarding discovery and dynamic registration, the Chairs
decided to issue an additional last call.

Please review the document and send comments to the Working Group
mailing list < kitten at itef.org > or the co-chairs < kitten-chairs
at tools.ietf.org > before the end of the WGLC.  Any and all comments
on the document are sought in order to access the strength of
consensus.  Even if you have read and commented on this or earlier
versions of the draft, please feel free to comment again.  This is
particularly important if you found issues with the previous version.

As a reminder, comments can be anything from "this looks fine" to
"this is a horrible idea"; they can include suggestions for minor
editorial corrections to significant editorial changes.

- Your Kitten Chairs

_______________________________________________
Kitten mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/kitten

_______________________________________________
OAuth mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/oauth

---

From: Bill Mills <[email-masked]>
Date: Fri, 2 Jan 2015 23:46:38 +0000 (UTC)

3 items fixed, thank you 

     On Friday, January 2, 2015 7:01 AM, "Ebling, Sebastian" <[email-masked]> wrote:

 Hello,

Section 3. contains

Regards

Sebastian Ebling

Hi all,

-Ben

---------- Forwarded message ----------
Date: Mon, 15 Dec 2014 12:14:30 -0500
From: Benjamin Kaduk <[email-masked]>
To: [email-masked]
Cc: [email-masked]
Subject: [kitten] WGLC of draft-ietf-kitten-sasl-oauth-18

- Your Kitten Chairs