Subject: [OAUTH-WG] Authentication Method Reference Values Specification

From: Mike Jones <[email-masked]>
Date: Wed, 22 Jul 2015 17:48:00 +0000

Phil Hunt and I have posted a new draft that defines some values used with the "amr" (Authentication Methods References) claim and establishes a registry for Authentication Method Reference values.  These values include commonly used authentication methods like "pwd" (password) and "otp" (one time password).  It also defines a parameter for requesting that specific authentication methods be used in the authentication.

The specification is available at:

*        https://tools.ietf.org/html/draft-jones-oauth-amr-values-00

An HTML formatted version is also available at:

*        http://self-issued.info/docs/draft-jones-oauth-amr-values-00.html

                                                            -- Mike

P.S.  This note was also posted at http://self-issued.info/?p=1429 and as @selfissued<https://twitter.com/selfissued>.

---

From: Justin Richer <[email-masked]>
Date: Thu, 23 Jul 2015 09:21:55 +0200

Useful work, but shouldn’t this be defined in the OIDF, where the “amr" parameter is defined?

 — Justin

> On Jul 22, 2015, at 7:48 PM, Mike Jones <[email-masked]> wrote:
> 
> Phil Hunt and I have posted a new draft that defines some values used with the “amr” (Authentication Methods References) claim and establishes a registry for Authentication Method Reference values.  These values include commonly used authentication methods like “pwd” (password) and “otp” (one time password).  It also defines a parameter for requesting that specific authentication methods be used in the authentication.
>  
> ·        https://tools.ietf.org/html/draft-jones-oauth-amr-values-00 <https://tools.ietf.org/html/draft-jones-oauth-amr-values-00>
>  
> ·        http://self-issued.info/docs/draft-jones-oauth-amr-values-00.html <http://self-issued.info/docs/draft-jones-oauth-amr-values-00.html>
>  
>                                                             -- Mike
>  
> P.S.  This note was also posted at http://self-issued.info/?p=1429 <http://self-issued.info/?p=1429> and as @selfissued <https://twitter.com/selfissued>.
> _______________________________________________
> OAuth mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/oauth

---

From: John Bradley <[email-masked]>
Date: Thu, 23 Jul 2015 09:30:12 +0200

I don’t personally have a problem with people defining values for AMR and creating a IANA registry. 

That exists for ACR.

I am on record as not supporting clients requesting amr as it ai a bad idea and the spec mentions that at the same time it defines a new request parameter for it.

It is probably not something I will put any real effort into fighting, if people insist on it.  I will continue to recommend only using ACR in the request.

John B.

> On Jul 23, 2015, at 9:21 AM, Justin Richer <[email-masked]> wrote:
> 
>> On Jul 22, 2015, at 7:48 PM, Mike Jones <[email-masked] <mailto:[email-masked]>> wrote:
>> 
>> [email-masked] <mailto:[email-masked]>
>> https://www.ietf.org/mailman/listinfo/oauth <https://www.ietf.org/mailman/listinfo/oauth>
> 
> [email-masked] <mailto:[email-masked]>
> https://www.ietf.org/mailman/listinfo/oauth <https://www.ietf.org/mailman/listinfo/oauth>

---

From: Mike Jones <[email-masked]>
Date: Thu, 23 Jul 2015 07:35:04 +0000

The key part of this is establishing a registry.  That can only be done in an RFC.

John, I encourage you to submit text beefing up the arguments about why using “acr” is preferable.  The text at http://self-issued.info/docs/draft-jones-oauth-amr-values-00.html#acrRelationship is a start at that.

                                                            -- Mike

From: John Bradley [mailto:[email-masked]]
Sent: Thursday, July 23, 2015 9:30 AM
To: Justin Richer
Cc: Mike Jones; <[email-masked]>
Subject: Re: [OAUTH-WG] Authentication Method Reference Values Specification

That exists for ACR.

John B.

On Jul 23, 2015, at 9:21 AM, Justin Richer <[email-masked]<mailto:[email-masked]>> wrote:

 — Justin

On Jul 22, 2015, at 7:48 PM, Mike Jones <[email-masked]<mailto:[email-masked]>> wrote:

The specification is available at:
•        https://tools.ietf.org/html/draft-jones-oauth-amr-values-00

An HTML formatted version is also available at:
•        http://self-issued.info/docs/draft-jones-oauth-amr-values-00.html

                                                            -- Mike

P.S.  This note was also posted at http://self-issued.info/?p=1429 and as @selfissued<https://twitter.com/selfissued>.
_______________________________________________
OAuth mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/oauth

_______________________________________________
OAuth mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/oauth

---

From: Brian Campbell <[email-masked]>
Date: Thu, 23 Jul 2015 10:49:18 +0200

So maybe a naive question but why does this draft define "amr_values" while
also suggesting that it's fragile and that "acr" & "acr_values" is
preferable? Seems contradictory. And I doubt I'm the only one that will
find it confusing.

On Thu, Jul 23, 2015 at 9:35 AM, Mike Jones <[email-masked]>
wrote:

> John, I encourage you to submit text beefing up the arguments about why
> using “acr” is preferable.  The text at
> http://self-issued.info/docs/draft-jones-oauth-amr-values-00.html#acrRelationship
> is a start at that.
>
>
>
>                                                             -- Mike
>
>
>
> *From:* John Bradley [mailto:[email-masked]]
> *Sent:* Thursday, July 23, 2015 9:30 AM
> *To:* Justin Richer
> *Cc:* Mike Jones; <[email-masked]>
> *Subject:* Re: [OAUTH-WG] Authentication Method Reference Values
> Specification
>
>
>
> I am on record as not supporting clients requesting amr as it ai a bad
> idea and the spec mentions that at the same time it defines a new request
> parameter for it.
>
>
>
> It is probably not something I will put any real effort into fighting, if
> people insist on it.  I will continue to recommend only using ACR in the
> request.
>
>
>
> John B.
>
>
>
> Phil Hunt and I have posted a new draft that defines some values used with
> the “amr” (Authentication Methods References) claim and establishes a
> registry for Authentication Method Reference values.  These values include
> commonly used authentication methods like “pwd” (password) and “otp” (one
> time password).  It also defines a parameter for requesting that specific
> authentication methods be used in the authentication.
>
>
>
> ·        https://tools.ietf.org/html/draft-jones-oauth-amr-values-00
>
>
>
> ·        http://self-issued.info/docs/draft-jones-oauth-amr-values-00.html
>
>
>
>                                                             -- Mike
>
>
>
> P.S.  This note was also posted at http://self-issued.info/?p=1429 and as
> @selfissued <https://twitter.com/selfissued>.
>

---

From: Phil Hunt <[email-masked]>
Date: Thu, 23 Jul 2015 11:55:30 +0200

I do tend to agree John that clients shouldn't be able to force the sp on choices. 

My thought was that it was useful to have a registry so we can have standard auth method values for protocols that get written like oidc.  It may be useful elsewhere. 

Anyway as a general rule I think it is sometimes useful for a client to signal a preference or capability in order that the server can make a good choice that meets its own needs. 

Phil

> On Jul 23, 2015, at 09:30, John Bradley <[email-masked]> wrote:
> 
>>> P.S.  This note was also posted at http://self-issued.info/?p=1429 and as @selfissued.

---

From: William Denniss <[email-masked]>
Date: Thu, 23 Jul 2015 12:05:26 +0200

Thanks for drafting this Mike. I'm in favor of having this registry.

In addition to the specific values, I propose we add some generic ones too
(trying to follow your naming scheme):

"rba":  "risk-based auth"
"upt":  "user presence test"

My fear of making things too specific is that RPs may get lost in the weeds
trying to work out what things they should care about and how. As an IdP we
like to guide RPs through these kinds of decisions, and prefer to pass a
more high level indication of what happened (such as these two values).  If
someone wanted to have best of both worlds, then both could be asserted,
e.g. "upt fpt" to indicate that the user presence was tested, using a
fingerprint test.

Regarding the proposed "wia" value. I don't know what it is, and the spec
doesn't help me find out, can a reference be added?  I also wonder if it
could be genericized to avoid being vendor specific values – but mostly I
just want to understand what it is.  Almost all the other values are
self-explanatory, perhaps "pop" could use a reference as well (or maybe
just a longer explanation).

I don't see the immediate value of "amr_values", can you elaborate with
some places where this would be applied?  Separately, I wonder if an
extension to OIDC should be included in this doc, which is otherwise a
fairly clean registry spec that could be used more broadly.

On Thu, Jul 23, 2015 at 10:49 AM, Brian Campbell <[email-masked]

> So maybe a naive question but why does this draft define "amr_values"
> while also suggesting that it's fragile and that "acr" & "acr_values" is
>> Phil Hunt and I have posted a new draft that defines some values used
>> with the “amr” (Authentication Methods References) claim and establishes
>> a registry for Authentication Method Reference values.  These values
>> include commonly used authentication methods like “pwd” (password) and “
>> otp” (one time password).  It also defines a parameter for requesting
>> that specific authentication methods be used in the authentication.
>>
>>
>>
>> ·
>> http://self-issued.info/docs/draft-jones-oauth-amr-values-00.html
>>
>>
>>
>>                                                             -- Mike
>>
>>
>>

---

From: Nat Sakimura <[email-masked]>
Date: Thu, 23 Jul 2015 18:22:06 +0200

So, allow me a naive question.
I supppose there are good random otp, as well as pretty bad otp etc.
Would it be useful to say just "otp". Would it not be better to have at
least a field that references a spec that specifies the security
requirement for that mechanism?

2015-07-23 12:05 GMT+02:00 William Denniss <[email-masked]>:

> My fear of making things too specific is that RPs may get lost in the
> weeds trying to work out what things they should care about and how. As an
> IdP we like to guide RPs through these kinds of decisions, and prefer to
> pass a more high level indication of what happened (such as these two
> values).  If someone wanted to have best of both worlds, then both could be
> asserted, e.g. "upt fpt" to indicate that the user presence was tested,
> using a fingerprint test.
>
> On Thu, Jul 23, 2015 at 10:49 AM, Brian Campbell <
> [email-masked]> wrote:
>
>>> It is probably not something I will put any real effort into fighting,
>>> if people insist on it.  I will continue to recommend only using ACR in the
>>> request.
>>>
>>>
>>>
>>> John B.
>>>
>>>
>>>
>>> with the “amr” (Authentication Methods References) claim and
>>> establishes a registry for Authentication Method Reference values.  These
>>> values include commonly used authentication methods like “pwd”
>>> (password) and “otp” (one time password).  It also defines a parameter
>>> for requesting that specific authentication methods be used in the
>>> authentication.
>>>
>>>
>>>
>>> P.S.  This note was also posted at http://self-issued.info/?p=1429 and
>>> as @selfissued <https://twitter.com/selfissued>.
>>>

-- 
Nat Sakimura (=nat)
Chairman, OpenID Foundation
http://nat.sakimura.org/
@_nat_en

---

From: Mike Jones <[email-masked]>
Date: Thu, 23 Jul 2015 16:29:26 +0000

I agree that an obvious good thing to do is to add spec references to the field definitions.

I need to investigate use cases for amr_values.  I think this came from developers who actually wanted this for a particular purpose but I’ll have to get back to the WG on that.  It’s defined here, rather than in another spec, because it’s highly related to the “amr” values.

                                                            -- Mike

From: OAuth [mailto:[email-masked]] On Behalf Of Nat Sakimura
Sent: Thursday, July 23, 2015 6:22 PM
To: William Denniss
Cc: <[email-masked]>
Subject: Re: [OAUTH-WG] Authentication Method Reference Values Specification

So, allow me a naive question.
I supppose there are good random otp, as well as pretty bad otp etc.
Would it be useful to say just "otp". Would it not be better to have at least a field that references a spec that specifies the security requirement for that mechanism?

2015-07-23 12:05 GMT+02:00 William Denniss <[email-masked]<mailto:[email-masked]>>:
Thanks for drafting this Mike. I'm in favor of having this registry.

In addition to the specific values, I propose we add some generic ones too (trying to follow your naming scheme):

"rba":  "risk-based auth"

My fear of making things too specific is that RPs may get lost in the weeds trying to work out what things they should care about and how. As an IdP we like to guide RPs through these kinds of decisions, and prefer to pass a more high level indication of what happened (such as these two values).  If someone wanted to have best of both worlds, then both could be asserted, e.g. "upt fpt" to indicate that the user presence was tested, using a fingerprint test.

Regarding the proposed "wia" value. I don't know what it is, and the spec doesn't help me find out, can a reference be added?  I also wonder if it could be genericized to avoid being vendor specific values – but mostly I just want to understand what it is.  Almost all the other values are self-explanatory, perhaps "pop" could use a reference as well (or maybe just a longer explanation).

I don't see the immediate value of "amr_values", can you elaborate with some places where this would be applied?  Separately, I wonder if an extension to OIDC should be included in this doc, which is otherwise a fairly clean registry spec that could be used more broadly.

On Thu, Jul 23, 2015 at 10:49 AM, Brian Campbell <[email-masked]<mailto:[email-masked]>> wrote:
So maybe a naive question but why does this draft define "amr_values" while also suggesting that it's fragile and that "acr" & "acr_values" is preferable? Seems contradictory. And I doubt I'm the only one that will find it confusing.

On Thu, Jul 23, 2015 at 9:35 AM, Mike Jones <[email-masked]<mailto:[email-masked]>> wrote:
The key part of this is establishing a registry.  That can only be done in an RFC.

John, I encourage you to submit text beefing up the arguments about why using “acr” is preferable.  The text at http://self-issued.info/docs/draft-jones-oauth-amr-values-00.html#acrRelationship<https://na01.safelinks.protection.outlook.com/?url=http%3a%2f%2fself-issued.info%2fdocs%2fdraft-jones-oauth-amr-values-00.html%23acrRelationship&data=01%7c01%7cMichael.Jones%40microsoft.com%7c45f73eec59c2463664de08d2937adf52%7c72f988bf86f141af91ab2d7cd011db47%7c1&sdata=6%2blPSyG0xfBMg0jxKaQt1lAcW6GV3%2fje4dmkE%2bb7Q8o%3d> is a start at that.

                                                            -- Mike

From: John Bradley [mailto:[email-masked]<mailto:[email-masked]>]
Sent: Thursday, July 23, 2015 9:30 AM
To: Justin Richer
Cc: Mike Jones; <[email-masked]<mailto:[email-masked]>>
Subject: Re: [OAUTH-WG] Authentication Method Reference Values Specification

That exists for ACR.

John B.

 — Justin

The specification is available at:
•        https://tools.ietf.org/html/draft-jones-oauth-amr-values-00<https://na01.safelinks.protection.outlook.com/?url=https%3a%2f%2ftools.ietf.org%2fhtml%2fdraft-jones-oauth-amr-values-00&data=01%7c01%7cMichael.Jones%40microsoft.com%7c45f73eec59c2463664de08d2937adf52%7c72f988bf86f141af91ab2d7cd011db47%7c1&sdata=mJ47K%2bCepKxx8Zyst%2bAveZIZb6EyTRYv6Lv2wp6z9vY%3d>

An HTML formatted version is also available at:
•        http://self-issued.info/docs/draft-jones-oauth-amr-values-00.html<https://na01.safelinks.protection.outlook.com/?url=http%3a%2f%2fself-issued.info%2fdocs%2fdraft-jones-oauth-amr-values-00.html&data=01%7c01%7cMichael.Jones%40microsoft.com%7c45f73eec59c2463664de08d2937adf52%7c72f988bf86f141af91ab2d7cd011db47%7c1&sdata=T9VLqO%2bJjpfBiF76qBEqkKO1btDrPra59sq%2bhNUpN5I%3d>

                                                            -- Mike

P.S.  This note was also posted at http://self-issued.info/?p=1429<https://na01.safelinks.protection.outlook.com/?url=http%3a%2f%2fself-issued.info%2f%3fp%3d1429&data=01%7c01%7cMichael.Jones%40microsoft.com%7c45f73eec59c2463664de08d2937adf52%7c72f988bf86f141af91ab2d7cd011db47%7c1&sdata=zv2zIrlN0UGAFKe9rADVphUGnJKOgHwiRYXk0toa5QQ%3d> and as @selfissued<https://na01.safelinks.protection.outlook.com/?url=https%3a%2f%2ftwitter.com%2fselfissued&data=01%7c01%7cMichael.Jones%40microsoft.com%7c45f73eec59c2463664de08d2937adf52%7c72f988bf86f141af91ab2d7cd011db47%7c1&sdata=GZB6%2f0FYZPSX0RUxQkjMUAc5uGaTJVuZbkYUcuSFBkA%3d>.
_______________________________________________
OAuth mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/oauth<https://na01.safelinks.protection.outlook.com/?url=https%3a%2f%2fwww.ietf.org%2fmailman%2flistinfo%2foauth&data=01%7c01%7cMichael.Jones%40microsoft.com%7c45f73eec59c2463664de08d2937adf52%7c72f988bf86f141af91ab2d7cd011db47%7c1&sdata=4aNhTxGD%2f9w8qD9WPXpi2%2bQfiprJDbsF2PK5EBxau34%3d>

_______________________________________________
OAuth mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/oauth<https://na01.safelinks.protection.outlook.com/?url=https%3a%2f%2fwww.ietf.org%2fmailman%2flistinfo%2foauth&data=01%7c01%7cMichael.Jones%40microsoft.com%7c45f73eec59c2463664de08d2937adf52%7c72f988bf86f141af91ab2d7cd011db47%7c1&sdata=4aNhTxGD%2f9w8qD9WPXpi2%2bQfiprJDbsF2PK5EBxau34%3d>

_______________________________________________
OAuth mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/oauth<https://na01.safelinks.protection.outlook.com/?url=https%3a%2f%2fwww.ietf.org%2fmailman%2flistinfo%2foauth&data=01%7c01%7cMichael.Jones%40microsoft.com%7c45f73eec59c2463664de08d2937adf52%7c72f988bf86f141af91ab2d7cd011db47%7c1&sdata=4aNhTxGD%2f9w8qD9WPXpi2%2bQfiprJDbsF2PK5EBxau34%3d>

_______________________________________________
OAuth mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/oauth<https://na01.safelinks.protection.outlook.com/?url=https%3a%2f%2fwww.ietf.org%2fmailman%2flistinfo%2foauth&data=01%7c01%7cMichael.Jones%40microsoft.com%7c45f73eec59c2463664de08d2937adf52%7c72f988bf86f141af91ab2d7cd011db47%7c1&sdata=4aNhTxGD%2f9w8qD9WPXpi2%2bQfiprJDbsF2PK5EBxau34%3d>

_______________________________________________
OAuth mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/oauth<https://na01.safelinks.protection.outlook.com/?url=https%3a%2f%2fwww.ietf.org%2fmailman%2flistinfo%2foauth&data=01%7c01%7cMichael.Jones%40microsoft.com%7c45f73eec59c2463664de08d2937adf52%7c72f988bf86f141af91ab2d7cd011db47%7c1&sdata=4aNhTxGD%2f9w8qD9WPXpi2%2bQfiprJDbsF2PK5EBxau34%3d>

--
Nat Sakimura (=nat)
Chairman, OpenID Foundation
http://nat.sakimura.org/<https://na01.safelinks.protection.outlook.com/?url=http%3a%2f%2fnat.sakimura.org%2f&data=01%7c01%7cMichael.Jones%40microsoft.com%7c45f73eec59c2463664de08d2937adf52%7c72f988bf86f141af91ab2d7cd011db47%7c1&sdata=OIEfHEFdwYJMfEWkZeAYxrEdedcUrtVuZaYw86jCBks%3d>
@_nat_en

---

From: Brian Campbell <[email-masked]>
Date: Sat, 25 Jul 2015 14:46:37 +0200

There's a method of authentication that is gaining in popularity which I'd
propose adding a method for. It is typically used as a second factor where
after a primary auth, like username and password, a push notification is
sent to the user's phone and they acknowledge it from the device. We have
the PingID product <https://www.pingidentity.com/en/products/pingid.html>
that does it and Entrust
<http://www.entrust.com/resource/entrust-identityguard-mobile-push-authentication-for-vpn-and-web-access>
and Duo <https://www.duosecurity.com/product/methods/duo-mobile>, among
others I'm sure, offer something similar.

It's commonly called "mobile push authentication" so maybe "mpa" could be
the amr value. But, as Nat pointed out, the really interesting
characteristic is that it's a second factor that utilizes only a secondary
channel - so perhaps "sca" for "second channel authentication" would be a
more appropriate general amr name.

Thoughts are welcome. But I believe it's becoming prevalent enough that it
deserves its own amr value in this doc.

On Thu, Jul 23, 2015 at 6:29 PM, Mike Jones <[email-masked]>
wrote:

> I need to investigate use cases for amr_values.  I think this came from
> developers who actually wanted this for a particular purpose but I’ll have
> to get back to the WG on that.  It’s defined here, rather than in another
> spec, because it’s highly related to the “amr” values.
>
>
>
>                                                             -- Mike
>
>
>
> *From:* OAuth [mailto:[email-masked]] *On Behalf Of *Nat Sakimura
> *Sent:* Thursday, July 23, 2015 6:22 PM
> *To:* William Denniss
> *Cc:* <[email-masked]>
> <https://na01.safelinks.protection.outlook.com/?url=http%3a%2f%2fself-issued.info%2fdocs%2fdraft-jones-oauth-amr-values-00.html%23acrRelationship&data=01%7c01%7cMichael.Jones%40microsoft.com%7c45f73eec59c2463664de08d2937adf52%7c72f988bf86f141af91ab2d7cd011db47%7c1&sdata=6%2blPSyG0xfBMg0jxKaQt1lAcW6GV3%2fje4dmkE%2bb7Q8o%3d>
> is a start at that.
>
>
>
>                                                             -- Mike
>
>
>
> <https://na01.safelinks.protection.outlook.com/?url=https%3a%2f%2ftools.ietf.org%2fhtml%2fdraft-jones-oauth-amr-values-00&data=01%7c01%7cMichael.Jones%40microsoft.com%7c45f73eec59c2463664de08d2937adf52%7c72f988bf86f141af91ab2d7cd011db47%7c1&sdata=mJ47K%2bCepKxx8Zyst%2bAveZIZb6EyTRYv6Lv2wp6z9vY%3d>
>
>
>
> <https://na01.safelinks.protection.outlook.com/?url=http%3a%2f%2fself-issued.info%2fdocs%2fdraft-jones-oauth-amr-values-00.html&data=01%7c01%7cMichael.Jones%40microsoft.com%7c45f73eec59c2463664de08d2937adf52%7c72f988bf86f141af91ab2d7cd011db47%7c1&sdata=T9VLqO%2bJjpfBiF76qBEqkKO1btDrPra59sq%2bhNUpN5I%3d>
>
>
>
>                                                             -- Mike
>
>
>
> P.S.  This note was also posted at http://self-issued.info/?p=1429
> <https://na01.safelinks.protection.outlook.com/?url=http%3a%2f%2fself-issued.info%2f%3fp%3d1429&data=01%7c01%7cMichael.Jones%40microsoft.com%7c45f73eec59c2463664de08d2937adf52%7c72f988bf86f141af91ab2d7cd011db47%7c1&sdata=zv2zIrlN0UGAFKe9rADVphUGnJKOgHwiRYXk0toa5QQ%3d> and
> as @selfissued
> <https://na01.safelinks.protection.outlook.com/?url=https%3a%2f%2ftwitter.com%2fselfissued&data=01%7c01%7cMichael.Jones%40microsoft.com%7c45f73eec59c2463664de08d2937adf52%7c72f988bf86f141af91ab2d7cd011db47%7c1&sdata=GZB6%2f0FYZPSX0RUxQkjMUAc5uGaTJVuZbkYUcuSFBkA%3d>
> .
>
> <https://na01.safelinks.protection.outlook.com/?url=https%3a%2f%2fwww.ietf.org%2fmailman%2flistinfo%2foauth&data=01%7c01%7cMichael.Jones%40microsoft.com%7c45f73eec59c2463664de08d2937adf52%7c72f988bf86f141af91ab2d7cd011db47%7c1&sdata=4aNhTxGD%2f9w8qD9WPXpi2%2bQfiprJDbsF2PK5EBxau34%3d>
>
>
>
> <https://na01.safelinks.protection.outlook.com/?url=https%3a%2f%2fwww.ietf.org%2fmailman%2flistinfo%2foauth&data=01%7c01%7cMichael.Jones%40microsoft.com%7c45f73eec59c2463664de08d2937adf52%7c72f988bf86f141af91ab2d7cd011db47%7c1&sdata=4aNhTxGD%2f9w8qD9WPXpi2%2bQfiprJDbsF2PK5EBxau34%3d>
>
>
>
>
> <https://na01.safelinks.protection.outlook.com/?url=https%3a%2f%2fwww.ietf.org%2fmailman%2flistinfo%2foauth&data=01%7c01%7cMichael.Jones%40microsoft.com%7c45f73eec59c2463664de08d2937adf52%7c72f988bf86f141af91ab2d7cd011db47%7c1&sdata=4aNhTxGD%2f9w8qD9WPXpi2%2bQfiprJDbsF2PK5EBxau34%3d>
>
>
>
>
> <https://na01.safelinks.protection.outlook.com/?url=https%3a%2f%2fwww.ietf.org%2fmailman%2flistinfo%2foauth&data=01%7c01%7cMichael.Jones%40microsoft.com%7c45f73eec59c2463664de08d2937adf52%7c72f988bf86f141af91ab2d7cd011db47%7c1&sdata=4aNhTxGD%2f9w8qD9WPXpi2%2bQfiprJDbsF2PK5EBxau34%3d>
>
>
>
>
> <https://na01.safelinks.protection.outlook.com/?url=https%3a%2f%2fwww.ietf.org%2fmailman%2flistinfo%2foauth&data=01%7c01%7cMichael.Jones%40microsoft.com%7c45f73eec59c2463664de08d2937adf52%7c72f988bf86f141af91ab2d7cd011db47%7c1&sdata=4aNhTxGD%2f9w8qD9WPXpi2%2bQfiprJDbsF2PK5EBxau34%3d>
>
>
>
>
>
> --
>
> Nat Sakimura (=nat)
>
> <https://na01.safelinks.protection.outlook.com/?url=http%3a%2f%2fnat.sakimura.org%2f&data=01%7c01%7cMichael.Jones%40microsoft.com%7c45f73eec59c2463664de08d2937adf52%7c72f988bf86f141af91ab2d7cd011db47%7c1&sdata=OIEfHEFdwYJMfEWkZeAYxrEdedcUrtVuZaYw86jCBks%3d>
> @_nat_en
>

---

From: Nat Sakimura <[email-masked]>
Date: Mon, 27 Jul 2015 05:02:31 +0900

I am in favor of William's proposal.
In addition, I would like to see one for 2nd channel auth, 2ch. That would
indicate some resilience against MITB.

On Saturday, July 25, 2015, Brian Campbell <[email-masked]>
wrote:

> On Thu, Jul 23, 2015 at 6:29 PM, Mike Jones <[email-masked]
> <javascript:_e(%7B%7D,'cvml',[email-masked]');>> wrote:
>
>> *From:* OAuth [mailto:[email-masked]
>> <javascript:_e(%7B%7D,'cvml',[email-masked]');>] *On Behalf Of *Nat
>> Sakimura
>> *Cc:* <[email-masked] <javascript:_e(%7B%7D,'cvml',[email-masked]');>>
>> 2015-07-23 12:05 GMT+02:00 William Denniss <[email-masked]
>> <javascript:_e(%7B%7D,'cvml',[email-masked]');>>:
>>
>> In addition to the specific values, I propose we add some generic ones
>> too (trying to follow your naming scheme):
>>
>>
>>
>> "rba":  "risk-based auth"
>>
>> [email-masked]
>> <javascript:_e(%7B%7D,'cvml',[email-masked]');>> wrote:
>>
>> On Thu, Jul 23, 2015 at 9:35 AM, Mike Jones <[email-masked]
>> <javascript:_e(%7B%7D,'cvml',[email-masked]');>> wrote:
>>
>> *From:* John Bradley [mailto:[email-masked]
>> <javascript:_e(%7B%7D,'cvml',[email-masked]');>]
>> *Cc:* Mike Jones; <[email-masked]
>> <javascript:_e(%7B%7D,'cvml',[email-masked]');>>
>>  On Jul 23, 2015, at 9:21 AM, Justin Richer <[email-masked]
>> <javascript:_e(%7B%7D,'cvml',[email-masked]');>> wrote:
>>
>>
>>
>>  On Jul 22, 2015, at 7:48 PM, Mike Jones <[email-masked]
>> <javascript:_e(%7B%7D,'cvml',[email-masked]');>> wrote:
>>
>>
>>
>> [email-masked] <javascript:_e(%7B%7D,'cvml',[email-masked]');>
>> [email-masked] <javascript:_e(%7B%7D,'cvml',[email-masked]');>
>> [email-masked] <javascript:_e(%7B%7D,'cvml',[email-masked]');>
>> [email-masked] <javascript:_e(%7B%7D,'cvml',[email-masked]');>
>> [email-masked] <javascript:_e(%7B%7D,'cvml',[email-masked]');>
>> [email-masked] <javascript:_e(%7B%7D,'cvml',[email-masked]');>