Subject: [OAUTH-WG] I-D Action: draft-ietf-oauth-jwsreq-03.txt

From: [email-masked]
Date: Mon, 06 Jul 2015 08:11:48 -0700

A New Internet-Draft is available from the on-line Internet-Drafts directories.
 This draft is a work item of the Web Authorization Protocol Working Group of the IETF.

        Title           : Request by JWS ver.1.0 for OAuth 2.0
        Authors         : Nat Sakimura
                          John Bradley
	Filename        : draft-ietf-oauth-jwsreq-03.txt
	Pages           : 10
	Date            : 2015-07-06

Abstract:
   The authorization request in OAuth 2.0 utilizes query parameter
   serialization.  This specification defines the authorization request
   using JWT serialization.  The request is sent through "request"
   parameter or by reference through "request_uri" parameter that points
   to the JWT, allowing the request to be optionally signed and
   encrypted.

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-ietf-oauth-jwsreq/

There's also a htmlized version available at:
https://tools.ietf.org/html/draft-ietf-oauth-jwsreq-03

A diff from the previous version is available at:
https://www.ietf.org/rfcdiff?url2=draft-ietf-oauth-jwsreq-03

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org.

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

---

From: Mike Jones <[email-masked]>
Date: Mon, 6 Jul 2015 18:18:00 +0000

The invalid_request_uri parameter has already been registered at http://www.iana.org/assignments/oauth-parameters/oauth-parameters.xhtml by OpenID Connect Core, and so cannot be re-registered.

invalid_request_format looks like a duplicate of the already registered invalid_request_object parameter.  Please change to use the existing error name.

Please also try to reconcile invalid_request_params with existing JWS request usage already specified by OpenID Connect Core.

				Thanks,
				-- Mike

-----Original Message-----
From: OAuth [mailto:[email-masked]] On Behalf Of [email-masked]
Sent: Monday, July 06, 2015 8:12 AM
To: [email-masked]
Cc: [email-masked]
Subject: [OAUTH-WG] I-D Action: draft-ietf-oauth-jwsreq-03.txt

Abstract:

Please note that it may take a couple of minutes from the time of submission until the htmlized version and diff are available at tools.ietf.org.

_______________________________________________
OAuth mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/oauth