Subject: [OAUTH-WG] JWT PoP Key Semantics WGLC followup 2 (was Re: proof-of-possession-02 unencrypted oct JWK in encrypted JWT okay?)

From: Brian Campbell <[email-masked]>
Date: Thu, 30 Jul 2015 12:12:35 -0600

I raised the below question during the WGLC back in March but never got any
response.

JWE does add nontrivial size overhead to the message and in the case that a
JWT containing a symmetric confirmation key is already a JWE, the spec
would seem to require two layers of encryption and the associated over
overhead that comes with it - even though the key is already encrypted by
the outer JWE layer.

I believe the draft should speak to how a symmetric key be represented as a
claim in the clear when the encryption of it is provided the JWE/JWT that
contains it.

On Mon, Mar 23, 2015 at 12:40 AM, Brian Campbell <[email-masked]
> wrote:

> When the JWT is itself encrypted as a JWE, would it not be reasonable to
> have a symmetric key be represented in the cnf claim with the jwk member as
> an unencrypted JSON Web Key?
>
> Is such a possibility left as an exercise to the reader? Or should it be
> more explicitly allowed or disallowed?
>
>
>

---

From: John Bradley <[email-masked]>
Date: Thu, 30 Jul 2015 15:28:41 -0300

Yes encrypting the claim should only be required when the entire JWT is not encrypted.   I will have a look.

John B.

> On Jul 30, 2015, at 3:12 PM, Brian Campbell <[email-masked]> wrote:
> 
> I raised the below question during the WGLC back in March but never got any response.
> 
> JWE does add nontrivial size overhead to the message and in the case that a JWT containing a symmetric confirmation key is already a JWE, the spec would seem to require two layers of encryption and the associated over overhead that comes with it - even though the key is already encrypted by the outer JWE layer. 
> 
> I believe the draft should speak to how a symmetric key be represented as a claim in the clear when the encryption of it is provided the JWE/JWT that contains it. 
> 
> 
> On Mon, Mar 23, 2015 at 12:40 AM, Brian Campbell <[email-masked] <mailto:[email-masked]>> wrote:
> When the JWT is itself encrypted as a JWE, would it not be reasonable to have a symmetric key be represented in the cnf claim with the jwk member as an unencrypted JSON Web Key?  
> 
> Is such a possibility left as an exercise to the reader? Or should it be more explicitly allowed or disallowed? 
> 
> 
> 
> _______________________________________________
> OAuth mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/oauth

---

From: Mike Jones <[email-masked]>
Date: Thu, 30 Jul 2015 19:57:25 +0000

I'm fine updating the draft to say that the symmetric key can be carried in the "jwk" element in an unencrypted form if the JWT is itself encrypted.  That's what you're looking for, right?

                                                                -- Mike

From: OAuth [mailto:[email-masked]] On Behalf Of John Bradley
Sent: Thursday, July 30, 2015 11:29 AM
To: Brian Campbell <[email-masked]>
Cc: oauth <[email-masked]>
Subject: Re: [OAUTH-WG] JWT PoP Key Semantics WGLC followup 2 (was Re: proof-of-possession-02 unencrypted oct JWK in encrypted JWT okay?)

John B.

On Jul 30, 2015, at 3:12 PM, Brian Campbell <[email-masked]<mailto:[email-masked]>> wrote:

On Mon, Mar 23, 2015 at 12:40 AM, Brian Campbell <[email-masked]<mailto:[email-masked]>> wrote:
When the JWT is itself encrypted as a JWE, would it not be reasonable to have a symmetric key be represented in the cnf claim with the jwk member as an unencrypted JSON Web Key?
Is such a possibility left as an exercise to the reader? Or should it be more explicitly allowed or disallowed?

_______________________________________________
OAuth mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/oauth

---

From: John Bradley <[email-masked]>
Date: Thu, 30 Jul 2015 17:35:58 -0300

Yes,  I think that is reasonable.   There is no point to double encrypting the key.   

> On Jul 30, 2015, at 4:57 PM, Mike Jones <[email-masked]> wrote:
> 
> I’m fine updating the draft to say that the symmetric key can be carried in the “jwk” element in an unencrypted form if the JWT is itself encrypted.  That’s what you’re looking for, right?
>  
>                                                                 -- Mike
>  
> On Jul 30, 2015, at 3:12 PM, Brian Campbell <[email-masked] <mailto:[email-masked]>> wrote:
>  
> [email-masked] <mailto:[email-masked]>
> https://www.ietf.org/mailman/listinfo/oauth <https://www.ietf.org/mailman/listinfo/oauth>

---

From: Brian Campbell <[email-masked]>
Date: Thu, 30 Jul 2015 14:38:26 -0600

Yep, that's what I'm looking for. Thanks.

On Thu, Jul 30, 2015 at 1:57 PM, Mike Jones <[email-masked]>
wrote:

> I’m fine updating the draft to say that the symmetric key can be carried
> in the “jwk” element in an unencrypted form if the JWT is itself
> encrypted.  That’s what you’re looking for, right?
>
>
>
>                                                                 -- Mike
>
>
>
> *From:* OAuth [mailto:[email-masked]] *On Behalf Of *John Bradley
> *Sent:* Thursday, July 30, 2015 11:29 AM
> *To:* Brian Campbell <[email-masked]>
> *Cc:* oauth <[email-masked]>
> *Subject:* Re: [OAUTH-WG] JWT PoP Key Semantics WGLC followup 2 (was Re:
> proof-of-possession-02 unencrypted oct JWK in encrypted JWT okay?)
>
>
>
> JWE does add nontrivial size overhead to the message and in the case that
> a JWT containing a symmetric confirmation key is already a JWE, the spec
> I believe the draft should speak to how a symmetric key be represented as
> a claim in the clear when the encryption of it is provided the JWE/JWT that
> contains it.
>
>
>
>
>
> On Mon, Mar 23, 2015 at 12:40 AM, Brian Campbell <
> [email-masked]> wrote:
>