Subject: [OAUTH-WG] “amr” Values spec updated

From: Mike Jones <[email-masked]>
Date: Fri, 14 Aug 2015 03:43:18 +0000

I’ve updated the Authentication Method Reference Values spec to incorporate feedback received from the OAuth working group.  Changes were:

·        Added the values “mca” (multiple-channel authentication), “risk” (risk-based authentication), and “user” (user presence test).

·        Added citations in the definitions of Windows integrated authentication, knowledge-based authentication, risk-based authentication, multiple-factor authentication, one-time password, and proof-of-possession.

·        Alphabetized the values.

·        Added Tony Nadalin as an author and added acknowledgements.

The specification is available at:

·        http://tools.ietf.org/html/draft-jones-oauth-amr-values-01

An HTML formatted version is also available at:

·        http://self-issued.info/docs/draft-jones-oauth-amr-values-01.html

                                                            -- Mike

P.S.  This note was also posted at http://self-issued.info/?p=1437 and as @selfissued<https://twitter.com/selfissued>.

---

From: William Denniss <[email-masked]>
Date: Fri, 14 Aug 2015 10:40:09 -0700

Looking good, thanks for putting this together.

I wonder if we should say "risk_based" rather than just "risk" to avoid
ambiguity (i.e. that it's not a risky authentication method, rather, it was
risk-based).  "user" seems to work well, e.g. "user mfa pwd otp" tells a
logical story.

On Thu, Aug 13, 2015 at 8:43 PM, Mike Jones <[email-masked]>
wrote:

> I’ve updated the Authentication Method Reference Values spec to
> incorporate feedback received from the OAuth working group.  Changes were:
>
> ·        Added the values “mca” (multiple-channel authentication), “risk”
> (risk-based authentication), and “user” (user presence test).
>
> ·        Added citations in the definitions of Windows integrated
> authentication, knowledge-based authentication, risk-based authentication,
> multiple-factor authentication, one-time password, and proof-of-possession.
>
> P.S.  This note was also posted at http://self-issued.info/?p=1437 and as
> @selfissued <https://twitter.com/selfissued>.
>
> _______________________________________________
> OAuth mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/oauth
>
>

---

From: Mike Jones <[email-masked]>
Date: Fri, 14 Aug 2015 17:44:33 +0000

I hear you, but we’re trying to keep the values short for space reasons – just like other identifiers in JWTs.  Ultimately, the values aren’t meaningful without referring to the spec in the first place, so the place to beef up the meaning is in the description in the spec – not in the “amr” value.  If you’d like to suggest any edits in that regard, have at it!

                                                            Thanks,
                                                            -- Mike

From: William Denniss [mailto:[email-masked]]
Sent: Friday, August 14, 2015 1:40 PM
To: Mike Jones
Cc: [email-masked]
Subject: Re: [OAUTH-WG] “amr” Values spec updated

I wonder if we should say "risk_based" rather than just "risk" to avoid ambiguity (i.e. that it's not a risky authentication method, rather, it was risk-based).  "user" seems to work well, e.g. "user mfa pwd otp" tells a logical story.

On Thu, Aug 13, 2015 at 8:43 PM, Mike Jones <[email-masked]<mailto:[email-masked]>> wrote:
I’ve updated the Authentication Method Reference Values spec to incorporate feedback received from the OAuth working group.  Changes were:

•        Added the values “mca” (multiple-channel authentication), “risk” (risk-based authentication), and “user” (user presence test).

•        Added citations in the definitions of Windows integrated authentication, knowledge-based authentication, risk-based authentication, multiple-factor authentication, one-time password, and proof-of-possession.

•        Alphabetized the values.

•        Added Tony Nadalin as an author and added acknowledgements.

•        http://tools.ietf.org/html/draft-jones-oauth-amr-values-01<https://na01.safelinks.protection.outlook.com/?url=http%3a%2f%2ftools.ietf.org%2fhtml%2fdraft-jones-oauth-amr-values-01&data=01%7c01%7cMichael.Jones%40microsoft.com%7c1f21f86f4e4a4858dff908d2a4cf71f3%7c72f988bf86f141af91ab2d7cd011db47%7c1&sdata=I5MFZbd1BMANLuVeDH24boBVJ1CSwybIg3P1RqTZweU%3d>

•        http://self-issued.info/docs/draft-jones-oauth-amr-values-01.html<https://na01.safelinks.protection.outlook.com/?url=http%3a%2f%2fself-issued.info%2fdocs%2fdraft-jones-oauth-amr-values-01.html&data=01%7c01%7cMichael.Jones%40microsoft.com%7c1f21f86f4e4a4858dff908d2a4cf71f3%7c72f988bf86f141af91ab2d7cd011db47%7c1&sdata=rpA2%2fLQGs5mdomEP4xBu7T9V4PWzVi2j8d1VTzPCCZg%3d>

                                                            -- Mike

P.S.  This note was also posted at http://self-issued.info/?p=1437<https://na01.safelinks.protection.outlook.com/?url=http%3a%2f%2fself-issued.info%2f%3fp%3d1437&data=01%7c01%7cMichael.Jones%40microsoft.com%7c1f21f86f4e4a4858dff908d2a4cf71f3%7c72f988bf86f141af91ab2d7cd011db47%7c1&sdata=sv5HbcRW%2bjRbYcd71MRZBcFdks%2froaDqZ%2fqTKOJrJ%2fo%3d> and as @selfissued<https://na01.safelinks.protection.outlook.com/?url=https%3a%2f%2ftwitter.com%2fselfissued&data=01%7c01%7cMichael.Jones%40microsoft.com%7c1f21f86f4e4a4858dff908d2a4cf71f3%7c72f988bf86f141af91ab2d7cd011db47%7c1&sdata=ex43UP5ytuIMsfe6SkABmPAvJbeOpXPbHQbnvixUNcQ%3d>.

_______________________________________________
OAuth mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/oauth<https://na01.safelinks.protection.outlook.com/?url=https%3a%2f%2fwww.ietf.org%2fmailman%2flistinfo%2foauth&data=01%7c01%7cMichael.Jones%40microsoft.com%7c1f21f86f4e4a4858dff908d2a4cf71f3%7c72f988bf86f141af91ab2d7cd011db47%7c1&sdata=hlMpGbGhXBCYimtMJa9IfEzWSFqXRy3kKHN8Z%2bLxjn0%3d>

---

From: William Denniss <[email-masked]>
Date: Fri, 14 Aug 2015 10:52:58 -0700

Fair point. RBA is a fairly common acronym for Risk-Based Authentication,
how about going with "rba"? Would align with existing "mfa", "mca"
definitions (while also saving 1 character and helping the ambiguity issue).

On Fri, Aug 14, 2015 at 10:44 AM, Mike Jones <[email-masked]>
wrote:

> I hear you, but we’re trying to keep the values short for space reasons –
> just like other identifiers in JWTs.  Ultimately, the values aren’t
> meaningful without referring to the spec in the first place, so the place
> to beef up the meaning is in the description in the spec – not in the “amr”
> value.  If you’d like to suggest any edits in that regard, have at it!
>
>
>
>                                                             Thanks,
>
>                                                             -- Mike
>
>
>
> *From:* William Denniss [mailto:[email-masked]]
> *Sent:* Friday, August 14, 2015 1:40 PM
> *To:* Mike Jones
> *Cc:* [email-masked]
> *Subject:* Re: [OAUTH-WG] “amr” Values spec updated
>
>
>
> <https://na01.safelinks.protection.outlook.com/?url=http%3a%2f%2ftools.ietf.org%2fhtml%2fdraft-jones-oauth-amr-values-01&data=01%7c01%7cMichael.Jones%40microsoft.com%7c1f21f86f4e4a4858dff908d2a4cf71f3%7c72f988bf86f141af91ab2d7cd011db47%7c1&sdata=I5MFZbd1BMANLuVeDH24boBVJ1CSwybIg3P1RqTZweU%3d>
>
>
>
> <https://na01.safelinks.protection.outlook.com/?url=http%3a%2f%2fself-issued.info%2fdocs%2fdraft-jones-oauth-amr-values-01.html&data=01%7c01%7cMichael.Jones%40microsoft.com%7c1f21f86f4e4a4858dff908d2a4cf71f3%7c72f988bf86f141af91ab2d7cd011db47%7c1&sdata=rpA2%2fLQGs5mdomEP4xBu7T9V4PWzVi2j8d1VTzPCCZg%3d>
>
>
>
>                                                             -- Mike
>
>
>
> P.S.  This note was also posted at http://self-issued.info/?p=1437
> <https://na01.safelinks.protection.outlook.com/?url=http%3a%2f%2fself-issued.info%2f%3fp%3d1437&data=01%7c01%7cMichael.Jones%40microsoft.com%7c1f21f86f4e4a4858dff908d2a4cf71f3%7c72f988bf86f141af91ab2d7cd011db47%7c1&sdata=sv5HbcRW%2bjRbYcd71MRZBcFdks%2froaDqZ%2fqTKOJrJ%2fo%3d>
> and as @selfissued
> <https://na01.safelinks.protection.outlook.com/?url=https%3a%2f%2ftwitter.com%2fselfissued&data=01%7c01%7cMichael.Jones%40microsoft.com%7c1f21f86f4e4a4858dff908d2a4cf71f3%7c72f988bf86f141af91ab2d7cd011db47%7c1&sdata=ex43UP5ytuIMsfe6SkABmPAvJbeOpXPbHQbnvixUNcQ%3d>
> .
>
>
> <https://na01.safelinks.protection.outlook.com/?url=https%3a%2f%2fwww.ietf.org%2fmailman%2flistinfo%2foauth&data=01%7c01%7cMichael.Jones%40microsoft.com%7c1f21f86f4e4a4858dff908d2a4cf71f3%7c72f988bf86f141af91ab2d7cd011db47%7c1&sdata=hlMpGbGhXBCYimtMJa9IfEzWSFqXRy3kKHN8Z%2bLxjn0%3d>
>
>
>

---

From: Brian Campbell <[email-masked]>
Date: Fri, 14 Aug 2015 12:03:27 -0600

+1 for "rba"

On Fri, Aug 14, 2015 at 11:52 AM, William Denniss <[email-masked]>
wrote:

>> ·
>> http://self-issued.info/docs/draft-jones-oauth-amr-values-01.html

---

From: Mike Jones <[email-masked]>
Date: Fri, 14 Aug 2015 18:05:35 +0000

OK – I’ve added “rba” to my to-do list for the next spec version.

                                                            -- Mike

From: Brian Campbell [mailto:[email-masked]]
Sent: Friday, August 14, 2015 2:03 PM
To: William Denniss
Cc: Mike Jones; [email-masked]
Subject: Re: [OAUTH-WG] “amr” Values spec updated

+1 for "rba"

On Fri, Aug 14, 2015 at 11:52 AM, William Denniss <[email-masked]<mailto:[email-masked]>> wrote:
Fair point. RBA is a fairly common acronym for Risk-Based Authentication, how about going with "rba"? Would align with existing "mfa", "mca" definitions (while also saving 1 character and helping the ambiguity issue).

On Fri, Aug 14, 2015 at 10:44 AM, Mike Jones <[email-masked]<mailto:[email-masked]>> wrote:
I hear you, but we’re trying to keep the values short for space reasons – just like other identifiers in JWTs.  Ultimately, the values aren’t meaningful without referring to the spec in the first place, so the place to beef up the meaning is in the description in the spec – not in the “amr” value.  If you’d like to suggest any edits in that regard, have at it!

                                                            Thanks,
                                                            -- Mike

From: William Denniss [mailto:[email-masked]<mailto:[email-masked]>]
Sent: Friday, August 14, 2015 1:40 PM
To: Mike Jones
Cc: [email-masked]<mailto:[email-masked]>
Subject: Re: [OAUTH-WG] “amr” Values spec updated

                                                            -- Mike

_______________________________________________
OAuth mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/oauth<https://na01.safelinks.protection.outlook.com/?url=https%3a%2f%2fwww.ietf.org%2fmailman%2flistinfo%2foauth&data=01%7c01%7cMichael.Jones%40microsoft.com%7ccd057e86f6f845862d8008d2a4d2b953%7c72f988bf86f141af91ab2d7cd011db47%7c1&sdata=AUc7mKLrEWIO3j1gkWFajQ2lqn5Nbw79m6akPTwbaMM%3d>

---

From: John Bradley <[email-masked]>
Date: Fri, 14 Aug 2015 16:08:08 -0300

+1

> On Aug 14, 2015, at 3:03 PM, Brian Campbell <[email-masked]> wrote:
> 
> +1 for "rba"
> 
> On Fri, Aug 14, 2015 at 11:52 AM, William Denniss <[email-masked] <mailto:[email-masked]>> wrote:
> On Fri, Aug 14, 2015 at 10:44 AM, Mike Jones <[email-masked] <mailto:[email-masked]>> wrote:
> From: William Denniss [mailto:[email-masked] <mailto:[email-masked]>] 
> Cc: [email-masked] <mailto:[email-masked]>
> On Thu, Aug 13, 2015 at 8:43 PM, Mike Jones <[email-masked] <mailto:[email-masked]>> wrote:
> 
> ·        http://tools.ietf.org/html/draft-jones-oauth-amr-values-01 <https://na01.safelinks.protection.outlook.com/?url=http%3a%2f%2ftools.ietf.org%2fhtml%2fdraft-jones-oauth-amr-values-01&data=01%7c01%7cMichael.Jones%40microsoft.com%7c1f21f86f4e4a4858dff908d2a4cf71f3%7c72f988bf86f141af91ab2d7cd011db47%7c1&sdata=I5MFZbd1BMANLuVeDH24boBVJ1CSwybIg3P1RqTZweU%3d>
>  
> 
> ·        http://self-issued.info/docs/draft-jones-oauth-amr-values-01.html <https://na01.safelinks.protection.outlook.com/?url=http%3a%2f%2fself-issued.info%2fdocs%2fdraft-jones-oauth-amr-values-01.html&data=01%7c01%7cMichael.Jones%40microsoft.com%7c1f21f86f4e4a4858dff908d2a4cf71f3%7c72f988bf86f141af91ab2d7cd011db47%7c1&sdata=rpA2%2fLQGs5mdomEP4xBu7T9V4PWzVi2j8d1VTzPCCZg%3d>
>  
> 
>                                                             -- Mike
> 
>  
> 
> P.S.  This note was also posted at http://self-issued.info/?p=1437 <https://na01.safelinks.protection.outlook.com/?url=http%3a%2f%2fself-issued.info%2f%3fp%3d1437&data=01%7c01%7cMichael.Jones%40microsoft.com%7c1f21f86f4e4a4858dff908d2a4cf71f3%7c72f988bf86f141af91ab2d7cd011db47%7c1&sdata=sv5HbcRW%2bjRbYcd71MRZBcFdks%2froaDqZ%2fqTKOJrJ%2fo%3d> and as @selfissued <https://na01.safelinks.protection.outlook.com/?url=https%3a%2f%2ftwitter.com%2fselfissued&data=01%7c01%7cMichael.Jones%40microsoft.com%7c1f21f86f4e4a4858dff908d2a4cf71f3%7c72f988bf86f141af91ab2d7cd011db47%7c1&sdata=ex43UP5ytuIMsfe6SkABmPAvJbeOpXPbHQbnvixUNcQ%3d>.
> 
> 
> [email-masked] <mailto:[email-masked]>
> https://www.ietf.org/mailman/listinfo/oauth <https://na01.safelinks.protection.outlook.com/?url=https%3a%2f%2fwww.ietf.org%2fmailman%2flistinfo%2foauth&data=01%7c01%7cMichael.Jones%40microsoft.com%7c1f21f86f4e4a4858dff908d2a4cf71f3%7c72f988bf86f141af91ab2d7cd011db47%7c1&sdata=hlMpGbGhXBCYimtMJa9IfEzWSFqXRy3kKHN8Z%2bLxjn0%3d>
>  
> 
> 
> 
> [email-masked] <mailto:[email-masked]>
> https://www.ietf.org/mailman/listinfo/oauth <https://www.ietf.org/mailman/listinfo/oauth>
> 
>

---

From: Phil Hunt <[email-masked]>
Date: Fri, 14 Aug 2015 12:20:56 -0700

+1

Phil

@independentid
www.independentid.com
[email-masked]

> On Aug 14, 2015, at 12:08 PM, John Bradley <[email-masked]> wrote:
> 
> +1
> 
>> On Aug 14, 2015, at 3:03 PM, Brian Campbell <[email-masked] <mailto:[email-masked]>> wrote:
>> 
>> +1 for "rba"
>>

---

From: Nat Sakimura <[email-masked]>
Date: Wed, 19 Aug 2015 11:28:30 +0900

+1

2015-08-15 4:20 GMT+09:00 Phil Hunt <[email-masked]>:

>> On Fri, Aug 14, 2015 at 10:44 AM, Mike Jones <[email-masked]
>> > wrote:
>>
>>> I hear you, but we’re trying to keep the values short for space reasons
>>> – just like other identifiers in JWTs.  Ultimately, the values aren’t

-- 
Nat Sakimura (=nat)
Chairman, OpenID Foundation
http://nat.sakimura.org/
@_nat_en

---

From: Mike Jones <[email-masked]>
Date: Fri, 21 Aug 2015 21:28:47 +0000

Done in -02.
________________________________
From: Nat Sakimura<mailto:[email-masked]>
Sent: ‎8/‎18/‎2015 7:28 PM
To: Phil Hunt<mailto:[email-masked]>
Cc: [email-masked]<mailto:[email-masked]>
Subject: Re: [OAUTH-WG] “amr” Values spec updated

+1

2015-08-15 4:20 GMT+09:00 Phil Hunt <[email-masked]<mailto:[email-masked]>>:
+1

Phil

@independentid
www.independentid.com<https://na01.safelinks.protection.outlook.com/?url=http%3a%2f%2fwww.independentid.com&data=01%7c01%7cMichael.Jones%40microsoft.com%7c501738a4097c4d7e3f9608d2a83de568%7c72f988bf86f141af91ab2d7cd011db47%7c1&sdata=SEPT1AMM6Wc8ja4fvXlSrRe6N1kSzZ7xmmEZjxcKSx0%3d>
[email-masked]<mailto:[email-masked]>

On Aug 14, 2015, at 12:08 PM, John Bradley <[email-masked]<mailto:[email-masked]>> wrote:

+1

On Aug 14, 2015, at 3:03 PM, Brian Campbell <[email-masked]<mailto:[email-masked]>> wrote:

+1 for "rba"

                                                            Thanks,
                                                            -- Mike

                                                            -- Mike

_______________________________________________
OAuth mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/oauth<https://na01.safelinks.protection.outlook.com/?url=https%3a%2f%2fwww.ietf.org%2fmailman%2flistinfo%2foauth&data=01%7c01%7cMichael.Jones%40microsoft.com%7c501738a4097c4d7e3f9608d2a83de568%7c72f988bf86f141af91ab2d7cd011db47%7c1&sdata=%2fwIM0fDpZUe7KcJcyh1JMndXAZTb0D07AgLb0ypX2Jc%3d>

_______________________________________________
OAuth mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/oauth<https://na01.safelinks.protection.outlook.com/?url=https%3a%2f%2fwww.ietf.org%2fmailman%2flistinfo%2foauth&data=01%7c01%7cMichael.Jones%40microsoft.com%7c501738a4097c4d7e3f9608d2a83de568%7c72f988bf86f141af91ab2d7cd011db47%7c1&sdata=%2fwIM0fDpZUe7KcJcyh1JMndXAZTb0D07AgLb0ypX2Jc%3d>

_______________________________________________
OAuth mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/oauth<https://na01.safelinks.protection.outlook.com/?url=https%3a%2f%2fwww.ietf.org%2fmailman%2flistinfo%2foauth&data=01%7c01%7cMichael.Jones%40microsoft.com%7c501738a4097c4d7e3f9608d2a83de568%7c72f988bf86f141af91ab2d7cd011db47%7c1&sdata=%2fwIM0fDpZUe7KcJcyh1JMndXAZTb0D07AgLb0ypX2Jc%3d>

_______________________________________________
OAuth mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/oauth<https://na01.safelinks.protection.outlook.com/?url=https%3a%2f%2fwww.ietf.org%2fmailman%2flistinfo%2foauth&data=01%7c01%7cMichael.Jones%40microsoft.com%7c501738a4097c4d7e3f9608d2a83de568%7c72f988bf86f141af91ab2d7cd011db47%7c1&sdata=%2fwIM0fDpZUe7KcJcyh1JMndXAZTb0D07AgLb0ypX2Jc%3d>

--
Nat Sakimura (=nat)
Chairman, OpenID Foundation
http://nat.sakimura.org/<https://na01.safelinks.protection.outlook.com/?url=http%3a%2f%2fnat.sakimura.org%2f&data=01%7c01%7cMichael.Jones%40microsoft.com%7c501738a4097c4d7e3f9608d2a83de568%7c72f988bf86f141af91ab2d7cd011db47%7c1&sdata=rIoMNwbWgT09bmV%2bis9oyApufBstcWzo1QcbQpzr5l8%3d>
@_nat_en

---

From: William Denniss <[email-masked]>
Date: Fri, 21 Aug 2015 14:33:58 -0700

Thanks Mike. Looks good.

On Fri, Aug 21, 2015 at 2:28 PM, Mike Jones <[email-masked]>
wrote:

> Done in -02.
> ------------------------------
> From: Nat Sakimura <[email-masked]>
> To: Phil Hunt <[email-masked]>
>
> Cc: [email-masked]
>> <https://na01.safelinks.protection.outlook.com/?url=http%3a%2f%2fwww.independentid.com&data=01%7c01%7cMichael.Jones%40microsoft.com%7c501738a4097c4d7e3f9608d2a83de568%7c72f988bf86f141af91ab2d7cd011db47%7c1&sdata=SEPT1AMM6Wc8ja4fvXlSrRe6N1kSzZ7xmmEZjxcKSx0%3d>
>> [email-masked]
>>
>>> Fair point. RBA is a fairly common acronym for Risk-Based
>>> Authentication, how about going with "rba"? Would align with existing
>>> "mfa", "mca" definitions (while also saving 1 character and helping the
>>> ambiguity issue).
>>>
>>> On Fri, Aug 14, 2015 at 10:44 AM, Mike Jones <
>>> [email-masked]> wrote:
>>>
>>>> On Thu, Aug 13, 2015 at 8:43 PM, Mike Jones <
>>>> [email-masked]> wrote:
>>>>
>>>> ·        Added the values “mca” (multiple-channel authentication), “
>>>> risk” (risk-based authentication), and “user” (user presence test).
>>>>
>>> <https://na01.safelinks.protection.outlook.com/?url=https%3a%2f%2fwww.ietf.org%2fmailman%2flistinfo%2foauth&data=01%7c01%7cMichael.Jones%40microsoft.com%7c501738a4097c4d7e3f9608d2a83de568%7c72f988bf86f141af91ab2d7cd011db47%7c1&sdata=%2fwIM0fDpZUe7KcJcyh1JMndXAZTb0D07AgLb0ypX2Jc%3d>
>>>
>>>
>> <https://na01.safelinks.protection.outlook.com/?url=https%3a%2f%2fwww.ietf.org%2fmailman%2flistinfo%2foauth&data=01%7c01%7cMichael.Jones%40microsoft.com%7c501738a4097c4d7e3f9608d2a83de568%7c72f988bf86f141af91ab2d7cd011db47%7c1&sdata=%2fwIM0fDpZUe7KcJcyh1JMndXAZTb0D07AgLb0ypX2Jc%3d>
>>
>>
>> <https://na01.safelinks.protection.outlook.com/?url=https%3a%2f%2fwww.ietf.org%2fmailman%2flistinfo%2foauth&data=01%7c01%7cMichael.Jones%40microsoft.com%7c501738a4097c4d7e3f9608d2a83de568%7c72f988bf86f141af91ab2d7cd011db47%7c1&sdata=%2fwIM0fDpZUe7KcJcyh1JMndXAZTb0D07AgLb0ypX2Jc%3d>
>>
>>
>>
>> <https://na01.safelinks.protection.outlook.com/?url=https%3a%2f%2fwww.ietf.org%2fmailman%2flistinfo%2foauth&data=01%7c01%7cMichael.Jones%40microsoft.com%7c501738a4097c4d7e3f9608d2a83de568%7c72f988bf86f141af91ab2d7cd011db47%7c1&sdata=%2fwIM0fDpZUe7KcJcyh1JMndXAZTb0D07AgLb0ypX2Jc%3d>
>>
>>
>
>
> --
> Nat Sakimura (=nat)
> <https://na01.safelinks.protection.outlook.com/?url=http%3a%2f%2fnat.sakimura.org%2f&data=01%7c01%7cMichael.Jones%40microsoft.com%7c501738a4097c4d7e3f9608d2a83de568%7c72f988bf86f141af91ab2d7cd011db47%7c1&sdata=rIoMNwbWgT09bmV%2bis9oyApufBstcWzo1QcbQpzr5l8%3d>
> @_nat_en
>