Subject: Re: [OAUTH-WG] Authentication Method Reference Values Specification

From: Mike Jones <[email-masked]>
Date: Fri, 14 Aug 2015 03:51:08 +0000

Thanks, William.  These were added in -01 with the names “risk” and “user”.  I added references to a bunch of the definitions, including one for “wia”.

About “amr_values”, I did the investigation I’d promised about whether it was being used, and it is in production use by Azure Active Directory at present.  Thus, I’ve left it in the spec at present.

                                                            -- Mike

From: William Denniss [mailto:[email-masked]]
Sent: Thursday, July 23, 2015 6:05 AM
To: Brian Campbell
Cc: Mike Jones; <[email-masked]>
Subject: Re: [OAUTH-WG] Authentication Method Reference Values Specification

Thanks for drafting this Mike. I'm in favor of having this registry.

In addition to the specific values, I propose we add some generic ones too (trying to follow your naming scheme):

"rba":  "risk-based auth"
"upt":  "user presence test"

My fear of making things too specific is that RPs may get lost in the weeds trying to work out what things they should care about and how. As an IdP we like to guide RPs through these kinds of decisions, and prefer to pass a more high level indication of what happened (such as these two values).  If someone wanted to have best of both worlds, then both could be asserted, e.g. "upt fpt" to indicate that the user presence was tested, using a fingerprint test.

Regarding the proposed "wia" value. I don't know what it is, and the spec doesn't help me find out, can a reference be added?  I also wonder if it could be genericized to avoid being vendor specific values – but mostly I just want to understand what it is.  Almost all the other values are self-explanatory, perhaps "pop" could use a reference as well (or maybe just a longer explanation).

I don't see the immediate value of "amr_values", can you elaborate with some places where this would be applied?  Separately, I wonder if an extension to OIDC should be included in this doc, which is otherwise a fairly clean registry spec that could be used more broadly.

On Thu, Jul 23, 2015 at 10:49 AM, Brian Campbell <[email-masked]<mailto:[email-masked]>> wrote:
So maybe a naive question but why does this draft define "amr_values" while also suggesting that it's fragile and that "acr" & "acr_values" is preferable? Seems contradictory. And I doubt I'm the only one that will find it confusing.

On Thu, Jul 23, 2015 at 9:35 AM, Mike Jones <[email-masked]<mailto:[email-masked]>> wrote:
The key part of this is establishing a registry.  That can only be done in an RFC.

John, I encourage you to submit text beefing up the arguments about why using “acr” is preferable.  The text at http://self-issued.info/docs/draft-jones-oauth-amr-values-00.html#acrRelationship<https://na01.safelinks.protection.outlook.com/?url=http%3a%2f%2fself-issued.info%2fdocs%2fdraft-jones-oauth-amr-values-00.html%23acrRelationship&data=01%7c01%7cMichael.Jones%40microsoft.com%7cf74ac3a9b7384765ed3008d293464724%7c72f988bf86f141af91ab2d7cd011db47%7c1&sdata=6dyozSx3gxBo8T5sxI%2fb8jfeN%2bfXVv5Yt2mKTvHD7Z0%3d> is a start at that.

                                                            -- Mike

From: John Bradley [mailto:[email-masked]<mailto:[email-masked]>]
Sent: Thursday, July 23, 2015 9:30 AM
To: Justin Richer
Cc: Mike Jones; <[email-masked]<mailto:[email-masked]>>
Subject: Re: [OAUTH-WG] Authentication Method Reference Values Specification

I don’t personally have a problem with people defining values for AMR and creating a IANA registry.

That exists for ACR.

I am on record as not supporting clients requesting amr as it ai a bad idea and the spec mentions that at the same time it defines a new request parameter for it.

It is probably not something I will put any real effort into fighting, if people insist on it.  I will continue to recommend only using ACR in the request.

John B.

On Jul 23, 2015, at 9:21 AM, Justin Richer <[email-masked]<mailto:[email-masked]>> wrote:

Useful work, but shouldn’t this be defined in the OIDF, where the “amr" parameter is defined?

 — Justin

On Jul 22, 2015, at 7:48 PM, Mike Jones <[email-masked]<mailto:[email-masked]>> wrote:

Phil Hunt and I have posted a new draft that defines some values used with the “amr” (Authentication Methods References) claim and establishes a registry for Authentication Method Reference values.  These values include commonly used authentication methods like “pwd” (password) and “otp” (one time password).  It also defines a parameter for requesting that specific authentication methods be used in the authentication.

The specification is available at:
•        https://tools.ietf.org/html/draft-jones-oauth-amr-values-00<https://na01.safelinks.protection.outlook.com/?url=https%3a%2f%2ftools.ietf.org%2fhtml%2fdraft-jones-oauth-amr-values-00&data=01%7c01%7cMichael.Jones%40microsoft.com%7cf74ac3a9b7384765ed3008d293464724%7c72f988bf86f141af91ab2d7cd011db47%7c1&sdata=gxXqEjnEXKNjkjUKBbjuYkqlm%2bAOY0BnG%2bW%2fCFu7iow%3d>

An HTML formatted version is also available at:
•        http://self-issued.info/docs/draft-jones-oauth-amr-values-00.html<https://na01.safelinks.protection.outlook.com/?url=http%3a%2f%2fself-issued.info%2fdocs%2fdraft-jones-oauth-amr-values-00.html&data=01%7c01%7cMichael.Jones%40microsoft.com%7cf74ac3a9b7384765ed3008d293464724%7c72f988bf86f141af91ab2d7cd011db47%7c1&sdata=poM7nzAkuGDBZ3rdLm5RGnrUmmuj%2b3AY0j4K3J5l8V4%3d>

                                                            -- Mike

P.S.  This note was also posted at http://self-issued.info/?p=1429<https://na01.safelinks.protection.outlook.com/?url=http%3a%2f%2fself-issued.info%2f%3fp%3d1429&data=01%7c01%7cMichael.Jones%40microsoft.com%7cf74ac3a9b7384765ed3008d293464724%7c72f988bf86f141af91ab2d7cd011db47%7c1&sdata=LwMDOuSwvq%2bjplucviMu7BV%2bWt8oTswZua9wbLtt6E0%3d> and as @selfissued<https://na01.safelinks.protection.outlook.com/?url=https%3a%2f%2ftwitter.com%2fselfissued&data=01%7c01%7cMichael.Jones%40microsoft.com%7cf74ac3a9b7384765ed3008d293464724%7c72f988bf86f141af91ab2d7cd011db47%7c1&sdata=U60HoWx0%2fUyyB%2f1vqy8SovvSDTNv3LceAUgo%2fo1x%2fTM%3d>.
_______________________________________________
OAuth mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/oauth<https://na01.safelinks.protection.outlook.com/?url=https%3a%2f%2fwww.ietf.org%2fmailman%2flistinfo%2foauth&data=01%7c01%7cMichael.Jones%40microsoft.com%7cf74ac3a9b7384765ed3008d293464724%7c72f988bf86f141af91ab2d7cd011db47%7c1&sdata=BsCTB4LCw7oH6JkVGyR%2bceO%2fxjmbBcT%2fYdeuDmWGtM8%3d>

_______________________________________________
OAuth mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/oauth<https://na01.safelinks.protection.outlook.com/?url=https%3a%2f%2fwww.ietf.org%2fmailman%2flistinfo%2foauth&data=01%7c01%7cMichael.Jones%40microsoft.com%7cf74ac3a9b7384765ed3008d293464724%7c72f988bf86f141af91ab2d7cd011db47%7c1&sdata=BsCTB4LCw7oH6JkVGyR%2bceO%2fxjmbBcT%2fYdeuDmWGtM8%3d>

_______________________________________________
OAuth mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/oauth<https://na01.safelinks.protection.outlook.com/?url=https%3a%2f%2fwww.ietf.org%2fmailman%2flistinfo%2foauth&data=01%7c01%7cMichael.Jones%40microsoft.com%7cf74ac3a9b7384765ed3008d293464724%7c72f988bf86f141af91ab2d7cd011db47%7c1&sdata=BsCTB4LCw7oH6JkVGyR%2bceO%2fxjmbBcT%2fYdeuDmWGtM8%3d>

_______________________________________________
OAuth mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/oauth<https://na01.safelinks.protection.outlook.com/?url=https%3a%2f%2fwww.ietf.org%2fmailman%2flistinfo%2foauth&data=01%7c01%7cMichael.Jones%40microsoft.com%7cf74ac3a9b7384765ed3008d293464724%7c72f988bf86f141af91ab2d7cd011db47%7c1&sdata=BsCTB4LCw7oH6JkVGyR%2bceO%2fxjmbBcT%2fYdeuDmWGtM8%3d>

---

From: Mike Jones <[email-masked]>
Date: Fri, 14 Aug 2015 03:52:57 +0000

I added references in a bunch of the definitions.  Please review them and suggest others, as appropriate.

                                                            -- Mike

From: Mike Jones
Sent: Thursday, July 23, 2015 12:29 PM
To: 'Nat Sakimura'; William Denniss
Cc: <[email-masked]>
Subject: RE: [OAUTH-WG] Authentication Method Reference Values Specification

I agree that an obvious good thing to do is to add spec references to the field definitions.

I need to investigate use cases for amr_values.  I think this came from developers who actually wanted this for a particular purpose but I’ll have to get back to the WG on that.  It’s defined here, rather than in another spec, because it’s highly related to the “amr” values.

                                                            -- Mike

From: OAuth [mailto:[email-masked]] On Behalf Of Nat Sakimura
Sent: Thursday, July 23, 2015 6:22 PM
To: William Denniss
Cc: <[email-masked]>
Subject: Re: [OAUTH-WG] Authentication Method Reference Values Specification

So, allow me a naive question.
I supppose there are good random otp, as well as pretty bad otp etc.
Would it be useful to say just "otp". Would it not be better to have at least a field that references a spec that specifies the security requirement for that mechanism?

2015-07-23 12:05 GMT+02:00 William Denniss <[email-masked]<mailto:[email-masked]>>:
Thanks for drafting this Mike. I'm in favor of having this registry.

"rba":  "risk-based auth"

John, I encourage you to submit text beefing up the arguments about why using “acr” is preferable.  The text at http://self-issued.info/docs/draft-jones-oauth-amr-values-00.html#acrRelationship<https://na01.safelinks.protection.outlook.com/?url=http%3a%2f%2fself-issued.info%2fdocs%2fdraft-jones-oauth-amr-values-00.html%23acrRelationship&data=01%7c01%7cMichael.Jones%40microsoft.com%7c45f73eec59c2463664de08d2937adf52%7c72f988bf86f141af91ab2d7cd011db47%7c1&sdata=6%2blPSyG0xfBMg0jxKaQt1lAcW6GV3%2fje4dmkE%2bb7Q8o%3d> is a start at that.

                                                            -- Mike

That exists for ACR.

John B.

 — Justin

The specification is available at:
•        https://tools.ietf.org/html/draft-jones-oauth-amr-values-00<https://na01.safelinks.protection.outlook.com/?url=https%3a%2f%2ftools.ietf.org%2fhtml%2fdraft-jones-oauth-amr-values-00&data=01%7c01%7cMichael.Jones%40microsoft.com%7c45f73eec59c2463664de08d2937adf52%7c72f988bf86f141af91ab2d7cd011db47%7c1&sdata=mJ47K%2bCepKxx8Zyst%2bAveZIZb6EyTRYv6Lv2wp6z9vY%3d>

An HTML formatted version is also available at:
•        http://self-issued.info/docs/draft-jones-oauth-amr-values-00.html<https://na01.safelinks.protection.outlook.com/?url=http%3a%2f%2fself-issued.info%2fdocs%2fdraft-jones-oauth-amr-values-00.html&data=01%7c01%7cMichael.Jones%40microsoft.com%7c45f73eec59c2463664de08d2937adf52%7c72f988bf86f141af91ab2d7cd011db47%7c1&sdata=T9VLqO%2bJjpfBiF76qBEqkKO1btDrPra59sq%2bhNUpN5I%3d>

                                                            -- Mike

P.S.  This note was also posted at http://self-issued.info/?p=1429<https://na01.safelinks.protection.outlook.com/?url=http%3a%2f%2fself-issued.info%2f%3fp%3d1429&data=01%7c01%7cMichael.Jones%40microsoft.com%7c45f73eec59c2463664de08d2937adf52%7c72f988bf86f141af91ab2d7cd011db47%7c1&sdata=zv2zIrlN0UGAFKe9rADVphUGnJKOgHwiRYXk0toa5QQ%3d> and as @selfissued<https://na01.safelinks.protection.outlook.com/?url=https%3a%2f%2ftwitter.com%2fselfissued&data=01%7c01%7cMichael.Jones%40microsoft.com%7c45f73eec59c2463664de08d2937adf52%7c72f988bf86f141af91ab2d7cd011db47%7c1&sdata=GZB6%2f0FYZPSX0RUxQkjMUAc5uGaTJVuZbkYUcuSFBkA%3d>.
_______________________________________________
OAuth mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/oauth<https://na01.safelinks.protection.outlook.com/?url=https%3a%2f%2fwww.ietf.org%2fmailman%2flistinfo%2foauth&data=01%7c01%7cMichael.Jones%40microsoft.com%7c45f73eec59c2463664de08d2937adf52%7c72f988bf86f141af91ab2d7cd011db47%7c1&sdata=4aNhTxGD%2f9w8qD9WPXpi2%2bQfiprJDbsF2PK5EBxau34%3d>

_______________________________________________
OAuth mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/oauth<https://na01.safelinks.protection.outlook.com/?url=https%3a%2f%2fwww.ietf.org%2fmailman%2flistinfo%2foauth&data=01%7c01%7cMichael.Jones%40microsoft.com%7c45f73eec59c2463664de08d2937adf52%7c72f988bf86f141af91ab2d7cd011db47%7c1&sdata=4aNhTxGD%2f9w8qD9WPXpi2%2bQfiprJDbsF2PK5EBxau34%3d>

_______________________________________________
OAuth mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/oauth<https://na01.safelinks.protection.outlook.com/?url=https%3a%2f%2fwww.ietf.org%2fmailman%2flistinfo%2foauth&data=01%7c01%7cMichael.Jones%40microsoft.com%7c45f73eec59c2463664de08d2937adf52%7c72f988bf86f141af91ab2d7cd011db47%7c1&sdata=4aNhTxGD%2f9w8qD9WPXpi2%2bQfiprJDbsF2PK5EBxau34%3d>

_______________________________________________
OAuth mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/oauth<https://na01.safelinks.protection.outlook.com/?url=https%3a%2f%2fwww.ietf.org%2fmailman%2flistinfo%2foauth&data=01%7c01%7cMichael.Jones%40microsoft.com%7c45f73eec59c2463664de08d2937adf52%7c72f988bf86f141af91ab2d7cd011db47%7c1&sdata=4aNhTxGD%2f9w8qD9WPXpi2%2bQfiprJDbsF2PK5EBxau34%3d>

_______________________________________________
OAuth mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/oauth<https://na01.safelinks.protection.outlook.com/?url=https%3a%2f%2fwww.ietf.org%2fmailman%2flistinfo%2foauth&data=01%7c01%7cMichael.Jones%40microsoft.com%7c45f73eec59c2463664de08d2937adf52%7c72f988bf86f141af91ab2d7cd011db47%7c1&sdata=4aNhTxGD%2f9w8qD9WPXpi2%2bQfiprJDbsF2PK5EBxau34%3d>

--
Nat Sakimura (=nat)
Chairman, OpenID Foundation
http://nat.sakimura.org/<https://na01.safelinks.protection.outlook.com/?url=http%3a%2f%2fnat.sakimura.org%2f&data=01%7c01%7cMichael.Jones%40microsoft.com%7c45f73eec59c2463664de08d2937adf52%7c72f988bf86f141af91ab2d7cd011db47%7c1&sdata=OIEfHEFdwYJMfEWkZeAYxrEdedcUrtVuZaYw86jCBks%3d>
@_nat_en

---

From: Mike Jones <[email-masked]>
Date: Fri, 14 Aug 2015 03:53:50 +0000

I added this in -01 as “mca” (multiple-channel authentication).

                                                            Thanks,
                                                            -- Mike

From: Brian Campbell [mailto:[email-masked]]
Sent: Saturday, July 25, 2015 8:47 AM
To: Mike Jones
Cc: Nat Sakimura; William Denniss; <[email-masked]>
Subject: Re: [OAUTH-WG] Authentication Method Reference Values Specification

There's a method of authentication that is gaining in popularity which I'd propose adding a method for. It is typically used as a second factor where after a primary auth, like username and password, a push notification is sent to the user's phone and they acknowledge it from the device. We have the PingID product<https://na01.safelinks.protection.outlook.com/?url=https%3a%2f%2fwww.pingidentity.com%2fen%2fproducts%2fpingid.html&data=01%7c01%7cMichael.Jones%40microsoft.com%7c62c2764a6dc44f6c012e08d294ef266e%7c72f988bf86f141af91ab2d7cd011db47%7c1&sdata=3Mq4ELCxwFiqefhqtW7Y4dqOto55FcvQT%2bJ9d1wNrMo%3d> that does it and Entrust<https://na01.safelinks.protection.outlook.com/?url=http%3a%2f%2fwww.entrust.com%2fresource%2fentrust-identityguard-mobile-push-authentication-for-vpn-and-web-access&data=01%7c01%7cMichael.Jones%40microsoft.com%7c62c2764a6dc44f6c012e08d294ef266e%7c72f988bf86f141af91ab2d7cd011db47%7c1&sdata=kGHuPm%2bWy1Tg125loJhifmVow%2bMUE7L47wrRZD4%2f9jk%3d> and Duo<https://na01.safelinks.protection.outlook.com/?url=https%3a%2f%2fwww.duosecurity.com%2fproduct%2fmethods%2fduo-mobile+&data=01%7c01%7cMichael.Jones%40microsoft.com%7c62c2764a6dc44f6c012e08d294ef266e%7c72f988bf86f141af91ab2d7cd011db47%7c1&sdata=Ax7nZLUqpCehO%2fMNqFGI56ZvzUgitk8Z2tT3mQ9V%2fco%3d>, among others I'm sure, offer something similar.
It's commonly called "mobile push authentication" so maybe "mpa" could be the amr value. But, as Nat pointed out, the really interesting characteristic is that it's a second factor that utilizes only a secondary channel - so perhaps "sca" for "second channel authentication" would be a more appropriate general amr name.
Thoughts are welcome. But I believe it's becoming prevalent enough that it deserves its own amr value in this doc.

On Thu, Jul 23, 2015 at 6:29 PM, Mike Jones <[email-masked]<mailto:[email-masked]>> wrote:
I agree that an obvious good thing to do is to add spec references to the field definitions.

                                                            -- Mike

From: OAuth [mailto:[email-masked]<mailto:[email-masked]>] On Behalf Of Nat Sakimura
Sent: Thursday, July 23, 2015 6:22 PM
To: William Denniss
Cc: <[email-masked]<mailto:[email-masked]>>
Subject: Re: [OAUTH-WG] Authentication Method Reference Values Specification

"rba":  "risk-based auth"

                                                            -- Mike

That exists for ACR.

John B.

 — Justin

                                                            -- Mike

_______________________________________________
OAuth mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/oauth<https://na01.safelinks.protection.outlook.com/?url=https%3a%2f%2fwww.ietf.org%2fmailman%2flistinfo%2foauth&data=01%7c01%7cMichael.Jones%40microsoft.com%7c62c2764a6dc44f6c012e08d294ef266e%7c72f988bf86f141af91ab2d7cd011db47%7c1&sdata=0PDDS8PACgJmwL5PYBHxVxJPIlIQ331YG09Qafzgwso%3d>

---

From: Mike Jones <[email-masked]>
Date: Fri, 14 Aug 2015 03:54:36 +0000

These were all added, per my other replies.

                                                            Thanks again,
                                                            -- Mike

From: Nat Sakimura [mailto:[email-masked]]
Sent: Sunday, July 26, 2015 4:03 PM
To: Brian Campbell
Cc: Mike Jones; William Denniss; <[email-masked]>
Subject: Re: [OAUTH-WG] Authentication Method Reference Values Specification

I am in favor of William's proposal.
In addition, I would like to see one for 2nd channel auth, 2ch. That would indicate some resilience against MITB.

On Saturday, July 25, 2015, Brian Campbell <[email-masked]<mailto:[email-masked]>> wrote:
There's a method of authentication that is gaining in popularity which I'd propose adding a method for. It is typically used as a second factor where after a primary auth, like username and password, a push notification is sent to the user's phone and they acknowledge it from the device. We have the PingID product<https://na01.safelinks.protection.outlook.com/?url=https%3a%2f%2fwww.pingidentity.com%2fen%2fproducts%2fpingid.html&data=01%7c01%7cMichael.Jones%40microsoft.com%7c1e014d22ad0a45a29ba208d295f52453%7c72f988bf86f141af91ab2d7cd011db47%7c1&sdata=kHpqzhIRYpbk7czSnWo14X%2fg25k7XeyMyZ0MpXL8Vwk%3d> that does it and Entrust<https://na01.safelinks.protection.outlook.com/?url=http%3a%2f%2fwww.entrust.com%2fresource%2fentrust-identityguard-mobile-push-authentication-for-vpn-and-web-access&data=01%7c01%7cMichael.Jones%40microsoft.com%7c1e014d22ad0a45a29ba208d295f52453%7c72f988bf86f141af91ab2d7cd011db47%7c1&sdata=D%2bKTzbh4BnaL5RxHdhMbWdE65yaZ8z0uBZj9mPk3BXI%3d> and Duo<https://na01.safelinks.protection.outlook.com/?url=https%3a%2f%2fwww.duosecurity.com%2fproduct%2fmethods%2fduo-mobile&data=01%7c01%7cMichael.Jones%40microsoft.com%7c1e014d22ad0a45a29ba208d295f52453%7c72f988bf86f141af91ab2d7cd011db47%7c1&sdata=t07t7CvtBkQBJ9%2boYkG3Ad5lFBB0DwrwDKOtXa2yACg%3d>, among others I'm sure, offer something similar.
It's commonly called "mobile push authentication" so maybe "mpa" could be the amr value. But, as Nat pointed out, the really interesting characteristic is that it's a second factor that utilizes only a secondary channel - so perhaps "sca" for "second channel authentication" would be a more appropriate general amr name.
Thoughts are welcome. But I believe it's becoming prevalent enough that it deserves its own amr value in this doc.

On Thu, Jul 23, 2015 at 6:29 PM, Mike Jones <[email-masked]<javascript:_e(%7B%7D,'cvml',[email-masked]');>> wrote:
I agree that an obvious good thing to do is to add spec references to the field definitions.

                                                            -- Mike

From: OAuth [mailto:[email-masked]<javascript:_e(%7B%7D,'cvml',[email-masked]');>] On Behalf Of Nat Sakimura
Sent: Thursday, July 23, 2015 6:22 PM
To: William Denniss
Cc: <[email-masked]<javascript:_e(%7B%7D,'cvml',[email-masked]');>>
Subject: Re: [OAUTH-WG] Authentication Method Reference Values Specification

2015-07-23 12:05 GMT+02:00 William Denniss <[email-masked]<javascript:_e(%7B%7D,'cvml',[email-masked]');>>:
Thanks for drafting this Mike. I'm in favor of having this registry.

"rba":  "risk-based auth"

On Thu, Jul 23, 2015 at 10:49 AM, Brian Campbell <[email-masked]<javascript:_e(%7B%7D,'cvml',[email-masked]');>> wrote:
So maybe a naive question but why does this draft define "amr_values" while also suggesting that it's fragile and that "acr" & "acr_values" is preferable? Seems contradictory. And I doubt I'm the only one that will find it confusing.

On Thu, Jul 23, 2015 at 9:35 AM, Mike Jones <[email-masked]<javascript:_e(%7B%7D,'cvml',[email-masked]');>> wrote:
The key part of this is establishing a registry.  That can only be done in an RFC.

                                                            -- Mike

From: John Bradley [mailto:[email-masked]<javascript:_e(%7B%7D,'cvml',[email-masked]');>]
Sent: Thursday, July 23, 2015 9:30 AM
To: Justin Richer
Cc: Mike Jones; <[email-masked]<javascript:_e(%7B%7D,'cvml',[email-masked]');>>
Subject: Re: [OAUTH-WG] Authentication Method Reference Values Specification

That exists for ACR.

John B.

On Jul 23, 2015, at 9:21 AM, Justin Richer <[email-masked]<javascript:_e(%7B%7D,'cvml',[email-masked]');>> wrote:

 — Justin

On Jul 22, 2015, at 7:48 PM, Mike Jones <[email-masked]<javascript:_e(%7B%7D,'cvml',[email-masked]');>> wrote:

                                                            -- Mike

P.S.  This note was also posted at http://self-issued.info/?p=1429<https://na01.safelinks.protection.outlook.com/?url=http%3a%2f%2fself-issued.info%2f%3fp%3d1429&data=01%7c01%7cMichael.Jones%40microsoft.com%7c45f73eec59c2463664de08d2937adf52%7c72f988bf86f141af91ab2d7cd011db47%7c1&sdata=zv2zIrlN0UGAFKe9rADVphUGnJKOgHwiRYXk0toa5QQ%3d> and as @selfissued<https://na01.safelinks.protection.outlook.com/?url=https%3a%2f%2ftwitter.com%2fselfissued&data=01%7c01%7cMichael.Jones%40microsoft.com%7c45f73eec59c2463664de08d2937adf52%7c72f988bf86f141af91ab2d7cd011db47%7c1&sdata=GZB6%2f0FYZPSX0RUxQkjMUAc5uGaTJVuZbkYUcuSFBkA%3d>.
_______________________________________________
OAuth mailing list
[email-masked]<javascript:_e(%7B%7D,'cvml',[email-masked]');>
https://www.ietf.org/mailman/listinfo/oauth<https://na01.safelinks.protection.outlook.com/?url=https%3a%2f%2fwww.ietf.org%2fmailman%2flistinfo%2foauth&data=01%7c01%7cMichael.Jones%40microsoft.com%7c45f73eec59c2463664de08d2937adf52%7c72f988bf86f141af91ab2d7cd011db47%7c1&sdata=4aNhTxGD%2f9w8qD9WPXpi2%2bQfiprJDbsF2PK5EBxau34%3d>

_______________________________________________
OAuth mailing list
[email-masked]<javascript:_e(%7B%7D,'cvml',[email-masked]');>
https://www.ietf.org/mailman/listinfo/oauth<https://na01.safelinks.protection.outlook.com/?url=https%3a%2f%2fwww.ietf.org%2fmailman%2flistinfo%2foauth&data=01%7c01%7cMichael.Jones%40microsoft.com%7c45f73eec59c2463664de08d2937adf52%7c72f988bf86f141af91ab2d7cd011db47%7c1&sdata=4aNhTxGD%2f9w8qD9WPXpi2%2bQfiprJDbsF2PK5EBxau34%3d>

_______________________________________________
OAuth mailing list
[email-masked]<javascript:_e(%7B%7D,'cvml',[email-masked]');>
https://www.ietf.org/mailman/listinfo/oauth<https://na01.safelinks.protection.outlook.com/?url=https%3a%2f%2fwww.ietf.org%2fmailman%2flistinfo%2foauth&data=01%7c01%7cMichael.Jones%40microsoft.com%7c45f73eec59c2463664de08d2937adf52%7c72f988bf86f141af91ab2d7cd011db47%7c1&sdata=4aNhTxGD%2f9w8qD9WPXpi2%2bQfiprJDbsF2PK5EBxau34%3d>

_______________________________________________
OAuth mailing list
[email-masked]<javascript:_e(%7B%7D,'cvml',[email-masked]');>
https://www.ietf.org/mailman/listinfo/oauth<https://na01.safelinks.protection.outlook.com/?url=https%3a%2f%2fwww.ietf.org%2fmailman%2flistinfo%2foauth&data=01%7c01%7cMichael.Jones%40microsoft.com%7c45f73eec59c2463664de08d2937adf52%7c72f988bf86f141af91ab2d7cd011db47%7c1&sdata=4aNhTxGD%2f9w8qD9WPXpi2%2bQfiprJDbsF2PK5EBxau34%3d>

_______________________________________________
OAuth mailing list
[email-masked]<javascript:_e(%7B%7D,'cvml',[email-masked]');>
https://www.ietf.org/mailman/listinfo/oauth<https://na01.safelinks.protection.outlook.com/?url=https%3a%2f%2fwww.ietf.org%2fmailman%2flistinfo%2foauth&data=01%7c01%7cMichael.Jones%40microsoft.com%7c45f73eec59c2463664de08d2937adf52%7c72f988bf86f141af91ab2d7cd011db47%7c1&sdata=4aNhTxGD%2f9w8qD9WPXpi2%2bQfiprJDbsF2PK5EBxau34%3d>

_______________________________________________
OAuth mailing list
[email-masked]<javascript:_e(%7B%7D,'cvml',[email-masked]');>
https://www.ietf.org/mailman/listinfo/oauth<https://na01.safelinks.protection.outlook.com/?url=https%3a%2f%2fwww.ietf.org%2fmailman%2flistinfo%2foauth&data=01%7c01%7cMichael.Jones%40microsoft.com%7c1e014d22ad0a45a29ba208d295f52453%7c72f988bf86f141af91ab2d7cd011db47%7c1&sdata=x3n1mg4YGN6SXo72iAPORyUluFqNkDp7gb1ekdmLFmg%3d>

--
Nat Sakimura (=nat)
Chairman, OpenID Foundation
http://nat.sakimura.org/<https://na01.safelinks.protection.outlook.com/?url=http%3a%2f%2fnat.sakimura.org%2f&data=01%7c01%7cMichael.Jones%40microsoft.com%7c1e014d22ad0a45a29ba208d295f52453%7c72f988bf86f141af91ab2d7cd011db47%7c1&sdata=KeEEvsHUR2KI6rv%2btpfPWmGD%2bktGKFf3%2bkpWR2zYjao%3d>
@_nat_en