Subject: Re: [OAUTH-WG] proof-of-possession-02 unencrypted oct JWK in encrypted JWT okay?

From: Mike Jones <[email-masked]>
Date: Tue, 11 Aug 2015 03:57:07 +0000

As discussed in the thread “[OAUTH-WG] JWT PoP Key Semantics WGLC followup 2 (was Re: proof-of-possession-02 unencrypted oct JWK in encrypted JWT okay?)”, I will update the draft to say that the symmetric key can be carried in the “jwk” element in an unencrypted form if the JWT is itself encrypted.  This will happen in -04.

                                                            -- Mike

From: OAuth [mailto:[email-masked]] On Behalf Of Brian Campbell
Sent: Sunday, March 22, 2015 11:41 PM
To: oauth
Subject: [OAUTH-WG] proof-of-possession-02 unencrypted oct JWK in encrypted JWT okay?

When the JWT is itself encrypted as a JWE, would it not be reasonable to have a symmetric key be represented in the cnf claim with the jwk member as an unencrypted JSON Web Key?
Is such a possibility left as an exercise to the reader? Or should it be more explicitly allowed or disallowed?

---

From: Brian Campbell <[email-masked]>
Date: Tue, 11 Aug 2015 07:49:53 -0600

Thank you

On Mon, Aug 10, 2015 at 9:57 PM, Mike Jones <[email-masked]>
wrote:

> As discussed in the thread “[OAUTH-WG] JWT PoP Key Semantics WGLC followup
> 2 (was Re: proof-of-possession-02 unencrypted oct JWK in encrypted JWT
> okay?)”, I will update the draft to say that the symmetric key can be
> carried in the “jwk” element in an unencrypted form if the JWT is itself
> encrypted.  This will happen in -04.
>
>
>
>                                                             -- Mike
>
>
>
> *From:* OAuth [mailto:[email-masked]] *On Behalf Of *Brian
> Campbell
> *Sent:* Sunday, March 22, 2015 11:41 PM
> *To:* oauth
> *Subject:* [OAUTH-WG] proof-of-possession-02 unencrypted oct JWK in
> encrypted JWT okay?
>
>
>
> When the JWT is itself encrypted as a JWE, would it not be reasonable to
> have a symmetric key be represented in the cnf claim with the jwk member as
> an unencrypted JSON Web Key?
>

---

From: John Bradley <[email-masked]>
Date: Tue, 11 Aug 2015 20:05:19 -0300

OK
> On Aug 11, 2015, at 12:57 AM, Mike Jones <[email-masked]> wrote:
> 
> _______________________________________________
> OAuth mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/oauth