Subject: [OAUTH-WG] client_id format: whitespaces allowed?

From: Mark Dobrinic <[email-masked]>
Date: Tue, 13 Oct 2015 19:42:44 +0200

Hey OAuth group,

While I though I knew this, I was looking closely at the OAuth 2.0 spec
and read that valid values of the client_id are specified as:

VSCHAR = %x20-7E
client-id = *VSCHAR

This means that the client-id may also contain whitespace characters.

Do I get that right?

Thanks for your insights,

Mark

---

From: Mike Jones <[email-masked]>
Date: Tue, 13 Oct 2015 18:07:35 +0000

It can contain space (%x20) but not tab, carriage return, linefeed, form feed, vertical tab, backspace, delete (or any other control characters).

-----Original Message-----
From: OAuth [mailto:[email-masked]] On Behalf Of Mark Dobrinic
Sent: Tuesday, October 13, 2015 10:43 AM
To: [email-masked]
Subject: [OAUTH-WG] client_id format: whitespaces allowed?

Hey OAuth group,

While I though I knew this, I was looking closely at the OAuth 2.0 spec and read that valid values of the client_id are specified as:

VSCHAR = %x20-7E
client-id = *VSCHAR

Do I get that right?

Mark

_______________________________________________
OAuth mailing list
[email-masked]
https://na01.safelinks.protection.outlook.com/?url=https%3a%2f%2fwww.ietf.org%2fmailman%2flistinfo%2foauth&data=01%7c01%7cMichael.Jones%40microsoft.com%7c459786d9bc6849cb85e908d2d3f5bafd%7c72f988bf86f141af91ab2d7cd011db47%7c1&sdata=2PQxSCLiBAtkCozNPfz8tW26FS4XE80nsj5nnvc9mFU%3d