Subject: [OAUTH-WG] Better title for OAuth 2.0 JWT Authorization Request

From: "Nat Sakimura" <[email-masked]>
Date: Fri, 9 Oct 2015 10:43:17 +0900

Hi OAuthers: 

One of the to do for https://tools.ietf.org/html/draft-ietf-oauth-jwsreq-05
is to come up with a better title. 

The current title "OAuth 2.0 JWT Authorization Request (JAR)", is somewhat
better than what it used to be, but if you can suggest a better name, I am
all for it. 

Please let me know if you have an idea. 

Best, 

-- 

Nat Sakimura < <mailto:[email-masked]> [email-masked]>

Nomura Research Institute, Ltd. 

PLEASE READ:

The information contained in this e-mail is confidential and intended for
the named recipient(s) only.

If you are not an intended recipient of this e-mail, you are hereby notified
that any review, dissemination, distribution or duplication of this message
is strictly prohibited. If you have received this message in error, please
notify the sender immediately and delete your copy from your system.

---

From: Jim Manico <[email-masked]>
Date: Fri, 9 Oct 2015 03:47:16 +0200

The word authorization is implied by OAuth, consider "OAuth 2.0 JWT Request".

--
Jim Manico
@Manicode
(808) 652-3805

> On Oct 9, 2015, at 3:43 AM, Nat Sakimura <[email-masked]> wrote:
> 
> Hi OAuthers:
>  
> One of the to do for https://tools.ietf.org/html/draft-ietf-oauth-jwsreq-05 is to come up with a better title.
> The current title “OAuth 2.0 JWT Authorization Request (JAR)”, is somewhat better than what it used to be, but if you can suggest a better name, I am all for it.
> 
> Nat Sakimura <[email-masked]>
> The information contained in this e-mail is confidential and intended for the named recipient(s) only.
> If you are not an intended recipient of this e-mail, you are hereby notified that any review, dissemination, distribution or duplication of this message is strictly prohibited. If you have received this message in error, please notify the sender immediately and delete your copy from your system.
>  
> _______________________________________________
> OAuth mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/oauth

---

From: <[email-masked]>
Date: Fri, 9 Oct 2015 08:30:44 +0200

"OAuth 2.0 OpenId-ification"

From: OAuth [mailto:[email-masked]] On Behalf Of Nat Sakimura
Sent: Freitag, 9. Oktober 2015 03:43
To: 'oauth'
Subject: [OAUTH-WG] Better title for OAuth 2.0 JWT Authorization Request

Hi OAuthers:

One of the to do for https://tools.ietf.org/html/draft-ietf-oauth-jwsreq-05 is to come up with a better title.
The current title "OAuth 2.0 JWT Authorization Request (JAR)", is somewhat better than what it used to be, but if you can suggest a better name, I am all for it.
Please let me know if you have an idea.
Best,
--
Nat Sakimura <[email-masked]<mailto:[email-masked]>>
Nomura Research Institute, Ltd.

PLEASE READ:

---

From: <[email-masked]>
Date: Fri, 9 Oct 2015 09:15:23 +0200

https://tools.ietf.org/html/rfc6749#section-4.1.1 Authorization Request is explicit too.

Naming could be about the why or the what. JAR is in the what-is-is category.
“Signed and Encrypted Authorization Request” would be more in the why category.

I think JAR is not bad.

-A

From: OAuth [mailto:[email-masked]] On Behalf Of Jim Manico
Sent: Freitag, 9. Oktober 2015 03:47
To: Nat Sakimura
Cc: oauth
Subject: Re: [OAUTH-WG] Better title for OAuth 2.0 JWT Authorization Request

On Oct 9, 2015, at 3:43 AM, Nat Sakimura <[email-masked]<mailto:[email-masked]>> wrote:
Hi OAuthers:

PLEASE READ:

_______________________________________________
OAuth mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/oauth

---

From: Nat Sakimura <[email-masked]>
Date: Sat, 10 Oct 2015 00:23:29 +0900

The reason for saying authorization request is that there are two types of
requests in RFC6749; authorization request and token request. This draft
deals with the former and thus named JAR.

Nat

2015年10月9日金曜日、Jim Manico<[email-masked]>さんは書きました:

> On Oct 9, 2015, at 3:43 AM, Nat Sakimura <[email-masked]
> <javascript:_e(%7B%7D,'cvml',[email-masked]');>> wrote:
>
> Hi OAuthers:
>
>
>
> One of the to do for
> https://tools.ietf.org/html/draft-ietf-oauth-jwsreq-05 is to come up with
> a better title.
> The current title “OAuth 2.0 JWT Authorization Request (JAR)”, is
> somewhat better than what it used to be, but if you can suggest a better
> name, I am all for it. Please let me know if you have an idea.
>
> Best,
>
> --
>
> Nat Sakimura <[email-masked]
> <javascript:_e(%7B%7D,'cvml',[email-masked]');>>
>
> If you are not an intended recipient of this e-mail, you are hereby
> notified that any review, dissemination, distribution or duplication of
> this message is strictly prohibited. If you have received this message in
> error, please notify the sender immediately and delete your copy from your
> system.
>
>
>
> [email-masked] <javascript:_e(%7B%7D,'cvml',[email-masked]');>

-- 
Nat Sakimura (=nat)
http://www.sakimura.org/en/
http://twitter.com/_nat_en

---

From: Jim Manico <[email-masked]>
Date: Fri, 9 Oct 2015 17:28:12 +0200

But its all authorization, even the token request....

--
Jim Manico
@Manicode
Secure Coding Education
+1 (808) 652-3805

> On Oct 9, 2015, at 5:23 PM, Nat Sakimura <[email-masked]> wrote:
> 
> The reason for saying authorization request is that there are two types of requests in RFC6749; authorization request and token request. This draft deals with the former and thus named JAR.  
> 
> Nat
>

---

From: John Bradley <[email-masked]>
Date: Fri, 9 Oct 2015 12:39:15 -0300

We could switch the order to say “JWT request to the Authorization Endpoint”, but that is a bit long.

John B.

> On Oct 9, 2015, at 12:23 PM, Nat Sakimura <[email-masked]> wrote:
> 
> 2015年10月9日金曜日、Jim Manico<[email-masked] <mailto:[email-masked]>>さんは書きました:
> On Oct 9, 2015, at 3:43 AM, Nat Sakimura <[email-masked] <javascript:_e(%7B%7D,'cvml',[email-masked]');>> wrote:
> 
>> Hi OAuthers:
>> 
>>  
>> 
>> One of the to do for https://tools.ietf.org/html/draft-ietf-oauth-jwsreq-05 <https://tools.ietf.org/html/draft-ietf-oauth-jwsreq-05> is to come up with a better title.
>> 
>> Nat Sakimura <[email-masked] <javascript:_e(%7B%7D,'cvml',[email-masked]');>>
>> 
>> https://www.ietf.org/mailman/listinfo/oauth <https://www.ietf.org/mailman/listinfo/oauth>
> 
> 
> -- 
> Nat Sakimura (=nat)
> http://www.sakimura.org/en/ <http://www.sakimura.org/en/>
> http://twitter.com/_nat_en <http://twitter.com/_nat_en>

---

From: "Nat Sakimura" <[email-masked]>
Date: Thu, 15 Oct 2015 13:52:46 +0900

That’s true, but RFC6749 uses the term Authorization request to mean the request sent to the authorization endpoint. 

See 4.1.1, 4.2.1, 4.3.1, 4.4.1 of RFC6749. 

Best, 

-- 

PLEASE READ:

From: Jim Manico [mailto:[email-masked]] 
Sent: Saturday, October 10, 2015 12:28 AM
To: Nat Sakimura <[email-masked]>
Cc: oauth <[email-masked]>
Subject: Re: [OAUTH-WG] Better title for OAuth 2.0 JWT Authorization Request

--

Jim Manico

@Manicode

Secure Coding Education

+1 (808) 652-3805

On Oct 9, 2015, at 5:23 PM, Nat Sakimura <[email-masked] <mailto:[email-masked]> > wrote:

Nat

2015年10月9日金曜日、Jim Manico<[email-masked] <mailto:[email-masked]> >さんは書きました:

--

Jim Manico

@Manicode

(808) 652-3805

On Oct 9, 2015, at 3:43 AM, Nat Sakimura <[email-masked] <javascript:_e(%7B%7D,'cvml',[email-masked]');> > wrote:

Hi OAuthers: 

Best, 

-- 

Nat Sakimura < <javascript:_e(%7B%7D,'cvml',[email-masked]');> [email-masked]>

PLEASE READ:

---

From: Jim Manico <[email-masked]>
Date: Thu, 15 Oct 2015 07:37:26 +0200

Ok then it looks like the name is good as is. :)

--
Jim Manico
@Manicode
Secure Coding Education
+1 (808) 652-3805

> On Oct 15, 2015, at 6:52 AM, Nat Sakimura <[email-masked]> wrote:
>