Subject: Re: [OAUTH-WG] [scim] Simple Federation Deployment server to server

From: Anthony Nadalin <[email-masked]>
Date: Wed, 6 Apr 2016 12:59:29 +0000

Good question, since SCIM does not really provide an authorization model and Oauth does not do provisioning this is sort of caught in the middle, so if I had to pick I would pick Oauth as this is a generic server to server issue

From: Hardt, Dick [mailto:[email-masked]]
Sent: Wednesday, April 6, 2016 5:52 AM
To: Anthony Nadalin <[email-masked]>
Cc: Gil Kirkpatrick <[email-masked]>; Nat Sakimura <[email-masked]>; Phil Hunt (IDM) <[email-masked]>; [email-masked]; [email-masked]
Subject: Re: [scim] [OAUTH-WG] Simple Federation Deployment

Sounds like there is interest.

SCIM or OAUTH?

-- Dick

On Apr 6, 2016, at 8:57 AM, Anthony Nadalin <[email-masked]<mailto:[email-masked]>> wrote:
I would be interested also

Sent from my Windows 10 phone

From: Gil Kirkpatrick<mailto:[email-masked]>
Sent: Wednesday, April 6, 2016 4:16 AM
To: 'Nat Sakimura'<mailto:[email-masked]>; 'Hardt, Dick'<mailto:[email-masked]>; 'Phil Hunt (IDM)'<mailto:[email-masked]>
Cc: [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>
Subject: Re: [scim] [OAUTH-WG] Simple Federation Deployment

That's an issue we're facing as well. Definitely interested.

-gil

From: OAuth [mailto:[email-masked]] On Behalf Of Nat Sakimura
Sent: Wednesday, April 6, 2016 4:57 PM
To: 'Hardt, Dick' <[email-masked]<mailto:[email-masked]>>; 'Phil Hunt (IDM)' <[email-masked]<mailto:[email-masked]>>
Cc: [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>
Subject: Re: [OAUTH-WG] [scim] Simple Federation Deployment

+1 for removing the manual cut-n-pastes!

Nat

--
PLEASE READ :This e-mail is confidential and intended for the
named recipient only. If you are not an intended recipient,
please notify the sender  and delete this e-mail.

From: scim [mailto:[email-masked]] On Behalf Of Hardt, Dick
Sent: Wednesday, April 6, 2016 7:26 AM
To: Phil Hunt (IDM) <[email-masked]<mailto:[email-masked]>>
Cc: [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>
Subject: Re: [scim] Simple Federation Deployment

I'm talking about removing manual steps in what happens today where configuring a SaaS app at an IdP (such as Google, Azure, Ping, Octa) requires is a bunch of cutting and pasting of access tokens / keys / certs and doing a bunch of  config that is error prone and unique for each relationship.

Don't want to solve on the thread ... looking to see if there is interest!

On 4/5/16, 7:11 PM, someone claiming to be "scim on behalf of Phil Hunt (IDM)" <[email-masked]<mailto:[email-masked]> on behalf of [email-masked]<mailto:[email-masked]>> wrote:

Is the idp the center of all things for these users?

Usually you have a provisioning system that coordinates state and uses things like scim connectors to do this.

Another approach from today would be to pass a scim event to the remote provider which then decides what needs to be done to facilitate the thingd you describe.

Iow. Either the idp (sender) or the sp (receiver) have a provisioning system to do this.

The solution and the simplicity depends on where the control needs to be.

Phil

On Apr 5, 2016, at 18:59, Hardt, Dick <[email-masked]<mailto:[email-masked]>> wrote:
Use case: An admin for an organization would like to enable her users to access a SaaS application at her IdP.

User experience:

  1.  Admin authenticates to IdP in browser
  2.  Admin selects SaaS app to federate with from list at IdP
  3.  IdP optionally presents config options
  4.  IdP redirects Admin to SaaS app
  5.  Admin authenticates to SaaS app
  6.  SaaS app optionally gathers config options
  7.  SaaS app redirects admin to IdP
  8.  IdP confirms successful federation => OIDC / SAML and SCIM are now configured and working between IdP and SaaS App
Who else is interested in solving this?

Is there interest in working on this in either SCIM or OAUTH Wgs?

Any one in BA interested in meeting on this topic this week?

- Dick
_______________________________________________
scim mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/scim<https://na01.safelinks.protection.outlook.com/?url=https%3a%2f%2fwww.ietf.org%2fmailman%2flistinfo%2fscim&data=01%7c01%7ctonynad%40microsoft.com%7c871da74138de485b0bb008d35deb6643%7c72f988bf86f141af91ab2d7cd011db47%7c1&sdata=%2fILmgXPgRyLfCIn%2b2EbpBbIcHqKJbKZVYKJBpUL%2fKnY%3d>

---

From: Brian Campbell <[email-masked]>
Date: Wed, 6 Apr 2016 10:05:25 -0300

OpenID ... ?

On Wed, Apr 6, 2016 at 9:59 AM, Anthony Nadalin <[email-masked]>
wrote:

> Good question, since SCIM does not really provide an authorization model
> and Oauth does not do provisioning this is sort of caught in the middle, so
> if I had to pick I would pick Oauth as this is a generic server to server
> issue
>
>
>
> *From:* Hardt, Dick [mailto:[email-masked]]
> *Sent:* Wednesday, April 6, 2016 5:52 AM
> *To:* Anthony Nadalin <[email-masked]>
> *Cc:* Gil Kirkpatrick <[email-masked]>; Nat Sakimura <
> [email-masked]>; Phil Hunt (IDM) <[email-masked]>;
> [email-masked]; [email-masked]
> *Subject:* Re: [scim] [OAUTH-WG] Simple Federation Deployment
>
>
>
> On Apr 6, 2016, at 8:57 AM, Anthony Nadalin <[email-masked]> wrote:
>
> *From: *Gil Kirkpatrick <[email-masked]>
> *Sent: *Wednesday, April 6, 2016 4:16 AM
> *To: *'Nat Sakimura' <[email-masked]>; 'Hardt, Dick'
> <[email-masked]>; 'Phil Hunt (IDM)' <[email-masked]>
> *Cc: [email-masked]; [email-masked]
> *Subject: *Re: [scim] [OAUTH-WG] Simple Federation Deployment
>
>
>
> That’s an issue we’re facing as well. Definitely interested.
>
>
>
> -gil
>
>
>
> *From:* OAuth [mailto:[email-masked] <[email-masked]>] *On
> Behalf Of *Nat Sakimura
> *Sent:* Wednesday, April 6, 2016 4:57 PM
> *To:* 'Hardt, Dick' <[email-masked]>; 'Phil Hunt (IDM)' <
> [email-masked]>
> *Cc:* [email-masked]; [email-masked]
> *Subject:* Re: [OAUTH-WG] [scim] Simple Federation Deployment
>
>
>
> *From:* scim [mailto:[email-masked] <[email-masked]>] *On
> Behalf Of *Hardt, Dick
> *Sent:* Wednesday, April 6, 2016 7:26 AM
> *To:* Phil Hunt (IDM) <[email-masked]>
> *Cc:* [email-masked]; [email-masked]
> *Subject:* Re: [scim] Simple Federation Deployment
>
>
>
> I’m talking about removing manual steps in what happens today where
> configuring a SaaS app at an IdP (such as Google, Azure, Ping, Octa)
> requires is a bunch of cutting and pasting of access tokens / keys / certs
> and doing a bunch of  config that is error prone and unique for each
> relationship.
>
>
>
> Don’t want to solve on the thread … looking to see if there is interest!
>
>
>
> On 4/5/16, 7:11 PM, someone claiming to be "scim on behalf of Phil Hunt
> (IDM)" <[email-masked] on behalf of [email-masked]> wrote:
>
>
>
> Another approach from today would be to pass a scim event to the remote
> provider which then decides what needs to be done to facilitate the thingd
> you describe.
>
>
>
> On Apr 5, 2016, at 18:59, Hardt, Dick <[email-masked]> wrote:
>
>    8. IdP confirms successful federation => OIDC / SAML and SCIM are now
>    configured and working between IdP and SaaS App
>
> — Dick
> [email-masked]
> https://www.ietf.org/mailman/listinfo/scim
> <https://na01.safelinks.protection.outlook.com/?url=https%3a%2f%2fwww.ietf.org%2fmailman%2flistinfo%2fscim&data=01%7c01%7ctonynad%40microsoft.com%7c871da74138de485b0bb008d35deb6643%7c72f988bf86f141af91ab2d7cd011db47%7c1&sdata=%2fILmgXPgRyLfCIn%2b2EbpBbIcHqKJbKZVYKJBpUL%2fKnY%3d>
>
>
> OAuth mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/oauth
>
>

---

From: "Hardt, Dick" <[email-masked]>
Date: Wed, 6 Apr 2016 14:44:08 +0000

Given this is authorization and configuration, both of which are being done in OAuth, it makes sense to me to do it there. I brought SCIM into the discussion as this type of work may be were that WG wants to go.

-- Dick

On Apr 6, 2016, at 10:06 AM, Brian Campbell <[email-masked]<mailto:[email-masked]>> wrote:

OpenID ... ?

On Wed, Apr 6, 2016 at 9:59 AM, Anthony Nadalin <[email-masked]<mailto:[email-masked]>> wrote:
Good question, since SCIM does not really provide an authorization model and Oauth does not do provisioning this is sort of caught in the middle, so if I had to pick I would pick Oauth as this is a generic server to server issue

From: Hardt, Dick [mailto:[email-masked]<mailto:[email-masked]>]
Sent: Wednesday, April 6, 2016 5:52 AM
To: Anthony Nadalin <[email-masked]<mailto:[email-masked]>>
Cc: Gil Kirkpatrick <[email-masked]<mailto:[email-masked]>>; Nat Sakimura <[email-masked]<mailto:[email-masked]>>; Phil Hunt (IDM) <[email-masked]<mailto:[email-masked]>>; [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>
Subject: Re: [scim] [OAUTH-WG] Simple Federation Deployment

SCIM or OAUTH?

-- Dick

-gil

Nat

Phil

User experience:

- Dick

_______________________________________________
OAuth mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/oauth

---

From: Justin Richer <[email-masked]>
Date: Thu, 7 Apr 2016 19:15:44 -0400

+1, this seems a better fit for openid.

 — Justin

> On Apr 6, 2016, at 9:05 AM, Brian Campbell <[email-masked]> wrote:
> 
> OpenID ... ? 
> 
> On Wed, Apr 6, 2016 at 9:59 AM, Anthony Nadalin <[email-masked] <mailto:[email-masked]>> wrote:
>   <>
> From: Hardt, Dick [mailto:[email-masked] <mailto:[email-masked]>] 
> To: Anthony Nadalin <[email-masked] <mailto:[email-masked]>>
> Cc: Gil Kirkpatrick <[email-masked] <mailto:[email-masked]>>; Nat Sakimura <[email-masked] <mailto:[email-masked]>>; Phil Hunt (IDM) <[email-masked] <mailto:[email-masked]>>; [email-masked] <mailto:[email-masked]>; [email-masked] <mailto:[email-masked]>
> On Apr 6, 2016, at 8:57 AM, Anthony Nadalin <[email-masked] <mailto:[email-masked]>> wrote:
> 
> From: Gil Kirkpatrick <mailto:[email-masked]>
> To: 'Nat Sakimura' <mailto:[email-masked]>; 'Hardt, Dick' <mailto:[email-masked]>; 'Phil Hunt (IDM)' <mailto:[email-masked]>
> Cc: [email-masked] <mailto:[email-masked]>; [email-masked] <mailto:[email-masked]>
> From: OAuth [mailto:[email-masked] <mailto:[email-masked]>] On Behalf Of Nat Sakimura
> To: 'Hardt, Dick' <[email-masked] <mailto:[email-masked]>>; 'Phil Hunt (IDM)' <[email-masked] <mailto:[email-masked]>>
> Cc: [email-masked] <mailto:[email-masked]>; [email-masked] <mailto:[email-masked]>
> From: scim [mailto:[email-masked] <mailto:[email-masked]>] On Behalf Of Hardt, Dick
> To: Phil Hunt (IDM) <[email-masked] <mailto:[email-masked]>>
> Cc: [email-masked] <mailto:[email-masked]>; [email-masked] <mailto:[email-masked]>
> I’m talking about removing manual steps in what happens today where configuring a SaaS app at an IdP (such as Google, Azure, Ping, Octa) requires is a bunch of cutting and pasting of access tokens / keys / certs and doing a bunch of  config that is error prone and unique for each relationship.
> 
>  
> 
> On 4/5/16, 7:11 PM, someone claiming to be "scim on behalf of Phil Hunt (IDM)" <[email-masked] <mailto:[email-masked]> on behalf of [email-masked] <mailto:[email-masked]>> wrote:
> 
>  
> 
> On Apr 5, 2016, at 18:59, Hardt, Dick <[email-masked] <mailto:[email-masked]>> wrote:
> 
> Admin authenticates to IdP in browser
> Admin selects SaaS app to federate with from list at IdP
> IdP optionally presents config options
> IdP redirects Admin to SaaS app
> Admin authenticates to SaaS app
> SaaS app optionally gathers config options
> SaaS app redirects admin to IdP
> IdP confirms successful federation => OIDC / SAML and SCIM are now configured and working between IdP and SaaS App
> [email-masked] <mailto:[email-masked]>
> https://www.ietf.org/mailman/listinfo/scim <https://na01.safelinks.protection.outlook.com/?url=https%3a%2f%2fwww.ietf.org%2fmailman%2flistinfo%2fscim&data=01%7c01%7ctonynad%40microsoft.com%7c871da74138de485b0bb008d35deb6643%7c72f988bf86f141af91ab2d7cd011db47%7c1&sdata=%2fILmgXPgRyLfCIn%2b2EbpBbIcHqKJbKZVYKJBpUL%2fKnY%3d>
> [email-masked] <mailto:[email-masked]>
> https://www.ietf.org/mailman/listinfo/oauth <https://www.ietf.org/mailman/listinfo/oauth>
> 
>

---

From: "Hardt, Dick" <[email-masked]>
Date: Thu, 7 Apr 2016 23:19:05 +0000

I'm writing an ID to submit in the OAuth WG

-- Dick

On Apr 7, 2016, at 8:16 PM, Justin Richer <[email-masked]<mailto:[email-masked]>> wrote:

 — Justin

On Apr 6, 2016, at 9:05 AM, Brian Campbell <[email-masked]<mailto:[email-masked]>> wrote:

OpenID ... ?

SCIM or OAUTH?

-- Dick

-gil

Nat

Phil

User experience:

— Dick